IOS 15.x, ip default-network and EIGRP

Hi,

It occured to me during various tests that trying to advertise a default route in EIGRP using ip default-network is not working any longer on IOS 15.x or IOS XE.

Long story short, same simple setup, two routers back to back, on 12.4 is working as designed, the neighbor routers are using that network to set the "Gateway of last resort" while on IOS 15.x or IOS XE (I have tested on a pair of 1841s and CSR1000v), although the Candidate Default Flag is set for that route, the neighbor routers are not using it to send traffic to destinations for which they do not have a match in RIB. 

Is something that somebody else experienced? Is this a new "feature"?

 

Many thanks,

 

Gabriel

Comments

  • we had that discussion here in forum already;

    Hi Martin,

     

    Thanks for your reply. Sorry fo double posting. I have tried to look for a similar discussion before opening the thread and all I could find was Cristian Matei's post about how it should work. 

    Anyways is clear now since I was about to go mental thinking that I do something wrong.

     

    Cheers,

     

    Gabriel

  • no problem with no double post; this forum structre is not user friendly; hard to find things.

    have u found answer? what was it? I dont' recall final answer. post link if u still have it

    Hi Martin,

    I haven't got the answer, or a real explanation to it. But since there are other people who got the same result then the problem seems to be someplace else than here, with me. 

    It can get frustrating when you hit a bug or a changed feature and spend half a day trying to discover what you did wrong. I'll try to keep looking and if I'll find the post you are talking about I'll put the link here.

     

    Gabriel

Sign In or Register to comment.