NAT with BGP urgent help

Gents

 

The scenario is that i have a router which will work as a CPE will run BGP with the PE. Suppose teh WAN interface IP is 1.1.1.1/30

My ethernet IP is 192.168.1.1/24 and its connected to a firewall 192.168.1.2/24. I have three networks behind firewall 172.1.1.0/24,172.1.2.0/24 and 172.1.3.0/24

All the networks which are behind the firewall shd get NAT/PAT to single ip 10.6.6.6/32 address and i shd only advertise 10.6.6.6/32 in BGP.

Here are my config

Interface Gig0/0 (LAN side)

ip nat insdie

interface Gig0/1 (WAN side)

ip nat outside

 

since 10.6.6.6 is not in the routing table i would advertise a static route to null0

ip route 10.6.6.6 255.255.255.255 null0

 

static routes for all three networks

ip route 172.1.1.0 255.255.255.0  192.168.1.2

ip route 172.1.2.0 255.255.255.0  192.168.1.2

ip route 172.1.3.0 255.255.255.0  192.168.1.2

 

NAT configuration

access-list 1 permit 172.1.1.0 0.0.0.255

access-list 1 permit 172.1.2.0 0.0.0.255

access-list 1 permit 172.1.3.0 0.0.0.255

 

ip nat pool mypool 10.6.6.6 10.6.6.6 netmask 255.255.255.255 (shd i use /32 as i have been given /32)

 

ip nat inside source list 1 pool mypool overload

 

BGP config

router bgp 6500

network 10.6.6.6 mask 255.255.255.255

 

Guys kindly help me out...will it work or i am missing something??

 

Thanks as always

Comments

  • peetypeety ✭✭✭

    Go back to square 1 and troubleshoot this issue.

    C'mon now, you're posting in a CCIE forum looking for "urgent" help, but you're not even displaying a CCNP-level attempt at the problem. Show us your topology, show us your debugs, give us a hint as to where you THINK the problem is, tell us the platform and code version, etc.

  • Oh the topolog y is as under:

     

    CPR router (which will do NAT) and its connected to a firewall which have those three IP subnets. The CPE will run bgp and will do the NAT.

     

    Is this clear now?

Sign In or Register to comment.