Foundation LAB 3 redistribution Issue

on foundation LAb 3 the RIP route 9.9.9.9 when redistributed on R1 loops are happen concerning this prefix

so what is the fix for that cause BGP task 5.2 can't be done between R1 & R9

 

Comments

  • MartinlMartinl ✭✭✭

    have you watch free videos from Brian on redistribution? CCIE Routing & Switching v5 Advanced Technologies - INE

    what methods of preventing loops did u use on R1?

  • Try configuring the distance on R1 for RIP prefixes, either for the whole process to be lower AD than OSPF or per prefix, like 9.9.9.9/32.

    You can also distribute-list on OSPF to remove it from the RIB, but it's still in the LSDB so you'll have to do the same on R2, R3 and R7.

  • MartinlMartinl ✭✭✭

    yes, I see R1 in RIP and OSPF, if route comes from RIP into osof, AD 120  losses to 110. it loops in ospf domain instead of going out thru R1 to R9

  • after configuring routers correctely i found no loops happen and this is the logic as we have just one exit point between the two domains RIP & OSPF through R1 and looping prevention on R1 will prevent loops as it is the advertising router

    we could have loops if we have two exit points between the two doamins and this is not in this case

    thanks again for your help and advise and very thanks to Brian Redistribution Videos that help alot

  • MartinlMartinl ✭✭✭

    Glad u figured it out. kudos!

  • For these loop preventions scenario i use either two options

    1) Filter R1 from learning 9.9.9.9/32 inbound in OSPF. That way, it'ld be learnt via RIP

    2) Change the AD per prefix 9.9.9.9/32 on OSPF. This will affect on the prefix 9.9.9.9/32

     

    If i have my way, i always avoid playing with the AD.

     

    HTH

Sign In or Register to comment.