Question about PIM Accept Register (ine ccie rsv5 workbook)

Hi Guys,

 

I followed the config from ine ccie rsv5.0 workbook PIM Accept Register. However, i use R1 to do a test and find it still be able to ping 224.10.10.10. I checked the logs on R5:

%PIM-4-INVALID_SRC_REG: Received Register from 155.1.45.4 for (155.1.146.1, 224.10.10.10), not willing to be RP

 

i'm not sure why R5 not willing to be RP for R1 but R1 still be able to ping 224.10.10.10.

 

Can anyone help?

 

Thanks

Sean

Comments

  • JoeMJoeM ✭✭✭

    Please place these in the sub-forum for the given workbook sections.  This way future candidates can see the puzzle and solution.  Thanks.

     

    Can you post your PIM configs?   

                show run | s pim|access-list

     

  • Hi Joe,

     

    Just realized there is a sub-section for the workbook. Next time will post under that section. Thanks!

    Below is my config:

    R5

    -----------------------------------------

    ip pim rp-address 150.1.5.5

    ip pim accept-register list VLAN146
    ip access-list extended VLAN146
     permit ip host 155.1.146.6 any
     deny   ip 155.1.146.0 0.0.0.255 any
     permit ip any any

    -----------------------------------------

    %PIM-4-INVALID_SRC_REG: Received Register from 155.1.45.4 for (155.1.146.1, 224.10.10.10), not willing to be RP

     

    There is a Note at the bottom of the lab, but i don't understand it [:'(]

    -----------------------------------------

    In this lab, we avoided doing verification on R1 and R4 for the
    Accept-Register configuration. This was to avoid issues related to
    packets being flooded out all-PIM enabled interfaces on these devices.
    In this particular configuration, this situation leads to traffic being
    able hit R5 (the RP) and thus being able to flow down the shared tree.

    ------------------------------------------

     

     

     

  • JoeMJoeM ✭✭✭

    i'm not sure why R5 not willing to be RP for R1 but R1 still be able to ping 224.10.10.10.

     

    Hi Sean,

    Take a look at the mroute table on R5, and see if you have the same result as I do

     

    This is what I found on R5 with show ip mroute.

    (155.1.15.1, 224.10.10.10), 00:00:08/00:02:51, flags: T
      Incoming interface: Tunnel10, RPF nbr 0.0.0.0
      Outgoing interface list:
        Ethernet1/0.58, Forward/Sparse, 00:00:08/00:03:21

     

    I also see the same expected error from a denied source (accept-register acl).

    %PIM-4-INVALID_SRC_REG: Received Register from 155.1.45.4 for (155.1.146.1, 224.10.10.10), not willing to be RP

     

    My next step was to find out what is going on with TUNNEL 10.  I did not configure this interface for PIM.   ???

    R5(config-if)#do sh ip pim int
    <snip>
    155.1.15.5       Tunnel10    v2/D   0      30     1      0.0.0.0
    <snip>

    R5(config-if)#do sh run int tun 10
    <snip>
    interface Tunnel10
     ip address 155.1.15.5 255.255.255.0
     ip pim dense-mode
    <snip>

     

    This is what I see happening.  R1 (acting as a source) sends a ping out all of its interfaces.

    R5 (RP) accept-register...

           rejects the source from 155.1.146.1 (correct)

           accepts the source on tun 10 (dense mode) and sent out e1/0.58 (sparse-mode)

     

    NOTE that R1 does not have pim configured on its exit interface, even though it is acting as a multicast source.  But R5 has pim dense-mode  pre-configured on the other end of tun 10.

  • hmmmmm, thanks Joe! u always give a lot of help!

    from this mistake i learn that we should look at the full pic instead of just focus on one small portion.

     

    thanks again!

  • JoeMJoeM ✭✭✭

    No problem. It was a good question.   Multicast is tricky. Very important to look at the output commands.

    For this specific task, it would probably be better if the workbook shuts down the tunnel interface.

Sign In or Register to comment.