Server and ISP communiction in Full Scale Labs

Is anyone else having issues with VRF communications with their CSR 1000v? I have had issues multiple times in both Full Scale lab 1 and 2 at the same point. I have verified and mirrored the INE solutions but still nothing. Here is the two spots I have issues with.

 

Full Scale Lab 1: Server1 communications (ping) to HSPR VIP. Can never ping the VIP after the task has been completed. Server 1 can ping R19 and R20 IPs but not the VIP. This has happened every time I have done this lab.

 

Full Scale Lab 2: Site W,X,Y,Z BGP communication across ISP A and/or B. R16 and 17 can communicate but no one lese can. The odd part is I have had this fail on ISP A only and aother time on ISP B only. I have also ran this lab once and had no issue. BGP forms neighbors, RIB on all devices is properly populated just no ping/traceroute.

 

The pattern Im seeing is an issue with VRFs configured to represent the servers and ISPs. The best I can tell traffic is not forwarding within a VRF even if its a directly connected link.

Yes I am using the ping vrf <vrf> x.x.x.x and traceroute vrf <vrf> x.x.x.x commands. I have also tried entering the VRF context as described in lab 1 with no change.

 

Cisco 1000v version: 15.4(3)S1,

Comments

  • Full Scale Lab 1: Server1 communications (ping) to HSPR VIP. Can never ping the VIP after the task has been completed. Server 1 can ping R19 and R20 IPs but not the VIP. This has happened every time I have done this lab.

    This seems to be an issue with HSRP. None of the devices on the LAN segment were being able to ping the HSRP active device, with the exception of the active device itself. I was able to solve it by adding the "standby use-bia" command on R19 and R20. This will be refleclected in the solution guide. 

    I will work on finding a solution for the Full Scale Lab 2 issue. 

  • searching for server_vip you can see that quite a few people have had this issue. It works just fine for me on the version listed below. Are older or more recent version affected?

    Cisco IOS XE Software, Version 03.12.00.S - Standard Support Release
    Cisco IOS Software, CSR1000V Software (X86_64_LINUX_IOSD-UNIVERSALK9-M), Version 15.4(2)S, RELEASE SOFTWARE (fc2)
    Compiled Wed 26-Mar-14 21:09 by mcpre

    i would have minor issues randomly with 32 GIGs of ram even with a decent SSD. increasing to 48 gigs stopped paging services to disk and everyting is running perfectly now.

     

    Leon

  • Hi 

    Regarding your HSRP issue, have you tried to modify port group settings of your ESX ?

     

    Inventory> Networking ...   Edit your port group settings

    Under Rule > Security ...  Make sure the 3 options (Promiscuous mode, MAC address modifications, Forged Transmissions) are set to "accept".

     

    Hope it'll help you.

     

Sign In or Register to comment.