unable to bring up EIGRP hub and spoke

Hi 

 

I am  trying to bring up EIGRP on a hub and spoke topology, but cannot seem to stabilize the neighbors from the hub to the spoke. 

Getting the famous (Tunnel0) is down: retry limit exceeded error.

 

I have no ip split horizon on the hub already. 

 

I am using GNS3 and the hub is not taking the "ip nhrp map multicast dynamic" command so i tried to define the spoke multicasts mapping statically. 

It did take them but then I had to disable "ip cef". With CEF enabled neither the static of dynamic multicast mappings work...get error:

R5(config-if)#ip nhrp map multicast 155.1.0.1

% WARNING: This interface is running CEF:

NHRP will only work on a CEF interface in case

it's an ATM interface running BGP as well.

 

In anycase with CEF disabled the neighbors still cannot get a Q count of 0.

 

Anyone seen this or have any recommendations. 

 

Thanks

 

Izzy

Comments

  • JoeMJoeM ✭✭✭

    This is strange.   I have never had to disable CEF for DMVPN.   Which IOS are you using?

    Can you do a normal ping from end-to-end (nbma addresses)?

    Besides the supposed CEF issue (strange), I am suspecting that you have a recursive routing issue (nbma addresses received over the tunnel).

    Is the tunnel up and down, or is it just an EIGRP neighbor issue?

     

    Please give these basic configs for the hub and spoke. It might be something simple to spot in the config (vs guessing).

          show run interface tun X

          show run | s router eigrp

     

     

  • Yep I can do end-to-end pings. 

    Dont believe it is the recursive router issue because debugs didn't show that though. 

    Here are the the configs

     

    Spoke

    interface Tunnel0

     ip address 155.1.0.2 255.255.255.0

     ip mtu 1400

     ip nhrp authentication NHRPPASS

     ip nhrp map 155.1.0.5 169.254.100.5

     ip nhrp map multicast 169.254.100.5

     ip nhrp network-id 1 

     ip nhrp holdtime 300

     ip nhrp nhs 155.1.0.5

     ip tcp adjust-mss 1360

     tunnel source GigabitEthernet1/0

     tunnel mode gre multipoint

     tunnel key 150

     no shutdown

     

    router eigrp 100

     no auto-summary

     network 150.1.0.0 0.0.255.255

     network 155.1.0.0 0.0.255.255

     

    HUB

     

    interface Tunnel0

     ip address 155.1.0.5 255.255.255.0

     ip mtu 1400

     ip nhrp authentication NHRPPASS

     ip nhrp map multicast dynamic   *** wouldn't allow me to add this with CEF***replaced with static mappings for the spoke

     ip nhrp map multicast  IP address of spoke overlay (tunnel address) 

    ip nhrp network-id 1

     ip tcp adjust-mss 1360

     delay 1000

     tunnel source GigabitEthernet1/0

     tunnel mode gre multipoint

     tunnel key 150

     no shutdown

    no ip split-horizon eigrp 100

     

    router eigrp 100

     no auto-summary

     network 150.1.0.0 0.0.255.255

     network 155.1.0.0 0.0.255.255

     

     

    Thanks

  • JoeMJoeM ✭✭✭

    Everything looks good to me in the config -- except CEF being disable.

     

    Are these the only DMVPN tunnels on your HUB? 

    I still am not clear as to whether the tunnel is staying up or not......or if it just an EIGRP neighbor issue?

     

    Also which IOS are you using?

    I am shooting a little in the dark on this.  Anyone else have a clue regarding the cef problem?

  • JoeMJoeM ✭✭✭

    ip nhrp map multicast dynamic   *** wouldn't allow me to add this with CEF***replaced with static mappings for the spoke
     ip nhrp map multicast  IP address of spoke overlay (tunnel address)

    Although I prefer that the first line is working...........this second line should be the NBMA address of the incoming spoke (not the tunnel address of the spoke).    The spoke is already outlining its own maps.

  • Hello JoeM 

     This is the version of software I am using. 

     I won't be surprised if this is the root cause. Any recommendation on what verion of software is ideal for GNS3 7200 series router. 

     7200 Software (C7200-K91P-M), Version 12.2(25)S15.

     

     I went ahead and fixed the NBMA address (for each of the spokes) on the hub tunnel interface. 

     To bring the EIGRP up, I went ahead and disabled CEF to allow me to add the nhrp commands on the tunnel interfaces and then went back in global mode to re-enable CEF. 

     That seemed to have worked and I see the neighbors up.

     

     Thanks again and let me know what version of IOS you recommend. 

     Izzy

  • use a 7200 router in GNS with the 15.2.4 IOS...the older IOS version do not support DMVPN Phase 3.

    also i do not recommend disabling CEF for DMVPN... :-)

    but with the 15. Code you can run DMVPN in GNS3 without problems

  • Oh didn't come back to say it worked. 

    Thanks much.

     

    Izzy

Sign In or Register to comment.