OSPF problem

Gateway of last resort is not set

     128.1.0.0/16 is variably subnetted, 6 subnets, 2 masks
O IA    128.1.136.0/24 [110/11] via 128.1.125.1, 00:10:47, Virtual-Access2
C       128.1.45.0/24 is directly connected, Dialer0
O IA    128.1.63.0/24 [110/11122] via 128.1.125.1, 00:10:47, Virtual-Access2
C       128.1.125.0/24 is directly connected, Virtual-Access1
                       is directly connected, Virtual-Access2
C       128.1.125.1/32 is directly connected, Virtual-Access1
C       128.1.125.2/32 is directly connected, Virtual-Access2
R5#

My lab is with R2 --- R5 --- R1 PPP over Frame Relay connections. R5's Virtual-Access1 and Virtual-Access2 are connected to R1 and R2 respectively. Networks 128.1.136.0/24 and 128.1.63.0/24 are advertised by OSPF from R1. I don't know why the above R5 routing table shows 128.1.136.0/24 and 128.1.63.0/24 are through Virtual-Access2. I cannot ping these networks from R2 via R5 to R1.

Can anybody help? Thanks.

Comments

  • <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">






    Well, it implies that those two routes are InterArea
    (Summary) routes.  Therefore I'd assume that R2 (Virtual-Access2) is an
    ABR?

     

    Do you have a peer between R1 and R2 (the two
    spokes)?  "show ip ospf neighbor" on them to see.

     

    But what you appear to be noting on there is that
    128.1.125.1 is the next hop.  Even though the LSA was brought in from Vi2
    (if an ABR, the higher RID) it should recurse to the correct
    link.

     

    You noted you can't ping from R2 --> R5 --> R1, but
    can you ping directly from R5 --> R1's networks?

     

    Just for fun, turn on "debug ip ospf adjacency" on R1/R2
    and see if there's anything irritating or out of the ordinary
    there.

     

    HTH,

     

    Scott





    From: [email protected] [mailto:[email protected]]
    On Behalf Of Eric Chan
    Sent: Saturday, September 06, 2008 3:21
    PM
    To: [email protected]
    Subject: [CCIE
    R&S] OSPF problem


    Gateway of last resort is not set

         128.1.0.0/16 is variably subnetted, 6 subnets, 2
    masks
    O IA    128.1.136.0/24 [110/11] via 128.1.125.1,
    00:10:47, Virtual-Access2
    C       128.1.45.0/24
    is directly connected, Dialer0
    O IA    128.1.63.0/24
    [110/11122] via 128.1.125.1, 00:10:47,
    Virtual-Access2
    C       128.1.125.0/24 is
    directly connected,
    Virtual-Access1
                          
    is directly connected, Virtual-Access2
    C      
    128.1.125.1/32 is directly connected,
    Virtual-Access1
    C       128.1.125.2/32 is
    directly connected, Virtual-Access2
    R5#

    My lab is with R2 --- R5 --- R1 PPP over Frame Relay connections. R5's
    Virtual-Access1 and Virtual-Access2 are connected to R1 and R2 respectively.
    Networks 128.1.136.0/24 and 128.1.63.0/24 are advertised by OSPF from R1. I
    don't know why the above R5 routing table shows 128.1.136.0/24 and 128.1.63.0/24
    are through Virtual-Access2. I cannot ping these networks from R2 via R5 to
    R1.

    Can anybody help? Thanks.




    Internetwork
    Expert - The Industry Leader in CCIE
    Preparation
    http://www.internetworkexpert.com

    Subscription information
    may be found
    at:
    http://www.ieoc.com/forums/ForumSubscriptions.aspx
  • This sounds very familiar....wouldnt happen to be Vol III lab 5 by any chance??

     

  • R2 and R1 are ABR. R2 is without adjacency for R1 directly and vice versa. Communication between R2 and R1 is through R5. R5 cannot ping 128.1.136.0/24 and 128.1.63.0/24 which connected to R1.

    It is strange in R5 why the next hop IP is R1's 128.1.125.1 for 128.1.136.0/24 and 128.1.63.0/24 but the interface is not Virtual-Access1 which connected to R1.

    The following R2 and R5 output of debug ip ospf spf is attached for your infomation please.

    *Mar  1 00:14:25.119: OSPF: Entered old delete routine

    *Mar  1 00:14:25.119: OSPF: ospf_gen_asbr_sum_all_areas

    *Mar  1 00:14:25.119: OSPF: running spf for summaries area 125

    *Mar  1 00:14:25.119: OSPF: Start processing Summary LSA 128.1.63.0, mask 255.255.255.0, adv 150.1.1.1, age 695, seq 0x80000001 (Area 125) type 3

    *Mar  1 00:14:25.119:    Add better path to LSA ID 128.1.63.0, gateway 0.0.0.0, dist 11123

    *Mar  1 00:14:25.119:    Add path: next-hop 128.1.125.5, interface Virtual-Access1

    *Mar  1 00:14:25.123:    Add Summary Route to 128.1.63.0/255.255.255.0. Metric: 11123, Next Hop: 128.1.125.5

    *Mar  1 00:14:25.127: OSPF: insert route list LS ID 128.1.63.0, type 3, adv rtr 150.1.1.1

    *Mar  1 00:14:25.131: OSPF: Start processing Summary LSA 128.1.136.0, mask 255.255.255.0, adv 150.1.1.1, age 362, seq 0x80000009 (Area 125) type 3

     

    R2#*Mar  1 00:14:25.135:    Add better path to LSA ID 128.1.136.0, gateway 0.0.0.0, dist 12

    *Mar  1 00:14:25.135:    Add path: next-hop 128.1.125.5, interface Virtual-Access1

    *Mar  1 00:14:25.143:    Add Summary Route to 128.1.136.0/255.255.255.0. Metric: 12, Next Hop: 128.1.125.5

    *Mar  1 00:14:25.147: OSPF: insert route list LS ID 128.1.136.0, type 3, adv rtr 150.1.1.1

     

    =============================================

     

    *Mar  1 00:23:31.831: OSPF: insert route list LS ID 128.1.125.5, type 0, adv rt

    R5#r 150.1.5.5

    *Mar  1 00:23:31.835: OSPF: Entered old delete routine

    *Mar  1 00:23:31.839: OSPF: ospf_gen_asbr_sum_all_areas

    *Mar  1 00:23:31.839: OSPF: running spf for summaries area 125

    *Mar  1 00:23:31.839: OSPF: Start processing Summary LSA 128.1.63.0, mask 255.255.255.0, adv 150.1.1.1, age 1357, seq 0x80000001 (Area 125) type 3

    *Mar  1 00:23:31.843:    Add better path to LSA ID 128.1.63.0, gateway 0.0.0.0, dist 11122

    *Mar  1 00:23:31.847:    Add path: next-hop 128.1.125.1, interface Virtual-Access2

    *Mar  1 00:23:31.851:    Add Summary Route to 128.1.63.0/255.255.255.0. Metric: 11122, Next Hop: 128.1.125.1

    *Mar  1 00:23:31.855: OSPF: insert route list LS ID 128.1.63.0, type 3, adv rtr 150.1.1.1

    *Mar  1 00:23:31.859: OSPF: Start processing Summary LSA 128.1.136.0, mask 255.255.255.0, adv 150.1.1.1, age 1023, seq 0x80000009 (Area 125) type 3

    *Mar  1 00:23:31.863:    Add better path to LSA ID 128.1.136.0, gateway 0.0.0.0, dist 11

    *Mar  1 00:23:31.863:    Add path: next-hop 1

    R5#28.1.125.1, interface Virtual-Access2

    *Mar  1 00:23:31.867:    Add Summary Route to 128.1.136.0/255.255.255.0. Metric: 11, Next Hop: 128.1.125.1

    *Mar  1 00:23:31.871: OSPF: insert route list LS ID 128.1.136.0, type 3, adv rtr 150.1.1.1

    *Mar  1 00:23:31.875: OSPF: sum_delete_old_routes area 125

    *Mar  1 00:23:31.875: OSPF: Started Building Type 5 External Routes

    *Mar  1 00:23:31.879: OSPF: ex_delete_old_routes

    *Mar  1 00:23:31.879: OSPF: Started Building Type 7 External Routes

    *Mar  1 00:23:31.879: OSPF: ex_delete_old_routes

    *Mar  1 00:23:32.291: OSPF: Detect change in LSA type 1, LSID 150.1.2.2, from 150.1.2.2 area 125

    *Mar  1 00:23:32.295: OSPF: Schedule SPF in area 125

          Change in LS ID 150.1.2.2, LSA type R, , spf-type Full

    R5#

    R5#:    Add better path to LSA ID 128.1.125.2, gateway 128.1.125.2, dist 1

    *Mar  1 00:23:41.919:    Add path: next-hop 128.1.125.2, interface Virtual-Access2

    *Mar  1 00:23:41.919: OSPF: Adding Stub nets

    *Mar  1 00:23:41.919: OSPF: delete lsa id 128.1.125.1, type 0, adv rtr 150.1.1.1 from delete list

    *Mar  1 00:23:41.919: OSPF: insert route list LS ID 128.1.125.1, type 0, adv rtr 150.1.1.1

    *Mar  1 00:23:41.923: OSPF: insert route list LS ID 128.1.125.2, type 0, adv rtr 150.1.2.2

    *Mar  1 00:23:41.927: OSPF: delete lsa id 128.1.125.5, type 0, adv rtr 150.1.5.5 from delete list

    *Mar  1 00:23:41.935: OSPF: insert route list LS ID 128.1.125.5, type 0, adv rtr 150.1.5.5

    *Mar  1 00:23:41.935: OSPF: Entered old delete routine

    *Mar  1 00:23:41.935: OSPF: ospf_gen_asbr_sum_all_areas

    *Mar  1 00:23:41.935: OSPF: running spf for summaries area 125

    *Mar  1 00:23:41.935: OSPF: Start processing Summary LSA 128.1.63.0, mask 255.255.255.0, adv 150.1.1.1, age 1367, seq 0x80000001 (Area 125) type

    R5#3

    *Mar  1 00:23:41.935:    Add better path to LSA ID 128.1.63.0, gateway 0.0.0.0, dist 11122

    *Mar  1 00:23:41.935:    Add path: next-hop 128.1.125.1, interface Virtual-Access2

    *Mar  1 00:23:41.943: OSPF: delete lsa id 128.1.63.0, type 3, adv rtr 150.1.1.1 from delete list

    *Mar  1 00:23:41.947:    Add Summary Route to 128.1.63.0/255.255.255.0. Metric: 11122, Next Hop: 128.1.125.1

    *Mar  1 00:23:41.951: OSPF: insert route list LS ID 128.1.63.0, type 3, adv rtr 150.1.1.1

    *Mar  1 00:23:41.951: OSPF: Start processing Summary LSA 128.1.136.0, mask 255.255.255.0, adv 150.1.1.1, age 1033, seq 0x80000009 (Area 125) type 3

    *Mar  1 00:23:41.951:    Add better path to LSA ID 128.1.136.0, gateway 0.0.0.0, dist 11

    *Mar  1 00:23:41.951:    Add path: next-hop 128.1.125.1, interface Virtual-Access2

    *Mar  1 00:23:41.951: OSPF: delete lsa id 128.1.136.0, type 3, adv rtr 150.1.1.1 from delete list

    *Mar  1 00:23:41.951:    Add Summary Route to 128.1.136.0/255.255.255.0. Metric: 11, Next Hop: 128.

    R5#1.125.1

    *Mar  1 00:23:41.951: OSPF: insert route list LS ID 128.1.136.0, type 3, adv rtr 150.1.1.1

    *Mar  1 00:23:41.951: OSPF: sum_delete_old_routes area 125

    *Mar  1 00:23:41.951: OSPF: Started Building Type 5 External Routes

    *Mar  1 00:23:41.951: OSPF: ex_delete_old_routes

    *Mar  1 00:23:41.951: OSPF: Started Building Type 7 External Routes

    *Mar  1 00:23:41.951: OSPF: ex_delete_old_routes

    R5#

     

  • What network type are you running in area 125?

     

  • Eric, can you please provide me the configuration of the three routers. Its sound insteresting this problem. I will try to see what are you trying to tell us.

    regards

  • Below is configured. Thanks in advance.

    host R1

    int s1/0
    encap frame
    no shut
    int s1/0.1 multipoint
    frame interface-dlci 105 ppp virtual-template1
    exit

    int virtual-template1
    ip address 128.1.125.1 255.255.255.0
    ip ospf network point-to-multipoint
    exit

    router ospf 55
    router-id 150.1.1.1
    network 128.1.136.1 0.0.0.0 area 0
    network 128.1.125.1 0.0.0.0 area 125
    exit
    ====================================
    host R2

    int s1/0
    encap frame
    no shut
    int s1/0.1 multipoint
    frame interface-dlci 205 ppp virtual-template1
    exit

    int virtual-template1
    ip address 128.1.125.2 255.255.255.0
    ip ospf network point-to-multipoint
    exit

    router ospf 55
    router-id 150.1.2.2
    network 128.1.125.2 0.0.0.0 area 125
    exit
    ======================================
    host R5

    int s1/0
    encap frame
    no shut
    int s1/0.1 multipoint
    frame interface-dlci 501 ppp virtual-template1
    frame interface-dlci 502 ppp virtual-template1
    exit

    int virtual-template1
    ip address 128.1.125.5 255.255.255.0
    ip ospf network point-to-multipoint
    exit

    router ospf 55
    router-id 150.1.5.5
    network 128.1.125.5 0.0.0.0 area 125
    exit

  • Very interesting situation Eric.

    I just configure OSPF between R1-R5 and have the same situation. No OSPF adjacency between R2-R5. So i think is not an OSPF situation with ABR´s an router-id

    What i did is to delete both frame-relay interface-dlci on R5. Then apply dlci to R2, wait the ppp to come up, then add the dlci to R1, and worked.

    When adding the dlci in order, first 301 and then 302 this is what i get

    R5#show ip ospf neighbor

    Neighbor ID     Pri   State           Dead Time   Address         Interface
    150.1.1.1         0   FULL/  -        00:01:45    128.1.125.1     Virtual-Access2

    R5#show ip route
    Gateway of last resort is not set

         128.1.0.0/16 is variably subnetted, 4 subnets, 2 masks
    O IA    128.1.136.0/24 [110/2] via 128.1.125.1, 00:00:02, Virtual-Access1
    C       128.1.125.0/24 is directly connected, Virtual-Access2
                           is directly connected, Virtual-Access1
    C       128.1.125.1/32 is directly connected, Virtual-Access2
    C       128.1.125.2/32 is directly connected, Virtual-Access1
    R5#ping 128.1.136.1

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 128.1.136.1, timeout is 2 seconds:
    .....
    Success rate is 0 percent (0/5)
    R5#


    When adding the dlci in the following order, first 302 and then 301 this is what i get

    R5#show ip ospf neighbor

    Neighbor ID     Pri   State           Dead Time   Address         Interface
    150.1.1.1         0   FULL/  -        00:01:58    128.1.125.1     Virtual-Access1
    R5#
    R5#show ip route 

         128.1.0.0/16 is variably subnetted, 4 subnets, 2 masks
    O IA    128.1.136.0/24 [110/2] via 128.1.125.1, 00:00:18, Virtual-Access1
    C       128.1.125.0/24 is directly connected, Virtual-Access2
                           is directly connected, Virtual-Access1
    C       128.1.125.1/32 is directly connected, Virtual-Access1
    C       128.1.125.2/32 is directly connected, Virtual-Access2
    R5#
    R5#ping 128.1.136.1          

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 128.1.136.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms
    R5#

    Can someone give an explanation!!!

  • I get the same results. Dang --  that is a wee bit quirky.

     

    R5(config)#no interface Serial0/0.1 multipoint
    R5(config)#interface Serial0/0.1 multipoint
    R5(config-subif)#frame-relay interface-dlci 502 ppp Virtual-Template1
    R5(config-fr-dlci)#frame-relay interface-dlci 501 ppp Virtual-Template1

    R5#p 128.1.136.1

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 128.1.136.1, timeout is 2 seconds:
    !!!!!

    R5(config)#no interface Serial0/0.1 multipoint
    R5(config)#interface Serial0/0.1 multipoint
    R5(config-subif)#frame-relay interface-dlci 501 ppp Virtual-Template1
    R5(config-fr-dlci)#frame-relay interface-dlci 502 ppp Virtual-Template1

    R5#p 128.1.136.1

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 128.1.136.1, timeout is 2 seconds:
    .....

  • <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">






    Try P2P?  There have been some interesting
    (translation = disturbing) changes in IOS versions about how differnt OSPF
    network types work or don't work in PPPoFR scenarios.

     

    You can try broadcast as well with R5 as the
    DR.

     

    Remind me which lab it is, and I'll try to put it on a rack
    tomorrow and get some better information for you guys...

     

    Scott

     





    From: [email protected] [mailto:[email protected]eoc.com]
    On Behalf Of bam
    Sent: Sunday, September 07, 2008 9:37
    PM
    To: [email protected]
    Subject: Re: [CCIE
    R&S] RE: OSPF problem


    I get the same results. Dang --  that is a wee bit quirky.

     

    R5(config)#no interface Serial0/0.1 multipoint

    R5(config)#interface Serial0/0.1 multipoint
    R5(config-subif)#frame-relay
    interface-dlci 502 ppp Virtual-Template1
    R5(config-fr-dlci)#frame-relay
    interface-dlci 501 ppp Virtual-Template1

    R5#p 128.1.136.1

    Type
    escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 128.1.136.1,
    timeout is 2 seconds:
    !!!!!

    R5(config)#no interface Serial0/0.1
    multipoint
    R5(config)#interface Serial0/0.1
    multipoint
    R5(config-fr-dlci)#frame-relay interface-dlci 501 ppp
    Virtual-Template1
    R5(config-fr-dlci)#frame-relay interface-dlci 502 ppp
    Virtual-Template1

    R5#p 128.1.136.1

    Type escape sequence to
    abort.
    Sending 5, 100-byte ICMP Echos to 128.1.136.1, timeout is 2
    seconds:
    .....




    Internetwork
    Expert - The Industry Leader in CCIE
    Preparation
    http://www.internetworkexpert.com

    Subscription information
    may be found
    at:
    http://www.ieoc.com/forums/ForumSubscriptions.aspx
  • I'm not sure which lab this is -- I just used the one that's posted. I'm betting that you need to use multipoint.

    The weirdness is that the first DLCI configured in the hub (R5) must be to the ABR (R1). So I suppose the question is... is there a technical reason for that or is this a 'feature'?

     

    BTW - I did try using p2p on R1 and R2 -- the problem is the same. Also tried broadcast -- 128.1.136.0 doesn't show up in R5's routing table but the summary lsa is in R5's DB.

    Neat.

  • This is deffinately IEWB Volume III Lab 5.

     

  • Just another question.

    Virtual-Template ospf default network type is point-to-point

    R5#show run int virtual-template 1
    !
    interface Virtual-Template1
     ip address 128.1.125.5 255.255.255.0
    !

    R5#show ip ospf interface


    Virtual-Access2 is up, line protocol is up
      Internet Address 128.1.125.5/24, Area 125
      Process ID 1, Router ID 150.1.1.3, Network Type POINT_TO_POINT, Cost: 1
      Transmit Delay is 1 sec, State POINT_TO_POINT,
      Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
        oob-resync timeout 40
        Hello due in 00:00:09
      Index 3/3, flood queue length 0
      Next 0x0(0)/0x0(0)
      Last flood scan length is 1, maximum is 1
      Last flood scan time is 0 msec, maximum is 0 msec
      Neighbor Count is 0, Adjacent neighbor count is 0
      Suppress hello for 0 neighbor(s)

    Virtual-Access1 is up, line protocol is up
      Internet Address 128.1.125.5/24, Area 125
      Process ID 1, Router ID 150.1.1.3, Network Type POINT_TO_POINT, Cost: 1
      Transmit Delay is 1 sec, State POINT_TO_POINT,
      Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
        oob-resync timeout 40
        Hello due in 00:00:08
      Index 2/2, flood queue length 0
      Next 0x0(0)/0x0(0)
      Last flood scan length is 1, maximum is 1
      Last flood scan time is 0 msec, maximum is 0 msec
      Neighbor Count is 1, Adjacent neighbor count is 1
        Adjacent with neighbor 150.1.1.1
      Suppress hello for 0 neighbor(s)


    Virtual-Template1 is down, line protocol is down
      Internet Address 128.1.125.5/24, Area 125
      Process ID 1, Router ID 150.1.1.3, Network Type POINT_TO_POINT, Cost: 1
      Transmit Delay is 1 sec, State DOWN,
      Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
        oob-resync timeout 40
    R5#

    So, why, if adjacency is up, network 128.1.136.0/24 is not inserted on the ip routing table.

    R5#show ip ospf neighbor

    Neighbor ID     Pri   State           Dead Time   Address         Interface
    150.1.1.1         0   FULL/  -        00:00:38    128.1.125.1     Virtual-Access1
    R5#

    R5#show ip ospf database

                OSPF Router with ID (150.1.1.3) (Process ID 1)

                    Router Link States (Area 125)

    Link ID         ADV Router      Age         Seq#       Checksum Link count
    150.1.1.1       150.1.1.1       468         0x80000037 0x000F0F 2
    150.1.1.3       150.1.1.3       380         0x80000041 0x00ED11 3

                    Summary Net Link States (Area 125)

    Link ID         ADV Router      Age         Seq#       Checksum
    128.1.136.0     150.1.1.1       468         0x80000004 0x00BCD8

    R5#show ip route 

         128.1.0.0/16 is variably subnetted, 3 subnets, 2 masks
    C       128.1.125.0/24 is directly connected, Virtual-Access1
                           is directly connected, Virtual-Access2
    C       128.1.125.1/32 is directly connected, Virtual-Access1
    C       128.1.125.2/32 is directly connected, Virtual-Access2
    R5#

    When having "ip ospf network point-to-multipoint" the debug shows:

    Sep  8 10:36:52.761 UTC: OSPF: Rcv Update Type 3, LSID 128.1.136.0, Adv rtr 150.1.1.1, age 435, seq 0x80000001
    Sep  8 10:36:52.761 UTC:       Mask /24
    Sep  8 10:36:55.261 UTC: OSPF: Ack Type 3, LSID 128.1.136.0, Adv rtr 150.1.1.1, age 435, seq 0x80000001
    Sep  8 10:37:02.805 UTC: RT: add 128.1.136.0/24 via 128.1.125.1, ospf metric [110/2]
    Sep  8 10:37:02.805 UTC: RT: NET-RED 128.1.136.0/24

    When removing "ip ospf network point-to-multipoint" the debug shows:

    Sep  8 10:38:21.581 UTC: OSPF: Rcv Update Type 3, LSID 128.1.136.0, Adv rtr 150.1.1.1, age 524, seq 0x80000001
    Sep  8 10:38:21.581 UTC:       Mask /24
    Sep  8 10:38:24.081 UTC: OSPF: Ack Type 3, LSID 128.1.136.0, Adv rtr 150.1.1.1, age 524, seq 0x80000001

    But no IP Routing insertion of the LSA Type 3.

  • Seems like this issue has been around awhile...

    http://forum.internetworkexpert.com/ubbthreads.php/ubb/showflat/Number/11492/page/1

    I'd say this is either not supported or a bug. Either way, perhaps the point of this lab is to point out this quirky behavior.

Sign In or Register to comment.