BGP DEFAULT ROUTE REDISTRIBUTION IN RIP AND OSPF

i tried to do redistribute bgp in rip and pushed default routes in to r3 and r4 via r5 and r6 over BGP respectively.

 

my first case got successful as bgp routes are redistributed into rip.

 

i created 5.5.5.5 as loop back interface in both r5 and r6 and advertised over EBGP .

 

i created a local preference so that all traffic should be pointed towards r6 if it fails r5 should take over the routes.

 

but when r6 link is live im not able to reach 5.5.5.5 through r1 but from r2 im able to reach 5.5.5.5

but when r6 link goes down im able to reach 5.5.5.5 through r1 but not from r2.

 

what could be the possible problem??

 

 

HOW TO UPLOAD MY FILES HERE SO THAT EVERYONE CAN GET AN IDEA!!!!

Comments

  • R1 and R2 are ospf neigbors and also with r3 r4 are bgp routers r5 and r6 are service providers.

    my configurations 

     

    R1 

    interface FastEthernet0/0

     ip address 192.168.12.1 255.255.255.0

     duplex auto

     speed auto

    !

    interface FastEthernet1/0

     ip address 192.168.13.1 255.255.255.0

     duplex auto

     speed auto

    !

    router ospf 1

     log-adjacency-changes

     network 0.0.0.0 255.255.255.255 area 0

    R2


    interface FastEthernet0/0

     ip address 192.168.12.2 255.255.255.0

     duplex auto

     speed auto

    !

    interface FastEthernet1/0

     ip address 192.168.24.2 255.255.255.0

     duplex auto

     speed auto

    !

    router ospf 1

     log-adjacency-changes

     network 0.0.0.0 255.255.255.255 area 0



    R3


    interface FastEthernet0/0

     ip address 192.168.35.3 255.255.255.0

     duplex auto

     speed auto

    !

    interface FastEthernet1/0

     ip address 192.168.13.3 255.255.255.0

     duplex auto

     speed auto

    !

    interface FastEthernet2/0

     ip address 192.168.34.3 255.255.255.0

     duplex auto

     speed auto

    !

    router ospf 1

     log-adjacency-changes

     redistribute bgp 1 metric 1 subnets

     network 192.168.13.0 0.0.0.255 area 0

     default-information originate

    !

    router bgp 1

     no synchronization

     bgp log-neighbor-changes

     network 192.168.13.0

     network 192.168.34.0

     network 192.168.35.0

     neighbor 192.168.34.4 remote-as 1

     neighbor 192.168.35.5 remote-as 2

     neighbor 192.168.35.5 route-map LOCAL_PREF in

     no auto-summary

    !

    no ip http server

    no ip http secure-server

    !

    !

    !

    !

    route-map LOCAL_PREF permit 10

     set local-preference 10



    R4


    interface FastEthernet0/0

     ip address 192.168.46.4 255.255.255.0

     duplex auto

     speed auto

    !

    interface FastEthernet1/0

     ip address 192.168.24.4 255.255.255.0

     duplex auto

     speed auto

    !

    interface FastEthernet2/0

     ip address 192.168.34.4 255.255.255.0

     duplex auto

     speed auto

    !

    router ospf 1

     log-adjacency-changes

     redistribute bgp 1 metric 1 subnets

     network 192.168.24.0 0.0.0.255 area 0

     default-information originate

    !

    router bgp 1

     no synchronization

     bgp log-neighbor-changes

     network 192.168.24.0

     network 192.168.34.0

     neighbor 192.168.34.3 remote-as 1

     neighbor 192.168.46.6 remote-as 3

     neighbor 192.168.46.6 shutdown

     neighbor 192.168.46.6 route-map LOCAL_PREF in

     no auto-summary

    !

    no ip http server

    no ip http secure-server

    !

    !

    !

    !

    route-map LOCAL_PREF permit 10

     set local-preference 200



    R5


    interface Loopback0

     ip address 5.5.5.5 255.255.255.0

    !

    interface FastEthernet0/0

     ip address 192.168.35.5 255.255.255.0

     duplex auto

     speed auto

    !

    interface FastEthernet1/0

     no ip address

     shutdown

     duplex auto

     speed auto

    !

    router bgp 2

     no synchronization

     bgp log-neighbor-changes

     network 5.5.5.0

     network 5.5.5.0 mask 255.255.255.0

     neighbor 192.168.35.3 remote-as 1

     neighbor 192.168.35.3 default-originate

     no auto-summary




    interface Loopback0

     ip address 5.5.5.5 255.255.255.0

    !

    interface FastEthernet0/0

     ip address 192.168.46.6 255.255.255.0

     duplex auto

     speed auto

    !

    interface FastEthernet1/0

     no ip address

     shutdown

     duplex auto

     speed auto

    !

    router bgp 3

     no synchronization

     bgp log-neighbor-changes

     network 5.5.5.0 mask 255.255.255.0

     neighbor 192.168.46.4 remote-as 1

     neighbor 192.168.46.4 default-originate

     no auto-summary



    R1 routes



    C    192.168.12.0/24 is directly connected, FastEthernet0/0

    C    192.168.13.0/24 is directly connected, FastEthernet1/0

    O    192.168.24.0/24 [110/2] via 192.168.12.2, 00:48:45, FastEthernet0/0

         5.0.0.0/24 is subnetted, 1 subnets

    O E2    5.5.5.0 [110/1] via 192.168.13.3, 00:41:32, FastEthernet1/0

    O E2 192.168.34.0/24 [110/1] via 192.168.13.3, 00:48:45, FastEthernet1/0

    O E2 192.168.35.0/24 [110/1] via 192.168.13.3, 00:48:45, FastEthernet1/0

    O*E2 0.0.0.0/0 [110/1] via 192.168.13.3, 00:30:53, FastEthernet1/0



    R2 routes


    C    192.168.12.0/24 is directly connected, FastEthernet0/0

    O    192.168.13.0/24 [110/2] via 192.168.12.1, 00:48:37, FastEthernet0/0

    C    192.168.24.0/24 is directly connected, FastEthernet1/0

         5.0.0.0/24 is subnetted, 1 subnets

    O E2    5.5.5.0 [110/1] via 192.168.12.1, 00:41:25, FastEthernet0/0

    O E2 192.168.34.0/24 [110/1] via 192.168.24.4, 00:48:37, FastEthernet1/0

    O E2 192.168.35.0/24 [110/1] via 192.168.12.1, 00:48:37, FastEthernet0/0

    O*E2 0.0.0.0/0 [110/1] via 192.168.12.1, 00:30:45, FastEthernet0/0




    R2#ping 5.5.5.5


    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 5.5.5.5, timeout is 2 seconds:

    ..




    R1#ping 5.5.5.5


    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 5.5.5.5, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 20/37/64 ms




  • hi gautam.ntwks

    becuse R5 doesn't have any roue to 192.168.12.0/24

    you can advertiset this link in r3

    you advertise just 192.168.13.0/24 and 192.168.34.0/24 and 192.168.24.0/0

    R2 chose R1-R3-R5

     

Sign In or Register to comment.