Setting up new Loopback interface in Linux for TermServ

Can anyone point me in the right direction on setting up a loopback interface on Linux to be used by the TermServ?

 

I set up a lo:0 interface by adding the following to my /etc/network/interfaces file:

auto lo:0
iface lo:0 inet static
address 10.100.100.100
netmask 255.255.255.0

I can ping this 10.100.100.100 from within Linux.

 

Under the TermServ dynagen config, I added the following line:

E0/0 = NIO_linux_eth:lo:0

 

I configured the TermServ's E0/0 with an IP address/mask of 10.100.100.101/24.   The TermServ cannot ping the 10.100.100.100 address on the Linux box's lo:0 interface.  I have a feeling the issue is with the dynagen .net config shown above.

 

Any suggestions?

Comments

  • Ok, I figured it out......

     


    firestarter was my issue.




    I found a good procedure at: http://www.blindhog.net/cisco-dynamips-with-linux-loopback-tap-interface/




    Based on that, I created the following shell script to set up the tap0
    interface. I discovered I didn't need to bridge it with any other
    interface:




    Code:



    #!/bin/bash


    echo creating tap0 device


    modprobe tun


    tunctl


    ifconfig tap0 10.100.100.100 netmask 255.255.255.0 up


    echo Complete






    I set up the Terminal Server's IP address as 10.100.100.1/24. At
    this point, I still couldn't ping or telnet from the TermServ to my
    linux box. If I stopped firestarter, it worked perfectly. I did some
    research at firestarter's website: http://www.fs-security.com/docs/vpn.php and added the following to the /etc/firestarter/user-pre file

     

    Code:



    # Allow traffic on the tap0 inteface


    $IPT -A INPUT -i tap0 -j ACCEPT


    $IPT -A OUTPUT -o tap0 -j ACCEPT







    Once I restarted firestarter, all was well.




    I hope this helps people out there because I spent several hours on
    this trying to figure it out. Things like this on Linux are definitely
    not user friendly.

  • Hi Awilkins,

    I tried the configuration line by line and it worked.  Looked elsewhere online to figure out how to set up the Terminal Server online but couldn't find anything.

    I really appreciate your post.

    It would seem though that I must create the script because the tap0 interface disappears after the reboot. 

    I have a linux noob question about the script above.  If I create the file above, do I need a ".sh" extension on it?  Most importantly, where do I put the file?  init.d directory??

    Is there anything else that I have to worry about? file permissions, etc??

    If you can pls respond and be detailed as I'm still new to linux.

    Thanks in advance and excellent post,

    Al

Sign In or Register to comment.