BPDUFilter Default - Portfast Issue

I am hoping that someone can shed some light on what I am overlooking... 

When I configure SW4 with BPDUfilter Default globally with portfast under the interface, when I do a show span int g1/0/20 detail, I see that the interface has BPDUfilter enabled by default and the port is in portfast mode, which is expected.

Here's my issue... Whenever I convert SW2 from a routed to switch port, SW's 4 interface g1/0/20 is no longer BPDUfilter enabled as designed, but it doesn't drop being portfast enabled.

I have read in a previous post that different VLANs on each end could possibley be the cause, so I verified that both interfaces are access for VLAN 10 and I have also tried appying portfast globally and interface level and still no dice. Any ideas?

 

Before SW2 sends BPDUs to SW4:

 

SW4#sh run int g1/0/20

Building configuration...

 

Current configuration : 114 bytes

!

interface GigabitEthernet1/0/20

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

 

SW4#sh span summ

Switch is in pvst mode

Root bridge for: none

EtherChannel misconfig guard is enabled

Extended system ID           is enabled

Portfast Default             is disabled

PortFast BPDU Guard Default  is disabled

Portfast BPDU Filter Default is enabled

Loopguard Default            is disabled

UplinkFast                   is disabled

BackboneFast                 is disabled

Configured Pathcost method used is short

 

SW4#sh span int g1/0/20 portfast

VLAN0010            enabled

 

SW4#sh span int g1/0/20 detail

 Port 20 (GigabitEthernet1/0/20) of VLAN0010 is designated forwarding

   Port path cost 4, Port priority 128, Port Identifier 128.20.

   Designated root has priority 10, address 649e.f3c4.2d00

   Designated bridge has priority 32778, address 649e.f3a4.fd80

   Designated port id is 128.20, designated path cost 23

   Timers: message age 0, forward delay 0, hold 0

   Number of transitions to forwarding state: 1

   The port is in the portfast mode

   Link type is point-to-point by default

   Bpdu filter is enabled by default

   BPDU: sent 6, received 0

 

After SW2 starts sending BPDUs:

SW4#sh span int g1/0/20 detail

 Port 20 (GigabitEthernet1/0/20) of VLAN0010 is alternate blocking

   Port path cost 4, Port priority 128, Port Identifier 128.20.

   Designated root has priority 10, address 649e.f3c4.2d00

   Designated bridge has priority 32778, address e8b7.48e3.1200

   Designated port id is 128.20, designated path cost 19

   Timers: message age 4, forward delay 0, hold 0

   Number of transitions to forwarding state: 1

   The port is in the portfast mode

   Link type is point-to-point by default

   BPDU: sent 1, received 12

 

SW4#sh span int g1/0/20 portfast

VLAN0010            enabled

 

 

 

 

 

Comments

  • All of the switches are running 15.2... I have tried enabling portfast under the interface and globally and the same result is produced.

    As you mentioned, after SW2 starts to send BPDUs to SW4, SW4's interface transitions from designating forwarding to alternate blocking, so it apears that int g1/0/20 did go through the STP process after it started receiving BPDUs, but from some reason, portfast is still enabled....

    After receiving BPDUs from SW2, SW4's interface is receiving BPDUs, but it is not sending any out...

     

     

     

  • Exactly. The port isn't sending out any BPDUs, but it is still enabled with portfast... The expected behavior should have been for the port to disable portfast and go through the STP process when it started receiving BPDUs. As we can see, it went through the STP process, but it didn't disable portfast on the interface...

    I understand the theory, but I am just trying to get down and dirty and figure out why the interface is still enabled for portfast.

    The STP mode is PVST.

  • I tried removing it from the interface and applying it globally, but no dice... I am going to poke around a little more to see why I am experiencing what I am seeing, but I don't plan to spend too much time on it. I need to move on...

    Thanks for your assistance.

  • I found the same issue here. Using IOUL2 15.2d image ( only one I could find where spanning-tree actually was working and wouldn't broadcast storm me into cpu hell ).

    Mine has the spanning-tree portfast {edge|network|normal} options. i'm using edge as this equates to the access ports. But I found the exact same results ( portfast mode remains regardless ). correct me if i'm wrong but the actual IE config lab uses IOU images as well nowadays and not real gear?

Sign In or Register to comment.