L2VPN no Layer 2 connectivity

Hi,

I have no problem connecting to INE both the crypto and xconnect are up.  I am also able to see on my switch via cdp at the INE switch CO-EoR-L2TP-SW.  However that is as far as I get!!! I do not see any mac addresses coming from the trunk port on my switch from INE and on the INE switch I do not see my switch via CDP or any mac addresses.  

Here is the configuration for my switch which is currnently connected to corack1:

PLEASE I am dying to start doing labs!!

SWITCH

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname CCIE-VOICE

!

boot-start-marker

boot-end-marker

!

!

!

username cisco privilege 15 password 0 cisco

no aaa new-model

system mtu routing 1504

vtp mode transparent

!

!

!

!

!

crypto pki trustpoint TP-self-signed-633617792

 enrollment selfsigned

 subject-name cn=IOS-Self-Signed-Certificate-633617792

 revocation-check none

 rsakeypair TP-self-signed-633617792

!

!

crypto pki certificate chain TP-self-signed-633617792

 certificate self-signed 01

  30820240 308201A9 A0030201 02020101 300D0609 2A864886 F70D0101 04050030 

  30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274 

  69666963 6174652D 36333336 31373739 32301E17 0D393330 33303130 30303134 

  315A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F 

  532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3633 33363137 

  37393230 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100 

  ABA4DE08 DD221466 DA03FB99 C48F7BDE 36C3C64E 23C2C16E C7F0228B F467DB54 

  7B7F48F7 17371752 AB4EB405 42C9A802 BCB0E5A4 32CA5332 B2AAE2CF F42F764F 

  4B27F9F2 FC3BBB6E 262DC416 58856DFC D9869EC1 17FDEAB8 214B2A38 7649B13D 

  E93C4637 F8C004A5 E2C127D7 DE3C0F94 7E69ED48 00F4B6FC 1AC806CC D428AD39 

  02030100 01A36A30 68300F06 03551D13 0101FF04 05300301 01FF3015 0603551D 

  11040E30 0C820A43 4349452D 564F4943 45301F06 03551D23 04183016 80145CD1 

  31B16FD5 8C9A9C54 C3D3F4ED 81954DE7 0104301D 0603551D 0E041604 145CD131 

  B16FD58C 9A9C54C3 D3F4ED81 954DE701 04300D06 092A8648 86F70D01 01040500 

  03818100 2405752B AA876BCF EFB6ABA7 CC3020C8 D122EC71 3549B194 4A5945BD 

  CF864580 570992BB 2CD599EE 21076D9A 713F3145 01CECDCE 2A367796 EEF2A673 

  836EB0C0 4C086FED FF628C4D 0002756F 1B4C80BB D1A30263 93D6E780 6FEA1864 

  D2E4992F 47DD1295 4B4D33AE D15FECB8 01CA2B3E F919429C 105FF8B8 0164565D 6E57077C

  quit

!

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

vlan 10,2011-2016,2021-2022 

!         

interface GigabitEthernet0/1

 switchport access vlan 2011

 switchport mode dot1q-tunnel

 l2protocol-tunnel cdp

 l2protocol-tunnel stp

 l2protocol-tunnel vtp

 no cdp enable

!

interface GigabitEthernet0/2

 switchport access vlan 2012

 switchport mode dot1q-tunnel

 l2protocol-tunnel cdp

 l2protocol-tunnel stp

 l2protocol-tunnel vtp

 no cdp enable

!

interface GigabitEthernet0/3

 switchport access vlan 2013

 switchport mode dot1q-tunnel

 l2protocol-tunnel cdp

 l2protocol-tunnel stp

 l2protocol-tunnel vtp

 no cdp enable

!

interface GigabitEthernet0/4

 switchport access vlan 2014

 switchport mode dot1q-tunnel

 l2protocol-tunnel cdp

 l2protocol-tunnel stp

 l2protocol-tunnel vtp

 no cdp enable

!

interface GigabitEthernet0/5

 switchport access vlan 2015

 switchport mode dot1q-tunnel

 l2protocol-tunnel cdp

 l2protocol-tunnel stp

 l2protocol-tunnel vtp

 no cdp enable

!

interface GigabitEthernet0/6

 switchport access vlan 2016

 switchport mode dot1q-tunnel

 l2protocol-tunnel cdp

 l2protocol-tunnel stp

 l2protocol-tunnel vtp

 no cdp enable

!

interface GigabitEthernet0/7

!         

interface GigabitEthernet0/8

 switchport trunk encapsulation dot1q

 switchport trunk native vlan 2999

 switchport trunk allowed vlan 2000-2999

!

interface GigabitEthernet0/9

!

interface GigabitEthernet0/10

!

interface GigabitEthernet0/11

!

interface GigabitEthernet0/12

!

interface GigabitEthernet0/13

!

interface GigabitEthernet0/14

!

interface GigabitEthernet0/15

!

interface GigabitEthernet0/16

!

interface GigabitEthernet0/17

!

interface GigabitEthernet0/18

!

interface GigabitEthernet0/19

!

interface GigabitEthernet0/20

!

interface GigabitEthernet0/21

!

interface GigabitEthernet0/22

!

interface GigabitEthernet0/23

 switchport access vlan 10

!

interface GigabitEthernet0/24

 switchport trunk encapsulation dot1q

 switchport trunk native vlan 2999

 switchport trunk allowed vlan 2000-2999

!

interface GigabitEthernet0/25

!

interface GigabitEthernet0/26

!

interface GigabitEthernet0/27

!

interface GigabitEthernet0/28

!

interface Vlan1

 no ip address

!

interface Vlan10

 ip address 192.168.200.143 255.255.255.0

!

ip http server

ip http secure-server

 

!

logging esm config

!

line con 0

line vty 0 4

 login local

line vty 5 15

 login

!         

end 

 

Router

pseudowire-class L2VPN

encapsulation l2tpv3

ip local interface Loopback0

ip pmtu max 1400



crypto ipsec client ezvpn INEVORACK

connect auto

group corack1 key XXXXXX

mode network-extension

peer 75.140.41.126

xauth userid mode interactive



interface Loopback0

description L2VPN

ip address 11.11.11.253 255.255.255.255

crypto ipsec client ezvpn INEVORACK inside



interface Vlan1

description LAN

ip address 192.168.200.254 255.255.255.0

ip flow ingress

ip flow egress

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1412

crypto ipsec client ezvpn INEVORACK inside



interface Dialer1

description To-ISP

ip ddns update no-ip

ip address negotiated

no ip redirects

no ip unreachables

ip mtu 1452

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication pap callin

ppp pap sent-username [email protected] password 0 XXXXXXX

ppp ipcp dns request

no cdp enable

crypto ipsec client ezvpn INEVORACK

 

Home-Router#sh xconnect all 

Legend:    XC ST=Xconnect State  S1=Segment1 State  S2=Segment2 State

  UP=Up       DN=Down            AD=Admin Down      IA=Inactive

  SB=Standby  RV=Recovering      NH=No Hardware

 

XC ST  Segment 1                         S1 Segment 2                         S2

------+---------------------------------+--+---------------------------------+--

 

UP     ac   Fa2(Ethernet)                UP l2tp 11.11.11.254:123             UP

 

Home-Router#sh l2tun session 

 

L2TP Session Information Total tunnels 1 sessions 1

 

LocID      RemID      TunID      Username, Intf/      State  Last Chg Uniq ID   

                                 Vcid, Circuit                                  

 

3003870272 25082      3446184502 123, Fa2             est    01:41:18 1 

 

 

Comments

Sign In or Register to comment.