NAT POOL seems not to be working in GNS3?

Hi Team,

 

I have configured a simple NAT pool with this topology attached.

I tried to cover all 14 hosts but still the last host 10.1.1.8 can't be translated... and I am running out of options

I tried using 10.1.1.0 0.0.0.16 to just cover:

10.1.1.5 - 10.1.1.8 but still only the last host is having problems.  Does the prefix length on the pool configuration need to match the wild card mask?

 

NAT router:

R3#sh run | s nat

ip nat pool my_traders 124.24.34.250 124.24.34.253 prefix-length 24

ip nat inside source list traders pool my_traders

R3#sh run | s access-list

ip access-list extended traders

 permit ip 10.1.1.0 0.0.0.16 any


 

Thanks,

Comments

  • NAT router:

    R3#sh run | s nat

    ip nat pool my_traders 124.24.34.250 124.24.34.253 prefix-length 24

    ip nat inside source list traders pool my_traders

    R3#sh run | s access-list

    ip access-list extended traders

     permit ip 10.1.1.0 0.0.0.16 any


    You only have 4 addresses availiable for NAT in your NAT pool(.250-.253). In your diagram you have 5 hosts. The last host to try and communicate through the NAT won't be able to get an address assigned to it, and therefore will not work.

     

    Your options are either extend your NAT pool, or add the overload keyword to the end of your ip nat inside statement to enable PAT.

  • thanks! you are right, on nat pool without overload, the number of hosts to be translated should equal to the number of translated or Natted IP's.

Sign In or Register to comment.