Task 1.6 Redistribution - Core Routing

If we redistribute routes from EIGRP into OSPF and RIP and filter their tags on R3,R4 that would mean that if either of R1 or R5 goes down the OSPF or RIP will stay without EIGRP routes right?

Are you sure that tagging and filtering of routes on R1 and R5 for mutual redistribution EIGRP to OSPF/RIP would not be a better solution here?

Also, I am not sure why you used distribute list on R3,R4? It could be done by simple filtering of tags for OSPF/RIP routes trying yo get back in their originating routing process.

Should this solution below work well? or even better in some situations? OR i broke some prerequisite that I don't see?

 

----------------------------------------------------------------------------------------
R1

router eigrp EIGRP
 !
 address-family ipv4 unicast autonomous-system 56
  !
  af-interface default
   authentication mode hmac-sha-256 7 123A265637344D0A0F
  exit-af-interface
  !
  topology base
   metric maximum-hops 10
   redistribute ospf 100 metric 1 1 1 1 1 route-map OSPF-EIGRP
  exit-af-topology
  network 136.5.17.1 0.0.0.0
  network 136.5.18.1 0.0.0.0
  metric weights 0 0 0 1 0 0 0
 exit-address-family
!
router ospf 100
 router-id 192.122.3.1
 area 20 virtual-link 192.122.3.3
 area 121 nssa default-information-originate
 redistribute connected subnets route-map OSPF
 redistribute eigrp 56 subnets route-map EIGRP-OSPF
 passive-interface GigabitEthernet1/0.117
!
route-map OSPF permit 10
 match interface GigabitEthernet1/0.14 GigabitEthernet1/0.17 GigabitEthernet1/0.18
 set metric 1000
 set metric-type type-1
 set tag 12
!
route-map EIGRP-OSPF deny 20
 match tag 11
!
route-map EIGRP-OSPF permit 30
 set tag 12
!
route-map OSPF-EIGRP deny 10
 match tag 12
!
route-map OSPF-EIGRP permit 20
 set tag 11

----------------------------------------------------------------------------------------

R3

router ospf 100
 router-id 192.122.3.3
 area 20 virtual-link 192.122.3.1
 redistribute connected subnets route-map OSPF
 redistribute rip subnets route-map RIP-OSPF
!
router rip
 version 2
 redistribute ospf 100 metric 1 route-map OSPF-RIP
 passive-interface default
 no passive-interface GigabitEthernet1/0.35
 no passive-interface GigabitEthernet1/0.36
 network 10.0.0.0
 no auto-summary
!
!
route-map OSPF permit 10
 match interface GigabitEthernet1/0.23 GigabitEthernet1/0.35 GigabitEthernet1/0.36
 set metric 1000
 set metric-type type-1
 set tag 10
!
route-map OSPF-RIP deny 10
 match tag 10
!
route-map OSPF-RIP permit 20
 set tag 20
!
route-map RIP-OSPF deny 10
 match tag 20
!
route-map RIP-OSPF permit 20
 set tag 10

----------------------------------------------------------------------------------------

R4

router ospf 100
 router-id 192.122.3.4
 area 30 virtual-link 192.122.3.2
 redistribute connected subnets route-map OSPF
 redistribute rip subnets route-map RIP-OSPF
 neighbor 10.0.24.1
!
router rip
 version 2
 redistribute ospf 100 metric 1 route-map OSPF-RIP
 passive-interface default
 no passive-interface GigabitEthernet1/0.45
 no passive-interface GigabitEthernet1/0.46
 network 10.0.0.0
 no auto-summary
!
route-map OSPF permit 10
 match interface GigabitEthernet1/0.14 GigabitEthernet1/0.45 GigabitEthernet1/0.46
 set metric 1000
 set metric-type type-1
 set tag 10
!
route-map OSPF-RIP deny 10
 match tag 10
!
route-map OSPF-RIP permit 20
 set tag 20
!
route-map RIP-OSPF deny 10
 match tag 20
!
route-map RIP-OSPF permit 20
 set tag 10

----------------------------------------------------------------------------------------

R5


router eigrp EIGRP
 !
 address-family ipv4 unicast autonomous-system 56
  !
  af-interface default
   authentication mode hmac-sha-256 7 0027304721644A082A
  exit-af-interface
  !
  topology base
   metric maximum-hops 10
   redistribute rip metric 1 1 1 1 1 route-map RIP-EIGRP
  exit-af-topology
  network 136.6.58.5 0.0.0.0
  metric weights 0 0 0 1 0 0 0
 exit-address-family
!
router rip
 version 2
 redistribute eigrp 56 metric 1 route-map EIGRP-RIP
 passive-interface default
 no passive-interface GigabitEthernet1/0.35
 no passive-interface GigabitEthernet1/0.45
 no passive-interface GigabitEthernet1/0.56
 network 10.0.0.0
 network 192.122.3.0
 no auto-summary
!
ip forward-protocol nd
!
!
no ip http server
ip http secure-server
!
!
route-map EIGRP-RIP deny 10
 match tag 11
!
route-map EIGRP-RIP permit 20
 set tag 12
!
route-map RIP-EIGRP deny 10
 match tag 12
!
route-map RIP-EIGRP permit 20
 set tag 11

 

 

Thanks,

Comments

  • Hello Valder, 

    As mentioned in previous posts and specified in the lab solutions, there are multiple ways to accomplish the same thing. If your configurations give you the results that the lab requested then that is all that matters at the end. From a grading perspective, it does not matter if you use solution A or B as long as you do not violate restrictions and accomplish the task.

    Redistribution is filled with "gives and takes". Your solution takes redundancy into account, but you end up with suboptimal routing. For example, R3 and R4 will route into the OSPF domain to get to RIP routes. Tagging and just denying them from being redistributed does not always work, because the routes still make it to the RIB via the other protocol. If you block the routes from entering the RIB then you end up with optimal routing, but then you lose redundancy....there is no "win/win" here. 

    Additinally, your solution would not work if external EIGRP routes were to be introduced (say if R7 or R8 redistributed their loopbacks or some other networks). The EIGRP routes redistributed into RIP on R5 would make it to R1 via OSPF, R1 would prefer them via OSPF (AD 110 vs 170) and would feed them back into EIGRP. The tagging mechanism you used here would not account for that.

    The lab was written to show multiple ways of dealing with issues in redistribution...each one has pros and cons. Its good to be able to have options, and not always stick to tagging and blocking from redistribution or whatever your favority mechanism may be. What if the lab restricts using one method? Knowing the options you have, and the pros/cons (redundancy vs optimal routing) of each solution is key. 

    Regards,

  • Yeah I think based on my solution, I didn't account for anything except reachability. I use tags on R1 and R5, block tags on R3, use AD on R4 and metrics on R5 and R4. It works [H]

     

    R1:

    router eigrp EIGRP

     !

     address-family ipv4 unicast autonomous-system 56

      !

      topology base

       redistribute ospf 100 metric 100000 0 255 1 1500

       !

    router ospf 100

     redistribute eigrp 56 subnets route-map TAG_EIGRP

    !

    route-map TAG_EIGRP permit 10

     set tag 56

     

     

     R3:

    router ospf 100

     redistribute rip subnets route-map TAGGED_EIGRP

    router rip

     redistribute ospf 100 metric 1 route-map TAGGED_EIGRP

    !

    route-map TAGGED_EIGRP deny 10

     match tag 56

    !

    route-map TAGGED_EIGRP deny 20

     

     

     R4:

    router ospf 100

     redistribute rip metric 121 subnets

    router rip

     redistribute ospf 100 metric 7

     

     

     R5:

     router eigrp EIGRP

     !

     address-family ipv4 unicast autonomous-system 56

      !

      topology base

       redistribute rip metric 10 0 255 1 1500

    router rip

     redistribute eigrp 56 metric 7 route-map TAG_EIGRP

     !

     route-map TAG_EIGRP permit 10

     set tag 56

  • Problem with redistributions might be "works now but not later" which means it may brake your topology and lab. Don't like redistributing.  Save and reload and check for loops.

     

  • Just tried lab this;  it is harder than it looks.....  got a headache now!

     

Sign In or Register to comment.