9.4 - IPv6 EUI-64 Addressing

Hello Guys!

 

I was doing the 9.4 - IPv6 EUI-64 Addressing task when I notice that when you manually configure the link-local address then after configure a EUI-64 address, this last inherit the host portion from the EUI-64 address that I have configured.

I'd like to know, this is a normal behavior?

Follow bellow the outputs:


===================================================

With link-local manually configured

===================================================

R4(config-subif)#do show run int e0/0.146

Building configuration...

 

Current configuration : 170 bytes

!

interface Ethernet0/0.146

 encapsulation dot1Q 146

 ip address 155.1.146.4 255.255.255.0

 ipv6 address FE80::4 link-local

 ipv6 address 2001:155:1:146::/64 eui-64

end

!

!

!                  ^

R4(config-subif)#do show ipv6 int e0/0.146

Ethernet0/0.146 is up, line protocol is up

  IPv6 is enabled, link-local address is FE80::4 

  No Virtual link-local address(es):

  Global unicast address(es):

    2001:155:1:146::4, subnet is 2001:155:1:146::/64 [EUI]

  Joined group address(es):

    FF02::1

    FF02::2

    FF02::1:FF00:4

  MTU is 1500 bytes

  ICMP error messages limited to one every 100 milliseconds

  ICMP redirects are enabled

  ICMP unreachables are sent

  ND DAD is enabled, number of DAD attempts: 1

  ND reachable time is 30000 milliseconds (using 30000)

  ND advertised reachable time is 0 (unspecified)

  ND advertised retransmit interval is 0 (unspecified)

  ND router advertisements are sent every 200 seconds

  ND router advertisements live for 1800 seconds

  ND advertised default router preference is Medium

  Hosts use stateless autoconfig for addresses.

!

!

!

===================================================

Without link-local manually configured

===================================================

R4(config-subif)#do show run int e0/0.146           

Building configuration...

 

Current configuration : 137 bytes

!

interface Ethernet0/0.146

 encapsulation dot1Q 146

 ip address 155.1.146.4 255.255.255.0

 ipv6 address 2001:155:1:146::/64 eui-64

end

!

!

!R4(config-subif)#do show ipv6 int e0/0.146          

Ethernet0/0.146 is up, line protocol is up

  IPv6 is enabled, link-local address is FE80::A8BB:CCFF:FE00:6800 

  No Virtual link-local address(es):

  Global unicast address(es):

    2001:155:1:146:A8BB:CCFF:FE00:6800, subnet is 2001:155:1:146::/64 [EUI]

  Joined group address(es):

    FF02::1

    FF02::2

    FF02::1:FF00:6800

  MTU is 1500 bytes

  ICMP error messages limited to one every 100 milliseconds

  ICMP redirects are enabled

  ICMP unreachables are sent

  ND DAD is enabled, number of DAD attempts: 1

  ND reachable time is 30000 milliseconds (using 30000)

  ND advertised reachable time is 0 (unspecified)

  ND advertised retransmit interval is 0 (unspecified)

  ND router advertisements are sent every 200 seconds

  ND router advertisements live for 1800 seconds

  ND advertised default router preference is Medium

  Hosts use stateless autoconfig for addresses.


Thanks in advance!

Renato Besson

Sign In or Register to comment.