MTI tunnel interface no input packets

Hi,

I have used the INE rack rentals and observed a problem in MVPN configs.

After a standard mdt configuration as below , only IOS XR router has a pim neighborship over the MTI tunnel yet  its IOS  PE neighbors will not have the same.show ip pim vrf X neighborship on 7200 12.233 SRE3 routers has no neighbor over the MTI . Debug ip pim vrf X hello shows only sent hellos over the tunnel and none received.Actually the tunnel int has 0 input packets.

 

ip multicast-routing

ip pim ssm default

!

ip multicast-routing vrf ABC

!

vrf definition ABC

address-family ipv4

mdt default 232.1.2.19

mdt data 232.2.255.0 0.0.0.255

!

interface Loopback0

ip pim sparse-mode

!

interface FastEthernet0/0

ip pim sparse-mode

!

interface FastEthernet1/0.24

ip pim sparse-mode

!

router bgp 26

address-family ipv4 mdt

neighbor 1.1.1.1 activate

neighbor 19.19.19.19 activate

exit-address-family

!

I am beginning to suspect hardware though i hope someone has a resolution for this. 

Comments



  • There are many possibilities that could be wrong here, I would start by asking to show me you're complete configs on the XRs "show run router pim" "show run multicast"

    On IOS sh run | s pim|multicast "show ip pim VRF X int"

    On XR you have to define your MDT source under global IPv4 unicast AF

    Likewise on IOS sometimes the mGRE tunnel does not come up after you define the MDT default address due to order of operations issues...

    The MDT AF is required to learn non directly connected MDT peers if there is no RP servicing the default MDT group address

    Likewise if you could show me the task your working on so I can reference it.

    On 26 Sep 2014, at 07:47, mwmaina <[email protected]> wrote:

    Hi,

    I have used the INE rack rentals and observed a problem in MVPN configs.

    After a standard mdt configuration as below , only IOS XR router has a pim neighborship over the MTI tunnel yet  its IOS  PE neighbors will not have the same.show ip pim vrf X neighborship on 7200 12.233 SRE3 routers has no neighbor over the MTI . Debug ip pim vrf X hello shows only sent hellos over the tunnel and none received.Actually the tunnel int has 0 input packets.

     

    ip multicast-routing

    ip pim ssm default

    !

    ip multicast-routing vrf ABC

    !

    vrf definition ABC

    address-family ipv4

    mdt default 232.1.2.19

    mdt data 232.2.255.0 0.0.0.255

    !

    interface Loopback0

    ip pim sparse-mode

    !

    interface FastEthernet0/0

    ip pim sparse-mode

    !

    interface FastEthernet1/0.24

    ip pim sparse-mode

    !

    router bgp 26

    address-family ipv4 mdt

    neighbor 1.1.1.1 activate

    neighbor 19.19.19.19 activate

    exit-address-family

    !

    I am beginning to suspect hardware though i hope someone has a resolution for this. 




    INE - The Industry Leader in CCIE Preparation

    http://www.INE.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx
  • I was working on full scale lab 2 on ine sp workbook and i effected all config under solution including mdt safi for both ios xr n ios.its strange ios xr 1 router could see the ios routers as neighbors under the mti but the same ios router did not have the ios xr as a neighbor on mti.i will download configs n send.

    regards,

    maureen

    On Sep 26, 2014 8:42 PM, "Sukhjit.Hayre" <[email protected]> wrote:


    There are many possibilities that could be wrong here, I would start by asking to show me you're complete configs on the XRs "show run router pim" "show run multicast"

    On IOS sh run | s pim|multicast "show ip pim VRF X int"

    On XR you have to define your MDT source under global IPv4 unicast AF

    Likewise on IOS sometimes the mGRE tunnel does not come up after you define the MDT default address due to order of operations issues...

    The MDT AF is required to learn non directly connected MDT peers if there is no RP servicing the default MDT group address

    Likewise if you could show me the task your working on so I can reference it.

    On 26 Sep 2014, at 07:47, mwmaina <[email protected]> wrote:

    Hi,

    I have used the INE rack rentals and observed a problem in MVPN configs.

    After a standard mdt configuration as below , only IOS XR router has a pim neighborship over the MTI tunnel yet  its IOS  PE neighbors will not have the same.show ip pim vrf X neighborship on 7200 12.233 SRE3 routers has no neighbor over the MTI . Debug ip pim vrf X hello shows only sent hellos over the tunnel and none received.Actually the tunnel int has 0 input packets.

     

    ip multicast-routing

    ip pim ssm default

    !

    ip multicast-routing vrf ABC

    !

    vrf definition ABC

    address-family ipv4

    mdt default 232.1.2.19

    mdt data 232.2.255.0 0.0.0.255

    !

    interface Loopback0

    ip pim sparse-mode

    !

    interface FastEthernet0/0

    ip pim sparse-mode

    !

    interface FastEthernet1/0.24

    ip pim sparse-mode

    !

    router bgp 26

    address-family ipv4 mdt

    neighbor 1.1.1.1 activate

    neighbor 19.19.19.19 activate

    exit-address-family

    !

    I am beginning to suspect hardware though i hope someone has a resolution for this. 




    INE - The Industry Leader in CCIE Preparation

    http://www.INE.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx



    INE - The Industry Leader in CCIE Preparation

    http://www.INE.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx
  • [View:/cfs-file.ashx/__key/CommunityServer.Components.UserFiles/00.00.01.60.80/2014.09.25_2D00_S4_2D00_23.32_2D00_sprack5.zip]

    the running config on IOS XR is as below

    multicast-routing

     address-family ipv4

      interface Loopback0

       enable

      !

      interface GigabitEthernet0/1/0/1

     no shutdown

       enable

      !

     !

     vrf ABC

      address-family ipv4

       interface POS0/6/0/0

        enable

       !

       mdt source Loopback0

       mdt default ipv4 232.1.2.19

      !

     !

    router pim

     vrf ABC

      address-family ipv4

       rp-address 10.0.0.1

      !

     !


    router bgp 26

     

     address-family ipv4 mdt

     !

     neighbor 1.1.1.1

      remote-as 26

      update-source Loopback0

      

      address-family ipv4 mdt

      !

     !

     neighbor 2.2.2.2


    remote-as 26

      update-source Loopback0

     

      address-family ipv4 mdt

      !

     !


    I have attached all configurations for R1,R2,XR1 and the intermediate routers.


    [View:/cfs-file.ashx/__key/CommunityServer.Components.UserFiles/00.00.01.60.80/2014.09.25_2D00_S4_2D00_23.32_2D00_sprack5.zip]

      

    I also saw a note on the 12.2(33)SRE release notes as below

    "
    • CSCtr34793

    Symptoms: The router cannot establish mVPN PIM adjacencies over an MDT tunnel. The core PIM still works normally.

    Conditions: This symptom may occur after router reload when mVPN with PIM is configured and PIM-hellos from the neighbors are coming to the line card with DFC. Another possible trigger could be removal/recreation of the MDT in a VRF definition.

    Workaround: Reload the line card."

    In my case it affected multicast traffic as "show ip mroute" did not show the other pim mdt neighbors sourced routes.I will check with other labs and report back.Please share your thoughts on the order of operations that affects this.

    Regards,

    Maureen


  • Did I mention i was working on INE sp workbook full scale lab 2 task 6.1 :-)

    Thanks,

    Maureen

  • Hi,

     

    What I have noticed from the first glance in your IOS-XR config is that you have your MDT source configured under VRF rather than under global. You probably want to correct this.

    multicast-routing

     address-family ipv4

      interface Loopback0

       enable

      !

      interface GigabitEthernet0/1/0/1

     no shutdown

       enable

      !

     !

     vrf ABC

      address-family ipv4

       interface POS0/6/0/0

        enable

       !

       mdt source Loopback0  <<<< should be under Global

       mdt default ipv4 232.1.2.19



  • Even if it is defined under the VRF it works fine and sources the mGRE packets from the address even though Cisco recommends this to be under the global IPv4 AF under multicast-routing..

    If you have no PIM MVPN default MDT group address adjacencies on all PE routers like I stated in my first mail and it seems you have not then check your configs, that bug Cisco talks about has been experienced before I fixed by removing and re-adding the MDT default group address in the VRF definition in IOS

    Basically when you define the default MDT group address in IOS it should trigger the auto mGRE tunnel if not it's buggy

    Make sure you have turned on the multicast process for VRF aware multicast routing

    ip multicast-routing VRF X

    show ip pim VRF x int <<< you should see the mGRE tunnel interface here if it's auto generated correctly

    show ip pim VRF x nei



    On 1 Oct 2014, at 19:11, danilzhig <[email protected]> wrote:

    Hi,

     

    What I have noticed from the first glance in your IOS-XR config is that you have your MDT source configured under VRF rather than under global. You probably want to correct this.

    multicast-routing

     address-family ipv4

      interface Loopback0

       enable

      !

      interface GigabitEthernet0/1/0/1

     no shutdown

       enable

      !

     !

     vrf ABC

      address-family ipv4

       interface POS0/6/0/0

        enable

       !

       mdt source Loopback0  <<<< should be under Global

       mdt default ipv4 232.1.2.19




    INE - The Industry Leader in CCIE Preparation

    http://www.INE.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx
  • I saw the syslog messages of the MTI interfaces come up as soon as mdt was activated under the vrf.
    This is how it appeared on R2..

    R2#sh ip pim vrf Acme int

    Address          Interface                Ver/   Nbr    Query  DR     DR
                                              Mode   Count  Intvl  Prior
    192.168.210.2    FastEthernet1/0          v2/S   1      30     1      192.168.210.10
    192.168.2.2      Loopback102              v2/S   0      30     1      192.168.2.2
    2.2.2.2          Tunnel0                  v2/S   0      30     1      2.2.2.2

    note neighbor count is 0 on the tunnel but on the IOS XR it has 2 neighbors on its MTI, R1 and R2 on its "show ip pim vrf Acme neighbor"
     
    Regards,
    Maureen

    On Thu, Oct 2, 2014 at 6:35 PM, Sukhjit.Hayre <[email protected]> wrote:


    Even if it is defined under the VRF it works fine and sources the mGRE packets from the address even though Cisco recommends this to be under the global IPv4 AF under multicast-routing..

    If you have no PIM MVPN default MDT group address adjacencies on all PE routers like I stated in my first mail and it seems you have not then check your configs, that bug Cisco talks about has been experienced before I fixed by removing and re-adding the MDT default group address in the VRF definition in IOS

    Basically when you define the default MDT group address in IOS it should trigger the auto mGRE tunnel if not it's buggy

    Make sure you have turned on the multicast process for VRF aware multicast routing

    ip multicast-routing VRF X

    show ip pim VRF x int <<< you should see the mGRE tunnel interface here if it's auto generated correctly

    show ip pim VRF x nei



    On 1 Oct 2014, at 19:11, danilzhig <[email protected]> wrote:

    Hi,

     

    What I have noticed from the first glance in your IOS-XR config is that you have your MDT source configured under VRF rather than under global. You probably want to correct this.

    multicast-routing

     address-family ipv4

      interface Loopback0

       enable

      !

      interface GigabitEthernet0/1/0/1

     no shutdown

       enable

      !

     !

     vrf ABC

      address-family ipv4

       interface POS0/6/0/0

        enable

       !

       mdt source Loopback0  <<<< should be under Global

       mdt default ipv4 232.1.2.19




    INE - The Industry Leader in CCIE Preparation

    http://www.INE.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx



    INE - The Industry Leader in CCIE Preparation

    http://www.INE.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx


  • on R1 and R2 can you post

    show bgp ipv4 mdt all summary

    show ip pim mdt bgp

    On Thu, Oct 2, 2014 at 6:30 PM, mwmaina <[email protected]> wrote:
    I saw the syslog messages of the MTI interfaces come up as soon as mdt was activated under the vrf.
    This is how it appeared on R2..

    R2#sh ip pim vrf Acme int

    Address          Interface                Ver/   Nbr    Query  DR     DR
                                              Mode   Count  Intvl  Prior
    192.168.210.2    FastEthernet1/0          v2/S   1      30     1      192.168.210.10
    192.168.2.2      Loopback102              v2/S   0      30     1      192.168.2.2
    2.2.2.2          Tunnel0                  v2/S   0      30     1      2.2.2.2

    note neighbor count is 0 on the tunnel but on the IOS XR it has 2 neighbors on its MTI, R1 and R2 on its "show ip pim vrf Acme neighbor"
     
    Regards,
    Maureen

    On Thu, Oct 2, 2014 at 6:35 PM, Sukhjit.Hayre <[email protected]> wrote:


    Even if it is defined under the VRF it works fine and sources the mGRE packets from the address even though Cisco recommends this to be under the global IPv4 AF under multicast-routing..

    If you have no PIM MVPN default MDT group address adjacencies on all PE routers like I stated in my first mail and it seems you have not then check your configs, that bug Cisco talks about has been experienced before I fixed by removing and re-adding the MDT default group address in the VRF definition in IOS

    Basically when you define the default MDT group address in IOS it should trigger the auto mGRE tunnel if not it's buggy

    Make sure you have turned on the multicast process for VRF aware multicast routing

    ip multicast-routing VRF X

    show ip pim VRF x int <<< you should see the mGRE tunnel interface here if it's auto generated correctly

    show ip pim VRF x nei



    On 1 Oct 2014, at 19:11, danilzhig <[email protected]> wrote:

    Hi,

     

    What I have noticed from the first glance in your IOS-XR config is that you have your MDT source configured under VRF rather than under global. You probably want to correct this.

    multicast-routing

     address-family ipv4

      interface Loopback0

       enable

      !

      interface GigabitEthernet0/1/0/1

     no shutdown

       enable

      !

     !

     vrf ABC

      address-family ipv4

       interface POS0/6/0/0

        enable

       !

       mdt source Loopback0  <<<< should be under Global

       mdt default ipv4 232.1.2.19




    INE - The Industry Leader in CCIE Preparation

    http://www.INE.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx



    INE - The Industry Leader in CCIE Preparation

    http://www.INE.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx




    INE - The Industry Leader in CCIE Preparation

    http://www.INE.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx

  • Hi,
    I finally got to the bottom of that mystery.
    there was a command wrongly input that made a difference on R1,R2
    before
    R2#sh ip pim vrf ABC int

    Address          Interface                Ver/   Nbr    Query  DR     DR
                                              Mode   Count  Intvl  Prior
    10.2.8.2         FastEthernet0/0          v2/S   1      30     1      10.2.8.8
    2.2.2.2          Tunnel1                  v2/S   0      30     1      2.2.2.2
    R2#sh ip pim vrf ABC neigh
    PIM Neighbor Table
    Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
          P - Proxy Capable, S - State Refresh Capable, G - GenID Capable
    Neighbor          Interface                Uptime/Expires    Ver   DR
    Address                                                            Prio/Mode
    10.2.8.8          FastEthernet0/0          00:36:35/00:01:36 v2    1 / DR S P G

    R2#sh bgp ipv4 mdt all
    BGP table version is 5, local router ID is 2.2.2.2
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
                  r RIB-failure, S Stale, m multipath, b backup-path, x best-external
    Origin codes: i - IGP, e - EGP, ? - incomplete

       Network          Next Hop            Metric LocPrf Weight Path
    Route Distinguisher: 26:65001 (default for vrf ABC)
    *>i1.1.1.1/32       1.1.1.1                  0    100      0 ?
    *> 2.2.2.2/32       0.0.0.0                                0 ?
    *>i19.19.19.19/32   19.19.19.19                   100      0 i

    instead of placing the "ip pim ssm default" on the IOS routers, i had "ip pim ssm range def" which refers to an unconfigured def access list.
    R2(config)#no ip pim ssm range def
    R2(config)#ip pim ssm defa
    R2(config)#!
    %PIM-5-NBRCHG: VRF ABC: neighbor 19.19.19.19 UP on interface Tunnel1
    %PIM-5-DRCHG: VRF ABC: DR change from neighbor 2.2.2.2 to 19.19.19.19 on interface Tunnel1
    %PIM-5-NBRCHG: VRF ABC: neighbor 1.1.1.1 UP on interface Tunnel1

    R1(config)#no ip pim ssm range def
    R1(config)#ip pim ssm defa
    R1(config)#!
    %PIM-5-NBRCHG: VRF ABC: neighbor 19.19.19.19 UP on interface Tunnel1
    %PIM-5-DRCHG: VRF ABC: DR change from neighbor 1.1.1.1 to 19.19.19.19 on interface Tunnel1
    %PIM-5-NBRCHG: VRF ABC: neighbor 2.2.2.2 UP on interface Tunnel1


    R2#sh ip pim vrf ABC neigh
    PIM Neighbor Table
    Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
          P - Proxy Capable, S - State Refresh Capable, G - GenID Capable
    Neighbor          Interface                Uptime/Expires    Ver   DR
    Address                                                            Prio/Mode
    10.2.8.8          FastEthernet0/0          01:03:11/00:01:33 v2    1 / DR S P G
    1.1.1.1           Tunnel1                  00:09:13/00:01:24 v2    1 / S P G
    19.19.19.19       Tunnel1                  00:09:14/00:01:32 v2    1 / DR G


    R1#sh ip pim vr ABC neigh
    PIM Neighbor Table
    Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
          P - Proxy Capable, S - State Refresh Capable, G - GenID Capable
    Neighbor          Interface                Uptime/Expires    Ver   DR
    Address                                                            Prio/Mode
    10.1.7.7          FastEthernet0/0          01:04:05/00:01:41 v2    0 / S P G
    2.2.2.2           Tunnel1                  00:10:08/00:01:25 v2    1 / S P G
    19.19.19.19       Tunnel1                  00:10:08/00:01:37 v2    1 / DR G

    Thanks everyone (especially Sujkhit) for all the input!
    Regards,
    Maureen



    On Mon, Oct 6, 2014 at 2:18 AM, Sukhjit.Hayre <[email protected]> wrote:

    on R1 and R2 can you post

    show bgp ipv4 mdt all summary

    show ip pim mdt bgp

    On Thu, Oct 2, 2014 at 6:30 PM, mwmaina <[email protected]> wrote:
    I saw the syslog messages of the MTI interfaces come up as soon as mdt was activated under the vrf.
    This is how it appeared on R2..

    R2#sh ip pim vrf Acme int

    Address          Interface                Ver/   Nbr    Query  DR     DR
                                              Mode   Count  Intvl  Prior
    192.168.210.2    FastEthernet1/0          v2/S   1      30     1      192.168.210.10
    192.168.2.2      Loopback102              v2/S   0      30     1      192.168.2.2
    2.2.2.2          Tunnel0                  v2/S   0      30     1      2.2.2.2

    note neighbor count is 0 on the tunnel but on the IOS XR it has 2 neighbors on its MTI, R1 and R2 on its "show ip pim vrf Acme neighbor"
     
    Regards,
    Maureen

    On Thu, Oct 2, 2014 at 6:35 PM, Sukhjit.Hayre <[email protected]> wrote:


    Even if it is defined under the VRF it works fine and sources the mGRE packets from the address even though Cisco recommends this to be under the global IPv4 AF under multicast-routing..

    If you have no PIM MVPN default MDT group address adjacencies on all PE routers like I stated in my first mail and it seems you have not then check your configs, that bug Cisco talks about has been experienced before I fixed by removing and re-adding the MDT default group address in the VRF definition in IOS

    Basically when you define the default MDT group address in IOS it should trigger the auto mGRE tunnel if not it's buggy

    Make sure you have turned on the multicast process for VRF aware multicast routing

    ip multicast-routing VRF X

    show ip pim VRF x int <<< you should see the mGRE tunnel interface here if it's auto generated correctly

    show ip pim VRF x nei



    On 1 Oct 2014, at 19:11, danilzhig <[email protected]> wrote:

    Hi,

     

    What I have noticed from the first glance in your IOS-XR config is that you have your MDT source configured under VRF rather than under global. You probably want to correct this.

    multicast-routing

     address-family ipv4

      interface Loopback0

       enable

      !

      interface GigabitEthernet0/1/0/1

     no shutdown

       enable

      !

     !

     vrf ABC

      address-family ipv4

       interface POS0/6/0/0

        enable

       !

       mdt source Loopback0  <<<< should be under Global

       mdt default ipv4 232.1.2.19




    INE - The Industry Leader in CCIE Preparation

    http://www.INE.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx



    INE - The Industry Leader in CCIE Preparation

    http://www.INE.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx




    INE - The Industry Leader in CCIE Preparation

    http://www.INE.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx




    INE - The Industry Leader in CCIE Preparation

    http://www.INE.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx

Sign In or Register to comment.