MDT configuration problem

Hello everyone,

 

I've got a problem with MDT configuration. Sometimes when I am configuring MDT I just can't make local PE start installing an (S,G) for itself. 

 

My topology is:

 

AS1              |   AS2

R2--R1--XR1-|-R3--R4

 

For example I am getting this output on R2:

 

R2#show ip mroute 

IP Multicast Routing Table

Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,

       L - Local, P - Pruned, R - RP-bit set, F - Register flag,

       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,

       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,

       U - URD, I - Received Source Specific Host Report, 

       Z - Multicast Tunnel, z - MDT-data group sender, 

       Y - Joined MDT-data group, y - Sending to MDT-data group, 

       G - Received BGP C-Mroute, g - Sent BGP C-Mroute, 

       Q - Received BGP S-A Route, q - Sent BGP S-A Route, 

       V - RD & Vector, v - Vector

Outgoing interface flags: H - Hardware switched, A - Assert winner

 Timers: Uptime/Expires

 Interface state: Interface, Next-Hop or VCD, State/Mode

 

(4.4.4.4, 232.0.0.1), 00:18:38/stopped, flags: sTIZV

  Incoming interface: Ethernet1/0, RPF nbr 10.0.12.1, vector 19.19.19.19

  Outgoing interface list:

    MVRF A, Forward/Sparse, 00:17:23/00:00:36

 

(*, 224.0.1.40), 00:19:39/00:02:25, RP 0.0.0.0, flags: DCL

  Incoming interface: Null, RPF nbr 0.0.0.0

  Outgoing interface list:

    Loopback0, Forward/Sparse, 00:19:38/00:02:25

For normal operational MDT I would expect to see there also this (S,G) record: (2.2.2.2, 232.0.0.1) but it is for some reason not being installed.

 

On the remote end it looks just the opposite:

 

R4#show ip mroute 

IP Multicast Routing Table

Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,

       L - Local, P - Pruned, R - RP-bit set, F - Register flag,

       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,

       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,

       U - URD, I - Received Source Specific Host Report, 

       Z - Multicast Tunnel, z - MDT-data group sender, 

       Y - Joined MDT-data group, y - Sending to MDT-data group, 

       G - Received BGP C-Mroute, g - Sent BGP C-Mroute, 

       Q - Received BGP S-A Route, q - Sent BGP S-A Route, 

       V - RD & Vector, v - Vector

Outgoing interface flags: H - Hardware switched, A - Assert winner

 Timers: Uptime/Expires

 Interface state: Interface, Next-Hop or VCD, State/Mode

 

(2.2.2.2, 232.0.0.1), 00:19:49/stopped, flags: sTIZV

  Incoming interface: Ethernet1/0, RPF nbr 10.0.34.3, vector 3.3.3.3

  Outgoing interface list:

    MVRF A, Forward/Sparse, 00:19:49/00:01:10

 

(*, 224.0.1.40), 00:21:50/00:02:13, RP 0.0.0.0, flags: DCL

  Incoming interface: Null, RPF nbr 0.0.0.0

  Outgoing interface list:

    Loopback0, Forward/Sparse, 00:21:48/00:02:13

It is missing the (4.4.4.4, 232.0.0.1).

 

It looks like some configuration error but I am really desperate in finding what I have missed.

 

At the same time when I am adding VRF A with the same MDT configuration on R3 it behaves just fine:

 

R3#show ip mroute 

IP Multicast Routing Table

Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,

       L - Local, P - Pruned, R - RP-bit set, F - Register flag,

       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,

       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,

       U - URD, I - Received Source Specific Host Report, 

       Z - Multicast Tunnel, z - MDT-data group sender, 

       Y - Joined MDT-data group, y - Sending to MDT-data group, 

       G - Received BGP C-Mroute, g - Sent BGP C-Mroute, 

       Q - Received BGP S-A Route, q - Sent BGP S-A Route, 

       V - RD & Vector, v - Vector

Outgoing interface flags: H - Hardware switched, A - Assert winner

 Timers: Uptime/Expires

 Interface state: Interface, Next-Hop or VCD, State/Mode

 

(3.3.3.3, 232.0.0.1), 00:00:04/00:03:25, flags: sT

  Incoming interface: Loopback0, RPF nbr 0.0.0.0

  Outgoing interface list:

    Ethernet1/1, Forward/Sparse, 00:00:04/00:03:25

 

(4.4.4.4, 232.0.0.1), 00:00:05/00:02:54, flags: sTIZ

  Incoming interface: Ethernet1/1, RPF nbr 10.0.34.4

  Outgoing interface list:

    MVRF A, Forward/Sparse, 00:00:05/00:02:54

 

(2.2.2.2, 232.0.0.1), 00:22:54/00:03:24, flags: sTIZV

  Incoming interface: Ethernet1/0, RPF nbr 10.0.193.19, vector 10.0.193.19

  Outgoing interface list:

    MVRF A, Forward/Sparse, 00:00:05/00:02:54

    Ethernet1/1, Forward/Sparse, 00:22:54/00:03:13

 

(*, 224.0.1.40), 00:24:52/00:02:18, RP 0.0.0.0, flags: DCL

  Incoming interface: Null, RPF nbr 0.0.0.0

  Outgoing interface list:

    Loopback0, Forward/Sparse, 00:24:51/00:02:18

And all neighbours recognize it as well:

 

R4#show ip mroute 

IP Multicast Routing Table

Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,

       L - Local, P - Pruned, R - RP-bit set, F - Register flag,

       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,

       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,

       U - URD, I - Received Source Specific Host Report, 

       Z - Multicast Tunnel, z - MDT-data group sender, 

       Y - Joined MDT-data group, y - Sending to MDT-data group, 

       G - Received BGP C-Mroute, g - Sent BGP C-Mroute, 

       Q - Received BGP S-A Route, q - Sent BGP S-A Route, 

       V - RD & Vector, v - Vector

Outgoing interface flags: H - Hardware switched, A - Assert winner

 Timers: Uptime/Expires

 Interface state: Interface, Next-Hop or VCD, State/Mode

 

(3.3.3.3, 232.0.0.1), 00:01:03/00:01:56, flags: sTIZ

  Incoming interface: Ethernet1/0, RPF nbr 10.0.34.3

  Outgoing interface list:

    MVRF A, Forward/Sparse, 00:01:03/00:01:56

 

(4.4.4.4, 232.0.0.1), 00:01:03/00:03:24, flags: sT

  Incoming interface: Loopback0, RPF nbr 0.0.0.0

  Outgoing interface list:

    Ethernet1/0, Forward/Sparse, 00:01:03/00:03:24

 

(2.2.2.2, 232.0.0.1), 00:23:52/stopped, flags: sTIZV

  Incoming interface: Ethernet1/0, RPF nbr 10.0.34.3, vector 3.3.3.3

  Outgoing interface list:

    MVRF A, Forward/Sparse, 00:23:52/00:00:06

 

(*, 224.0.1.40), 00:25:53/00:02:12, RP 0.0.0.0, flags: DCL

  Incoming interface: Null, RPF nbr 0.0.0.0

  Outgoing interface list:

    Loopback0, Forward/Sparse, 00:25:52/00:02:12

R2#show ip mroute 

IP Multicast Routing Table

Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,

       L - Local, P - Pruned, R - RP-bit set, F - Register flag,

       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,

       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,

       U - URD, I - Received Source Specific Host Report, 

       Z - Multicast Tunnel, z - MDT-data group sender, 

       Y - Joined MDT-data group, y - Sending to MDT-data group, 

       G - Received BGP C-Mroute, g - Sent BGP C-Mroute, 

       Q - Received BGP S-A Route, q - Sent BGP S-A Route, 

       V - RD & Vector, v - Vector

Outgoing interface flags: H - Hardware switched, A - Assert winner

 Timers: Uptime/Expires

 Interface state: Interface, Next-Hop or VCD, State/Mode

 

(3.3.3.3, 232.0.0.1), 00:00:48/00:02:11, flags: sTIZV

  Incoming interface: Ethernet1/0, RPF nbr 10.0.12.1, vector 19.19.19.19

  Outgoing interface list:

    MVRF A, Forward/Sparse, 00:00:48/00:02:11

 

(4.4.4.4, 232.0.0.1), 00:24:36/stopped, flags: sTIZV

  Incoming interface: Ethernet1/0, RPF nbr 10.0.12.1, vector 19.19.19.19

  Outgoing interface list:

    MVRF A, Forward/Sparse, 00:23:20/00:00:39

 

(*, 224.0.1.40), 00:25:36/00:02:24, RP 0.0.0.0, flags: DCL

  Incoming interface: Null, RPF nbr 0.0.0.0

  Outgoing interface list:

    Loopback0, Forward/Sparse, 00:25:35/00:02:24

 

What is the most surprising for me that after I add this VRF on R3, R4 starts to behave as expected. However no changes are made on R4, only on R3.

 

 

Here are configurations from R1,R2,R3,R4,XR1:

 

 

############## R1 ###############

 

 

hostname R1

!

boot-start-marker

boot-end-marker

!

!

!

no aaa new-model

no ip icmp rate-limit unreachable

!

!

!

!

!

!

no ip domain lookup

ip cef    

no ipv6 cef

!         

!         

multilink bundle-name authenticated

!

!

!

!

!

!

!

!

!

!

!

!

ip tcp synwait-time 5

!

!

!

!

!

!

!

!

interface Loopback0

 ip address 1.1.1.1 255.255.255.255

 ip router isis 

 ip pim sparse-mode

!

interface FastEthernet0/0

 no ip address

 shutdown

 duplex full

!

interface Ethernet1/0

 ip address 10.0.12.1 255.255.255.0

 ip router isis 

 ip pim sparse-mode

 duplex full

!

interface Ethernet1/1

 ip address 10.0.119.1 255.255.255.0

 ip router isis 

 ip pim sparse-mode

 duplex full

!

interface Ethernet1/2

 no ip address

 ip pim sparse-mode

 shutdown

 duplex full

!

interface Ethernet1/3

 no ip address

 ip pim sparse-mode

 shutdown

 duplex full

!

router isis

 net 49.0001.0000.0000.0001.00

 mpls ldp autoconfig

!

ip forward-protocol nd

!

!

no ip http server

no ip http secure-server

ip pim ssm default

!

!

!         

!

control-plane

!

!

line con 0

 exec-timeout 0 0

 privilege level 15

 logging synchronous

 stopbits 1

line aux 0

 exec-timeout 0 0

 privilege level 15

 logging synchronous

 stopbits 1

line vty 0 4

 login

!

!

end

 

############## R2 ###############

 

hostname R2

!

boot-start-marker

boot-end-marker

!

!

vrf definition A

 rd 1:1

 route-target export 1:1

 route-target import 1:1

 !

 address-family ipv4

  mdt default 232.0.0.1

 exit-address-family

!

!         

no aaa new-model

no ip icmp rate-limit unreachable

!

!

!

!

!

!

no ip domain lookup

ip multicast-routing 

ip multicast-routing vrf A 

ip multicast rpf proxy vector

ip multicast vrf A rpf proxy rd vector

ip cef

no ipv6 cef

!

!

multilink bundle-name authenticated

!

!

!

!

!

!         

!

!

!

!

!

!

ip tcp synwait-time 5

!

!

!

!

!

!

!

!

interface Loopback0

 ip address 2.2.2.2 255.255.255.255

 ip router isis 

 ip pim sparse-mode

!

interface Loopback1

 vrf forwarding A

 ip address 192.168.0.2 255.255.255.255

 ip pim sparse-mode

!

interface FastEthernet0/0

 no ip address

 shutdown

 duplex full

!

interface Ethernet1/0

 ip address 10.0.12.2 255.255.255.0

 ip router isis 

 ip pim sparse-mode

 duplex full

!

interface Ethernet1/1

 no ip address

 ip pim sparse-mode

 shutdown

 duplex full

!

interface Ethernet1/2

 no ip address

 ip pim sparse-mode

 shutdown

 duplex full

!

interface Ethernet1/3

 no ip address

 ip pim sparse-mode

 shutdown

 duplex full

!

router isis

 net 49.0001.0000.0000.0002.00

 mpls ldp autoconfig

!

router bgp 1

 bgp log-neighbor-changes

 neighbor 19.19.19.19 remote-as 1

 neighbor 19.19.19.19 update-source Loopback0

 !

 address-family ipv4

  no neighbor 19.19.19.19 activate

 exit-address-family

 !

 address-family vpnv4

  neighbor 19.19.19.19 activate

  neighbor 19.19.19.19 send-community extended

 exit-address-family

 !

 address-family ipv4 mdt

  neighbor 19.19.19.19 activate

  neighbor 19.19.19.19 send-community extended

 exit-address-family

 !

 address-family ipv4 vrf A

  redistribute connected

 exit-address-family

!

ip forward-protocol nd

!

!

no ip http server

no ip http secure-server

ip pim ssm default

!

!

!

!

control-plane

!

!

line con 0

 exec-timeout 0 0

 privilege level 15

 logging synchronous

 stopbits 1

line aux 0

 exec-timeout 0 0

 privilege level 15

 logging synchronous

 stopbits 1

line vty 0 4

 login

!

!

end

 

 

############## R3 ###############

 

hostname R3

!

boot-start-marker

boot-end-marker

!

!

!    ############ This was not here in the first outputs from R1 and R2 #################

vrf definition A

 rd 1:1

 route-target export 1:1

 route-target import 1:1

 !

 address-family ipv4

  mdt default 232.0.0.1

 exit-address-family

!      ############ This was not here in the first outputs from R1 and R2 #################   

!

no aaa new-model

no ip icmp rate-limit unreachable

!

!

!

!

!

!

no ip domain lookup

ip multicast-routing 

ip multicast rpf proxy vector

ip cef

no ipv6 cef

!

!

multilink bundle-name authenticated

!

!

!

!

!

!         

!

!

!

!

!

!

ip tcp synwait-time 5

!

!

!

!

!

!

!

!

interface Loopback0

 ip address 3.3.3.3 255.255.255.255

 ip pim sparse-mode

!

interface FastEthernet0/0

 no ip address

 shutdown 

 duplex full

!

interface Ethernet1/0

 ip address 10.0.193.3 255.255.255.0

 ip pim sparse-mode

 duplex full

 mpls bgp forwarding

!

interface Ethernet1/1

 ip address 10.0.34.3 255.255.255.0

 ip pim sparse-mode

 duplex full

!

interface Ethernet1/2

 no ip address

 ip pim sparse-mode

 shutdown

 duplex full

!

interface Ethernet1/3

 no ip address

 ip pim sparse-mode

 shutdown 

 duplex full

!

router ospf 1

 network 0.0.0.0 255.255.255.255 area 0

 mpls ldp autoconfig

!

router bgp 2

 bgp log-neighbor-changes

 no bgp default route-target filter

 neighbor 4.4.4.4 remote-as 2

 neighbor 4.4.4.4 update-source Loopback0

 neighbor 10.0.193.19 remote-as 1

 !

 address-family ipv4

  neighbor 4.4.4.4 activate

  no neighbor 10.0.193.19 activate

 exit-address-family

 !

 address-family vpnv4

  neighbor 4.4.4.4 activate

  neighbor 4.4.4.4 send-community both

  neighbor 4.4.4.4 next-hop-self

  neighbor 10.0.193.19 activate

  neighbor 10.0.193.19 send-community both

 exit-address-family

 !

 address-family ipv4 mdt

  neighbor 4.4.4.4 activate

  neighbor 4.4.4.4 next-hop-self

  neighbor 10.0.193.19 activate

 exit-address-family

!

ip forward-protocol nd

!

!

no ip http server

no ip http secure-server

ip pim ssm default

!

!

!

!

control-plane

!

!

line con 0

 exec-timeout 0 0

 privilege level 15

 logging synchronous

 stopbits 1

line aux 0

 exec-timeout 0 0

 privilege level 15

 logging synchronous

 stopbits 1

line vty 0 4

 login

!

!

end

 

 

############## R4 ###############

 

hostname R4

!

boot-start-marker

boot-end-marker

!

!

vrf definition A

 rd 1:1

 route-target export 1:1

 route-target import 1:1

 !

 address-family ipv4

  mdt default 232.0.0.1

 exit-address-family

!

!

no aaa new-model

no ip icmp rate-limit unreachable

!

!

!

!

!

!

no ip domain lookup

ip multicast-routing 

ip multicast-routing vrf A 

ip multicast rpf proxy vector

ip multicast vrf A rpf proxy rd vector

ip cef

no ipv6 cef

!

!

multilink bundle-name authenticated

!

!

!

!

!

!         

!

!

!

!

!

!

ip tcp synwait-time 5

!

!

!

!

!

!

!

!

interface Loopback0

 ip address 4.4.4.4 255.255.255.255

 ip pim sparse-mode

!

interface Loopback1

 vrf forwarding A

 ip address 192.168.0.4 255.255.255.255

 ip pim sparse-mode

!

interface FastEthernet0/0

 no ip address

 shutdown

 duplex full

!

interface Ethernet1/0

 ip address 10.0.34.4 255.255.255.0

 ip pim sparse-mode

 duplex full

!

interface Ethernet1/1

 no ip address

 ip pim sparse-mode

 shutdown

 duplex full

!

interface Ethernet1/2

 no ip address

 ip pim sparse-mode

 shutdown

 duplex full

!

interface Ethernet1/3

 no ip address

 ip pim sparse-mode

 shutdown

 duplex full

!

router ospf 1

 network 0.0.0.0 255.255.255.255 area 0

 mpls ldp autoconfig

!

router bgp 2

 bgp log-neighbor-changes

 neighbor 3.3.3.3 remote-as 2

 neighbor 3.3.3.3 update-source Loopback0

 !

 address-family vpnv4

  neighbor 3.3.3.3 activate

  neighbor 3.3.3.3 send-community both

 exit-address-family

 !

 address-family ipv4 mdt

  neighbor 3.3.3.3 activate

  neighbor 3.3.3.3 send-community both

 exit-address-family

 !

 address-family ipv4 vrf A

  redistribute connected

 exit-address-family

!

ip forward-protocol nd

!

!

no ip http server

no ip http secure-server

ip pim ssm default

ip pim vrf A bsr-candidate Loopback1 0

ip pim vrf A rp-candidate Loopback1

!

!

!

!

control-plane

!

!

line con 0

 exec-timeout 0 0

 privilege level 15

 logging synchronous

 stopbits 1

line aux 0

 exec-timeout 0 0

 privilege level 15

 logging synchronous

 stopbits 1

line vty 0 4

 login

!

!

end

 

############## XR1 ###############

 

 

hostname XR1

telnet vrf default ipv4 server max-servers 10

cdp

line template TELNET

 exec-timeout 0 0

!

line console

 exec-timeout 0 0

!

line default

 exec-timeout 0 0

!

vty-pool default 0 99 line-template TELNET

ntp

 server vrf R1 10.0.100.1

!

interface Loopback0

 ipv4 address 19.19.19.19 255.255.255.255

!

interface MgmtEth0/0/CPU0/0

 ipv4 address 172.16.33.206 255.255.255.0

!

interface GigabitEthernet0/0/0/0

 cdp

!

interface GigabitEthernet0/0/0/0.100

 ipv4 address 10.0.119.19 255.255.255.0

 encapsulation dot1q 100

!

interface GigabitEthernet0/0/0/0.101

 ipv4 address 10.0.193.19 255.255.255.0

 encapsulation dot1q 101

!

route-policy PASS

  pass

end-policy

!

router static

 address-family ipv4 unicast

  0.0.0.0/0 172.16.33.254

  10.0.193.3/32 GigabitEthernet0/0/0/0.101

 !

!

router isis 1

 net 49.0001.0000.0000.0019.00

 address-family ipv4 unicast

  mpls ldp auto-config

 !

 interface Loopback0

  address-family ipv4 unicast

  !

 !

 interface GigabitEthernet0/0/0/0.100

  address-family ipv4 unicast

  !

 !

 interface GigabitEthernet0/0/0/0.101

  address-family ipv4 unicast

  !

 !

!

router bgp 1

 address-family vpnv4 unicast

  retain route-target all

 !

 address-family ipv4 mdt

 !

 neighbor 2.2.2.2

  remote-as 1

  update-source Loopback0

  address-family vpnv4 unicast

   next-hop-self

  !

  address-family ipv4 mdt

   next-hop-self

  !

 !

 neighbor 10.0.193.3

  remote-as 2

  address-family vpnv4 unicast

   route-policy PASS in

   route-policy PASS out

  !

  address-family ipv4 mdt

   route-policy PASS in

   route-policy PASS out

  !

 !

!

mpls ldp

!

multicast-routing

 address-family ipv4

  interface all enable

 !

!

end

 

 

 

Sign In or Register to comment.