PPPoE in GNS3 / Labs Ideas and Configs

Hello everyone I have been trying to practice PPPoE but wondered how other people are doing this - I am happy to use GNS3 with FA ports - but wondered what other people have as server and client config as I can't seem to get the dial interface to working on my 7200 routers? Maybe a IOS issue - Any one in the same boat?  Thoughts and ideas welcome [:D]

Comments

  • I tested it out on the 3725 images, they work.

    HTH

  • JoeMJoeM ✭✭✭

    Hi djjohnmerry,

    Show us your config.   Let's troubleshoot it.    ;-)

  • JoeMJoeM ✭✭✭

    Hello everyone I have been trying to practice PPPoE but wondered how other people are doing this - I am happy to use GNS3 with FA ports - but wondered what other people have as server and client config as I can't seem to get the dial interface to working on my 7200 routers? Maybe a IOS issue - Any one in the same boat?  Thoughts and ideas welcome Big Smile

    This is most likely not an IOS issue. I have it working with both versions 7200 (15.2) and 3725 (12.4T).

     

    Post your PPPoE config for both sides, and let's work out why it is not working. Troubleshooting.

    Using this debug on both sides, seems to tell the best story.  Is it a dhcp problem or pppoe issue?  etc

                       debug ppp negot

     

    To reinitialize the attempt, clear the client side.

                             clear pppoe all

  • Hi all, thanks for the replies yes it was my config that was the issue not GNS3/IOS - I was copying the config from docs cd - but notepad takes the italic font away so I was adding extra words and stopped it working when I tried to place it into the router - Good tip for the exam!

    Just one quick question I seem to have my hub running and I can ping the spokes and the spokes can ping the hub all running PPPoE - but the hub cannot ping it's own interface(s)? Is this correct?

    ***HUB***

    bba-group pppoe PPPOE

     virtual-template 1

    !

    bba-group pppoe PPPOE2

     virtual-template 2

    !

    interface FastEthernet0/0

     no ip address

     pppoe enable group PPPOE

    !

    interface FastEthernet1/0

     no ip address

     pppoe enable group PPPOE2

    !

    interface Virtual-Template1

     mtu 1400

     ip address 155.1.12.1 255.255.255.0

    !

    interface Virtual-Template2

     mtu 1400

     ip address 155.1.13.1 255.255.255.0

    !

     router eigrp 1

     network 155.1.0.0


    ***SPOKE 1***



    interface FastEthernet0/0

     no ip address

     pppoe enable group 1

     pppoe-client dial-pool-number 1

    !

    interface Dialer1

     mtu 1400

     ip address 155.1.12.2 255.255.255.0

     encapsulation ppp

     dialer pool 1

     dialer-group 1

    !

    router eigrp 1

     network 155.1.0.0



    ***SPOKE2***



    interface FastEthernet1/0

     no ip address

     pppoe enable group 1

     pppoe-client dial-pool-number 1

    !

    interface Dialer1

     mtu 1400

     ip address 155.1.13.3 255.255.255.0

     encapsulation ppp

     dialer pool 1

     dialer-group 1

    !

    router eigrp 1

     network 155.1.0.0



    If you see any issues in the config please let me know - Going to try and add autenication now - Fingers crossed
  • I'm pretty sure that's normal.  Try using ip unnumbered to a local real or logical interface rather than numbering the VT if you need to ping the local interface.

Sign In or Register to comment.