HTTPs client/server

Hi, 

 

I tried the HTTP lab, I am good with normal HTTP but can't get https working with the same config as in the workbook. 

When I debug http server this is what I get on the server side:

 

%HTTPS: SSL handshake fail (-6992)

HTTP: ssl handshake failed (-40404)

 

http_client_request:

 

httpc_setup_request:

http_client_process_request:

httpc_request: Have the credentials

http_transaction_free:

http_transaction_free: freed httpc_transaction_t with id 29

http_client_abort_request:

http_client_abort_request: Bad Transaction Id

In tried to re-generate the certificats but no luck.

 

Any idea?

 

Server config:

username CISCO privilege 15 password 0 CISCO

ip http server

ip http port 8080

ip http authentication local

ip http secure-server

ip http secure-port 4043

ip http max-connections 2

ip http path bootflash:



client config


no ip http server

no ip http secure-server

ip http client source-interface Loopback0

ip http client username CISCO

ip http client password 0 CISCO


Thanks.

 

Comments

  • This lab doesn't work for me either. Can't get files to copy. Don't know why. Just another one that doesn't work as expected......(sigh)

    R4#sh run | s http
    no ip http server
    no ip http secure-server
    ip http client source-interface Loopback0
    ip http client username CISCO
    ip http client password 0 CISCO
    ip http client secure-ciphersuite 3des-ede-cbc-sha

    R6#sh run | s username|http
    username CISCO privilege 15 password 0 CISCO
    ip http server
    ip http port 8080
    ip http access-class 99
    ip http authentication local
    ip http secure-server
    ip http secure-ciphersuite 3des-ede-cbc-sha
    ip http secure-port 4043
    ip http max-connections 2
    ip http path flash0:
    access-list 99 permit 150.1.0.0 0.0.255.255

    R4#copy http://155.1.146.6:8080/baseline.cfg null:
    Accessing http://155.1.146.6:8080/baseline.cfg...
    %Error opening http://155.1.146.6:8080/baseline.cfg (Permission denied)

    R6#sh debugging
    HTTP Server:
    HTTP Server Authentication debugging is on

    R6#
    R6#
    R6#
    HTTP: Authentication failed for realm level_15 or view_access
    HTTP: Authentication failed for level 15

Sign In or Register to comment.