PUTTY keepalive is echoing "q"

Using putty on a new setup, and the keepalive is echoing the letter "q".

I am sure that this is it, because if I lower the keepalive to 2 seconds, the echo matches.

It is kind of disruptive, especially if it comes in the middle of config input.

 

What is the change that I need to make in putty?   

Thanks for any help with this.

Comments

  • Oh I had this a year ago.

    I don't remember exactly the setting but it was one of the keepalive settings. Go through all options and you will find the culprit checked.

     

    HtH

  • Hi Joe,

    It this what you're looking for ?

    4.3.8 ‘Local echo’


    With local echo disabled, characters you type into the PuTTY window are not echoed in the window by PuTTY. They are simply sent to the server. (The server might choose to echo them back to you; this can't be controlled from the PuTTY control panel.)


    Some types of session need local echo, and many do not. In its default
    mode, PuTTY will automatically attempt to deduce whether or not local
    echo is appropriate for the session you are working in. If you find it
    has made the wrong decision, you can use this configuration option to
    override its choice: you can force local echo to be turned on, or force
    it to be turned off, instead of relying on the automatic detection.

    putty.echo

  • JoeMJoeM ✭✭✭

    I may be using the wrong word when I say "echo".  This is a result of the keepalive.

    For a test for the cause, I set the keepalive at 5 secs, which makes it tick every 5 secs.

        Branch-2>qqqqqqqqqqqqqqqqqqqqqqqqqqqq

    For background, this is on a remote IOU implementation (linux based).  Everything else seems to work correctly.

     

    @thejapa,  What do you think about the "character set" (see image below).   Do you remember changing with this setting?   I am grasping a little with this.

    @ciprian,  That echo setting is the default.  I am not sure why I would change this. I think that we always want it on "auto", don't we?

     

    @anyone,  I have exhausted my creativity on keyword searches. Any help is very much appreciated.

     

    image

  • Try this

    Uncheck Connection->Enable TCP Keepalives

    See image...

    https://www.dropbox.com/s/x9iu2rqzbsx6ywg/PuttyKeepAlive.png

    (didn't attach it and kinda in haste right now to get it on other share)

  • JoeMJoeM ✭✭✭

    Try this

    Uncheck Connection->Enable TCP Keepalives

    Done.  But no effect.   

    Funny thing.  Same thing in logging.  qqqqq

     

    It is as if Putty is sending the letter "q".   It should be null.

  • Yeah, I had the same issue 1 year ago. I was sure that was the fix.

    So... Have you considered OSX? Or SecureCRT? ;)

    Just kidding, I remember finding some crazy option that fixed it. But a little after I switched to Mac. Good luck though

     

  • I have the same issue with the latest tera term, fwiw.  I haven't been motivated enough to figure out why, though.  It appears to be some sort of local echo, though, since hitting enter after one of them doesn't close my window.

  • I am able to reproduce issue in SecureCRT by enabling "Send Protocol NO-OP every X seconds". Obviously to fix I just disabled it.

    In PuTTY, I was able to reproduce issue under Connection, "Seconds between keepalives (0 to turn off)" using any number != 0. I fixed it by setting number to 0.

    TeraTerm I do not have around to play.

  • JoeMJoeM ✭✭✭

    My only solution so far, has been to disable the keepalives with "0".

     

    My problem is only with an IOU installation.  It is not a problem on anything else (i.e. racks, gns, or other).

     

    I am always surprised when I can not find something on the Internet. It reminds me that the Internet has spoiled us these days. We have information at our fingertips -- except for some little things like this.  ;-)

     

    Is this only with IOU for each of you?

     

    Thanks for the help and confirmation of the problem.

  • No, not on IOU, but on a few specific pieces of networking gear.  Anything from zhone, and a couple devices I get to through console servers.

  • JoeMJoeM ✭✭✭

    Hi Po8,   Thanks for trying to help with this.

    Okay.  If it isn't an IOU issue, then my next step of logic is.....maybe linux based appliances?

    I am surviving (disabled keepalives).  No problem for now.   Was just hoping that more people knew about this issue.

    Cheers!

Sign In or Register to comment.