GNS3 IOU issue...

I'm a contributor to the GNS3 kickstarter program and recently downloaded and started using the Alpha 8 release. For the most part, everything seems to be working fine. I have no issues when connecting IOS devices to other IOS devices and IOU devices to other IOU devices. However, I can't get an IOS L3 device such as a router and L2 device such as IOU switch to connect. I googled the internet and did find a partial solution. A poster on the GNS3 forum suggested adding a route to the VM in virtual box pointing to my host machine. When I did that, the IOS router and IOU switch connected, but neither of the devices could ping eachother. I connected a couple IOS routers to the IOU switch and they couldn't ping eachother either. Has anyone else encountered this problem, and if so, is there workaround, or configuration that will make this work. BTW, here's the error message I received when I tried to connect the IOS and IOU devices before adding the route in the VM:"Server error [-3200] from 192.168.56.101:8000: IOU1: Could not create an UDP connection to 192.168.0.2:10001: [Errno 101] Network is unreachable

Comments

  • Hello,

    Your setup is not clear to me. What is running inside the VMs? IOU? GNS3? 

    In any case, I am not using GNS3 for my studies, but it just ocurred me you might be running VirtualBox in host-only network mode. Have you tried changing the VirtualBox network adapter to bridged mode?  

    Just remember virtualbox in bridged mode will basicly connect your VMs to your physical NICs, so make sure you are not connected to your production network, you can wreak havoc by accident. 

    HtH

  • Hello,

    Your setup is not clear to me. What is running inside the VMs? IOU? GNS3? 

    In any case, I am not using GNS3 for my studies, but it just ocurred me you might be running VirtualBox in host-only network mode. Have you tried changing the VirtualBox network adapter to bridged mode?  

    Just remember virtualbox in bridged mode will basicly connect your VMs to your physical NICs, so make sure you are not connected to your production network, you can wreak havoc by accident. 

    HtH

    I'm running the IOU on my VM. The instructions that came with GNS3 said to use host only adapter. The weird thing is that I can get a connection between my IOU and IOS when I add a route in the VM toward my local machine. However, I still cannot ping between the two. Others have had the same problem. I was hoping to find someone who had successful connected and pinged between an IOU and IOS device in GNS3. Thanks for your reply.

  • This is odd , i never had the problem..

     

     

    I have 

     

    [IOS-7200-12.2(33)]-----[IOU-15.1g]

     

    interface on 7200 is 10mb full , IOU set to full duplex

     

    they are happy 

     

     

     

    cdp from IOS router....  and I can ping  it , I turned port to L3 port on switch, L2 also works fine through switch.

     

    R1#sh cdp neighbors

    Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge

                      S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone

     

    Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID

    Switch           Fas 0/0           178          R S I     Linux Uni Eth 0/0

     

     

     

    I use virtualbox with these settings on network adapter...

     

    host-only adapter

    adapter type PCnet-FASTIII

    promiscious mode : allow all

    cable connected ticked

     

    am using the latest alpha 

     

    let me know if you need any other info to help.

  • This is odd , i never had the problem..

     

     

    I have 

     

    [IOS-7200-12.2(33)]-----[IOU-15.1g]

     

    interface on 7200 is 10mb full , IOU set to full duplex

     

    they are happy 

     

     

     

    cdp from IOS router....  and I can ping  it , I turned port to L3 port on switch, L2 also works fine through switch.

     

    R1#sh cdp neighbors

    Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge

                      S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone

     

    Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID

    Switch           Fas 0/0           178          R S I     Linux Uni Eth 0/0

     

     

     

    I use virtualbox with these settings on network adapter...

     

    host-only adapter

    adapter type PCnet-FASTIII

    promiscious mode : allow all

    cable connected ticked

     

    am using the latest alpha 

     

    let me know if you need any other info to help.

    This is a quote from a poster on another board as he and others are having the same issue as I am. I did what he suggested and got the same results. Before you add a route to your machine on the VM, you get nothing when click on the add a link tool in GNS3. After you add the route, you get a connection between the IOS router and IOU switch, but they cannont ping eachother, or any device connected to the IOU switch. When you connect 2 IOU switches togethor, everthing works fine. They link and you can ping the 2 IOU devices. Here's the quote from the poster on the GNS3 board"I had this problem. The IOU VM doesn't have a default route, so can't connect an IOU device to anything not on the same network as it (eg 192.168.95.0/24)

    To fix this you can configure a static route on the IOU VM. Something like this would probably work for you;

    ip route add 192.168.1.0/24 via 192.168.95.1

    depending on what the IPs on you computer are

    After this I could make a connection between an IOS router and an IOU device but cannot ping between them. My search for a solution to that brought me to this thread"

    Then I found this response on another thread:"Most likely your VM cannot communicate with the local server IP address. A solution can be to set the host binding to an address in the same subnet, for instance: 192.168.56.1 if your VM has 192.168.56.101." I'm thinking this could be a solution to the problem as I am running Windows 7. I'm just not sure how to implement the solution. Thanks

  • tmanitotmanito ✭✭✭

    Under Edit>Preferences>GNS3 Server>Local Server.

    The host binding must be in the network of the GNS3 IOU VM in order for you to connect an L3 IOS image with an L2/L3 IOU image. 

    HTH

    Timothy Manito

    Hope this helps!

    Timothy Q. Manito

  • Under Edit>Preferences>GNS3 Server>Local Server.

    The host binding must be in the network of the GNS3 IOU VM in order for you to connect an L3 IOS image with an L2/L3 IOU image. 

    HTH

    Timothy Manito

    I changed the host binding in GNS3 to the same network as the GNS3 IOU and they connect. However, I still cannot ping another device. Everytime I try to ping another IOS device, I get a message that says "unrecognized host or address, or protocol not running". I can connect 2 IOU devices togethor and put virtual interfaces on both of them, and they can ping eachother. You think it could be the IOU that I'm using:  i86bi-linux-l2-ipbasek9-15.1b.bin ,or something in the configuration of the switch.

  • Okay, another question.

    What is your main OS?

    Because I spent two days now getting the following setup to work:

    Main OS: OSX Mavericks

    IOU VM: CentOS

    Virtualization SW: VMWare Fusion

    GNS version 0.8.7

    And I got as far as getting the GNS3 router to ping an interface inside the CentOS VM. Now there is something wrong with my IOU setup because my cloud device in IOU is not working (yet).

    If you are using a Mac, you will need to setup a tun/tap device via a opensource driver and run GNS3 as root, so GNS3 can create the tap0 device. Then you need to bridge the VMnic to the tap0 device via OSX commands. 

    If you are not using a Mac just ignore everything I said... [:P]

  • tmanitotmanito ✭✭✭

    What is your topology? did you already put the command "no switchport" under the ethernet interface, or put already the "ip routing" command on the global config mode? 

    Hope this helps!

    Timothy Q. Manito

  •  I just have a basic topolgy with a IOU device connected to a IOS c7200 router. I wanted to get them to work properly before going any further. On the IOU L2 switch, I have done only the basic configuration of hostname, passwords etc. I'm wondering if I need more configuration to connect to the IOS device. When I connect the IOU device to IOU device, the basic configuration works and they can ping eachother.

    If this helps, when I show run the running config on the IOU switch only shows duplex settings with a default for full duplex. It doesn't show speed settings and when I try to configure speed settings on an interface on the switch, it doesn't recognize the command. It says invalid command. I did make sure that the duplex settings on the router were full also, and changed the speed settings on the router to 10, 100, and 1000 in an attempt to hopefully match the speed of the IOU switch. That didn't work either. BTW, I am running Windows 7, and the IOU and IOS do connect now since I set the host binding in GNS3 to the same subnetworks. However, I still can't ping between the 2 devices.

     

  • tmanitotmanito ✭✭✭

    In my topology, my 3725 router is directly connected to the IOU. I only configure the interface of the 3725 to have an ip address and my IOU switch with an SVI, and they can ping each other successfully. 

    Hope this helps!

    Timothy Q. Manito

  • Thanks to all the above for their replies.  Everything is now working as it should. Thanks a bunch!

  • tmanitotmanito ✭✭✭

    [B][Y][B][Y][H]

    Hope this helps!

    Timothy Q. Manito

  • Great!

    And thanks to you too, that was a great challenge (albeit outside of the CCIE R&S studies).

    In my case I got it solved right now. The problem on my IOU cloud was solved when I decided to create the cloud entry on the NETMAP second line. I dunno exactly what is the limitation, but it is working now.

    So I have a full OSX GNS3 <-> VMWare IOU <-> Outside world environment as well. Quite a bit of low-level tinkering but well worth the effort.

Sign In or Register to comment.