Weird problem

I've got a wierd problem at work I wanted to share to see if someone can fix it. Below is my simple topology.  The switches are Foundary, but it's all the same stuff anyway.

 

Sw3 eth25 -----------------------eth24 Sw1 eth25----------------------------fa0/0 R1

 

The links runs vlan 10 across all ports. Sw3 can't ping the standby IP on the router. However it can ping the physical interface IP.

 

r1#sh run int fa0/0.1
Building configuration...

Current configuration : 369 bytes
!
interface FastEthernet0/0.1
description Sales DATA VLAN
encapsulation dot1Q 10
ip address 172.26.40.1 255.255.255.0
ip helper-address 172.31.19.250
ip policy route-map DIA
no snmp trap link-status
standby 10 ip 172.26.40.10
standby 10 priority 105
standby 10 preempt
standby 10 name SalesOficeData
standby 10 track Serial0/0/0:0 20

 

[email protected]#ping 172.26.40.1       
Sending 1, 16-byte ICMP Echo to 172.26.40.1, timeout 5000 msec, TTL 64
Type Control-c to abort
Reply from 172.26.40.1 : bytes=16 time=1ms TTL=255
Success rate is 100 percent (1/1), round-trip min/avg/max=1/1/1 ms.
[email protected]#ping 172.26.40.10
Sending 1, 16-byte ICMP Echo to 172.26.40.10, timeout 5000 msec, TTL 64
Type Control-c to abort
Request timed out.
No reply from remote host.

 


The output below shows this switch (switch 3) is the root bridge for vlan 10 (i.e. all ports are designated forwarding)

[email protected]#show 802-1w vlan 10

--- VLAN 10 [ STP Instance owned by VLAN 10 ] ----------------------------

VLAN 10 BPDU cam_index is 0 and the DMA master Are(HEX) 0 3 5 7 C D F

Bridge IEEE 802.1W Parameters:

Bridge Bridge Bridge Bridge Force tx
Identifier MaxAge Hello FwdDly Version Hold
hex sec sec sec cnt
8000000cdbd23cfc 20 2 15 Default 3

RootBridge RootPath DesignatedBri- Root Max Fwd Hel
Identifier Cost dge Identifier Port Age Dly lo
hex hex sec sec sec
8000000cdbd23cfc 0 8000000cdbd23cfc Root 20 15 2

Port IEEE 802.1W Parameters:

<--- Config Params -->|<-------------- Current state ----------------->
Port Pri PortPath P2P Edge Role State Designa- Designated
Num Cost Mac Port ted cost bridge
1 128 200000 F F DESIGNATED FORWARDING 0 8000000cdbd23cfc
2 128 200000 F F DESIGNATED FORWARDING 0 8000000cdbd23cfc
3 128 0 F F DISABLED DISABLED 0 0000000000000000
4 128 200000 F F DISABLED DISABLED 0 8000000cdbd23cfc
5 128 200000 F F DESIGNATED FORWARDING 0 8000000cdbd23cfc
6 128 200000 F F DESIGNATED FORWARDING 0 8000000cdbd23cfc
7 128 200000 F F DESIGNATED FORWARDING 0 8000000cdbd23cfc
8 128 200000 F F DESIGNATED FORWARDING 0 8000000cdbd23cfc
9 128 200000 F F DESIGNATED FORWARDING 0 8000000cdbd23cfc
10 128 200000 F F DESIGNATED FORWARDING 0 8000000cdbd23cfc
11 128 200000 F F DESIGNATED FORWARDING 0 8000000cdbd23cfc
12 128 200000 F F DESIGNATED FORWARDING 0 8000000cdbd23cfc
13 128 200000 F F DESIGNATED FORWARDING 0 8000000cdbd23cfc
14 128 200000 F F DESIGNATED FORWARDING 0 8000000cdbd23cfc
15 128 200000 F F DESIGNATED FORWARDING 0 8000000cdbd23cfc
16 128 0 F F DISABLED DISABLED 0 0000000000000000
17 128 0 F F DISABLED DISABLED 0 0000000000000000
18 128 0 F F DISABLED DISABLED 0 0000000000000000
19 128 200000 F F DESIGNATED FORWARDING 0 8000000cdbd23cfc
20 128 200000 F F DESIGNATED FORWARDING 0 8000000cdbd23cfc
21 128 200000 F F DESIGNATED FORWARDING 0 8000000cdbd23cfc
22 128 200000 F F DESIGNATED FORWARDING 0 8000000cdbd23cfc
23 128 200000 F F DISABLED DISABLED 0 8000000cdbd23cfc
24 128 200000 F F DESIGNATED FORWARDING 0 8000000cdbd23cfc
25 128 200000 F F DESIGNATED FORWARDING 0 8000000cdbd23cfc
26 128 200000 F F DESIGNATED FORWARDING 0 8000000cdbd23cfc

 


So I thought maybe it had a bad arp entry for the virtual IP.

06230r1#sh int fa0/0.1           
FastEthernet0/0.1 is up, line protocol is up
Hardware is MV96340 Ethernet, address is 0019.aa00.5050 (bia 0019.aa00.5050)
06230r1#sh standby 
FastEthernet0/0.1 - Group 10
State is Active
19 state changes, last state change 18w1d
Virtual IP address is 172.26.40.10
Active virtual MAC address is 0000.0c07.ac0a
Local virtual MAC address is 0000.0c07.ac0a (v1 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 0.596 secs
Preemption enabled
Active router is local
Standby router is 172.26.40.2, priority 95 (expires in 7.684 sec)
Priority 105 (configured 105)
Track interface Serial0/0/0:0 state Up decrement 20
[email protected]#sh arp | i 172.26.40.1
         IP              Mac                  Port Age VlanId
172.26.40.10 0000.0c07.ac0a 5 0 10
172.26.40.1 0019.aa00.5050 25 0 10

 


Is this like the wierdest problem or what?

Comments

Sign In or Register to comment.