AToM not passing traffic even with vc up.

Dear Community member,

 

I need you to assist to suggest possible reason for the following issues in the attached diagram.

 

1. IGP is OSPF

2. mpls is enable across the network.

3. reachability is confirm between the two end cisco router where AToM config is turn on.

4. The environment is mixture of cisco router and mikrotic as depicted in the diagram.

The following are the show command I got but could not find what may be the possible issues with the setup...

======================================

RT_ATOM_1#ping mpls pseudowire 172.27.11.254 10 reply mode router-alert

Sending 5, 100-byte MPLS Echos to 172.27.11.254,

     timeout is 2 seconds, send interval is 0 msec:

Codes: '!' - success, 'Q' - request not sent, '.' - timeout,

  'L' - labeled output interface, 'B' - unlabeled output interface,

  'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,

  'M' - malformed request, 'm' - unsupported tlvs, 'N' - no label entry,

  'P' - no rx intf label prot, 'p' - premature termination of LSP,

  'R' - transit router, 'I' - unknown upstream index,

  'X' - unknown return code, 'x' - return code 0

 

Type escape sequence to abort.

 

*Jul  9 10:22:23.227: ATOM-disposition: incoming tag 117441733 in Fa0/0, size 108, packet dropped, Inband Control packet dropped.

*Jul  9 10:22:25.103: ATOM-disposition: incoming tag 117441733 in Fa0/0, size 108, packet dropped, Inband Control packet dropped.

*Jul  9 10:22:27.071: ATOM-disposition: incoming tag 117441733 in Fa0/0, size 108, packet dropped, Inband Control packet dropped.

*Jul  9 10:22:28.939: ATOM-disposition: incoming tag 117441733 in Fa0/0, size 108, packet dropped, Inband Control packet dropped.

*Jul  9 10:22:30.927: ATOM-disposition: incoming tag 117441733 in Fa0/0, size 108, packet dropped, Inband Control packet dropped.

Success rate is 0 percent (0/5)

=======================================================================

RT_ATOM_1#sho mpls l2transport vc 10 detail

Local interface: Fa8 up, line protocol up, Ethernet up

  Destination address: 172.27.11.254, VC ID: 10, VC status: up

    Output interface: Gi0, imposed label stack {142090 1221}

    Preferred path: not configured

    Default path: active

    Next hop: 172.27.1.1

  Create time: 00:25:32, last status change time: 00:19:08

  Signaling protocol: LDP, peer 172.27.11.254:0 up

    Targeted Hello: 172.27.11.252(LDP Id) -> 172.27.11.254

    Status TLV support (local/remote)   : enabled/not supported

      Label/status state machine        : established, LruRru

      Last local dataplane   status rcvd: no fault

      Last local SSS circuit status rcvd: no fault

      Last local SSS circuit status sent: no fault

      Last local  LDP TLV    status sent: no fault

      Last remote LDP TLV    status rcvd: not sent

    MPLS VC labels: local 1223, remote 1221

    Group ID: local 0, remote 0

    MTU: local 1500, remote 1500

    Remote interface description:

  Sequencing: receive disabled, send disabled

  VC statistics:

    packet totals: receive 0, send 4318

    byte totals:   receive 0, send 474880

    packet drops:  receive 0, seq error 0, send 0

=============================================================================

RT_ATOM_1#sho mpls l2transport binding

  Destination Address: 172.27.11.254,  VC ID: 10

    Local Label:  1223

        Cbit: 1,    VC Type: Ethernet,    GroupID: 0

        MTU: 1500,   Interface Desc: n/a

        VCCV: CC Type: CW [1], RA [2]

              CV Type: LSPV [2]

    Remote Label: 1221

        Cbit: 1,    VC Type: Ethernet,    GroupID: 0

        MTU: 1500,   Interface Desc: n/a

        VCCV: CC Type: CW [1], RA [2]

              CV Type: LSPV [2]

===========================================================================

 

RT_ATOM_1#sho mpls forwarding-table | i l2

1223       No Label   l2ckt(10)        0             Fa8        point2point

===========================================================================

 

RT_ATOM_2#sho mpls l2transport vc 10 detail

Local interface: Fa0/1 up, line protocol up, Ethernet up

  Destination address: 172.27.11.252, VC ID: 10, VC status: up

    Next hop: 172.27.14.25

    Output interface: Fa0/0, imposed label stack {550 1223}

  Create time: 00:11:53, last status change time: 00:08:18

  Signaling protocol: LDP, peer 172.27.11.252:0 up

    MPLS VC labels: local 1221, remote 1223

    Group ID: local 0, remote 0

    MTU: local 1500, remote 1500

    Remote interface description:

  Sequencing: receive disabled, send disabled

  VC statistics:

    packet totals: receive 2446, send 1553

    byte totals:   receive 224196, send 213523

    packet drops:  receive 15, seq error 0, send 0

==============================================================

RT_ATOM_1#sho mpls l2transport binding 10

  Destination Address: 172.27.11.254,  VC ID: 10

    Local Label:  1223

        Cbit: 1,    VC Type: Ethernet,    GroupID: 0

        MTU: 1500,   Interface Desc: n/a

        VCCV: CC Type: CW [1], RA [2]

              CV Type: LSPV [2]

    Remote Label: 1221

        Cbit: 1,    VC Type: Ethernet,    GroupID: 0

        MTU: 1500,   Interface Desc: n/a

        VCCV: CC Type: CW [1], RA [2]

              CV Type: LSPV [2]

yourname#

=====================================================

RT_ATOM_2#sho mpls l2transport binding 10

  Destination Address: 172.27.11.252,  VC ID: 10

    Local Label:  1221

        Cbit: 1,    VC Type: Ethernet,    GroupID: 0

        MTU: 1500,   Interface Desc: n/a

        VCCV: CC Type: CW [1], RA [2]

              CV Type: LSPV [2]

    Remote Label: 1223

        Cbit: 1,    VC Type: Ethernet,    GroupID: 0

        MTU: 1500,   Interface Desc: n/a

        VCCV: CC Type: CW [1], RA [2]

              CV Type: LSPV [2]

===========================================================

Looking at output of command sho mpls l2transport vc 10 detail it can be observed that ATOM_2 is sending and receiving packet but that is not the case for ATOM_1

What could be wrong with this scenario?

Your input will be appreciated.image

Thank you,

Comments

  • Is this a physical router or a VM/IOU? If the latter I don't think the data plane is supported for AToM. 

    Brian McGahan, 4 x CCIE #8593 (R&S/SP/SC/DC), CCDE #2013::13
    [email protected]
     
    Internetwork Expert, Inc.
    http://www.INE.com

    On Jul 10, 2014, at 5:20 AM, "adeyholar" <[email protected]> wrote:

    Dear Community member,

     

    I need you to assist to suggest possible reason for the following issues in the attached diagram.

     

    1. IGP is OSPF

    2. mpls is enable across the network.

    3. reachability is confirm between the two end cisco router where AToM config is turn on.

    4. The environment is mixture of cisco router and mikrotic as depicted in the diagram.

    The following are the show command I got but could not find what may be the possible issues with the setup...

    ======================================

    RT_ATOM_1#ping mpls pseudowire 172.27.11.254 10 reply mode router-alert

    Sending 5, 100-byte MPLS Echos to 172.27.11.254,

         timeout is 2 seconds, send interval is 0 msec:

    Codes: '!' - success, 'Q' - request not sent, '.' - timeout,

      'L' - labeled output interface, 'B' - unlabeled output interface,

      'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,

      'M' - malformed request, 'm' - unsupported tlvs, 'N' - no label entry,

      'P' - no rx intf label prot, 'p' - premature termination of LSP,

      'R' - transit router, 'I' - unknown upstream index,

      'X' - unknown return code, 'x' - return code 0

     

    Type escape sequence to abort.

     

    *Jul  9 10:22:23.227: ATOM-disposition: incoming tag 117441733 in Fa0/0, size 108, packet dropped, Inband Control packet dropped.

    *Jul  9 10:22:25.103: ATOM-disposition: incoming tag 117441733 in Fa0/0, size 108, packet dropped, Inband Control packet dropped.

    *Jul  9 10:22:27.071: ATOM-disposition: incoming tag 117441733 in Fa0/0, size 108, packet dropped, Inband Control packet dropped.

    *Jul  9 10:22:28.939: ATOM-disposition: incoming tag 117441733 in Fa0/0, size 108, packet dropped, Inband Control packet dropped.

    *Jul  9 10:22:30.927: ATOM-disposition: incoming tag 117441733 in Fa0/0, size 108, packet dropped, Inband Control packet dropped.

    Success rate is 0 percent (0/5)

    =======================================================================

    RT_ATOM_1#sho mpls l2transport vc 10 detail

    Local interface: Fa8 up, line protocol up, Ethernet up

      Destination address: 172.27.11.254, VC ID: 10, VC status: up

        Output interface: Gi0, imposed label stack {142090 1221}

        Preferred path: not configured

        Default path: active

        Next hop: 172.27.1.1

      Create time: 00:25:32, last status change time: 00:19:08

      Signaling protocol: LDP, peer 172.27.11.254:0 up

        Targeted Hello: 172.27.11.252(LDP Id) -> 172.27.11.254

        Status TLV support (local/remote)   : enabled/not supported

          Label/status state machine        : established, LruRru

          Last local dataplane   status rcvd: no fault

          Last local SSS circuit status rcvd: no fault

          Last local SSS circuit status sent: no fault

          Last local  LDP TLV    status sent: no fault

          Last remote LDP TLV    status rcvd: not sent

        MPLS VC labels: local 1223, remote 1221

        Group ID: local 0, remote 0

        MTU: local 1500, remote 1500

        Remote interface description:

      Sequencing: receive disabled, send disabled

      VC statistics:

        packet totals: receive 0, send 4318

        byte totals:   receive 0, send 474880

        packet drops:  receive 0, seq error 0, send 0

    =============================================================================

    RT_ATOM_1#sho mpls l2transport binding

      Destination Address: 172.27.11.254,  VC ID: 10

        Local Label:  1223

            Cbit: 1,    VC Type: Ethernet,    GroupID: 0

            MTU: 1500,   Interface Desc: n/a

            VCCV: CC Type: CW [1], RA [2]

                  CV Type: LSPV [2]

        Remote Label: 1221

            Cbit: 1,    VC Type: Ethernet,    GroupID: 0

            MTU: 1500,   Interface Desc: n/a

            VCCV: CC Type: CW [1], RA [2]

                  CV Type: LSPV [2]

    ===========================================================================

     

    RT_ATOM_1#sho mpls forwarding-table | i l2

    1223       No Label   l2ckt(10)        0             Fa8        point2point

    ===========================================================================

     

    RT_ATOM_2#sho mpls l2transport vc 10 detail

    Local interface: Fa0/1 up, line protocol up, Ethernet up

      Destination address: 172.27.11.252, VC ID: 10, VC status: up

        Next hop: 172.27.14.25

        Output interface: Fa0/0, imposed label stack {550 1223}

      Create time: 00:11:53, last status change time: 00:08:18

      Signaling protocol: LDP, peer 172.27.11.252:0 up

        MPLS VC labels: local 1221, remote 1223

        Group ID: local 0, remote 0

        MTU: local 1500, remote 1500

        Remote interface description:

      Sequencing: receive disabled, send disabled

      VC statistics:

        packet totals: receive 2446, send 1553

        byte totals:   receive 224196, send 213523

        packet drops:  receive 15, seq error 0, send 0

    ==============================================================

    RT_ATOM_1#sho mpls l2transport binding 10

      Destination Address: 172.27.11.254,  VC ID: 10

        Local Label:  1223

            Cbit: 1,    VC Type: Ethernet,    GroupID: 0

            MTU: 1500,   Interface Desc: n/a

            VCCV: CC Type: CW [1], RA [2]

                  CV Type: LSPV [2]

        Remote Label: 1221

            Cbit: 1,    VC Type: Ethernet,    GroupID: 0

            MTU: 1500,   Interface Desc: n/a

            VCCV: CC Type: CW [1], RA [2]

                  CV Type: LSPV [2]

    yourname#

    =====================================================

    RT_ATOM_2#sho mpls l2transport binding 10

      Destination Address: 172.27.11.252,  VC ID: 10

        Local Label:  1221

            Cbit: 1,    VC Type: Ethernet,    GroupID: 0

            MTU: 1500,   Interface Desc: n/a

            VCCV: CC Type: CW [1], RA [2]

                  CV Type: LSPV [2]

        Remote Label: 1223

            Cbit: 1,    VC Type: Ethernet,    GroupID: 0

            MTU: 1500,   Interface Desc: n/a

            VCCV: CC Type: CW [1], RA [2]

                  CV Type: LSPV [2]

    ===========================================================

    Looking at output of command sho mpls l2transport vc 10 detail it can be observed that ATOM_2 is sending and receiving packet but that is not the case for ATOM_1

    What could be wrong with this scenario?

    Your input will be appreciated.

    Thank you,




    INE - The Industry Leader in CCIE Preparation

    http://www.INE.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx
  • Thanks for your response Brian. The is actually a physical devices. As indicated even this same scenario work well with GNS3 but it quite strange that vc is up data-plane activated correctly but traffic cannot still pass. I am guess it could be mikrotic along the traffic path but I have no clue how that can be.

    Here are the show version of the same devices. and some show run..

     

    sho version
    Cisco IOS Software, C890 Software (C890-UNIVERSALK9-M), Version 15.2(4)M3, RELEASE SOFTWARE (fc2)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2013 by Cisco Systems, Inc.
    Compiled Tue 26-Feb-13 13:19 by prod_rel_team

    ROM: System Bootstrap, Version 12.4(22r)YB3, RELEASE SOFTWARE (fc1)

    RT_ATOM_1 uptime is 1 day, 1 hour, 0 minutes
    System returned to ROM by power-on
    System image file is "flash:c890-universalk9-mz.152-4.M3.bin"
    Last reload type: Normal Reload
    Last reload reason: power-on

     

    This product contains cryptographic features and is subject to United
    States and local country laws governing import, export, transfer and
    use. Delivery of Cisco cryptographic products does not imply
    third-party authority to import, export, distribute or use encryption.
    Importers, exporters, distributors and users are responsible for
    compliance with U.S. and local country laws. By using this product you
    agree to comply with applicable laws and regulations. If you are unable
    to comply with U.S. and local laws, return this product immediately.

    A summary of U.S. laws governing Cisco cryptographic products may be found at:
    http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

    If you require further assistance please contact us by sending email to
    [email protected]

    Cisco 891 (MPC8300) processor (revision 1.0) with 498688K/25600K bytes of memory.
    Processor board ID FCZ1721C27P

    9 FastEthernet interfaces
    1 Gigabit Ethernet interface
    1 Serial interface
    1 terminal line
    1 Virtual Private Network (VPN) Module
    256K bytes of non-volatile configuration memory.
    247464K bytes of ATA CompactFlash (Read/Write)


    License Info:

    License UDI:

    -------------------------------------------------
    Device#   PID                   SN
    -------------------------------------------------
    *0        CISCO891-K9           FCZ1721C27P

     

    License Information for 'c890'
        License Level: advipservices   Type: Permanent
        Next reboot license Level: advipservices


    Configuration register is 0x2102

    ======================================

    sho run
    Building configuration...

    Current configuration : 5597 bytes
    !
    ! Last configuration change at 12:31:06 UTC Wed Jul 9 2014 by admin
    version 15.2
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname RT_ATOM_1
    !
    boot-start-marker
    boot-end-marker
    !
    !
    logging buffered 102400
    logging console informational
    !
    no aaa new-model
    !
    ip cef
    !
    !
    !
    !
    no ip domain lookup
    ip domain name yourdomain.com
    no ipv6 cef
    !
    !
    !
    !
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    !
    !
    license udi pid CISCO891-K9 sn FCZ1721C27P
    !
    !
    username admin privilege 15 password 0 cisco
    !
    redundancy
    !
    !
    !
    !
    !
    pseudowire-class MPLS
     encapsulation mpls
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface Loopback0
     ip address 172.27.11.252 255.255.255.255
    !
    interface FastEthernet0
     no ip address
    !
    interface FastEthernet1
     no ip address
    !
    interface FastEthernet2
     no ip address
    !
    interface FastEthernet3
     no ip address
    !
    interface FastEthernet4
     no ip address
    !
    interface FastEthernet5
     no ip address
    !
    interface FastEthernet6
     no ip address
    !
    interface FastEthernet7
     no ip address
    !
    interface FastEthernet8
     no ip address
     duplex auto
     speed auto
     xconnect 172.27.11.254 10 pw-class MPLS
    !
    interface GigabitEthernet0
    description connection to mikrotic router
     mtu 1600
     ip address 172.27.1.2 255.255.255.248
     ip ospf mtu-ignore
     duplex auto
     speed auto
     mpls ip
    !
    interface Vlan1
     description $ETH_LAN$
     ip address 10.10.10.1 255.255.255.248
     ip tcp adjust-mss 1452
     shutdown
    !
    interface Async1
     no ip address
     encapsulation slip
    !
    router ospf 101
     network 0.0.0.0 255.255.255.255 area 1
    !
    ip forward-protocol nd
    ip http server
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    mgcp profile default
    !
    !
    !
    !
    !
    !
    end

    ======================================

    RT_ATOM_2 sho ver

    sho ver
    Cisco IOS Software, 1841 Software (C1841-SPSERVICESK9-M), Version 12.4(15)T14, RELEASE SOFTWARE (fc2)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2010 by Cisco Systems, Inc.
    Compiled Tue 17-Aug-10 05:25 by prod_rel_team

    ROM: System Bootstrap, Version 12.4(13r)T, RELEASE SOFTWARE (fc1)

    RT_ATOM_2 uptime is 25 minutes
    System returned to ROM by power-on
    System image file is "flash:c1841-spservicesk9-mz.124-15.T14.bin"


    This product contains cryptographic features and is subject to United
    States and local country laws governing import, export, transfer and
    use. Delivery of Cisco cryptographic products does not imply
    third-party authority to import, export, distribute or use encryption.
    Importers, exporters, distributors and users are responsible for
    compliance with U.S. and local country laws. By using this product you
    agree to comply with applicable laws and regulations. If you are unable
    to comply with U.S. and local laws, return this product immediately.

    A summary of U.S. laws governing Cisco cryptographic products may be found at:
    http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

    If you require further assistance please contact us by sending email to
    [email protected]

    Cisco 1841 (revision 7.0) with 116736K/14336K bytes of memory.
    Processor board ID FCZ111922K9
    2 FastEthernet interfaces
    1 Serial(sync/async) interface
    2 Low-speed serial(sync/async) interfaces
    DRAM configuration is 64 bits wide with parity disabled.
    191K bytes of NVRAM.
    62720K bytes of ATA CompactFlash (Read/Write)

    Configuration register is 0x2102

    RT_ATOM_2#

    RT_ATOM_2#sho run
    Building configuration...

    Current configuration : 1409 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname RT_ATOM_2
    !
    boot-start-marker
    boot-end-marker
    !
    logging buffered 4096
    enable secret 5 $1$HEDc$NCqFZHFqsKMwYwU2dpQcD1
    !
    no aaa new-model
    dot11 syslog
    ip cef
    !
    !
    pseudowire-class MPLS
     encapsulation mpls
    !
    !
    !
    !
    interface Loopback0
     ip address 172.27.11.254 255.255.255.255
    !
    interface FastEthernet0/0
     mtu 1600
     ip address 172.27.14.26 255.255.255.252
     ip ospf mtu-ignore
     speed 100
     full-duplex
     mpls ip
    !
    interface FastEthernet0/1
     no ip address
     duplex auto
     speed auto
     xconnect 172.27.11.252 10 pw-class MPLS
    !
    interface Serial0/0/0
     no ip address
     shutdown
     clock rate 2000000
    !
    interface Serial0/1/0
     no ip address
     shutdown
     clock rate 125000
    !
    interface Serial0/1/1
     no ip address
     shutdown
     clock rate 125000
    !
    router ospf 101
     router-id 172.17.11.254
     log-adjacency-changes
     redistribute connected subnets
     network 0.0.0.0 255.255.255.255 area 0
    !
    ip forward-protocol nd
    !
    !
    ip http server
    no ip http secure-server
    !
    mpls ldp router-id Loopback0 force
    !
    !
    !
    control-plane
    !
    !

     

    Any idea will be appreciated.

     

    Thanks.

Sign In or Register to comment.