Task 3.4

Hi!

I can't find relative thread in archive section, however I'm sure that people already know, that SG for 3.4 contradicts with lab's DOs'nd'DON'Ts. So I'm talking about init configs for R4 and R5, which looks like:

hostname Rack1R4

interface Serial0/1
encapsulation frame-relay
no shutdown

hostname Rack1R5

interface Serial0/1
encapsulation frame-relay
no shutdown
In turn SG changes encapsulation type to ppp and go further. However, changing encapsulation type is not permitted.

Comments

  • hey Ntllect, i often see where people state this violates rules ...like altering the encapsulation or only use physical interface..etc etc;....i dont know how else to get around the MD5 problem of having different passwords to the different endpoints...and i tried for bout an hour for alternate solution w/o using PPPoFrame-Relay...i bet somebody can get alternate....

    ...but does it violate?  are you changing the encapsulation?  the physical is still Frame-Relay... 

     

  • Hi,

     

    I was considering to change the encapsulation to PPP from the first  glance, but Do-Don'tDo explicitly deny it. It means that the solution is wrong or the initial configuration.

    It's possible to solve that task without changing encapsulation:

    interface Serial0/1
     no ip address
     encapsulation frame-relay
     no keepalive
    !
    interface Serial1/1.45 point-to-point
     ip unnumbered Loopback1
     frame-relay interface-dlci 405   

    !

    router eigrp 10
     network 167.1.45.5 0.0.0.0
     no auto-summary
    !

    :) we should enable the EIGRP for this link  in 4.4 anyway. I think it would be an appropriate solution.

     

  • Agreed.  The initial configured encapsulation is frame relay and the the SG changes it to PPP.  The Lab clearly states "Do not change any interface encapsulations unless otherwise specified". 

  • The questions asks you to configure 2 /32 subnets on R4 and R5. You can only solve this by using PPP which advertises a host (/32) route to the neighbors' address. So you are allowed to use PPP here, because this is what they are asking for.

    How did you solve it without it and without using static routes?

    Rick Mur

    CCIE #21946 (R&S)

    CCNP, CCIP, JNCIA-ER, MCSE

    [email protected]

    On 10 Dec 2008 08:47:42 -0800


    "[email protected]" <[email protected]> wrote:

    Agreed. The initial configured encapsulation is frame relay and the

    the SG changes it to PPP. The Lab clearly states "Do not change any

    interface encapsulations unless otherwise specified".


    "Internetwork Expert - The Industry Leader in CCIE Preparation


    http://www.internetworkexpert.com

    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx

    "

  • I don't think this question can be configured any other way.  At least I couldn't figure out a way to use Frame Relay.  I agree that the obvious answer to the question is to use PPP but they don't specifically say "use PPP" or "you are allowed to change the encapsulation type".  They do specifically say at the beginning of the lab not to change the encapsulation type unless otherwise specified.  To me that means don't change it unless we specifically tell you to. 

     

  • The questions asks you to configure 2 /32 subnets on R4 and R5. You can only solve this by using PPP which advertises a host (/32) route to the neighbors' address. So you are allowed to use PPP here, because this is what they are asking for.

    How did you solve it without it and without using static routes?



    Hm, you're right may be, the encapsulation on the physical interface is still Frame-relay, we just configure PPP over it, but it's possible to solve this without PPP and static [;)],  I don't think it will 100% correct but as workaround was quite interesting,  look here:


    config on R4:

    interface Loopback1
     ip address 167.1.45.4 255.255.255.255

    interface Serial0/1
     no ip address
     encapsulation frame-relay
     no keepalive
     serial restart-delay 0
    end


    interface Serial0/1.45 point-to-point
     ip unnumbered Loopback1
     snmp trap link-status
     frame-relay interface-dlci 405  
    end


    router eigrp 10
     network 167.1.45.4 0.0.0.0
     no auto-summary

    on R5:

    interface Loopback1
     ip address 167.1.45.5 255.255.255.255


    interface Serial0/1
     no ip address
     encapsulation frame-relay
     no keepalive
     serial restart-delay 0
    end


    interface Serial0/1.45 point-to-point
     ip unnumbered Loopback1
     snmp trap link-status
     frame-relay interface-dlci 405  
    end

    router eigrp 10
     network 167.1.45.5 0.0.0.0
     no auto-summary

     then check the EIGRP neigbors and routing table:

    Rack1R4#sh ip eigrp nei
    IP-EIGRP neighbors for process 10
    H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                                (sec)         (ms)       Cnt Num
    0   167.1.45.5              Se0/1.45          11 00:01:23   20   450  0  3


    Rack1R4#sh ip route eigrp
         167.1.0.0/16 is variably subnetted, 4 subnets, 2 masks
    D       167.1.45.5/32 [90/2297856] via 167.1.45.5, 00:09:49, Serial0/1.45

     

    Rack1R5#sh ip eigrp nei
    IP-EIGRP neighbors for process 10
    H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                                (sec)         (ms)       Cnt Num
    0   167.1.45.4              Se0/1.45          12 00:01:30 1252  5000  0  3


    Rack1R5#sh ip route eigr
         167.1.0.0/16 is variably subnetted, 8 subnets, 2 masks
    D       167.1.45.4/32 [90/2297856] via 167.1.45.4, 00:08:46, Serial0/1.45

    and the pings:

    Rack1R4#ping 167.1.45.5 source lo 1

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 167.1.45.5, timeout is 2 seconds:
    Packet sent with a source address of 167.1.45.4
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 8/23/36 ms

    Rack1R5#ping 167.1.45.4 source lo 1        

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 167.1.45.4, timeout is 2 seconds:
    Packet sent with a source address of 167.1.45.5
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/17/28 ms

  • Yeah I don't think that's really the solution if you're still in the layer 2 section :p but it works though!

    Could anyone of IE respond if changing the encapsulation in this task is really allowed (it should be) and this is just a mistake in the initial config? It's also quite wrong since only the encapsulation is set and they didn't turn of LMI. 

    HTH,

    Rick  

    Sent from my iPhone

    On 11 dec 2008, at 18:04, <[email protected]> wrote:

    imagermur:

    The questions asks you to configure 2 /32 subnets on R4 and R5. You can only solve this by using PPP which advertises a host (/32) route to the neighbors' address. So you are allowed to use PPP here, because this is what they are asking for.

    How did you solve it without it and without using static routes?



    Hm, you're right may be, the encapsulation on the physical interface is still Frame-relay, we just configure PPP over it, but it's possible to solve this without PPP and static Wink,  I don't think it will 100% correct but as workaround was quite interesting,  look here:


    config on R4:

    interface Loopback1
     ip address 167.1.45.4 255.255.255.255

    interface Serial0/1
     no ip address
     encapsulation frame-relay
     no keepalive
     serial restart-delay 0
    end


    interface Serial0/1.45 point-to-point
     ip unnumbered Loopback1
     snmp trap link-status
     frame-relay interface-dlci 405  
    end


    router eigrp 10
     network 167.1.45.4 0.0.0.0
     no auto-summary

    on R5:

    interface Loopback1
     ip address 167.1.45.5 255.255.255.255


    interface Serial0/1
     no ip address
     encapsulation frame-relay
     no keepalive
     serial restart-delay 0
    end


    interface Serial0/1.45 point-to-point
     ip unnumbered Loopback1
     snmp trap link-status
     frame-relay interface-dlci 405  
    end

    router eigrp 10
     network 167.1.45.5 0.0.0.0
     no auto-summary

     then check the EIGRP neigbors and routing table:

    Rack1R4#sh ip eigrp nei
    IP-EIGRP neighbors for process 10
    H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                                (sec)         (ms)       Cnt Num
    0   167.1.45.5              Se0/1.45          11 00:01:23   20   450  0  3


    Rack1R4#sh ip route eigrp
         167.1.0.0/16 is variably subnetted, 4 subnets, 2 masks
    D       167.1.45.5/32 [90/2297856] via 167.1.45.5, 00:09:49, Serial0/1.45

     

    Rack1R5#sh ip eigrp nei
    IP-EIGRP neighbors for process 10
    H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                                (sec)         (ms)       Cnt Num
    0   167.1.45.4              Se0/1.45          12 00:01:30 1252  5000  0  3


    Rack1R5#sh ip route eigr
         167.1.0.0/16 is variably subnetted, 8 subnets, 2 masks
    D       167.1.45.4/32 [90/2297856] via 167.1.45.4, 00:08:46, Serial0/1.45

    and the pings:

    Rack1R4#ping 167.1.45.5 source lo 1

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 167.1.45.5, timeout is 2 seconds:
    Packet sent with a source address of 167.1.45.4
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 8/23/36 ms

    Rack1R5#ping 167.1.45.4 source lo 1        

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 167.1.45.4, timeout is 2 seconds:
    Packet sent with a source address of 167.1.45.5
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/17/28 ms




    "Internetwork Expert - The Industry Leader in CCIE Preparation

    http://www.internetworkexpert.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx
    "
  • I interpreted this one a little different.  I kept the encapsulation as FR as I thought this was part of the challenge of the lab.  I disabled keepalives and created "another interface" using PPPoFR and then just assigned the two /32's there as they were obviously looking for peer neighbor route negioation.  I'm not sure where the MD5 issue comes into play here, but I'm able to establish my adjancies just fine.  If I were required to create loopback1 for this problem, then unnumbered should behave the same.

     

    -ryan

  • It's been a tiring last couple of weeks, the loopbacks are needed Bad mask /32 for address 167.1.45.4.  I'm on autopilot with typing =/

  • This one pissed me off after I saw the solution guide. SG said don't change the encapsulation... I figured this is a level 10 lab, I have to be able to do it. So I added virtual-template 45 and couldn't assign a 32 bit mask to it. So I had to make Loopback45 and assign that as unnumbered to the virtual-template. I spent about 1.5 hours thinking of a way to pull it off.

    R4 configuration

    interface Serial0/1
     no ip address
     encapsulation frame-relay
     no ip route-cache
     no ip mroute-cache
     no keepalive
     clock rate 2000000
     frame-relay interface-dlci 101 ppp Virtual-Template45

    interface Virtual-Template45
     ip unnumbered Loopback45

    interface Loopback45
     ip address 167.1.45.4 255.255.255.255

    who output from R4
      Interface    User               Mode         Idle     Peer Address
      Vi2                             PPPoFR       00:01:39 167.1.45.4

    show ip route 167.1.45.5
    Routing entry for 167.1.45.5/32
      Known via "connected", distance 0, metric 0 (connected, via interface)
      Routing Descriptor Blocks:
      * directly connected, via Virtual-Access2
          Route metric is 0, traffic share count is 1

    -----------------------------------------------------------------------------------------------

    R5 configuration

    interface Serial0/1
     no ip address
     encapsulation frame-relay
     no ip route-cache
     no ip mroute-cache
     no keepalive
     clock rate 2000000
     frame-relay interface-dlci 101 ppp Virtual-Template45

    interface Virtual-Template45
     ip unnumbered Loopback45

    interface Loopback45
     ip address 167.1.45.5 255.255.255.255

    who output from R5
      Interface    User               Mode         Idle     Peer Address
      Vi2                             PPPoFR       00:01:39 167.1.45.4

    show ip route 167.1.45.4
    Routing entry for 167.1.45.4/32
      Known via "connected", distance 0, metric 0 (connected, via interface)
      Routing Descriptor Blocks:
      * directly connected, via Virtual-Access2
          Route metric is 0, traffic share count is 1


    ------------------------------------------------------------------------------------------

     

    Verification...

    RSRack1R4#ping 167.1.45.5

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 167.1.45.5, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

     

    RSRack1R5#ping 167.1.45.4

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 167.1.45.4, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

Sign In or Register to comment.