MPLS VPN using OSPF

Hey Guys, 

I've done a pretty simple lab but I have a doubt. I have attached my topology , its better for everybody understand.

Everything is working, but I think that I've done the wrong configurations on my MPLS network.....

The weird behavior is: from R8, if I ping R7 loopback, the packet go trough MPLS (as I am expecting) but if I tracert I cant see the MPLS Labels ....

When I jump to R5 and tracert to R7 loopback using the fa0/0(VRF interface) as a source I can see the mpls labels...

 

 

image

 

FROM R8 TO R7 LOOPBACK

R8#traceroute 150.1.7.7

 

Type escape sequence to abort.

Tracing the route to 150.1.7.7

 

  1 172.16.58.5 64 msec 52 msec 36 msec

  2 192.168.35.3 252 msec 172 msec 348 msec

  3 192.168.13.1 324 msec 128 msec 144 msec

  4 172.16.67.6 116 msec 72 msec 96 msec

  5 172.16.67.7 224 msec *  212 msec

R8#



FROM R5 VRF INTERFACE TO R7 LOOPBACK



R5#traceroute vrf VPN 172.16.67.7


Type escape sequence to abort.

Tracing the route to 172.16.67.7


  1 192.168.35.3 [MPLS: Labels 22/29 Exp 0] 72 msec 172 msec 60 msec

  2 192.168.13.1 [MPLS: Labels 22/29 Exp 0] 60 msec 88 msec 120 msec

  3 172.16.67.6 44 msec 108 msec 132 msec

  4 172.16.67.7 108 msec *  132 msec



 shouldn't R8 be able to see the labels as weel ?

Comments


  • FROM R5 VRF INTERFACE TO R7 LOOPBACK



    R5#traceroute vrf VPN 172.16.67.7


    Type escape sequence to abort.

    Tracing the route to 172.16.67.7


      1 192.168.35.3 [MPLS: Labels 22/29 Exp 0] 72 msec 172 msec 60 msec

      2 192.168.13.1 [MPLS: Labels 22/29 Exp 0] 60 msec 88 msec 120 msec

      3 172.16.67.6 44 msec 108 msec 132 msec

      4 172.16.67.7 108 msec *  132 msec



     shouldn't R8 be able to see the labels as weel ?

    Hello Ranato,

    I believe the CE can see the MPLS labels and the hosts are unable to see the same. Please make sure that your R5 & R8 have same IOS version to verify about the labels. 

    Additionally, please check for the routing and ensure there is no asymmetric routing in place. Not really sure but it could also cause the same. 

    HTH

  • Hi,

     

    1: Is the link between R7<------->R8 up. Traceroute should go this way first if the routing is OK.

    2: Please paste the config for Routers at least R8 and R5 to see where is the problem.

     

    Thanks

     

     

  • Murad,

    The link between R7 and R8 is shutdown.

    Follow the relevant configs:

    R5#sh run | section interface|router bgp|router ospf|ip vrf

    ip vrf VPN

     rd 100:5

     route-target export 100:5

     route-target import 100:5

     route-target import 100:6

    interface Loopback0

     ip address 150.1.5.5 255.255.255.255

    interface Loopback1

     ip vrf forwarding VPN

     ip address 150.1.55.55 255.255.255.255

    interface FastEthernet0/0

     ip vrf forwarding VPN

     ip address 172.16.58.5 255.255.255.0

     duplex auto

     speed auto

    interface FastEthernet0/1

     ip address 192.168.35.5 255.255.255.0

     duplex auto

     speed auto

     mpls ip

    router ospf 200 vrf VPN

     router-id 172.16.5.5

     log-adjacency-changes

     area 0 sham-link 150.1.55.55 150.1.66.66

     redistribute bgp 100 subnets

     network 172.16.58.5 0.0.0.0 area 0

    router ospf 1

     router-id 150.1.5.5

     log-adjacency-changes

     network 150.1.5.5 0.0.0.0 area 0

     network 192.168.35.5 0.0.0.0 area 0

    router bgp 100

     no synchronization

     bgp log-neighbor-changes

     network 150.1.55.0 mask 255.255.255.0

     neighbor 150.1.1.1 remote-as 100

     neighbor 150.1.1.1 update-source Loopback0

     neighbor 150.1.2.2 remote-as 100

     neighbor 150.1.2.2 update-source Loopback0

     neighbor 150.1.3.3 remote-as 100

     neighbor 150.1.3.3 update-source Loopback0

     neighbor 150.1.4.4 remote-as 100

     neighbor 150.1.4.4 update-source Loopback0

     neighbor 150.1.6.6 remote-as 100

     neighbor 150.1.6.6 update-source Loopback0

     no auto-summary

     !

     address-family vpnv4

     neighbor 150.1.6.6 activate

     neighbor 150.1.6.6 send-community extended

     exit-address-family

     !

     address-family ipv4 vrf VPN

     redistribute ospf 200 vrf VPN

     no auto-summary

     no synchronization

     network 150.1.55.55 mask 255.255.255.255

     exit-address-family

    R5#



    R8#sh run | section interface|router bgp|router ospf|ip vrf

    interface Loopback0

     ip address 150.1.8.8 255.255.255.0

    interface FastEthernet0/0

     ip address 172.16.58.8 255.255.255.0

     duplex auto

     speed auto

    i

    router ospf 200

     router-id 150.1.8.8

     log-adjacency-changes

     network 150.1.8.8 0.0.0.0 area 0

     network 172.16.58.8 0.0.0.0 area 0


    R8#


    there are exaclty the same config in the other side, but If you want I can post here as well.


    The R5 have ldp  neighbor with R3 and R3 have ldp neighbor with R1 and R1 with R6.






     

  • Renato,

    I think it's an IOS specific stuff since I was able to see the label on CE routers in past days which were real gears. I believe you have been doing this on GNS3, which could have older IOS image and probably not able to give the output as you required.

    Please take a look into this thread: 

    https://supportforums.cisco.com/thread/2192214

    HTH

  • which could have older IOS image and probably not able to give the output as you required.

    Yes, I just went through some of my CE routers and the older ones are not able to give the label information. 

     

Sign In or Register to comment.