BGP prefix Dampening

Hello All,

Why is it that when I do the dampening directly on the network command it seems to take no effect?My relevant config is as below :-

R4(config-router)#do show ip bgp dampen param
% dampening not enabled for base
R4(config-router)#do show run | s router bgp
router bgp 400
 no synchronization
 bgp log-neighbor-changes
 network 4.0.0.0
 network 40.4.4.0 mask 255.255.255.0 route-map DAMP1
 network 44.4.4.0 mask 255.255.255.0 route-map DAMP2
 neighbor 10.1.34.3 remote-as 300
 neighbor 10.1.45.5 remote-as 500
 no auto-summary
R4(config-router)#do show run | sec route-map
 network 40.4.4.0 mask 255.255.255.0 route-map DAMP1
 network 44.4.4.0 mask 255.255.255.0 route-map DAMP2
route-map DAMP1 permit 10
 match ip address 10
 set dampening 20 800 2400 90
route-map DAMP2 permit 10
 match ip address 11
 set dampening 15 700 2000 60
R4(config-router)#show ip access-list
                   ^
% Invalid input detected at '^' marker.

R4(config-router)#do show ip access-list
Standard IP access list 10
    10 permit 40.4.4.0, wildcard bits 0.0.0.255 (1 match)
Standard IP access list 11
    10 permit 44.4.4.0, wildcard bits 0.0.0.255 (1 match)
R4(config-router)#

BUT when i do it under usind the bgp damp route-map and i combine the two route maps into one it works:

route-map DAMP3 permit 10
 match ip address 10
 set dampening 20 800 2400 90
route-map DAMP3 permit 20
 match ip address 11
 set dampening 15 700 2000 60

router bgp 400
bgp dampe route-map DAMP3

 

Comments

  • From the config guide:

     

    bgp dampening


    To enable BGP route dampening or change various BGP route dampening factors, use the bgp dampening command in address family or router configuration mode. To disable the function or restore the default values, use the no form of this command.


    bgp dampening [half-life reuse suppress max-suppress-time] [route-map map-name]

    no bgp dampening [half-life reuse suppress max-suppress-time] [route-map map-name]

     

    So you need to do this:

     

    router bgp XXX

     bgp dampening route-map XXXXX

     

    Applying a route-map on a network statement is not the way to implement this feature.

     

  • As bobby pointed out is the right way to do it.

    Also if you look at your first configuration optoion, you are trying to match the same prefix two times and set dampening. Once in a route map and again in network statement  [:D]

    HTH

     

    Hello All,

    Why is it that when I do the dampening directly on the network command it seems to take no effect?My relevant config is as below :-

    R4(config-router)#do show ip bgp dampen param
    % dampening not enabled for base
    R4(config-router)#do show run | s router bgp
    router bgp 400
     no synchronization
     bgp log-neighbor-changes
     network 4.0.0.0
     network 40.4.4.0 mask 255.255.255.0 route-map DAMP1
     network 44.4.4.0 mask 255.255.255.0 route-map DAMP2
     neighbor 10.1.34.3 remote-as 300
     neighbor 10.1.45.5 remote-as 500
     no auto-summary
    R4(config-router)#do show run | sec route-map
     network 40.4.4.0 mask 255.255.255.0 route-map DAMP1
     network 44.4.4.0 mask 255.255.255.0 route-map DAMP2
    route-map DAMP1 permit 10
     match ip address 10
     set dampening 20 800 2400 90
    route-map DAMP2 permit 10
     match ip address 11
     set dampening 15 700 2000 60
    R4(config-router)#show ip access-list
                       ^
    % Invalid input detected at '^' marker.

    R4(config-router)#do show ip access-list
    Standard IP access list 10
        10 permit 40.4.4.0, wildcard bits 0.0.0.255 (1 match)
    Standard IP access list 11
        10 permit 44.4.4.0, wildcard bits 0.0.0.255 (1 match)
    R4(config-router)#

    BUT when i do it under usind the bgp damp route-map and i combine the two route maps into one it works:

    route-map DAMP3 permit 10
     match ip address 10
     set dampening 20 800 2400 90
    route-map DAMP3 permit 20
     match ip address 11
     set dampening 15 700 2000 60

    router bgp 400
    bgp dampe route-map DAMP3

     

     

  • It's commonly used for the specific prefix which is going down/up, but still you have different option for that. 

    It depends on the situation but in the lab environment, it may be anything like direct to the network statement or else.

    HTH

  • I understand, but my question is that directly on the network command it doesnt seem to work! Or at least i can see the parameters that i have configured with the "show ip bgp dampe para", i hope iam clearer now

  • peetypeety ✭✭✭

    I understand, but my question is that directly on the network command it doesnt seem to work! Or at least i can see the parameters that i have configured with the "show ip bgp dampe para", i hope iam clearer now

    Dampening only applies to the 'bgp dampen' command.  If you simply configure 'bgp dampen [numbers]', your dampening applies to all routes.  If you configure 'bgp dampen route-map <blah>', you can then apply different dampening tunings to different groups of routes as specified in route-map <blah>.  However, if you were to reuse route-map <blah> for other purposes, the dampen actions would be ignored in those other contexts.

    Think of it like qos options: if you put 'set precedence 5' in your BGP route maps, would you expect your BGP table to have precedences?  I hope not; the BGP table just injects routes into the main RIB, but the RIB isn't capable of influencing QoS policy.

  • I get you, thank you all[Y]

Sign In or Register to comment.