BGP Backdoor not working

I need somehelp with, I cant see what is wrong the network backdoor option doesnt seem to work, when i have backup connection between R3 and R2, i can learn loopback 1 through the IGP and even when i remove the "backdoor" keyword i learn the same routes through BGP. BUT when i shut down the fa0/0 interfaces with the backdoor keyword configured i dont learn those routes. My config is basic as below

R3(config-if)#do show run
Building configuration...

Current configuration : 1553 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip source-route
!
!
!
!
no ip domain lookup
ip domain name lab.local
ip cef
no ipv6 cef
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 3.3.3.3 255.0.0.0
!
interface Loopback1
 ip address 150.1.3.3 255.255.255.0
!
interface FastEthernet0/0
 ip address 150.1.23.3 255.255.255.0
 shutdown
 speed auto
 duplex auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 speed auto
 duplex auto
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
!
interface Serial1/0.31 point-to-point
 ip address 10.1.13.3 255.255.255.0
 frame-relay interface-dlci 301
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router eigrp 100
 network 150.1.0.0
!
router rip
 version 2
 network 10.0.0.0
 no auto-summary
!
router bgp 300
 no synchronization
 bgp log-neighbor-changes
 network 3.0.0.0
 network 150.1.23.0 mask 255.255.255.0 backdoor
 neighbor 10.1.13.1 remote-as 100
 no auto-summary
!
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
end

R3(config-if)#
image

Sign In or Register to comment.