iSCSI virtual target, logging in but see no devices on INE rack

Doing the iSCSI lab and not getting the disk to show up. Initiator logs into the iSCSI target apparently just fine but doesn't seem to see any devices. Also the lab guide implies I should see something on both fc1/9-10 but I'm not seeing anything there.(note this is all on dcrack5)

 

Verified server1 could ping with do not fragment set using a 7972 byte payload. 

 

Configs below with some other stuff I pulled. 

 

 

 

##MDS Configuration/troubleshooting ###

 

MDS3(config)# show flogi database

--------------------------------------------------------------------------------

INTERFACE        VSAN    FCID           PORT NAME               NODE NAME

--------------------------------------------------------------------------------

fc1/9            101   0x630000  21:02:00:1b:32:44:5e:dc 20:02:00:1b:32:44:5e:dc

iscsi1/1         101   0x630101  10:00:00:00:15:c5:10:01 21:01:00:0d:ec:4a:21:02

 

Total number of flogi = 2.

 

MDS3(config)# show fcns database

 

VSAN 101:

--------------------------------------------------------------------------

FCID        TYPE  PWWN                    (VENDOR)        FC4-TYPE:FEATURE

--------------------------------------------------------------------------

0x630000    N     21:02:00:1b:32:44:5e:dc                 scsi-fcp:target

0x630101    N     10:00:00:00:15:c5:10:01 (Cisco)         scsi-fcp:init isc..w

 

Total number of entries = 2

MDS3(config)# show iscsi session detail

Initiator 10.0.0.11

  Initiator name iqn.1991-05.com.microsoft:rack5server1

  Session #1 (index 13)

    Target iqn.1987-05.com.cisco:05.mds3.01-01.2102001b32445edc

    VSAN 101, ISID 400001370000, TSIH 12288, Status active, no reservation

    Type Normal, ExpCmdSN 11, MaxCmdSN 138, Barrier 0

    MaxBurstSize 262144, MaxConn 1, DataPDUInOrder Yes

    DataSeqInOrder Yes, InitialR2T No, ImmediateData Yes

    Registered LUN 0, Mapped LUN 0

    Stats:

      PDU: Command: 10, Response: 10

      Bytes: TX: 324, RX: 0

    Number of connection: 1

    Connection #1 (index 1)

      Local IP address: 10.0.0.63, Peer IP address: 10.0.0.11

      CID 1, State: Full-Feature

      StatSN 12, ExpStatSN 0

      MaxRecvDSLength 65536, our_MaxRecvDSLength 262144

      CSG 3, NSG 3, min_pdu_size 48 (w/ data 48)

      AuthMethod none, HeaderDigest None (len 0), DataDigest None (len 0)

      Version Min: 0, Max: 0

      FC target: Up, Reorder PDU: No, Marker send: No (int 0)

      Received MaxRecvDSLen key: Yes

      Stats:

        Bytes: TX: 324, RX: 0

 

MDS3(config)# show iscsi virtual-target ?

*** No matching command found in current mode, matching in (exec) mode ***

  <CR>

  >           Redirect it to a file

  >>          Redirect it to a file in append mode

  WORD        ISCSI virtual-target Node Name (Max Size 223)

  configured  Show information about configured virtual-targets

  |           Pipe command output to filter

 

MDS3(config)# show iscsi virtual-target configured

MDS3(config)# show iscsi virtual-target configured  ?

*** No matching command found in current mode, matching in (exec) mode ***

  <CR>

  >      Redirect it to a file

  >>     Redirect it to a file in append mode

  WORD   ISCSI virtual-target Node Name (Max Size 223)

  |      Pipe command output to filter

 

MDS3(config)# show iscsi virtual-target

target: iqn.1987-05.com.cisco:05.mds3.01-01.2102001b32445edc

  * Port WWN 21:02:00:1b:32:44:5e:dc , VSAN 101

    Auto-created node (iSCSI)

MDS3(config)# show flogi database

--------------------------------------------------------------------------------

INTERFACE        VSAN    FCID           PORT NAME               NODE NAME

--------------------------------------------------------------------------------

fc1/9            101   0x630000  21:02:00:1b:32:44:5e:dc 20:02:00:1b:32:44:5e:dc

iscsi1/1         101   0x630101  10:00:00:00:15:c5:10:01 21:01:00:0d:ec:4a:21:02

 

Total number of flogi = 2.

 

MDS3(config)# show fcns database

 

VSAN 101:

--------------------------------------------------------------------------

FCID        TYPE  PWWN                    (VENDOR)        FC4-TYPE:FEATURE

--------------------------------------------------------------------------

0x630000    N     21:02:00:1b:32:44:5e:dc                 scsi-fcp:target

0x630101    N     10:00:00:00:15:c5:10:01 (Cisco)         scsi-fcp:init isc..w

 

Total number of entries = 2

MDS3(config)# show is

iscsi   islb

MDS3(config)# show iscsi session detail

Initiator 10.0.0.11

  Initiator name iqn.1991-05.com.microsoft:rack5server1

  Session #1 (index 13)

    Target iqn.1987-05.com.cisco:05.mds3.01-01.2102001b32445edc

    VSAN 101, ISID 400001370000, TSIH 12288, Status active, no reservation

    Type Normal, ExpCmdSN 11, MaxCmdSN 138, Barrier 0

    MaxBurstSize 262144, MaxConn 1, DataPDUInOrder Yes

    DataSeqInOrder Yes, InitialR2T No, ImmediateData Yes

    Registered LUN 0, Mapped LUN 0

    Stats:

      PDU: Command: 10, Response: 10

      Bytes: TX: 324, RX: 0

    Number of connection: 1

    Connection #1 (index 1)

      Local IP address: 10.0.0.63, Peer IP address: 10.0.0.11

      CID 1, State: Full-Feature

      StatSN 12, ExpStatSN 0

      MaxRecvDSLength 65536, our_MaxRecvDSLength 262144

      CSG 3, NSG 3, min_pdu_size 48 (w/ data 48)

      AuthMethod none, HeaderDigest None (len 0), DataDigest None (len 0)

      Version Min: 0, Max: 0

      FC target: Up, Reorder PDU: No, Marker send: No (int 0)

      Received MaxRecvDSLen key: Yes

      Stats:

        Bytes: TX: 324, RX: 0

 

MDS3(config)# show iscsi initiator ?

*** No matching command found in current mode, matching in (exec) mode ***

  <CR>

  >              Redirect it to a file

  >>             Redirect it to a file in append mode

  WORD           Enter initiator node name (Max Size 223)

  configured     Show iSCSI initiator configured information

  detail         Show more detailed information

  fcp-session    Show FC session details

  iscsi-session  Show iSCSI session details

  summary        Show iSCSI initiator summary information

  |              Pipe command output to filter

 

MDS3(config)# show iscsi initiator detail

iSCSI Node name is 10.0.0.11

    iSCSI Initiator name: iqn.1991-05.com.microsoft:rack5server1

    iSCSI alias name:

    Configured node (iSCSI)

    Node WWN is 21:01:00:0d:ec:4a:21:02 (dynamic)

    Member of vsans: 101

    Number of Virtual n_ports: 1

 

    Virtual Port WWN is 10:00:00:00:15:c5:10:01 (configured)

      Interface iSCSI 1/1, Portal group tag is 0x3000

      VSAN ID 101, FCID 0x630101

      1 FC sessions, 1 iSCSI sessions

      iSCSI session details

        Target: iqn.1987-05.com.cisco:05.mds3.01-01.2102001b32445edc

          Statistics:

            PDU: Command: 10, Response: 10

            Bytes: TX: 324, RX: 0

            Number of connection: 1

          TCP parameters

            Local 10.0.0.63:3260, Remote 10.0.0.11:49534

            Path MTU: 7998 bytes

            Retransmission timeout: 300 ms

            Round trip time: Smoothed 5 ms, Variance: 9

            Advertized receive window: Current: 85 KB, Maximum: 23 KB, Scale: 6

            Peer window: Current: 68 KB, Maximum: 68 KB, Scale: 8

            Congestion window: Current: 14 KB

 

      FCP Session details

        Target FCID: 0x630000 (S_ID of this session: 0x630101)

          pWWN: 21:02:00:1b:32:44:5e:dc, nWWN: 20:02:00:1b:32:44:5e:dc

          Session state: LOGGED_IN

          1 iSCSI sessions share this FC session

            Target: iqn.1987-05.com.cisco:05.mds3.01-01.2102001b32445edc

          Negotiated parameters

            RcvDataFieldSize 2048 our_RcvDataFieldSize 2048

            MaxBurstSize 0, EMPD: FALSE

            Random Relative Offset: FALSE, Sequence-in-order: Yes

          Statistics:

            PDU: Command: 0, Response: 10

 

MDS3(config)# 

 

MDS3(config)# show zone active

zone name test vsan 101

* fcid 0x630101 [pwwn 10:00:00:00:15:c5:10:01]

* fcid 0x630000 [pwwn 21:02:00:1b:32:44:5e:dc]

 

MDS3(config)# show zoneset active

zoneset name foo vsan 101

  zone name test vsan 101

  * fcid 0x630101 [pwwn 10:00:00:00:15:c5:10:01]

  * fcid 0x630000 [pwwn 21:02:00:1b:32:44:5e:dc]

MDS3(config)#

 

 

Config:

 

 

vsan database

  vsan 101

 

vsan database

  vsan 101 interface iscsi1/1

  vsan 101 interface fc1/9

  vsan 101 interface fc1/10

 

iscsi import target fc

iscsi initiator ip-address 10.0.0.11

  static pWWN 10:00:00:00:15:c5:10:01

  vsan 101

 

 

interface fc1/9

  switchport speed 2000

interface fc1/10

  switchport speed 2000

interface fc1/9

  switchport mode F

interface fc1/10

  switchport mode F

 

zone mode enhanced vsan 101

!Active Zone Database Section for vsan 101

zone name test vsan 101

    member pwwn 10:00:00:00:15:c5:10:01

    member pwwn 21:02:00:1b:32:44:5e:dc

 

zoneset name foo vsan 101

    member test

 

zoneset activate name foo vsan 101

 

 

zone commit vsan 101

 

 

 

interface fc1/9

  no shutdown

 

interface fc1/10

  no shutdown

 

 

interface GigabitEthernet1/1

  ip address 10.0.0.63 255.255.255.0

  switchport mtu 8000

  no shutdown

 

 

 

 

#### 5k config ####

!verified qos policy by sending a large ping with do-not-frag set and got responses

 

N5K2# show run int eth1/1,eth1/14

 

!Command: show running-config interface Ethernet1/1, Ethernet1/14

!Time: Thu Jan 23 07:09:53 2014

 

version 5.1(3)N2(1c)

 

interface Ethernet1/1

  switchport access vlan 101

  spanning-tree port type edge

  speed 1000

 

interface Ethernet1/14

  description to 3750 gig1/0/9

  switchport mode trunk

  switchport access vlan 101

  speed 1000

 

vlan 101

  name transit

 

policy-map type network-qos iscsi-lab-policy

  class type network-qos class-fcoe

    pause no-drop

    mtu 2158

  class type network-qos class-default

    mtu 9216

    multicast-optimize

system qos

  service-policy type network-qos iscsi-lab-policy

 

 

 

### 3750 

 

vlan 101

 name lab-iscsi

 

 

interface GigabitEthernet1/0/5

 description To MDS3 Gig1/1

 switchport access vlan 101

 

interface GigabitEthernet1/0/9

 description To N5K2 E1/14

 switchport trunk encapsulation dot1q

 switchport trunk allowed vlan 1,101

 switchport mode trunk

 

system jumbo mtu seemed missing but when attempting to set it to some value other than 9000 I get the following:

 

3750G-2(config)#system mtu jumbo 8192

Changes to the system jumbo MTU will not take effect until the next reload is done

3750G-2(config)#system mtu jumbo 9000

3750G-2(config)#

3750G-2(config)#

3750G-2(config)#system mtu jumbo 2000

Changes to the system jumbo MTU will not take effect until the next reload is done

3750G-2(config)#system mtu jumbo 9000

 

3750G-2#show system mtu

 

System MTU size is 1500 bytes

System Jumbo MTU size is 9000 bytes

System Alternate MTU size is 1500 bytes

Routing MTU size is 1500 bytes

3750G-2#

 

What horrible thing am I overlooking?

Sign In or Register to comment.