EOMPLS QOS help needed from all CCIE's

Hi all CCIE members,

 

Can you guys guide me i am stuck in one major issue in eompls qos.

 

Actually i was using this topology in eompls qos CE1( dot1q 2811router)-->PE1(2811router)---->P(2811router)---->PE2(2811router)----->CE2(dot1q 2811router).When i am using this topology i can see and mark the traffic on each router.

 

But when i am using this topology(CE1(dot1q 2811router)------->PE1(2811router)--------->P(6523 layer3 switch)---------->PE2(2811router)-------------->CE2(dot1q  2811router)with 6523 layer3 switch i am unable to see any traffic mark with exp5 or exp, see traffic on class-default with exp0.

 

0n (P)6523 switch config:

 

class-map exp5

match mpls experimental topmost 5

 

policy-map foo

class exp5

 

 

int gi1/1

ip 192.168.23.3

mpls ip

mtu 1546

service-policy output foo

 

 

 

 

int gi1/2

ip 192.168.34.4

mpls ip

mtu 1546

service-policy output foo

 

 

i can see traffic marked on ce1, pe1 but no traffic marked or seen on router P, PE2 and CE2.

I have tried mls qos command globally on 6523.also tried on interface trust command: mls qos trust cos , mls trust mpls exp topmost. but still no success.

 

Any additional configuration needed on 6523 switch.because this switch is the core eompls it should pass through exp5 but its converting exp0 why?

 

------------------------------------------------------------------------------------

PE1 configuration:

 

class-map match-all QOS_G_5

match qos-group 5

class-map match-any LOO1

match cos  5

!

!

policy-map EF

class LOO1

  set qos-group 5

policy-map QOS_G_5

class QOS_G_5

  set mpls experimental topmost 5

!

interface Loopback0

ip address 3.3.3.3 255.255.255.255

!

interface FastEthernet0/0

ip address 192.168.23.2 255.255.255.0

ip ospf network point-to-point

duplex auto

speed auto

mpls ip

service-policy output QOS_G_5

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

!

interface FastEthernet0/1.455

encapsulation dot1Q 455

xconnect 5.5.5.5 455 encapsulation mpls

service-policy input EF

!

PE1#show policy-map interface

FastEthernet0/0

 

  Service-policy output: QOS_G_5

 

    Class-map: QOS_G_5 (match-all)

      10 packets, 1440 bytes

      5 minute offered rate 0 bps, drop rate 0 bps

      Match: qos-group 5

      QoS Set

        mpls experimental topmost 5

          Packets marked 10

 

    Class-map: class-default (match-any)

      0 packets, 0 bytes

      5 minute offered rate 0 bps, drop rate 0 bps

      Match: any

FastEthernet0/1.455

 

  Service-policy input: EF

 

    Class-map: LOO1 (match-any)

      10 packets, 1180 bytes

      5 minute offered rate 0 bps, drop rate 0 bps

      Match: cos  5

        10 packets, 1180 bytes

        5 minute rate 0 bps

      QoS Set

        qos-group 5

          Packets marked 10

 

    Class-map: class-default (match-any)

      0 packets, 0 bytes

      5 minute offered rate 0 bps, drop rate 0 bps

      Match: any

------------------------------------------------------------------

CE1(R1) configuration:

 

interface FastEthernet0/0.455

encapsulation dot1Q 455

ip address 172.16.15.1 255.255.255.0

!

service-policy output EF

 

class-map match-all EF

match access-group 1

!

!

policy-map EF

class EF

set cos 5

!

access-list 1 permit 172.16.15.1

 

router ospf 1

log-adjacency-changes

network 3.3.3.3 0.0.0.0 area 0

network 192.168.23.2 0.0.0.0 area 0

------------------------------------------------------------------

Ping from CE1 to CE2:

 

Protocol [ip]:

Target IP address: 172.16.15.2

Repeat count [5]:

Datagram size [100]:

Timeout in seconds [2]:

Extended commands [n]: y

Source address or interface: 172.16.15.1

Type of service [0]: 0xb8

Set DF bit in IP header? [no]:

Validate reply data? [no]:

Data pattern [0xABCD]:

Loose, Strict, Record, Timestamp, Verbose[none]:

Sweep range of sizes [n]:

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.15.2, timeout is 2 seconds:

Packet sent with a source address of 172.16.15.1

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 88/100/112 ms 

Sign In or Register to comment.