Multicast in DC rack

Hello group,

 

Currently trying to do some multicast routing in the basic DC rack (no add-ons included). Server 5 is the receiver and server 6 is the source of the multicast stream. I'm using jperf to generate some multicast streams (5 as server, 6 as client).

On server 5 I'm using 10.0.100.10/24 and on server 6 I'm using 10.0.200.20/24. Gateway on both networks are .254. I've also created a static route for my multicast group (239.1.2.3) pointing towards the local server interface in the 10.x.x.x network. TTL is set to 10, so that should do the trick also.

Relevant config on N5K5:

N5K5# sh running-config

!

feature lacp

!

vlan 1,100

port-channel load-balance ethernet source-dest-port

!

interface Vlan1

interface port-channel75

  switchport mode trunk

  speed 10000

!

interface Ethernet1/1

  switchport access vlan 100

  spanning-tree port type edge

  speed 1000

!

interface Ethernet1/6

  switchport mode trunk

  channel-group 75 mode active

!
interface Ethernet1/7

  switchport mode trunk

  channel-group 75 mode active

 

Relevant config on N5K6:

N5K6# sh running-config

!

feature lacp

!

vlan 1,200

port-channel load-balance ethernet source-dest-port

!

interface Vlan1

interface port-channel751

  switchport mode trunk

  speed 10000

!

interface Ethernet1/2

  switchport access vlan 200

  spanning-tree port type edge

  speed 1000

!

interface Ethernet1/8

  switchport mode trunk

  channel-group 751 mode active

!
interface Ethernet1/9

  switchport mode trunk

  channel-group 751 mode active


Currently I'm only using one single router to eliminate any problems with the routing.


Relevant config on N7K5:



N7K5# sh running-config

!

feature pim

feature eigrp

feature interface-vlan

feature hsrp

feature lacp


ip pim auto-rp rp-candidate loopback1 group-list 224.0.0.0/4

ip pim auto-rp mapping-agent loopback1

ip pim log-neighbor-changes

ip pim ssm range 232.0.0.0/8

ip pim auto-rp forward listen

!

vlan 1,100,200

!

interface Vlan100

  no shutdown

  ip address 10.0.100.75/24

  ip router eigrp 100

  ip pim sparse-mode

  ip igmp version 3

  hsrp 100

    ip 10.0.100.254



interface Vlan200

  no shutdown

  ip address 10.0.200.75/24

  ip router eigrp 100

  ip pim sparse-mode

  ip igmp version 3

  hsrp 200

    ip 10.0.200.254



interface port-channel75

  switchport

  switchport mode trunk

  medium p2p

!

interface port-channel751

  switchport

  switchport mode trunk

  medium p2p

!

interface Ethernet2/21

  switchport mode trunk

  medium p2p

  channel-group 751 mode active

  no shutdown

!

interface Ethernet2/22

  switchport mode trunk

  medium p2p

  channel-group 751 mode active

  no shutdown

!

interface loopback0

  ip address 10.0.0.75/32

  ip router eigrp 100

  ip pim sparse-mode



interface loopback1

  ip address 10.0.0.1/32

  ip router eigrp 100

  ip pim sparse-mode

!

router eigrp 100

  autonomous-system 100

!



I only see intermittend packets coming through between sender and receiver. I can't figure out, what the problem is and I suspect the problem might be with the servers. 


Some relevant show outputs:



N5K6# sh ip igmp snooping vlan 200

IGMP Snooping information for vlan 200

  IGMP snooping enabled

  Optimised Multicast Flood (OMF) disabled

  IGMP querier present, address: 10.0.200.75, version: 3, i/f Po751

  Querier interval: 125 secs

  Querier last member query interval: 1 secs

  Querier robustness: 2

  Switch-querier disabled

  IGMPv3 Explicit tracking enabled

  IGMPv2 Fast leave disabled

  IGMPv1/v2 Report suppression enabled

  IGMPv3 Report suppression disabled

  Link Local Groups suppression enabled

  Router port detection using PIM Hellos, IGMP Queries

  Number of router-ports: 1

  Number of groups: 0

  VLAN vPC function disabled

  Active ports:

    Eth1/2      Po751



N5K5# show ip igmp snooping vlan 100


IGMP Snooping information for vlan 100

  IGMP snooping enabled

  Optimised Multicast Flood (OMF) disabled

  IGMP querier present, address: 10.0.100.75, version: 3, i/f Po75

  Querier interval: 125 secs

  Querier last member query interval: 1 secs

  Querier robustness: 2

  Switch-querier disabled

  IGMPv3 Explicit tracking enabled

  IGMPv2 Fast leave disabled

  IGMPv1/v2 Report suppression enabled

  IGMPv3 Report suppression disabled

  Link Local Groups suppression enabled

  Router port detection using PIM Hellos, IGMP Queries

  Number of router-ports: 2

  Number of groups: 3

  VLAN vPC function disabled

  Active ports:

    Eth1/1      Po75






N7K5# show ip igmp interface vlan 100

IGMP Interfaces for VRF "default"

Vlan100, Interface status: protocol-up/link-up/admin-up

  IP address: 10.0.100.75, IP subnet: 10.0.100.0/24

  Active querier: 10.0.100.75, expires: 00:03:38, querier version: 3

  Membership count: 1

  Old Membership count 0

  IGMP version: 3, host version: 3

  IGMP query interval: 125 secs, configured value: 125 secs

  IGMP max response time: 10 secs, configured value: 10 secs

  IGMP startup query interval: 31 secs, configured value: 31 secs

  IGMP startup query count: 2

  IGMP last member mrt: 1 secs

  IGMP last member query count: 2

  IGMP group timeout: 260 secs, configured value: 260 secs

  IGMP querier timeout: 255 secs, configured value: 255 secs

  IGMP unsolicited report interval: 10 secs

  IGMP robustness variable: 2, configured value: 2

  IGMP reporting for link-local groups: disabled

  IGMP interface enable refcount: 3

  IGMP interface immediate leave: disabled

  IGMP VRF name default (id 1)

  IGMP Report Policy: None

  IGMP State Limit: None

  IGMP interface statistics: (only non-zero values displayed)

    General (sent/received):

      v2-queries: 24/24, v2-reports: 0/6, v2-leaves: 0/5

      v3-queries: 180/214, v3-reports: 163/325

    Errors:

      Report version mismatch: 18, Query version mismatch: 0

      Unknown IGMP message type: 0

  Interface PIM DR: Yes

  Interface vPC SVI: No

  Interface vPC CFS statistics:

N7K5# show ip igmp interface vlan 200

IGMP Interfaces for VRF "default"

Vlan200, Interface status: protocol-up/link-up/admin-up

  IP address: 10.0.200.75, IP subnet: 10.0.200.0/24

  Active querier: 10.0.200.75, version: 3, next query sent in: 00:00:48

  Membership count: 0

  Old Membership count 0

  IGMP version: 3, host version: 3

  IGMP query interval: 125 secs, configured value: 125 secs

  IGMP max response time: 10 secs, configured value: 10 secs

  IGMP startup query interval: 31 secs, configured value: 31 secs

  IGMP startup query count: 2

  IGMP last member mrt: 1 secs

  IGMP last member query count: 2

  IGMP group timeout: 260 secs, configured value: 260 secs

  IGMP querier timeout: 255 secs, configured value: 255 secs

  IGMP unsolicited report interval: 10 secs

  IGMP robustness variable: 2, configured value: 2

  IGMP reporting for link-local groups: disabled

  IGMP interface enable refcount: 3

  IGMP interface immediate leave: disabled

  IGMP VRF name default (id 1)

  IGMP Report Policy: None

  IGMP State Limit: None

  IGMP interface statistics: (only non-zero values displayed)

    General (sent/received):

      v2-queries: 0/0, v2-reports: 0/0, v2-leaves: 0/4

      v3-queries: 57/57, v3-reports: 74/142

    Errors:

  Interface PIM DR: Yes

  Interface vPC SVI: No

  Interface vPC CFS statistics:

N7K5#




N7K5# sh ip igmp groups 239.1.2.3

IGMP Connected Group Membership for VRF "default" - matching  Group "239.1.2.3"

Type: S - Static, D - Dynamic, L - Local, T - SSM Translated

Group Address      Type Interface           Uptime    Expires   Last Reporter

239.1.2.3          D    Vlan100             00:04:25  00:01:17  10.0.100.10



N7K5# sh ip pim rout 239.1.2.3

PIM Routing Table for VRF "default" - 3 entries



(*, 239.1.2.3/32), RP 10.0.0.1*, expires 00:01:06, RP-bit

  Incoming interface: loopback1, RPF nbr 10.0.0.1

  Oif-list: (0) 00000000, timeout-list: (0) 00000000

  Timeout-interval: 1, JP-holdtime round-up: 3



(10.0.200.20/32, 239.1.2.3/32), expires 00:02:10, register

  Incoming interface: Vlan200, RPF nbr 10.0.200.20

  Oif-list:       (0) 00000000, timeout-list: (0) 00000000

  Immediate-list: (0) 00000000, timeout-list: (0) 00000000

  Timeout-interval: 1, JP-holdtime round-up: 3



N7K5# sh ip mroute 239.1.2.3

IP Multicast Routing Table for VRF "default"



(*, 239.1.2.3/32), uptime: 00:05:15, igmp pim ip

  Incoming interface: loopback1, RPF nbr: 10.0.0.1

  Outgoing interface list: (count: 1)

    Vlan100, uptime: 00:05:15, igmp



(10.0.200.20/32, 239.1.2.3/32), uptime: 00:05:44, ip pim mrib

  Incoming interface: Vlan200, RPF nbr: 10.0.200.20, internal

  Outgoing interface list: (count: 1)

    Vlan100, uptime: 00:05:15, mrib





Any ideas what could be wrong...?

Comments

  • Correct me if wrong, but shouldn't the (*,G) entry on the RP itself show incoming interface null ?

    (*, 239.1.2.3/32), uptime: 00:05:15, igmp pim ip

      Incoming interface: loopback1, RPF nbr: 10.0.0.1



    So, can we check the show ip pim rp mapping on both sides? Also, what does debug ip mpacket 239.1.2.3 show on the 7k?
Sign In or Register to comment.