FCOE LINK DOWN

Hi,

 

today i was doing FCOE in INE rack but for some reason my VFC link towards Server is not coming up , i have did manytime in CISCO PEC lab link comes UP in a Sec but i don;t know why link is not coming UP here 

 

below is Output i have taken...

 

please let me know if i am missing something here

 

N5K3# sh int vfc 1

vfc1 is trunking

    Bound interface is Ethernet101/1/1

    Hardware is Ethernet 

    Port WWN is 20:00:00:05:9b:1e:82:ff

    Admin port mode is F, trunk mode is on

    snmp link state traps are enabled

    Port mode is TF

    Port vsan is 101

    Trunk vsans (admin allowed and active) (101)

    Trunk vsans (up)                       ()

    Trunk vsans (isolated)                 ()

    Trunk vsans (initializing)             (101)

 

N5K3# sh system  internal dcbx info interface e101/1/1

 

Interface info for if_index: 0x1f640000(Eth101/1/1)

 

 

 

Interface info for if_index: 0x1f640000(Eth1/1)

tx_enabled: TRUE

rx_enabled: TRUE

dcbx_enabled: TRUE

DCX Protocol: CEE

DCX CEE NIV extension: disabled

 

N5K3# sh vsan membership 

 

vsan 101 interfaces:

    vfc1 

 

N5K3# show vlan fcoe 

 

Original VLAN ID        Translated VSAN ID      Association State

----------------        ------------------      -----------------

 

      101                       101              Operational

 

interface Ethernet101/1/1

  switchport mode trunk

  switchport trunk native vlan 10

  switchport trunk allowed vlan 10,101

  spanning-tree port type edge trunk

 

 

N5K3# sh queuing interface e101/1/1

Ethernet101/1/1 queuing information:

  Input buffer allocation:

  Qos-group: 1 

  frh: 3

  drop-type: no-drop

  cos: 3

  xon       xoff      buffer-size

  ---------+---------+-----------

  8960      14080     24320    

 

  Qos-group: 0 

  frh: 8

  drop-type: drop

  cos: 0 1 2 4 5 6

  xon       xoff      buffer-size

  ---------+---------+-----------

  0         117760    126720   

 

  Queueing:

  queue    qos-group    cos            priority  bandwidth mtu 

  --------+------------+--------------+---------+---------+----

  2        0            0 1 2 4 5 6     WRR        50      1600

  3        1            3               WRR        50      2240

 

storage controller --CISCO VIC FCOE Storport Miniport      

Comments

  • did you enable fcoe under fex configuration? as far as i remember it is eVPC topology

    fex 101

    fcoe

     

     

     

  • Can you post the complete config ? Can provide some inputs accordingly.

    In the meantime, this doc for the basic troubleshooting of FCoE

    http://www.cisco.com/en/US/docs/switches/datacenter/nexus5000/sw/troubleshooting/guide/n5K_ts_fcoe.html

  • Each FEX is single Homed to UPstream 5K

  • Hi,

     

    Please find the config below

     

     

    interface Ethernet101/1/1

      switchport mode trunk

      switchport trunk native vlan 10

      switchport trunk allowed vlan 10,101

      spanning-tree port type edge trunk

     

     

    interface vfc101

      bind interface Ethernet101/1/1

      switchport trunk allowed vsan 101

      no shutdown

     

    N5K5# sh vsan  membership 

    vsan 1 interfaces:

        fc2/1             fc2/2             fc2/3             fc2/4            

        fc2/5             fc2/6             fc2/7             fc2/8            

        san-port-channel 1

     

    vsan 101 interfaces:

        vfc101        

     

     

    system qos

      service-policy type queuing input default-in-policy

      service-policy type queuing output default-out-policy

      service-policy type qos input default-in-policy

      service-policy type network-qos default-nq-policy

     

    lldp tlv-select system-capabilities

    N5K5# sh policy-map type network-qos 

     

     

      Type network-qos policy-maps

      ===============================

     

      policy-map type network-qos default-nq-policy

        class type network-qos class-fcoe

     

          pause no-drop 

          mtu 2158

        class type network-qos class-default

     

          mtu 1500

     

     

    N5K5# sh int vfc 101

    vfc101 is trunking

        Bound interface is Ethernet101/1/1

        Hardware is Ethernet 

        Port WWN is 20:64:00:05:9b:2a:a9:3f

        Admin port mode is F, trunk mode is on

        snmp link state traps are enabled

        Port mode is TF

        Port vsan is 101

        Trunk vsans (admin allowed and active) (101)

        Trunk vsans (up)                       ()

        Trunk vsans (isolated)                 ()

        Trunk vsans (initializing)             (101)

  • Please try the following:


    switch(config)# interface vfc 101
    switch(config-if)# bind interface ethernet 101/1/1
    switch(config-if)# no shutdown
    switch(config-if)# exit

    This creates the vfc interface , then put it into an VSAN that is mapped to an FCoE enabled VLAN ( else it will report it down)

    something like...vfc101 is down (VSAN not mapped to an FCoE enabled VLAN)...so do the following ( I see it missing in your output, if you already have it, then skip it)

    switch(config)# vlan 101
    switch(config-vlan)# fcoe vsan 101
    switch(config-vlan)# exit

     The other commands which I see missing are the below ones. You need to assign the vfc interface to the appropriate VSAN with these commands:

    switch(config)# vsan database
    switch(config-vsan-db)# vsan <number> interface vfc <number>
    switch(config-vsan-db)# exit

    Now check the sh  flogi database. If all this is already there( I put it since I see some missing commands), then we will check further.

  • Hi 

    you see that the vfc is in "initializing" state, so it does not necessarily mean that there is anything wrong on the switch side, it simply means that the server at the other end did not flogi yet... it is perfectly normal to see this state until the server flogi into the switch

    now what type of server is it, UCS C series with M81KR card ? note that for the C series server to flogi in, you need to setup the CIMC properly and specify the fcoe VSAN , set it for FC boot san, then reboot the server before it will actually flogi

     

    Regards 

  • I am not sure of what type of server i am Using INE rack rentals..

     

    i did not see any emulex or one command application installed in server !! in device Manager storage controller shows as VIC  Miniport controller if remmember correctly!!

     

    i tried twice in INE rack rental but same result.

     

    Be default when we enable FCOE in 5020 it enable System QOS setting also , so no Issue there.

     

    i can see DCX protocol is CEE  which what i want to see!!

    show queueing shows two QOS  group 1 for FCOE and another for rest of the traffic!!

     

    if anyone has faced same issue with INE rack rental using FEX as  i  succesfully did the practical in CISCO PEC it was working fine but not using FEX...

     

  • Initializing usually points to some negotiation issue with the end host.My session for 2k is after 5 days. I will work on this task and see if I am also facing the same issue. Till then, can you send the output of the following commands :

     

    show system internal dcbx info interface Ethernet101/1/1
    show platform software fcoe_mgr info interface vfc  101

    In the INE labs, it's Emulex CNA's. I'm surprised that the OneCommand GUI is not there , as per your last statement.

     

  • Hi,

     

    I have already posted the output of show system internal dcbx info interface Ethernet101/1/1 above in my first post..

     

    i did not find any Application for FC adapter installed in server!! last time my server hanged to somer service notification i have notified to INE but no response yet :( i was unable to login into Server 

  • And what about the output of the second command "show platform software fcoe_mgr info interface vfc  101". Can you send this output and the sh run of the 5k switch? Maybe we are missing something very minor here.

  • Wondering if you ever figured this out.  I had the same problem today - was unable to get the Emulex server to flogi and no Emulex software was on the server.  Thanks.

  • i didn't able to yet i have accessed the RACK 2 times but same result better we have to ask someone who has did !!

  • I have a session in 10 minutes . Will reproduce it and confirm. But the diagram for Rack5 is not there in the physical diagram layout.( have access to Rack5 today).

  • I was able to get this to work (somewhat).  My initial problem was that I had not put the vfc interface in a vsan.  I did that in my next session and saw the server flogi.  The server in that rack had the emulex tools as well, but i still was not able to mount a LUN.  I think that was an issue with the JBOD though.

  • Did this task today. Below are some observations:

    1. DCBX/LLDP is fine as per the below outputs:

     

    N5K1(config)# show lldp interface ethernet 101/1/1
    Interface Information:
      Enable (tx/rx/dcbx): Y/Y/Y    Port Mac address: f0:29:29:ff:02:02

    Peer's LLDP TLVs:
    Type Length Value
    ---- ------ -----
    001  007    04d48cb5 bd4609
    002  007    03d48cb5 bd4609
    003  002    0078
    127  055    001b2102 020a0000 00000001 00000001 080a0000 c0008906 001b2108
                06060000 c000ff08 04110000 c000ffff ffff0000 00000000 000008
    127  005    00014201 01

     

    N5K1(config)# show system internal dcbx info interface Ethernet101/1/1

    Interface info for if_index: 0x1f640000(Eth101/1/1)

    Interface info for if_index: 0x1f640000(Eth1/1)
    tx_enabled: TRUE
    rx_enabled: TRUE
    dcbx_enabled: TRUE
    DCX Protocol: CEE

    DCX CEE NIV extension: disabled

     

    Also no errors reported for the received DCBX frames:

    DCBX pkt stats:

        Total frames out: 98
        Total Entries aged: 11
        Total frames in: 101
        DCBX frames in: 101

        Total frames received in error: 0    Total frames discarded: 0    Total TLVs unrecognized: 0

     

    It seems the Fcoe TLV negotiation is failing for some reason( FIP solicitation is failing)

     

    Peer's DCX TLV:
    DCBX TLV Proto(1) type: 1(Control) DCBX TLV Length: 10 DCBX TLV Value
    00  00  00  00  00  01  00  00  00  01
      sub_type 0, error 0, willing 0, enable 0, max_version 0, oper_version 0
    DCBX TLV Proto(1) type: 4(App) DCBX TLV Length: 10 DCBX TLV Value
    00  00  c0  00  89  06  00  1b  21  08
      sub_type 0, error 0, willing 1, enable 1, max_version 0, oper_version 0
    DCBX TLV Proto(1) type: 3(PFC) DCBX TLV Length: 6 DCBX TLV Value
    00  00  c0  00  ff  08
      sub_type 0, error 0, willing 1, enable 1, max_version 0, oper_version 0
    DCBX TLV Proto(1) type: 2(PriGrp) DCBX TLV Length: 17 DCBX TLV Value
    00  00  c0  00  ff  ff  ff  ff  00  00  00  00  00  00  00  00  08
      sub_type 0, error 0, willing 1, enable 1, max_version 0, oper_version 0

    No Fcoe TLV seen in the above output. To add to it, do not see the triggered event FCOE_MGR_VFC_EV_FIP_VLAN_DISCOVERY . Below were the events:

     

    >>>>FSM: <vfc111> has 12 logged transitions<<<<<

    1) FSM:<vfc111> Transition at 717903 usecs after Fri Dec 27 14:02:56 2013
        Previous state: [FCOE_MGR_VFC_ST_INIT]
        Triggered event: [FCOE_MGR_VFC_EV_CREATE]
        Next state: [FCOE_MGR_VFC_ST_CREATE_WAIT]

    2) FSM:<vfc111> Transition at 720471 usecs after Fri Dec 27 14:02:56 2013
        Previous state: [FCOE_MGR_VFC_ST_CREATE_WAIT]
        Triggered event: [FCOE_MGR_VFC_EV_CREATE_SUCC]
        Next state: [FCOE_MGR_VFC_ST_CREATED]

    3) FSM:<vfc111> Transition at 18636 usecs after Fri Dec 27 14:03:09 2013
        Previous state: [FCOE_MGR_VFC_ST_CREATED]
        Triggered event: [FCOE_MGR_VFC_EV_BIND]
        Next state: [FCOE_MGR_VFC_ST_BIND_WAIT]

    4) FSM:<vfc111> Transition at 21541 usecs after Fri Dec 27 14:03:09 2013
        Previous state: [FCOE_MGR_VFC_ST_BIND_WAIT]
        Triggered event: [FCOE_MGR_VFC_EV_BIND_SUCC]
        Next state: [FCOE_MGR_VFC_ST_DOWN]

    5) FSM:<vfc111> Transition at 20213 usecs after Fri Dec 27 14:03:34 2013
        Previous state: [FCOE_MGR_VFC_ST_DOWN]
        Triggered event: [FCOE_MGR_VFC_EV_BRING_UP_EVAL]
        Next state: [FSM_ST_NO_CHANGE]

    6) FSM:<vfc111> Transition at 20317 usecs after Fri Dec 27 14:03:34 2013
        Previous state: [FCOE_MGR_VFC_ST_DOWN]
        Triggered event: [FCOE_MGR_VFC_EV_BRING_UP]
        Next state: [FCOE_MGR_VFC_ST_BRINGUP_WAIT]

    7) FSM:<vfc111> Transition at 31249 usecs after Fri Dec 27 14:03:34 2013
        Previous state: [FCOE_MGR_VFC_ST_BRINGUP_WAIT]
        Triggered event: [FCOE_MGR_VFC_EV_BRING_UP_SUCC]
        Next state: [FCOE_MGR_VFC_ST_PHY_UP]

    8) FSM:<vfc111> Transition at 44238 usecs after Fri Dec 27 14:03:34 2013
        Previous state: [FCOE_MGR_VFC_ST_PHY_UP]
        Triggered event: [FCOE_MGR_VFC_EV_BRING_UP_EVAL]
        Next state: [FSM_ST_NO_CHANGE]

    9) FSM:<vfc111> Transition at 44415 usecs after Fri Dec 27 14:03:34 2013
        Previous state: [FCOE_MGR_VFC_ST_PHY_UP]
        Triggered event: [FCOE_MGR_VFC_EV_BRING_UP]
        Next state: [FSM_ST_NO_CHANGE]

    10) FSM:<vfc111> Transition at 247940 usecs after Fri Dec 27 14:03:59 2013
        Previous state: [FCOE_MGR_VFC_ST_PHY_UP]
        Triggered event: [FCOE_MGR_VFC_EV_BRING_DOWN_EVAL]
        Next state: [FSM_ST_NO_CHANGE]

    11) FSM:<vfc111> Transition at 277767 usecs after Fri Dec 27 14:03:59 2013
        Previous state: [FCOE_MGR_VFC_ST_PHY_UP]
        Triggered event: [FCOE_MGR_VFC_EV_BRING_UP_EVAL]
        Next state: [FSM_ST_NO_CHANGE]

    12) FSM:<vfc111> Transition at 278721 usecs after Fri Dec 27 14:03:59 2013
        Previous state: [FCOE_MGR_VFC_ST_PHY_UP]
        Triggered event: [FCOE_MGR_VFC_EV_BRING_UP]
        Next state: [FSM_ST_NO_CHANGE]

     

      So, in a nutshell. Some FIP solicitation failing for some reason and the VFC stuck in an initializing state. Same output as you got but do not know why it is happening.

     

     

     

  • i am not sure why it is failing , does we require Storage driver to be installed to identify FIP exchange or it simply have emulex card by defualt will do!!

  • Redid this. This is WORKING. Reboot the Emulex server.ANd the OC Manger and NIC teaming is there on that machine. Try it again. Once you have the zone set, reboot the Emulex. Please share the result and also in case it still doesn't work take the two outputs again ( although it should work this time),

     


    show system internal dcbx info interface ethernet 101/1/1
    sh lldp  neighbors interface e101/1/1

  • although even i am able to make it work but for some reason my VSAN trunk is not coming on 1 of the 5K i am receving below error.

     

    N5K6 %FWM-2-FWM_VE_NOT_SUPPORTED: FCoE cannot be enabled for E mode (VE) on this platform

  • The trunk link should come up even if you get this message. I got this message but it didn't effect any of the lab task results. I would wait for a second opinion on this, but this message didn't effect any of the tasks when I did the tasks. I just ignored it ... (seemed like a cosmetic error to me )

  •  

    I'm currently in a rack rental, and having the same issue. No FLOGI on the VF interface, and VSAN 101 stuck in "initializing".

    To add insult to injury, I am COMPLETELY unable to access the emulex server (the RDP connection goes directly to "connection closed"). Opened an "emergency" ticket, which now (almost two hours and several e-mails later) remains unsolved.

    [ Edit: The support staff was unable to solve the issue in time, so I was refunded the tokens for the lab. Oh well... guess I'll try again! :) ]

    As parvikram said before, the interface gets stuck before FIP VLAN discovery (there's no such event in my output either).

     

     

     

    Here are the relevant outputs:

     

    N5K1# sh platform software fcoe_mgr info interface vfc111

    vfc111(0x8474194), if_index: 0x1e00006e, VFC RID vfc111 

      FSM current state: FCOE_MGR_VFC_ST_PHY_UP

      PSS Runtime Config:-

          Type: 3

          Bound IF: Eth101/1/1

          FCF Priority: 128 (Global)

          Disable FKA: 0

      PSS Runtime Data:-

          IOD: 0x00000000, WWN: 20:6e:00:05:9b:1d:65:7f

          Created at: Tue Jan 14 13:14:49 2014

     

          FC Admin State: up

          Oper State: up, Reason: down

          Eth IF Index: Eth101/1/1

          Port Vsan: 101

          Port Mode: F port

          Config Vsan: 101

          Oper Vsan: 101

          Solicits on vsan: 

          Isolated Vsan: 

          FIP Capable ? : TRUE

          UP using DCBX ? : FALSE

          Peer MAC : 00:00:00:00:00:00

     

     

    >>>>FSM: <vfc111> has 48 logged transitions<<<<<

     

    1) FSM:<vfc111> Transition at 8303 usecs after Tue Jan 14 13:14:49 2014

        Previous state: [FCOE_MGR_VFC_ST_INIT]

        Triggered event: [FCOE_MGR_VFC_EV_CREATE]

        Next state: [FCOE_MGR_VFC_ST_CREATE_WAIT]

     

    2) FSM:<vfc111> Transition at 14406 usecs after Tue Jan 14 13:14:49 2014

        Previous state: [FCOE_MGR_VFC_ST_CREATE_WAIT]

        Triggered event: [FCOE_MGR_VFC_EV_CREATE_SUCC]

        Next state: [FCOE_MGR_VFC_ST_CREATED]

     

    3) FSM:<vfc111> Transition at 948016 usecs after Tue Jan 14 13:14:55 2014

        Previous state: [FCOE_MGR_VFC_ST_CREATED]

        Triggered event: [FCOE_MGR_VFC_EV_BIND]

        Next state: [FCOE_MGR_VFC_ST_BIND_WAIT]

     

    4) FSM:<vfc111> Transition at 950140 usecs after Tue Jan 14 13:14:55 2014

        Previous state: [FCOE_MGR_VFC_ST_BIND_WAIT]

        Triggered event: [FCOE_MGR_VFC_EV_BIND_SUCC]

        Next state: [FCOE_MGR_VFC_ST_DOWN]

     

    5) FSM:<vfc111> Transition at 376815 usecs after Tue Jan 14 13:14:58 2014

        Previous state: [FCOE_MGR_VFC_ST_DOWN]

        Triggered event: [FCOE_MGR_VFC_EV_BRING_UP_EVAL]

        Next state: [FSM_ST_NO_CHANGE]

     

    6) FSM:<vfc111> Transition at 376918 usecs after Tue Jan 14 13:14:58 2014

        Previous state: [FCOE_MGR_VFC_ST_DOWN]

        Triggered event: [FCOE_MGR_VFC_EV_BRING_UP]

        Next state: [FCOE_MGR_VFC_ST_BRINGUP_WAIT]

     

    7) FSM:<vfc111> Transition at 387676 usecs after Tue Jan 14 13:14:58 2014

        Previous state: [FCOE_MGR_VFC_ST_BRINGUP_WAIT]

        Triggered event: [FCOE_MGR_VFC_EV_BRING_UP_SUCC]

        Next state: [FCOE_MGR_VFC_ST_PHY_UP]

     

    8) FSM:<vfc111> Transition at 409964 usecs after Tue Jan 14 13:14:58 2014

        Previous state: [FCOE_MGR_VFC_ST_PHY_UP]

        Triggered event: [FCOE_MGR_VFC_EV_BRING_UP_EVAL]

        Next state: [FSM_ST_NO_CHANGE]

     

    9) FSM:<vfc111> Transition at 411184 usecs after Tue Jan 14 13:14:58 2014

        Previous state: [FCOE_MGR_VFC_ST_PHY_UP]

        Triggered event: [FCOE_MGR_VFC_EV_BRING_UP]

        Next state: [FSM_ST_NO_CHANGE]

     

    10) FSM:<vfc111> Transition at 418472 usecs after Tue Jan 14 13:14:58 2014

        Previous state: [FCOE_MGR_VFC_ST_PHY_UP]

        Triggered event: [FCOE_MGR_VFC_EV_BRING_UP_EVAL]

        Next state: [FSM_ST_NO_CHANGE]

     

    11) FSM:<vfc111> Transition at 269287 usecs after Tue Jan 14 13:15:31 2014

        Previous state: [FCOE_MGR_VFC_ST_PHY_UP]

        Triggered event: [FCOE_MGR_VFC_EV_BRING_DOWN_EVAL]

        Next state: [FSM_ST_NO_CHANGE]

     

    12) FSM:<vfc111> Transition at 312607 usecs after Tue Jan 14 13:15:31 2014

        Previous state: [FCOE_MGR_VFC_ST_PHY_UP]

        Triggered event: [FCOE_MGR_VFC_EV_BRING_UP_EVAL]

        Next state: [FSM_ST_NO_CHANGE]

     

    13) FSM:<vfc111> Transition at 316810 usecs after Tue Jan 14 13:15:31 2014

        Previous state: [FCOE_MGR_VFC_ST_PHY_UP]

        Triggered event: [FCOE_MGR_VFC_EV_BRING_UP]

        Next state: [FSM_ST_NO_CHANGE]

     

    14) FSM:<vfc111> Transition at 345095 usecs after Tue Jan 14 13:15:31 2014

        Previous state: [FCOE_MGR_VFC_ST_PHY_UP]

        Triggered event: [FCOE_MGR_VFC_EV_BRING_DOWN_EVAL]

        Next state: [FSM_ST_NO_CHANGE]

     

    15) FSM:<vfc111> Transition at 350403 usecs after Tue Jan 14 13:15:31 2014

        Previous state: [FCOE_MGR_VFC_ST_PHY_UP]

        Triggered event: [FCOE_MGR_VFC_EV_BRING_UP_EVAL]

        Next state: [FSM_ST_NO_CHANGE]

     

    16) FSM:<vfc111> Transition at 350502 usecs after Tue Jan 14 13:15:31 2014

        Previous state: [FCOE_MGR_VFC_ST_PHY_UP]

        Triggered event: [FCOE_MGR_VFC_EV_BRING_UP]

        Next state: [FSM_ST_NO_CHANGE]

     

    17) FSM:<vfc111> Transition at 362869 usecs after Tue Jan 14 13:15:31 2014

        Previous state: [FCOE_MGR_VFC_ST_PHY_UP]

        Triggered event: [FCOE_MGR_VFC_EV_BRING_UP_EVAL]

        Next state: [FSM_ST_NO_CHANGE]

     

    18) FSM:<vfc111> Transition at 1045 usecs after Tue Jan 14 13:15:54 2014

        Previous state: [FCOE_MGR_VFC_ST_PHY_UP]

        Triggered event: [FCOE_MGR_VFC_EV_BRING_DOWN_EVAL]

        Next state: [FSM_ST_NO_CHANGE]

     

    19) FSM:<vfc111> Transition at 21116 usecs after Tue Jan 14 13:15:54 2014

        Previous state: [FCOE_MGR_VFC_ST_PHY_UP]

        Triggered event: [FCOE_MGR_VFC_EV_BRING_UP_EVAL]

        Next state: [FSM_ST_NO_CHANGE]

     

    20) FSM:<vfc111> Transition at 21215 usecs after Tue Jan 14 13:15:54 2014

        Previous state: [FCOE_MGR_VFC_ST_PHY_UP]

        Triggered event: [FCOE_MGR_VFC_EV_BRING_UP]

        Next state: [FSM_ST_NO_CHANGE]

     

    21) FSM:<vfc111> Transition at 441106 usecs after Tue Jan 14 13:51:59 2014

        Previous state: [FCOE_MGR_VFC_ST_PHY_UP]

        Triggered event: [FCOE_MGR_VFC_EV_ETH_LOGICAL_DOWN]

        Next state: [FSM_ST_NO_CHANGE]

     

    22) FSM:<vfc111> Transition at 444314 usecs after Tue Jan 14 13:51:59 2014

        Previous state: [FCOE_MGR_VFC_ST_PHY_UP]

        Triggered event: [FCOE_MGR_VFC_EV_BRING_DOWN_EVAL]

        Next state: [FSM_ST_NO_CHANGE]

     

    23) FSM:<vfc111> Transition at 451408 usecs after Tue Jan 14 13:51:59 2014

        Previous state: [FCOE_MGR_VFC_ST_PHY_UP]

        Triggered event: [FCOE_MGR_VFC_EV_BRING_UP_EVAL]

        Next state: [FSM_ST_NO_CHANGE]

     

    24) FSM:<vfc111> Transition at 590711 usecs after Tue Jan 14 13:51:59 2014

        Previous state: [FCOE_MGR_VFC_ST_PHY_UP]

        Triggered event: [FCOE_MGR_VFC_EV_ETH_DOWN]

        Next state: [FSM_ST_NO_CHANGE]

     

    25) FSM:<vfc111> Transition at 596296 usecs after Tue Jan 14 13:51:59 2014

        Previous state: [FCOE_MGR_VFC_ST_PHY_UP]

        Triggered event: [FCOE_MGR_VFC_EV_BRING_DOWN_EVAL]

        Next state: [FSM_ST_NO_CHANGE]

     

    26) FSM:<vfc111> Transition at 616365 usecs after Tue Jan 14 13:51:59 2014

        Previous state: [FCOE_MGR_VFC_ST_PHY_UP]

        Triggered event: [FCOE_MGR_VFC_EV_BRING_DOWN_EVAL]

        Next state: [FSM_ST_NO_CHANGE]

     

    27) FSM:<vfc111> Transition at 618395 usecs after Tue Jan 14 13:51:59 2014

        Previous state: [FCOE_MGR_VFC_ST_PHY_UP]

        Triggered event: [FCOE_MGR_VFC_EV_BRING_DOWN_EVAL]

        Next state: [FSM_ST_NO_CHANGE]

     

    28) FSM:<vfc111> Transition at 618483 usecs after Tue Jan 14 13:51:59 2014

        Previous state: [FCOE_MGR_VFC_ST_PHY_UP]

        Triggered event: [FCOE_MGR_VFC_EV_BRING_DOWN]

        Next state: [FCOE_MGR_VFC_ST_BRINGDOWN_WAIT]

     

    29) FSM:<vfc111> Transition at 622223 usecs after Tue Jan 14 13:51:59 2014

        Previous state: [FCOE_MGR_VFC_ST_BRINGDOWN_WAIT]

        Triggered event: [FCOE_MGR_VFC_EV_BRING_DOWN_DONE]

        Next state: [FCOE_MGR_VFC_ST_DOWN]

     

    30) FSM:<vfc111> Transition at 121470 usecs after Tue Jan 14 13:52:00 2014

        Previous state: [FCOE_MGR_VFC_ST_DOWN]

        Triggered event: [FCOE_MGR_VFC_EV_BRING_UP_EVAL]

        Next state: [FSM_ST_NO_CHANGE]

     

    31) FSM:<vfc111> Transition at 133613 usecs after Tue Jan 14 13:52:00 2014

        Previous state: [FCOE_MGR_VFC_ST_DOWN]

        Triggered event: [FCOE_MGR_VFC_EV_BRING_DOWN_EVAL]

        Next state: [FSM_ST_NO_CHANGE]

     

    32) FSM:<vfc111> Transition at 135377 usecs after Tue Jan 14 13:52:00 2014

        Previous state: [FCOE_MGR_VFC_ST_DOWN]

        Triggered event: [FCOE_MGR_VFC_EV_BRING_DOWN_EVAL]

        Next state: [FSM_ST_NO_CHANGE]

     

    33) FSM:<vfc111> Transition at 869391 usecs after Tue Jan 14 13:52:05 2014

        Previous state: [FCOE_MGR_VFC_ST_DOWN]

        Triggered event: [FCOE_MGR_VFC_EV_ETH_UP]

        Next state: [FSM_ST_NO_CHANGE]

     

    34) FSM:<vfc111> Transition at 875391 usecs after Tue Jan 14 13:52:05 2014

        Previous state: [FCOE_MGR_VFC_ST_DOWN]

        Triggered event: [FCOE_MGR_VFC_EV_BRING_UP_EVAL]

        Next state: [FSM_ST_NO_CHANGE]

     

    35) FSM:<vfc111> Transition at 875476 usecs after Tue Jan 14 13:52:05 2014

        Previous state: [FCOE_MGR_VFC_ST_DOWN]

        Triggered event: [FCOE_MGR_VFC_EV_BRING_UP]

        Next state: [FCOE_MGR_VFC_ST_BRINGUP_WAIT]

     

    36) FSM:<vfc111> Transition at 911110 usecs after Tue Jan 14 13:52:05 2014

        Previous state: [FCOE_MGR_VFC_ST_BRINGUP_WAIT]

        Triggered event: [FCOE_MGR_VFC_EV_BRING_UP_SUCC]

        Next state: [FCOE_MGR_VFC_ST_PHY_UP]

     

    37) FSM:<vfc111> Transition at 924837 usecs after Tue Jan 14 13:52:05 2014

        Previous state: [FCOE_MGR_VFC_ST_PHY_UP]

        Triggered event: [FCOE_MGR_VFC_EV_BRING_UP_EVAL]

        Next state: [FSM_ST_NO_CHANGE]

     

    38) FSM:<vfc111> Transition at 955255 usecs after Tue Jan 14 13:52:05 2014

        Previous state: [FCOE_MGR_VFC_ST_PHY_UP]

        Triggered event: [FCOE_MGR_VFC_EV_ETH_L2_VLAN_CHANGE]

        Next state: [FSM_ST_NO_CHANGE]

     

    39) FSM:<vfc111> Transition at 961913 usecs after Tue Jan 14 13:52:05 2014

        Previous state: [FCOE_MGR_VFC_ST_PHY_UP]

        Triggered event: [FCOE_MGR_VFC_EV_BRING_DOWN_EVAL]

        Next state: [FSM_ST_NO_CHANGE]

     

    40) FSM:<vfc111> Transition at 976312 usecs after Tue Jan 14 13:52:05 2014

        Previous state: [FCOE_MGR_VFC_ST_PHY_UP]

        Triggered event: [FCOE_MGR_VFC_EV_BRING_DOWN_EVAL]

        Next state: [FSM_ST_NO_CHANGE]

     

    41) FSM:<vfc111> Transition at 978073 usecs after Tue Jan 14 13:52:05 2014

        Previous state: [FCOE_MGR_VFC_ST_PHY_UP]

        Triggered event: [FCOE_MGR_VFC_EV_BRING_DOWN_EVAL]

        Next state: [FSM_ST_NO_CHANGE]

     

    42) FSM:<vfc111> Transition at 978162 usecs after Tue Jan 14 13:52:05 2014

        Previous state: [FCOE_MGR_VFC_ST_PHY_UP]

        Triggered event: [FCOE_MGR_VFC_EV_BRING_DOWN]

        Next state: [FCOE_MGR_VFC_ST_BRINGDOWN_WAIT]

     

    43) FSM:<vfc111> Transition at 991107 usecs after Tue Jan 14 13:52:05 2014

        Previous state: [FCOE_MGR_VFC_ST_BRINGDOWN_WAIT]

        Triggered event: [FCOE_MGR_VFC_EV_BRING_DOWN_DONE]

        Next state: [FCOE_MGR_VFC_ST_DOWN]

     

    44) FSM:<vfc111> Transition at 491449 usecs after Tue Jan 14 13:52:06 2014

        Previous state: [FCOE_MGR_VFC_ST_DOWN]

        Triggered event: [FCOE_MGR_VFC_EV_BRING_UP_EVAL]

        Next state: [FSM_ST_NO_CHANGE]

     

    45) FSM:<vfc111> Transition at 491536 usecs after Tue Jan 14 13:52:06 2014

        Previous state: [FCOE_MGR_VFC_ST_DOWN]

        Triggered event: [FCOE_MGR_VFC_EV_BRING_UP]

        Next state: [FCOE_MGR_VFC_ST_BRINGUP_WAIT]

     

    46) FSM:<vfc111> Transition at 499124 usecs after Tue Jan 14 13:52:06 2014

        Previous state: [FCOE_MGR_VFC_ST_BRINGUP_WAIT]

        Triggered event: [FCOE_MGR_VFC_EV_BRING_UP_SUCC]

        Next state: [FCOE_MGR_VFC_ST_PHY_UP]

     

    47) FSM:<vfc111> Transition at 512934 usecs after Tue Jan 14 13:52:06 2014

        Previous state: [FCOE_MGR_VFC_ST_PHY_UP]

        Triggered event: [FCOE_MGR_VFC_EV_BRING_UP_EVAL]

        Next state: [FSM_ST_NO_CHANGE]

     

    48) FSM:<vfc111> Transition at 513031 usecs after Tue Jan 14 13:52:06 2014

        Previous state: [FCOE_MGR_VFC_ST_PHY_UP]

        Triggered event: [FCOE_MGR_VFC_EV_BRING_UP]

        Next state: [FSM_ST_NO_CHANGE]

     

     

        Curr state: [FCOE_MGR_VFC_ST_PHY_UP]

     

    PROTOS Info:

     


    N5K1(config-if)# sh system internal dcbx info interface e101/1/1


    Interface info for if_index: 0x1f640000(Eth101/1/1)




    Interface info for if_index: 0x1f640000(Eth1/1)

    tx_enabled: TRUE

    rx_enabled: TRUE

    dcbx_enabled: TRUE

    DCX Protocol: CEE

    DCX CEE NIV extension: disabled



    Port MAC address:  f0:29:29:ff:02:02



    DCX Control FSM Variables: seq_no: 0x1, ack_no: 0x1,my_ack_no: 0x1, peer_seq_no: 0x1 oper_version: 0x0,  max_version: 0x0 fast_retri

    es 0x0


    Lock Status: UNLOCKED

    PORT STATE: UP

    LLDP Neighbors


    Remote Peers Information on interface Eth101/1/1

    Remote peer's MSAP: length 12 Bytes:

    d4    8c    b5    bd    46    09    d4    8c    b5    bd    46    09    


    LLDP TLV's

    LLDP TLV type:Chassis ID  LLDP TLV Length: 7 

    04  d4  8c  b5  bd  46  09  

    Chassis type: 04        Chassis ID:d4  8c  b5  bd  46  09  

    LLDP TLV type:Port ID  LLDP TLV Length: 7 

    03  d4  8c  b5  bd  46  09  

    Port ID subtype: 03     Port ID:d4  8c  b5  bd  46  09  

    LLDP TLV type:Time to Live  LLDP TLV Length: 2 

    00  78  

    TTL = 00

    LLDP TLV type:LLDP Organizationally Specific  LLDP TLV Length: 55 

    00  1b  21  02  02  0a  00  00  00  00  00  01  00  00  00  01  08  0a  00  00  c0  00  89  06  00  1b  21  08  06  06  00  00  c0  

    00  ff  08  04  11  00  00  c0  00  ff  ff  ff  ff  00  00  00  00  00  00  00  00  08  

    LLDP TLV type:LLDP Organizationally Specific  LLDP TLV Length: 5 

    00  01  42  01  01  

    LLDP TLV type:END of LLDP PDU  LLDP TLV Length: 0 




    Peer's DCX TLV:

    DCBX TLV Proto(1) type: 1(Control) DCBX TLV Length: 10 DCBX TLV Value 

    00  00  00  00  00  01  00  00  00  01  

      sub_type 0, error 0, willing 0, enable 0, max_version 0, oper_version 0

    DCBX TLV Proto(1) type: 4(App) DCBX TLV Length: 10 DCBX TLV Value 

    00  00  c0  00  89  06  00  1b  21  08  

      sub_type 0, error 0, willing 1, enable 1, max_version 0, oper_version 0

    DCBX TLV Proto(1) type: 3(PFC) DCBX TLV Length: 6 DCBX TLV Value 

    00  00  c0  00  ff  08  

      sub_type 0, error 0, willing 1, enable 1, max_version 0, oper_version 0

    DCBX TLV Proto(1) type: 2(PriGrp) DCBX TLV Length: 17 DCBX TLV Value 

    00  00  c0  00  ff  ff  ff  ff  00  00  00  00  00  00  00  00  08  

      sub_type 0, error 0, willing 1, enable 1, max_version 0, oper_version 0


     5 Features on this intf for Protocol DCX CIN(0)


    Feature type PFC (3)

    feature type 3(DCX CIN-PFC)sub_type 0

    Feature State Variables: oper_version 0 error 0 local error 0 oper_mode 0 

         feature_seq_no 0 remote_feature_tlv_present 0 remote_tlv_aged_out 1

         remote_tlv_not_present_notification_sent 0

    Feature Register Params: max_version 0, enable 1, willing 0 advertise 1 

         disruptive_error 0 mts_addr_node 0x2201 mts_addr_sap 0x179

    Other server mts_addr_node 0x4, mts_addr_sap 0x0


    Desired config cfg length: 1 data bytes:08    


    Operating config cfg length: 0 data bytes:


    Peer config cfg length: 0 data bytes:



    Feature type App (5)sub_type FCoE iSCSI (0)

    feature type 5(DCX CIN-App)sub_type 0

    Feature State Variables: oper_version 0 error 0 local error 0 oper_mode 0 

         feature_seq_no 0 remote_feature_tlv_present 0 remote_tlv_aged_out 1

         remote_tlv_not_present_notification_sent 0

    Feature Register Params: max_version 0, enable 1, willing 0 advertise 1 

         disruptive_error 0 mts_addr_node 0x2201 mts_addr_sap 0x179

    Other server mts_addr_node 0x4, mts_addr_sap 0x0


    Desired config cfg length: 1 data bytes:08    


    Operating config cfg length: 0 data bytes:


    Peer config cfg length: 0 data bytes:



    Feature type PriMtu (8)

    feature type 8(DCX CIN-PriMtu)sub_type 0

    Feature State Variables: oper_version 0 error 0 local error 0 oper_mode 0 

         feature_seq_no 0 remote_feature_tlv_present 0 remote_tlv_aged_out 1

         remote_tlv_not_present_notification_sent 0

    Feature Register Params: max_version 0, enable 1, willing 0 advertise 1 

         disruptive_error 0 mts_addr_node 0x2201 mts_addr_sap 0x179

    Other server mts_addr_node 0x4, mts_addr_sap 0x0


    Desired config cfg length: 16 data bytes:05    dc    05    dc    05    dc    08    6e    05    dc    05    dc    05    dc    05    d

    c    


    Operating config cfg length: 0 data bytes:


    Peer config cfg length: 0 data bytes:



    Feature type PriGrp (2)

    feature type 2(DCX CIN-PriGrp)sub_type 0

    Feature State Variables: oper_version 0 error 0 local error 0 oper_mode 0 

         feature_seq_no 0 remote_feature_tlv_present 0 remote_tlv_aged_out 1

         remote_tlv_not_present_notification_sent 0

    Feature Register Params: max_version 0, enable 1, willing 0 advertise 1 

         disruptive_error 0 mts_addr_node 0x2201 mts_addr_sap 0x179

    Other server mts_addr_node 0x4, mts_addr_sap 0x0


    Desired config cfg length: 24 data bytes:32    32    00    00    00    00    00    00    00    0f    00    0f    00    0e    20    6

    4    00    0e    00    0e    00    0e    00    0e    


    Operating config cfg length: 0 data bytes:


    Peer config cfg length: 0 data bytes:



    Feature type LLS (6)sub_type LAN Logical Link Status (1)

    feature type 6(DCX CIN-LLS)sub_type 1

    Feature State Variables: oper_version 0 error 0 local error 0 oper_mode 0 

         feature_seq_no 0 remote_feature_tlv_present 0 remote_tlv_aged_out 1

         remote_tlv_not_present_notification_sent 0

    Feature Register Params: max_version 0, enable 1, willing 0 advertise 1 

         disruptive_error 0 mts_addr_node 0x2201 mts_addr_sap 0xaf

    Other server mts_addr_node 0x4, mts_addr_sap 0x0


    Desired config cfg length: 1 data bytes:80    


    Operating config cfg length: 0 data bytes:


    Peer config cfg length: 0 data bytes:



     3 Features on this intf for Protocol DCX CEE(1)


    Feature type PFC (3)

    feature type 3(DCX CEE-PFC)sub_type 0

    Feature State Variables: oper_version 0 error 0 local error 0 oper_mode 1 

         feature_seq_no 0 remote_feature_tlv_present 1 remote_tlv_aged_out 0

         remote_tlv_not_present_notification_sent 0

    Feature Register Params: max_version 0, enable 1, willing 0 advertise 1 

         disruptive_error 0 mts_addr_node 0x2201 mts_addr_sap 0x179

    Other server mts_addr_node 0x4, mts_addr_sap 0x0


    Desired config cfg length: 2 data bytes:08    08    


    Operating config cfg length: 2 data bytes:08    08    


    Peer config cfg length: 0 data bytes:



    Feature type App (4)sub_type FCoE iSCSI (0)

    feature type 4(DCX CEE-App)sub_type 0

    Feature State Variables: oper_version 0 error 0 local error 0 oper_mode 1 

         feature_seq_no 0 remote_feature_tlv_present 1 remote_tlv_aged_out 0

         remote_tlv_not_present_notification_sent 0

    Feature Register Params: max_version 0, enable 1, willing 0 advertise 1 

         disruptive_error 0 mts_addr_node 0x2201 mts_addr_sap 0x179

    Other server mts_addr_node 0x4, mts_addr_sap 0x0


    Desired config cfg length: 6 data bytes:89    06    00    1b    21    08    


    Operating config cfg length: 6 data bytes:89    06    00    1b    21    08    


    Peer config cfg length: 0 data bytes:



    Feature type PriGrp (2)

    feature type 2(DCX CEE-PriGrp)sub_type 0

    Feature State Variables: oper_version 0 error 0 local error 0 oper_mode 1 

         feature_seq_no 0 remote_feature_tlv_present 1 remote_tlv_aged_out 0

         remote_tlv_not_present_notification_sent 0

    Feature Register Params: max_version 0, enable 1, willing 0 advertise 1 

         disruptive_error 0 mts_addr_node 0x2201 mts_addr_sap 0x179

    Other server mts_addr_node 0x4, mts_addr_sap 0x0


    Desired config cfg length: 13 data bytes:00    01    00    00    32    32    00    00    00    00    00    00    02    


    Operating config cfg length: 13 data bytes:00    01    00    00    32    32    00    00    00    00    00    00    02    


    Peer config cfg length: 0 data bytes:



    Features on this intf for LLDP


    lldp feature type 2(PriMtu)sub_type 0

    lldp feature register params max_version 0, enable 1, willing 0 advertise 1, disruptive_error 0 mts_addr_node 0x2201 mts_addr_sap 0x

    179


    Desired config cfg length: 16 data bytes:05    dc    05    dc    05    dc    08    6e    05    dc    05    dc    05    dc    05    d

    c    


    Peer config cfg length: 0 data bytes:


    lldp feature type 1(LLS)sub_type 1

    lldp feature register params max_version 0, enable 1, willing 0 advertise 1, disruptive_error 0 mts_addr_node 0x2201 mts_addr_sap 0x

    af


    Desired config cfg length: 1 data bytes:01    


    Peer config cfg length: 1 data bytes:01    




     Traffic Counters

    DCBX pkt stats: 


        Total frames out: 124

        Total Entries aged: 14

        Total frames in: 125

        DCBX frames in: 125

        Total frames received in error: 0

        Total frames discarded: 0

        Total TLVs unrecognized: 0





    N5K1(config-if)# sh int vfc111

    vfc111 is trunking

        Bound interface is Ethernet101/1/1

        Hardware is Ethernet 

        Port WWN is 20:6e:00:05:9b:1d:65:7f

        Admin port mode is F, trunk mode is on

        snmp link state traps are enabled

        Port mode is TF

        Port vsan is 101

        Trunk vsans (admin allowed and active) (101)

        Trunk vsans (up)                       ()

        Trunk vsans (isolated)                 ()

        Trunk vsans (initializing)             (101)

        1 minute input rate 0 bits/sec, 0 bytes/sec, 0 frames/sec

        1 minute output rate 0 bits/sec, 0 bytes/sec, 0 frames/sec

          872173 frames input, 1824977636 bytes

            0 discards, 0 errors

          58679 frames output, 92381108 bytes

            0 discards, 0 errors

        last clearing of "show interface" counters never

        Interface last changed at Tue Jan 14 14:01:08 2014



    N5K1(config-if)# sh run


    !Command: show running-config

    !Time: Tue Jan 14 14:08:53 2014


    version 5.1(3)N2(1c)

    feature fcoe


    switchname N5K1


    feature telnet

    no feature http-server

    feature lldp

    feature fex


    role name cisco

      rule 99 deny command delete *

      rule 98 deny command format *

      rule 96 deny command mkdir *

      rule 95 deny command rmdir *

      rule 94 deny command move *

      rule 91 deny command config t ; no feature telnet

      rule 90 deny command config t ; interface mgmt0

      rule 10 permit read-write  

    username admin password 5 $1$VFg6PArs$10y7glmrO0y.9gY8PeEls/  role network-admin

    username cisco password 5 $1$n8kMBx5X$C1sxN0lmsY0MNCNe6jvBm0  role cisco

    no password strength-check


    banner motd %

    User/password is cisco/cisco.  Feature FEX is available.

    If you see 'SFP Invalid', just run that link at 1 gigabit/s and everything will work.

    You will need to set both ends of the link; Nexus doesn't support auto-negotation

    from 10 gigabits/s to 1 gigabits/s.

    %


    ip domain-lookup

    class-map type qos class-fcoe

    class-map type queuing class-all-flood

      match qos-group 2

    class-map type queuing class-ip-multicast

      match qos-group 2

    class-map type network-qos class-all-flood

      match qos-group 2

    class-map type network-qos class-ip-multicast

      match qos-group 2

    fex 101

      pinning max-links 1

      description "FEX0101"

    slot 2

    snmp-server user admin network-admin auth md5 0x0a6be7f71750adeed2d16b18a61b1940 priv 0x0a6be7f71750adeed2d16b18a61b1940 localizedke

    y

    snmp-server user cisco cisco auth md5 0xe8bc18a6d77415b245b1e3c5047f987c priv 0xe8bc18a6d77415b245b1e3c5047f987c localizedkey


    vrf context management

      ip route 0.0.0.0/0 192.168.0.1

    vlan 1,10

    vlan 1101

      fcoe vsan 101 

    port-channel load-balance ethernet source-dest-port


    vsan database

      vsan 101 



    interface san-port-channel 11

      channel mode active

      switchport mode E

      switchport trunk allowed vsan 101

      switchport speed 2000


    interface vfc111

      bind interface Ethernet101/1/1

      switchport trunk allowed vsan 101

      no shutdown

    vsan database

      vsan 101 interface vfc111



    interface fc2/1

      channel-group 11 force

      no shutdown


    interface fc2/2

      channel-group 11 force

      no shutdown


    interface fc2/3


    interface fc2/4


    interface fc2/5


    interface fc2/6


    interface fc2/7


    interface fc2/8


    interface Ethernet1/1


    interface Ethernet1/2


    interface Ethernet1/3


    interface Ethernet1/4


    interface Ethernet1/5


    interface Ethernet1/6


    interface Ethernet1/7


    interface Ethernet1/8


    interface Ethernet1/9


    interface Ethernet1/10

      switchport mode fex-fabric

      fex associate 101


    interface Ethernet1/11

      shutdown


    interface Ethernet1/12


    interface Ethernet1/13


    interface Ethernet1/14


    interface Ethernet1/15


    interface Ethernet1/16


    interface Ethernet1/17


    interface Ethernet1/18


    interface Ethernet1/19


    interface Ethernet1/20


    interface Ethernet1/21


    interface Ethernet1/22


    interface Ethernet1/23


    interface Ethernet1/24


    interface Ethernet1/25


    interface Ethernet1/26


    interface Ethernet1/27


    interface Ethernet1/28


    interface Ethernet1/29


    interface Ethernet1/30


    interface Ethernet1/31


    interface Ethernet1/32


    interface Ethernet1/33


    interface Ethernet1/34


    interface Ethernet1/35


    interface Ethernet1/36


    interface Ethernet1/37


    interface Ethernet1/38


    interface Ethernet1/39


    interface Ethernet1/40


    interface mgmt0

      ip address 192.168.0.51/24


    interface Ethernet101/1/1

      switchport mode trunk

      switchport trunk native vlan 10

      switchport trunk allowed vlan 10,1101

      spanning-tree port type edge trunk


    interface Ethernet101/1/2


    interface Ethernet101/1/3


    interface Ethernet101/1/4


    interface Ethernet101/1/5


    interface Ethernet101/1/6


    interface Ethernet101/1/7


    interface Ethernet101/1/8


    interface Ethernet101/1/9


    interface Ethernet101/1/10


    interface Ethernet101/1/11


    interface Ethernet101/1/12


    interface Ethernet101/1/13


    interface Ethernet101/1/14


    interface Ethernet101/1/15


    interface Ethernet101/1/16


    interface Ethernet101/1/17


    interface Ethernet101/1/18


    interface Ethernet101/1/19


    interface Ethernet101/1/20


    interface Ethernet101/1/21


    interface Ethernet101/1/22


    interface Ethernet101/1/23


    interface Ethernet101/1/24


    interface Ethernet101/1/25


    interface Ethernet101/1/26


    interface Ethernet101/1/27


    interface Ethernet101/1/28


    interface Ethernet101/1/29


    interface Ethernet101/1/30


    interface Ethernet101/1/31


    interface Ethernet101/1/32

    line console

    line vty

    boot kickstart bootflash:/n5000-uk9-kickstart.5.1.3.N2.1c.bin

    boot system bootflash:/n5000-uk9.5.1.3.N2.1c.bin 

    interface fc2/1

      switchport speed 2000

    interface fc2/2

      switchport speed 2000

    interface fc2/1

      switchport mode E

    interface fc2/2

      switchport mode E

    interface fc2/3

    interface fc2/4

    interface fc2/5

    interface fc2/6

    interface fc2/7

    interface fc2/8

    no logging console


     

  • Hi,

     

    can upload this cmd output !!

     

    show port internal info interface vfc <number>

  • N5K1# sh port internal info  interface vfc 111

     

     

    vfc111 - if_index: 0x1E00006E, phy_port_index: 0x106e 

         local_index: 0xffff

      Admin Config - state(up), mode(F), speed(auto), trunk(on)

        beacon(off), snmp trap(on), tem(false)

        description()

        port owner()

        Link failure syslog level = 5

      Operational Info - state(trunking), mode(TF), speed(auto), trunk(on)

        32-bit state reason(None), state reason(None) 

        phy port enable (1), phy layer (FC), port_osm_mode(OSM)

        participating(1), fcid(0x000000), bb_scn(0)

        config port vsan (101), oper port vsan (101) 

        rx bb_credit(0), rx bb_credit multiplier(0)

        rx bb_credit performance buffers(0), tx bb_credit(0)

        not first time port bringup is 1

        Port WWN is 20:6e:00:05:9b:1d:65:7f 

        current state [PI_FSM_ST_TXPORT_INIT_TRUNKING_ENABLED]

        port_init_eval_flag(0x00000001), cfg wait for none

            FC_PORT_INIT_DATA_VALID (0)

            FC_PORT_INIT_PHY_PORT_UP (49)

        Mts node id 0x0

        Lock Info: resource [vfc111] 

          type[0] p_gwrap[(nil)]

              FREE @ 676839 usecs after Tue Jan 14 14:34:17 2014

          type[1] p_gwrap[(nil)]

              FREE @ 678008 usecs after Tue Jan 14 14:34:17 2014

          type[2] p_gwrap[(nil)]

              FREE @ 678304 usecs after Tue Jan 14 14:34:17 2014

        0x10000001e00006e

        eport_init_flag(0x00000000), elp_chk_flag(0x00000000)

        elp_rcvd_fc2_handle(0x00000000), elp_sent_fc2_handle(0x00000000)

        esc_chk_flag(0x00000000), esc_fc2_handle(0x00000000)

        elp_flags(0x0000), classes_supported(F), tx bb_credit(0)

        Peer ELP Revision: 0 

        Timer active for PI_FSM_EV_TE_2_E_TIMER_EXPIRED

        cnt_link_failure(0), cnt_link_success(0), cnt_port_up(0)

        cnt_cfg_wait_timeout(5), cnt_port_cfg_failure(5), cnt_init_retry(0)

        nos link failures (0), debounce window (300 ms), elp wait tout (750 ms)

        link fail reason (0x0)    num_elps_before_up (0) 

        internal_reinit_counter (0) external_reinit_counter (0) 

      Trunk Info - 

        trunk vsans (allowed active) (101)

        trunk vsans (operational allowed) (101)

        trunk vsans (up) ()

        trunk vsans (isolated) ()

      TE port per vsan information

      vfc111, Vsan 101 - state(down), state reason(waiting for flogi), fcid(0x000000)

        port init flag(0x0), 

        Lock Info: resource [vfc111, vsan 101] 

          type[0] p_gwrap[(nil)]

              FREE @ 676147 usecs after Tue Jan 14 14:34:17 2014

          type[1] p_gwrap[(nil)]

              FREE @ 676148 usecs after Tue Jan 14 14:34:17 2014

          type[2] p_gwrap[(nil)]

              FREE @ 676148 usecs after Tue Jan 14 14:34:17 2014

        0x40000651e00006e

    current state [TE_FSM_ST_WAIT_FOR_FLOGI]

        RNID info not found.

        first time elp: 1

        Peer ELP Revision: 0 

      Pacer Info - 

        Pacer state: released credits due to timer expiry 

    PQP: not in progress

  • I just did, but it's pending moderation :( . Hopefully it will be approved soon :)

     

  • Hi,

    i have checked the output you have sent  , at very bottom if u see you VSAN is down !! it is most probably that your server is unable to do FLOGI !! your config looks pretty ok !!

     

    Try  rack rental one more time you would definatley able to nail it ..Make sure you have Emluex server Access with onecommand app installed

  • I just redid the config. This time the VFC went up from the first try, without any issues.

    Considering the issues I had the last time (unable to access the server via RDP), I'm assuming that the issue was on the server side. 

    I will recheck all my configs (and compare them to the ones I posted here), and if I find anything I had missed I will update this thread.

    Thank you for your help!

Sign In or Register to comment.