MULTICAST-RPF FAILURE ISSUE

Hi,

I am having problem with multicast to make this work.

My topology looks like:

R1--s0/0.1-----FRME-RELAY------s0/0 R2-------s0/0-----R3

 

R1 can ping 225.25.25.25 on R3, but cant ping 239.39.39.39 on R3 as well...

 

Logs on R2:

 

Rack1R2#

*Jan 29 15:15:57.915: IP(0): s=141.1.123.1 (Serial0/0) d=225.25.25.25 (Serial0/0  ) id=21, ttl=254, prot=1, len=100(100), mforward

Rack1R2#

*Jan 29 15:16:07.119: IP(0): s=141.1.123.1 (Serial0/0) d=239.39.39.39 id=22, ttl  =254, prot=1, len=104(100), RPF lookup failed for source or RP




Rack1R1#ping 225.25.25.25


Type escape sequence to abort.

Sending 1, 100-byte ICMP Echos to 225.25.25.25, timeout is 2 seconds:


Reply to request 0 from 141.1.123.3, 44 ms

Reply to request 0 from 141.1.123.3, 108 ms

Rack1R1#ping 239.39.39.39


Type escape sequence to abort.

Sending 1, 100-byte ICMP Echos to 239.39.39.39, timeout is 2 seconds:

.

Rack1R1#




I have enable the ip pim nbma-mode on R2 - s0/0.

Comments

  • JoeMJoeM ✭✭✭ ✭✭✭

    RPF lookup failed for source or RP

    ^ this is a problem for 239.39.39.39

     

    What is the output for    show ip mroute 239.39.39.39

  • Hari.sapkotaHari.sapkota ✭✭ ✭✭



    Rack1R1#ping 225.25.25.25


    Type escape sequence to abort.

    Sending 1, 100-byte ICMP Echos to 225.25.25.25, timeout is 2 seconds:


    Reply to request 0 from 141.1.123.3, 44 ms

    Reply to request 0 from 141.1.123.3, 108 ms

    Rack1R1#ping 239.39.39.39


    Type escape sequence to abort.

    Sending 1, 100-byte ICMP Echos to 239.39.39.39, timeout is 2 seconds:

    .

    Rack1R1#




    I have enable the ip pim nbma-mode on R2 - s0/0.

    In the hub and spoke network type, always set the hub as a DR with higher DR priority. Also, do not forget to enable "ip pim nbma-mode" command.

    HTH

  • JoeMJoeM ✭✭✭ ✭✭✭

    I do not see a reason that one mcast address is working, but the other is not.

    Are they igmp (joined) at the same location?  Is this a GNS3 setup?

     

    After you add the nbma-mode, try clearing the mroute table on all of the routers

            clear ip mroute *

    Then ping and  show ip mroute for both routes.   What is the difference?

  • Hi Renato,

    Please send us these outpouts on each router:

    sh ip pim neig

    sh run | sec rp

    sh run int s0/0

    !

     

Sign In or Register to comment.