Task 4.3 (OSPF)

This is really confusing... the question states:

• Configure OSPF area 0 on the Frame Relay link between R3 and R4.
• Do not change the default OSPF network type.
• Do not use any network commands.
• Configure MD5 authentication, use string of 1OSPF2
• Authentication should be enabled at the process level.

 

However, in the solution guide, it tells you to change the default network to non-broadcast.

interface Serial0/0/0.403
ip ospf 1 area 0
ip ospf network non-broadcast
ip ospf message-digest-key 1 md5 1OSPF2
!
router ospf 1
neighbor 161.1.34.3
area 0 authentication message-digest

 

This doesn't add up, because if you aren't supposed to change the network type, why does it say that in the solution guide?  I was moving forward with adjusting the timers so that the hello packets were agreeing on the config.  Which one is the right one to do?

Comments

  • Emelloul,

    After having quick look into your case, I found that the task has told you not to change the default OSPF network of non-broadcast, it does mean that you can have non-broadcast network type on your interface since this is the deafult one for FR cloud. 

    Further, there might be difference in wording between two workbook versions as i'm looking it into the version 5. Please check!

    Hope this helps!

  • That's the part that is confusing, because the version of the PDF that I have, which was released under the members section on 12/4/13, does not have the verbiage that you have, otherwise I wouldn't be asking that question  :)

    It gets really frustrating when you're studying and you rely on the information in the document to be accurate, only to find out that there's inconsistencies all throughout the lab and it doesn't correlate with what's in the solution guide.

  • Agreed - I downloaded the set of Vol.3 PDFs that were published on 12-5-2013 and my version is v4.51.

    What the v4.51 states.....

    4.3. OSPF
    • Configure OSPF area 0 on the Frame Relay link between R3 and R4.
    • Do not change the default OSPF network type.
    • Do not use any network commands.
    • Configure MD5 authentication, use string of 1OSPF2
    • Authentication should be enabled at the process level.

     

    Is there a version 5 because I don't see it?

  • Emelloul,

    One more thing...I had a feeling this topic was mis-worded. Simply changing the OSPF timers wouldn't solve this issue because R3 would need a DR present (LSA Type 2) and R4 would not. This mismatch between OSPF network types can lead to incorrect path calculations which would have caused issues down the road on this lab. However, by modifying the timers, you still get an OSPF adjacency to appear.

    Mike

  • The workbook you are referring might have been updated but not the solution guide. So, the combination of task and the solution may not be correct one. I suggest you to go with task requirement rather than refering the solution guide for all the tasks.

    Hope this helps!

  • Just so we're clear...I'm using v4.51 for both the scenarios and the solution guide. Those are the two most current versions I see when I down the updated text. Since the task and the solution are not in sync, we must look to the forum to verify our sanity. Unfortunately, in this case...looking to the task requirements would prevent us from completely the tast since the wording is wrong.

    Mike

  • I am also using the Vol 3 posted on 12/5/13.

    This is most definitely a [bad] mistake in the workbook. Per Task 3.2 

     

    • Configure two separate Frame Relay connections between R3 & R4 and
    • R4 & R5 using the subnets 161.X.34.0/24 and 161.X.45.0/24 respectively.
    • R3 and R5 should use their main interfaces while R4 should use two point-to-point sub-interfaces as per the diagram.
    • Do not use Frame Relay Inverse-ARP queries on R3 or R5.
    • Use Frame-Relay encapsulation type of CISCO.
    • Make sure each router can ping itself on the frame-relay interfaces.

     

    This very clearly dictates that R3 must be using the main interface for its FR connection and that R4 must use a Point-to-Point sub interface.

    Fast foward to Task 4.3 and it says:

     

    • Configure OSPF area 0 on the Frame Relay link between R3 and R4.
    • Do not change the default OSPF network type.
    • Do not use any network commands.
    • Configure MD5 authentication, use string of 1OSPF2
    • Authentication should be enabled at the process level.
    Now, since R4 uses a point-to-point sub-interface the default OSPF network type is Point-to-point.

     

    Serial0/1/0.403 is up, line protocol is up


      Internet Address 161.1.34.4/24, Area 0

      Process ID 1, Router ID 150.1.4.4, Network Type POINT_TO_POINT, Cost: 65

      Enabled by interface config, including secondary ip addresses

      Transmit Delay is 1 sec, State POINT_TO_POINT

      Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

        oob-resync timeout 40

        Hello due in 00:00:01

      Supports Link-local Signaling (LLS)

      Cisco NSF helper support enabled

      IETF NSF helper support enabled

      Index 1/1, flood queue length 0

      Next 0x0(0)/0x0(0)

      Last flood scan length is 0, maximum is 0

      Last flood scan time is 0 msec, maximum is 0 msec

      Neighbor Count is 0, Adjacent neighbor count is 0

      Suppress hello for 0 neighbor(s)


     

    And since R3 uses the main interface, the default network type is non-broadcast.

     

    RSRack1R3(config-if)#do sh ip ospf int


    Serial0/1/0:0 is up, line protocol is up

      Internet Address 161.1.34.3/24, Area 0

      Process ID 1, Router ID 150.1.3.3, Network Type NON_BROADCAST, Cost: 65

      Enabled by interface config, including secondary ip addresses

      Transmit Delay is 1 sec, State DR, Priority 1

      Designated Router (ID) 150.1.3.3, Interface address 161.1.34.3

      No backup designated router on this network

      Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5

        oob-resync timeout 120

        Hello due in 00:00:18

      Supports Link-local Signaling (LLS)

      Cisco NSF helper support enabled

      IETF NSF helper support enabled

      Index 1/1, flood queue length 0

      Next 0x0(0)/0x0(0)

      Last flood scan length is 0, maximum is 0

      Last flood scan time is 0 msec, maximum is 0 msec

      Neighbor Count is 0, Adjacent neighbor count is 0

      Suppress hello for 0 neighbor(s)

     


    This will NEVER work. It doesn't matter if you tweak the timers to match, you will just end up with a more confusing problem. R3 will believe that there should be a DR/BDR on the link since network type non-broadcast uses a DR/BDR. R4, using network type Point-to-Point does NOT use a DR/BR (it wouldn't provide any advantage since there are only ever 2 routers on a p2p link). This can be a very difficult problem to spot because you can actually form an adjacency if the routers timers are set to match, but the SPF algorithm will fail because one router sees the link as a transit type while the other sees it as a point-to-point. I changed the timers on R3 quick to match so they did form adjacency:

     

    RSRack1R3(config-if)#do sh ip ospf data router self



                OSPF Router with ID (150.1.3.3) (Process ID 1)


                    Router Link States (Area 0)


      LS age: 11

      Options: (No TOS-capability, DC)

      LS Type: Router Links

      Link State ID: 150.1.3.3

      Advertising Router: 150.1.3.3

      LS Seq Number: 80000002

      Checksum: 0xAB7B

      Length: 36

      Number of Links: 1


        Link connected to: a Transit Network                !<--- This is the FR link from R3's perspective

         (Link ID) Designated Router address: 161.1.34.3

         (Link Data) Router Interface address: 161.1.34.3

          Number of TOS metrics: 0

           TOS 0 Metrics: 65



    !----R4


    RSRack1R4(config-subif)#do sh ip ospf data router self


                OSPF Router with ID (150.1.4.4) (Process ID 1)


                    Router Link States (Area 0)


      LS age: 60

      Options: (No TOS-capability, DC)

      LS Type: Router Links

      Link State ID: 150.1.4.4

      Advertising Router: 150.1.4.4

      LS Seq Number: 80000002

      Checksum: 0x181F

      Length: 48

      Number of Links: 2


        Link connected to: another Router (point-to-point)       !<--- This is the FR link from R4's perspective



         (Link ID) Neighboring Router ID: 150.1.3.3

         (Link Data) Router Interface address: 161.1.34.4

          Number of TOS metrics: 0

           TOS 0 Metrics: 65


        Link connected to: a Stub Network

         (Link ID) Network/subnet number: 161.1.34.0

         (Link Data) Network Mask: 255.255.255.0

          Number of TOS metrics: 0

           TOS 0 Metrics: 65




    So just to repeat it one more time - this will not work under any circumstance. I don't care what timers you tweak. The confusing part is the adjacency will go to the full status if you make the timers match:





    RSRack1R3(config-if)#do sh ip ospf ne


    Neighbor ID     Pri   State           Dead Time   Address         Interface

    150.1.4.4         1   FULL/BDR        00:00:36    161.1.34.4      Serial0/1/0:0



    !----R4


    RSRack1R4(config-subif)#do sh ip ospf neigh


    Neighbor ID     Pri   State           Dead Time   Address         Interface

    150.1.3.3         0   FULL/  -        00:00:33    161.1.34.3      Serial0/1/0.403





    But you won't be able install any routes that go across that link. Again notice that R3 thinks that R4 is the BDR (from the earlier 'sh ip ospf int' output you can see R3 thinks he is the DR) and R4 doesnt think their should be a DR/BDR elections.



    The parameters that need to match to form a neighbor relationship between OSPF peers can all be tweaked w/o changing the network type EXCEPT the use of and DR/BDR. That cannot be fixed. So you can peer between broadcast and non-broadcast all day. You can peer between point-to-point, point-to-multipoint, & point-to-multipoint nonbroadcast all day. But you cannot peer between those 2 groups.


    Not to ruin any surprises for anyone, but there a very 'fun' troubleshooting in Vol 4 on this issue.



    Back to task 4.3 - I presume it should read:


    Do not change the default OSPF network type on R3


    Good Luck in your studies!

  • Mike, thank you for reiterating the exact same problem I was facing!  I was burning hours on this trying to figure out what I missed, yet correlate that to what is in the forum.  I always check INE to make sure that there isn't a newer version, but it really seems that Workbook-3 was put together rather quickly without attention to details like this.  I approached it from the same way you were thinking, and even tried adjusting the timers but got some weird behavior later on in the lab.  I'm trying to take the lab in a few months before v5 comes out and snags like this are very frustrating.

  • Guys,

    Despite what has been told, SG is still incomplete. Assuming that I need to change OSPF network type to NON_BROADCAST on R4 to get this to work, I would also need to define neighbors under OSPF process, right? This part is missing in the SG.

  • Martino,

     

    The SG I have (v4.51) does show the 'neighbor 161.1.34.3' command applied on R4 under the OSPF process ID 1 on Task 4.3, which as you stated is requied for either of the OSPF non-broadcast network types (non-broadcast or point-to-multipoint non-broadcast).

     

    Happy Studies!

  • I would also need to define neighbors under OSPF process, right? This part is missing in the SG.

    Martin,

    There are some workbook versions with different updates. So, just because of different workbook version that you have, you may not have the solution as Mike told. I think the most updated version does have correct task & solution. :)

     

Sign In or Register to comment.