CCIE Service Provider Task 4.11 Sham link

I have tried to do task 4.11 in dynamips but it never came up .Can anyone guide me how to bring this Sham link up in dynamips.

 

 

Witing eagerly for your reply

Comments

  • I got such an issue for OSPF virtual-link but never tested with sham-link. [8-|]

     

  • Sham-link between PE1 and PE2.

    PE1-

    Int loop100

    ip vrf for A

    ip add 1.1.1.1 255.255.255.255

    !

    router bgp xx

    add ipv4 vrf A

    network 1.1.1.1 mask 255.255.255.255

    !

    router ospf x vrf A

    area x sham-link 1.1.1.1 2.2.2.2

    !

     

    PE2-


    Int loop100

    ip vrf for A

    ip add 2.2.2.2 255.255.255.255

    !

    router bgp xx

    add ipv4 vrf A

    network 2.2.2.2 mask 255.255.255.255

    !

    router ospf x vrf A

    area x sham-link 2.2.2.2 1.1.1.1

    !

    key points-

    1. Configure a new loopback interface for the VRF

    2. Advertise new loopback IP in BGP

    3. Configure sham-link in OSPF VRF process

    AB.

  • I have tried to do task 4.11 in dynamips but it never came up .Can anyone guide me how to bring this Sham link up in dynamips.

    There is absolutely no difference in the configuration of a sham link with real hardware or dynamips. 

Sign In or Register to comment.