9.2 Can't ping from SW1 to R6

Task:

Enable IPv6 processing on the links between R6 & SW1 and R3 & SW1.
•  Use the ULA IPv6 prefixes FC00:X:0:67::Y/64 and FC00:X:0:37::Y/64 for
the links between R1 (SW1) & R6 and R3 & SW1 respectively.

For some reason, I cannot ping R6 from SW1 VLAN 67. SW1 to R3 works fine, R6 to SW1 works fine, but not from SW1 to R6.

Relevant config:

!!!!!!!! SW1 !!!!!!!!
Rack9SW1#sh sdm prefer
 The current template is "desktop IPv4 and IPv6 routing" template.
 The selected template optimizes the resources in
 the switch to support this level of features for
 8 routed interfaces and 1024 VLANs.

Rack9SW1#sh run int vlan 67
interface Vlan67
 ip address 155.9.67.7 255.255.255.0
 ip rip advertise 10
 ipv6 address FC00:9:0:67::7/64
end

!NO NEIGHBOR LISTED HERE FOR R6 ULA
Rack9SW1#show ipv6 neighbors
IPv6 Address                              Age Link-layer Addr State Interface
FC00:9:0:37::3                              3 0012.001c.e620  STALE Fa0/3
FE80::212:FF:FE1C:E620                      3 0012.001c.e620  STALE Fa0/3
FE80::21C:F6FF:FE12:7EB2                   20 001c.f612.7eb2  STALE Vl67

Rack9SW1#show ipv6 route FC00:9:0:67::6
Routing entry for FC00:9:0:67::/64
  Known via "connected", distance 0, metric 0, type connected
  Route count is 1/1, share count 0
  Routing paths:
    directly connected via Vlan67
      Last updated 00:22:44 ago
     
!!!!!!! R6 !!!!!!
Rack9R6#sh run int f0/0.67
interface FastEthernet0/0.67
 encapsulation dot1Q 67
 ip address 155.9.67.6 255.255.255.0
 ip rip advertise 10
 ipv6 address FC00:9:0:67::6/64
end

Rack9R6#show ipv6 neighbors
IPv6 Address                              Age Link-layer Addr State Interface
FE80::219:55FF:FEE6:D3C3                   19 0019.55e6.d3c3  STALE Fa0/0.67
FC00:9:0:67::7                             19 0019.55e6.d3c3  STALE Fa0/0.67

Rack9R6#show ipv6 route FC00:9:0:67::7
Routing entry for FC00:9:0:67::/64
  Known via "connected", distance 0, metric 0, type connected
  Route count is 1/1, share count 0
  Routing paths:
    directly connected via FastEthernet0/0.67
      Last updated 00:52:06 ago

!R6 Works fine
Rack9R6#debug ipv6 packet
  IPv6 unicast packet debugging is on
Rack9R6#ping FC00:9:0:67::7 repeat 1

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to FC00:9:0:67::7, timeout is 2 seconds:
!
Success rate is 100 percent (1/1), round-trip min/avg/max = 4/4/4 ms
Rack9R6#
Nov 24 11:25:49.927: IPv6: Looking up FC00:9:0:67::7 [Source ::] in FIB
Nov 24 11:25:49.927: IPv6: FIB lookup failed for FC00:9:0:67::7
Nov 24 11:25:49.927: IPv6-Sas: SAS picked source FE80::21C:F6FF:FE12:7EB2 for FC00:9:0:67::7 (FastEthernet0/0.67)
Nov 24 11:25:49.927: IPV6: source FE80::21C:F6FF:FE12:7EB2 (local)
Nov 24 11:25:49.927:       dest FC00:9:0:67::7 (FastEthernet0/0.67)
Nov 24 11:25:49.927:       traffic class 0, flow 0x0, len 100+0, prot 58, hops 64, originating
Nov 24 11:25:49.927: IPv6-Fwd: Sending on FastEthernet0/0.67
Nov 24 11:25:49.927: IPV6: source FC00:9:0:67::7 (FastEthernet0/0.67)
Nov 24 11:25:49.927:       dest FE80::21C:F6FF:FE12:7EB2
Rack9R6# (FastEthernet0/0.67)
Nov 24 11:25:49.931:       traffic class 0, flow 0x0, len 100+14, prot 58, hops 64, forward to ulp

!SW1fails
Rack9SW1#debug ipv6 pack
  IPv6 unicast packet debugging is on
Rack9SW1#ping FC00:9:0:67::6 repeat 1

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to FC00:9:0:67::6, timeout is 2 seconds:
.
Success rate is 0 percent (0/1)
Rack9SW1#
*Mar  1 00:33:28.828: IPv6: Looking up FC00:9:0:67::6 [Source ::] in FIB
*Mar  1 00:33:28.828: IPv6: FIB lookup for FC00:9:0:67::6 succeeded. if=Vlan67, nexthop FC00:9:0:67::6
*Mar  1 00:33:28.828: IPv6-Sas: SAS picked source FC00:9:0:67::7 for FC00:9:0:67::6 (Vlan67)
*Mar  1 00:33:28.836: IPV6: source FC00:9:0:67::7 (local)
*Mar  1 00:33:28.836:       dest FC00:9:0:67::6 (Vlan67)
*Mar  1 00:33:28.836:       traffic class 0, flow 0x0, len 100+0, prot 58, hops 64, originating
*Mar  1 00:33:28.836: IPV6: source FC00:9:0:67::7 (local)
*Mar  1 00:33:28.836:       dest FF02::1:FF00:6 (Vlan67)
*Mar  1 00:33:28.836:       traffic class 224, flow 0x0, len 72+0, prot 58, hops 255, originating
*Mar  1 00:33:28.836: IPv6-Fwd: Sending on Vlan67
*Mar  1 00:33:28.836: IPv6-Fwd: Encapsulation postponed, performing resolution
*Mar  1 00:33:29.843: IPV6: source FC00:9:0:67::7 (local)
*Mar  1 00:33:29.843:       dest FF02::1:FF00:6 (Vlan67)
*Mar  1 00:33:29.843:       traffic class 224, flow 0x0, len 72+0, prot 58, hops 255, originating
*Mar  1 00:33:29.843: IPv6-Fwd: Sending on Vlan67
*Mar  1 00:33:30.849: IPV6: source FC00:9:0:67::7 (local)
*Mar  1 00:33:30.849:       dest FF02::1:FF00:6 (Vlan67)
*Mar  1 00:33:30.849:       traffic class 224, flow 0x0, len 72+0, prot 58, hops 255, originating
*Mar  1 00:33:30.849: IPv6-Fwd: Sending on Vlan67

What am I missing here? It's driving me nuts!

 

 

Comments

Sign In or Register to comment.