Understanding OSPF External Route Path Selection

please answer in this regard

I want to type exactly wat i did

R1

config

int f0/0

no shut

int f0/0.12

encapsulation dot1q 1

ip add 10.1.12.1 /24

int f0/0.13

encapsulation dot1q 2

ip add 10.1.13.1 /24

router ospf 1

network 10.1.12.0 area 0

network 10.1.13.0 area 0

R2

config

int f0/0

no shut

int f0/0.12

encapsulation dot1q 1

ip add 10.1.12.2 /24

int f0/0.24

encapsulation dot1q 2

ip add 10.1.24.2 /24

router ospf 1

network 10.1.12.0 area 0

network 10.1.24.0 area 1

R3

config

int f0/0

no shut

int f0/0.13

encapsulation dot1q 2

ip add 10.1.13.3

int f0/0.35

encapsulation dot1q 1

ip add 10.1.35.3

router ospf 1

network 10.1.35.0 area 1

network 10.1.13.0 area 0

My question is if we put 1 sub-interface in 1 area and another in
another area and we repeat this porcess for 3 routers …….. Why we get
Virtual link error ?


i receive Virtual-link error message on R2 and R3

Comments

  • Hi,

    I think you have discontiguous OSPF areas configured between R1, R2 & R3. If you have an area that is not directly connected to the area 0, you get such an error because of discontiguous area. Please post the config if you have any doubt.

    Hope this helps!

  • Is R2's f0/0.24 and R3's f0/0.13 in the same VLAN (2)? They are probably seeing hellos from each other being a broadcast segment and seeing that their area numbers mismatch. Of course they still wouldn't form an adjacency since their IP subnets are not the same either.

  • int f0/0.12


    encapsulation dot1q 1

    ip add 10.1.12.2 /24

    int f0/0.24
    encapsulation dot1q 2

    ip add 10.1.24.2 /24



    No they are in siffernt vlans ...............

    Digram is below

    image

  • Is R2's f0/0.24 and R3's f0/0.13 in the same VLAN (2)? They are probably seeing hellos from each other being a broadcast segment and seeing that their area numbers mismatch. Of course they still wouldn't form an adjacency since their IP subnets are not the same either.

    Agree, just make sure that you have configured similar area in the particular segment. Otherwise, it would give an error and interrupt another segment which was functioning correctly. ;)

    Good luck!

  • so it means i use differnt vlan for every segment..... this is topology of INE .... i want to test E1 and E2 behaviour

  • JoeMJoeM ✭✭✭

    My question is if we put 1 sub-interface in 1 area and another in
    another area and we repeat this porcess for 3 routers …….. Why we get
    Virtual link error ?


    i receive Virtual-link error message on R2 and R3

    Hi MaybeCCIE,

    What topology are you using?   I am trying to understand how your interfaces are all connected.

    I do see a mismatch of subnets for each vlan.

    Vlan 1:

             10.1.12.0       R1,R2

             10.1.35.0       R3

    Vlan 2

             10.1.13.0       R1,R3

             10.1.24.0      R2

     

    Also, I am curious about your Virtual-Link error on R2 and R3.   I do not see anything in your configuration for a virtual-link.   You will not get this error, unless there is a router trying to set up a virtual-link.

    Notice this whenever you setup a virtual-link between two routers.  If you set up one side and wait a little, the other side will start complaining until it is setup (correctly).

    Can you post the error?   Thanks.













  • Dear Sir ,

     

    Pls find the attachment. so it means i use differnt vlan
    for every segment..... this is topology of INE .... i want to test E1 and E2
    behaviour



    http://blog.ine.com/wp-content/uploads/2011/04/ospf.external.routing.png

    From: [email protected]
    [mailto:[email protected]] On Behalf Of JoeM

    Sent: Thursday, October 31, 2013 5:42 PM

    To: [email protected]

    Subject: Re: [CCIE R&S] Understanding OSPF External Route Path
    Selection

     



    imageMaybeCCIE:



    My question is if we put 1 sub-interface in 1 area and another in another
    area and we repeat this porcess for 3 routers …….. Why we get Virtual link
    error ?

    i receive Virtual-link error message on R2 and R3



    Hi MaybeCCIE,

    What topology are you using?   I am trying to understand how your
    interfaces are all connected.

    I see a mismatch of subnets for each vlan.

    Vlan 1:

             10.1.12.0    
      R1,R2

             10.1.35.0       R3

    Vlan 2

             10.1.13.0      
    R1,R3

             10.1.24.0      R2

     

    Also, I am curious about your Virtual-Link error on R2 and R3.   I
    do not see anything in your configuration for a virtual-link.   You
    will not get this error, unless there is a router trying to set up a virtual-link.

    Notice this whenever you setup a virtual-link between two routers.  If
    you set up one side and wait a little, the other side will start complaining
    until it is setup (correctly).

    Can you post the errror?   Thanks.







    INE - The Industry Leader in CCIE Preparation

    http://www.INE.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx





  • JoeMJoeM ✭✭✭


    i receive Virtual-link error message on R2 and R3

    Dear Sir ,


     Pls find the attachment. so it means i use differnt vlan
    for every segment..... this is topology of INE .... i want to test E1 and E2
    behaviour

    In your initial post, you said you were getting a virtual-link error.  Where is the virtual-link configured?  Please post the error?

     

    For the topology, the diagram is showing it as though the sub-interfaces are directly connected to each router.

    http://blog.ine.com/wp-content/uploads/2011/04/ospf.external.routing.png

     

    The problem is that in order to split F0/0 on all routers, we need to have at least one switch trunking and separating the vlans.

    Do we have full-connectivity between the routers?  Is it possible to ping all interfaces?

     

    Are you just trying to get the network working, or do you have a question about the OSPF metric-types E1 and E2? 

     

  • Also, I am curious about your Virtual-Link error on R2 and R3.   I do not see anything in your configuration for a virtual-link.   You will not get this error, unless there is a router trying to set up a virtual-link.

    You can see such an issue whenever there is an area id mismatch. 

    *Mar  1 00:01:00.735: %OSPF-4-ERRRCV: Received invalid packet: mismatch area ID, from backbone area must be virtual-link but not found from 10.1.1.1, Ethernet0/0

    I believe he is trying to explain about this issue since he doesn't have any virtual-link configured in this scenario. So, probably it has an issue with mismatched area-id.





  • 1. yes exactly i have configured NO virtual-link configured. Obviously u don't need it when u have only 2 area's ( 0 and 1)

    2. I have Used switch. This topology digram is of INE. They made it that way i cannot say anything.

    3. As i mentioned i get error on R2 and R3.

    4. Now i want to make this topology in GNS3 and Test CCIE level stuff . Like OE1 and OE2 behavior .

     

    Now one friend on this post he replied for using differnt vlan for every segment. In this way i will not get this virtual link error.

     

  • JoeMJoeM ✭✭✭

    Also, I am curious about your Virtual-Link error on R2 and R3.   I do not see anything in your configuration for a virtual-link.   You will not get this error, unless there is a router trying to set up a virtual-link.

    You can see such an issue whenever there is an area id mismatch. 

    *Mar  1 00:01:00.735: %OSPF-4-ERRRCV: Received invalid packet: mismatch area ID, from backbone area must be virtual-link but not found from 10.1.1.1, Ethernet0/0

    I believe he is trying to explain about this issue since he doesn't have any virtual-link configured in this scenario. So, probably it has an issue with mismatched area-id.






    Hi Hari,

    Thanks for this info.

    This is interesting, as it is the same exact error as the one that I am explaining.

    One side configured....the other not configured.

    %OSPF-4-ERRRCV: Received invalid packet: mismatch area ID, from backbone area must be virtual-link but not found from 173.1.23.8, FastEthernet0/0

     

    Here is the Cisco-DOC for Mismatched Area ID

     

     

     

     

  • but mine error is NOT like that.[:(]

  • JoeMJoeM ✭✭✭

    1. yes exactly i have configured NO virtual-link configured. Obviously u don't need it when u have only 2 area's ( 0 and 1)

    2. I have Used switch. This topology digram is of INE. They made it that way i cannot say anything.

    3. As i mentioned i get error on R2 and R3.

    4. Now i want to make this topology in GNS3 and Test CCIE level stuff . Like OE1 and OE2 behavior .

     

    Now one friend on this post he replied for using differnt vlan for every segment. In this way i will not get this virtual link error.

     

    MaybeCCIE,

    Can you give this information:

    How is the network (before OSPF)? I am not clear on this. Are you able to ping from interface to interface (testing basic vlan/interface setup)?

     

    Also, please post the folowing for the three routers.   This will give interfaces with areas and neighbor count.

                      show ip ospf interface brief

     

  • JoeMJoeM ✭✭✭

    but mine error is NOT like that.Sad

    What is it like? 

    Can you post the error message?   This will make sure that we are talking about the same thing.  Thanks.

  • but mine error is NOT like that.Sad

     

    Please post the error message too, without posting it we can't get into the actual case. 

     

  • Dear Mr.Hari sapkota,

    1. I have solve the issue.

    2. I remove all valn configurations from Layer 2 switch. Only and only i used vlan 1 and put all interfaces in 1 vlan.

    3. Made one trunk port for another switch [:D]

    4. Now i have no virtaul-link error .

    5. I have one advice for INE ... I love this group now . CCIE people replying its very very cool.   But Please make this group design at international level. What i mean when you see the page you think i came back in 1986  Era lolzz. Make options Easier and obvious for replying and also so that we paste our topology image easily. I WANT TO SAY ITS GREAT PALCE TO LEARN THINGS. But i am hope u get my point.

    6. I saw that INE has made topology digram so confusing .

    7. I want to share my gns3 file ... how i should share ?

    8. Thank u so much INE again ...

     

     

     

     

     

  • Hi,

    That's great! You solved it on your own. 

    We know that you are not so familiar with the forum in detail. So, keep posting your doubts, you will feel more comfortable. 

    Your advice has already reached upto the forum support & I hope it will be taken care as much as possible.

    Good luck!

     

  • Thank you so so so much INE....................... Really thank ful.

    Definately i will be using this forum 24/7 . When CCIE people reply to ur questions what else u need lolzzzzzzzzzzzzz

     

     

  • JoeMJoeM ✭✭✭

    1. I have solve the issue.

    2. I remove all valn configurations from Layer 2 switch. Only and only i used vlan 1 and put all interfaces in 1 vlan.

    3. Made one trunk port for another switch Big Smile

    4. Now i have no virtaul-link error

    Congrats on getting to the stage where you can test OSPF E1 and E2.

    When you get a chance, you may want to come back and work on the actual problem you had.  This is very very important L2 information -- for all certification levels.  Also, it is great practice for vlan/trunking.

    You have folded all interfaces into one (1) vlan, and created a single flat broadcast domain (vlan 1).   This is critical, as it defeats the idea of using a switch to breakup broadcast domains.

     

    Each subnet that uses the switch should have its own vlan -- separated into separate broadcast domains.  If you like, I can help you get the the dynamips file correct.  Read below for how to post your GNS files (must be in a zip file).

     

    UPLOAD ZIP FILE (with GNS3 files):

    1. Click on your name at the top of the forum.  This takes you to your profile.

    2.  Go to 'My Files'

    3.   Select and Add your zip file

    4.  Paste the URL for the webpage 

     

    Here is an example:

    http://ieoc.com/members/JoeM/files/CCIE-RS-Exam-Checklist-1Apr10-rev-2.zip.aspx

     

     

    Let us know if you need anymore help.  Good luck.

  • JoeMJoeM ✭✭✭

     

    Here is your diagram inserted into the thread.   Use the same method, but not in a zip file.

    In your forum post, use the "Insert Media" button.  Paste the URL in the popup box.

    image

  • Mr.Joe,

     

    Thank you sir. Learned alot. I downaloaded ur file also. Inshallah i will aks more questions as i go from Multicast, IPV6 and QOS .... topics [;)]

Sign In or Register to comment.