CUPC Voicemail & Unity Connection IMAP problem

Hi,

I am trying to set up voicemail for a CUPC client. (CUPC v 7.0.1, CUCX v 7.0.2). Under server health on CUPC, voicemail
shows up as Failed to connect: Invalid credentials or account locked. I have configured the password to match what is set for the "web application" password in Unity Connection (the voice mail password is the same anyway) and set the same username password on the client.

I suspected a problem with the server so I telnetted to unity connection on port 143 and noticed sometimes I would get the prompt
"* OK  UMSS IMAP4rev1 Server Completed" and then nothing. I checked the Connection IMAP Server service in serviceability and the service had stopped. This keeps happening despite reboots of the server.

I took a wireshark trace and can see that the client tries to log in via IMAP with the correct login details and then nothing from unity connection.

Has anyone seen this behaviour or am I missing something very obvious ( I have checked Allow Users to Access Voice Mail Using an IMAP Client)

Thanks
Samson

Comments

  • Hi have you checked that the authentication rule is not set to change on first login?

  • Sorry I meant in the password settings on user template.

  • Hi Walt,

    Thanks for the reply. yes this is unchecked. I've also tried "unlock password" and the failed login attempts
    field shows up as 0.

    Rgds

    Samson

  • O.k Are the users in cucm and do they have end user role? Also add the cuc server as a application server in ucm if not already. 

  • Hi,

    Yes all of the above were done. I am pretty sure my configuration is ok.

    To summarise:
    CoS has "Allow Users to Access Voice Mail Using an IMAP Client", "Allow Users to Access Message Bodies" and "Allow Users to Use Unified Client to Access Voice Mail" checked  
    Authentication rules have been relaxed
    users "web" password matches login credentials on CUPC
    web password set to never expire


    I suspect this is something to do with my vmware environment.

    I tried telnetting to the IMAP server again and as soon as I try and login with the below command, the connection gets terminated
    and the IMAP service crashes.

    HQ-2821#telnet 192.168.25.8 143
    Trying 192.168.25.8, 143 ... Open
    * OK  UMSS IMAP4rev1 Server Completed

    2 login blinus 55555  <<=======

    [Connection to 192.168.25.8 closed by foreign host]



    I checked the CLI logs on Unity Connection and noticed that every time a crash happened a file was generated with the following info:

    admin:file view activelog cuc/diag_CuImapSvr_00000015.uc

    10/11/2013 17:01:07.825 |18811,,,-1,-1,The Connection IMAP Server could not initialize one of the listening sockets. Another application may be using one of ports reserved for IMAP.  Stop that application and restart the Connection IMAP service.|
    10/11/2013 17:01:07.848 |GEN getTraceObject = 0x82fdf38, m_pGenTrace = 0x82fdf38|
    10/11/2013 17:01:07.848 |GENAccessTrace obj is being used|
    10/11/2013 17:01:07.848 |RISGENAccess::init(): no mmfId, Invalid sourceName: Connection IMAP Server|

    Have tried re-installing - same problem ..so I give up!!

     

     

     

     

     

Sign In or Register to comment.