What could cause a IPv4 MDT address not being learnt on mrib ?

RP/0/3/CPU0:XR2#show bgp ipv4 mdt 

Fri Feb 18 08:28:42.605 UTC

BGP router identifier 20.20.20.20, local AS number 65001

BGP generic scan interval 60 secs

BGP table state: Active

Table ID: 0xe0000000

BGP main routing table version 3

BGP scan interval 60 secs

 

Status codes: s suppressed, d damped, h history, * valid, > best

              i - internal, r RIB-failure, S stale

Origin codes: i - IGP, e - EGP, ? - incomplete

   Network            Next Hop            Metric LocPrf Weight Path

Route Distinguisher: 65000:1

*>i2.2.2.2/96         2.2.2.2                  0    100      0 65000 ?

Route Distinguisher: 65001:1

*> 20.20.20.20/96     0.0.0.0                                0 i

 

Processed 2 prefixes, 2 paths

RP/0/3/CPU0:XR2#

RP/0/3/CPU0:XR2#sh bgp ipv4 mdt vrf VPN_A 2.2.2.2

Fri Feb 18 08:28:29.349 UTC

% Network not in table

 

What could cause this behavior ?

 

-=-=-= Configs -=-=-=-=-

R2#sh run 

Building configuration...

 

Current configuration : 3228 bytes

!

! Last configuration change at 15:07:18 UTC Sun Sep 29 2013

!

version 12.2

no service pad

no service timestamps debug uptime

no service timestamps log uptime

!

hostname R2

!

boot-start-marker

warm-reboot

boot-end-marker

!

vrf definition VPN_A

 rd 65000:1

 route-target export 65000:1

 route-target import 65001:1

 !

 address-family ipv4

 route-target export 65000:1

 route-target import 65001:1

 bgp next-hop Loopback0

 mdt default 232.0.0.1

 mdt data 232.0.1.0 0.0.0.255

 

 exit-address-family

!

vrf definition VPN_B

 rd 65000:2

 route-target export 65000:2

 route-target import 65001:2

 !

 address-family ipv4

 exit-address-family

!

security passwords min-length 1

enable password cisco

!

no aaa new-model

ip source-route

!

!

!

!         

no ip domain lookup

ip multicast-routing 

ip multicast-routing vrf VPN_A 

ip cef

no ipv6 cef

!

!

multilink bundle-name authenticated

!

!

!

!

!

!

!

!

!

interface Loopback0

 ip address 2.2.2.2 255.255.255.255

 ip pim sparse-mode

 ip igmp join-group 232.0.0.200 source 20.20.20.20

 ip igmp join-group 232.0.0.2 source 20.20.20.20

 ip ospf 1 area 0

!

interface FastEthernet0/0

 no ip address

 duplex full

!

interface FastEthernet0/0.25

 encapsulation dot1Q 25

 ip address 20.2.5.2 255.255.255.0

 ip pim sparse-mode

!

interface FastEthernet0/0.29

 vrf forwarding VPN_A

 encapsulation dot1Q 29

 ip address 30.2.9.2 255.255.255.0

 ip pim sparse-mode

!

interface FastEthernet0/0.210

 vrf forwarding VPN_B

 encapsulation dot1Q 210

 ip address 40.2.10.2 255.255.255.0

!

interface FastEthernet1/0

 no ip address

 shutdown

 duplex half

!

interface Serial2/0

 no ip address

 shutdown

 serial restart-delay 0

!

interface Serial2/1

 no ip address

 shutdown

 serial restart-delay 0

!

interface Serial2/2

 no ip address

 shutdown

 serial restart-delay 0

!

interface Serial2/3

 no ip address

 shutdown

 serial restart-delay 0

!

router ospf 1

 router-id 2.2.2.2

 log-adjacency-changes

 passive-interface Loopback0

 network 20.2.5.2 0.0.0.0 area 0

 mpls ldp autoconfig

!

router rip

 !

 address-family ipv4 vrf VPN_B

  redistribute bgp 65000 metric 1

  network 40.0.0.0

  no auto-summary

  version 2

 exit-address-family

 !

 address-family ipv4 vrf VPN_A

  redistribute bgp 65000 metric 1

  network 30.0.0.0

  no auto-summary

  version 2

 exit-address-family

!

router bgp 65000

 no bgp default ipv4-unicast

 bgp log-neighbor-changes

 neighbor 5.5.5.5 remote-as 65000

 neighbor 5.5.5.5 update-source Loopback0

 !

 address-family ipv4

  no synchronization

  no auto-summary

 exit-address-family

 !

 address-family vpnv4

  neighbor 5.5.5.5 activate

  neighbor 5.5.5.5 send-community extended

 exit-address-family

 !

 address-family ipv4 mdt

  neighbor 5.5.5.5 activate

  neighbor 5.5.5.5 send-community extended

 exit-address-family

 !

 address-family ipv4 vrf VPN_A

  no synchronization

  redistribute connected

  redistribute rip

 exit-address-family

 !

 address-family ipv4 vrf VPN_B

  no synchronization

  redistribute rip

 exit-address-family

!

!

!

no ip http server

no ip http secure-server

!

!

mpls ldp router-id Loopback0 force

!

!

control-plane

!

!

line con 0

 exec-timeout 0 0

 logging synchronous level 0 limit 20

 transport preferred none

 stopbits 1

line aux 0

 stopbits 1

line vty 0 4

 no login

!

end

 

-=-=-= 

 

RP/0/3/CPU0:XR2#sh run 

Fri Feb 18 08:33:32.686 UTC

Building configuration...

!! IOS XR Configuration 3.9.1

!! Last configuration change at Fri Feb 18 07:10:44 2000 by xr2

!

hostname XR2

banner login "Note: XR2 default login/password is xr2/cisco"

domain lookup disable

username xr2

 group root-lr

 password 7 0822455D0A16

!

cdp

vrf VPN_A

 address-family ipv4 unicast

  import route-target

   65000:1

  !

  export route-target

   65001:1

  !

 !

!

vrf VPN_B

 address-family ipv4 unicast

  import route-target

   65000:2

  !

  export route-target

   65001:2

  !

 !

!

line console

 exec-timeout 0 0

!

interface Loopback0

 ipv4 address 20.20.20.20 255.255.255.255

!

interface MgmtEth0/3/CPU0/0

 shutdown

!

interface MgmtEth0/3/CPU0/1

 shutdown

!

interface MgmtEth0/3/CPU0/2

 shutdown

!

interface GigabitEthernet0/4/0/0

 cdp

!

interface GigabitEthernet0/4/0/0.620

 ipv4 address 20.6.20.20 255.255.255.0

 dot1q vlan 620

!

interface GigabitEthernet0/4/0/0.920

 vrf VPN_B

 ipv4 address 40.9.20.20 255.255.255.0

 dot1q vlan 920

!

interface GigabitEthernet0/4/0/0.1020

 vrf VPN_A

 ipv4 address 30.10.20.20 255.255.255.0

 dot1q vlan 1020

!

interface GigabitEthernet0/4/0/1

 shutdown

!

interface GigabitEthernet0/4/0/2

 shutdown

!

interface GigabitEthernet0/4/0/3

 shutdown

!

interface POS0/7/0/0

 shutdown

!

interface POS0/7/0/1

 shutdown

!

interface POS0/7/0/2

 shutdown

!

interface POS0/7/0/3

 shutdown

!

route-policy RIP

  if destination in (0.0.0.0/0) then

    set rip-metric 1

  else

    pass

  endif

end-policy

!

router bgp 65001

 address-family ipv4 unicast

  network 20.6.20.0/24

  network 20.20.20.20/32

  allocate-label all

 !

 address-family vpnv4 unicast

 !

 address-family ipv4 mdt

 !

 neighbor 6.6.6.6

  remote-as 65001

  update-source Loopback0

  address-family ipv4 labeled-unicast

  !

  address-family vpnv4 unicast

  !

  address-family ipv4 mdt

  !

 !

 vrf VPN_A

  rd 65001:1

  address-family ipv4 unicast

   redistribute connected

   redistribute rip

  !

 !

 vrf VPN_B

  rd 65001:2

  address-family ipv4 unicast

   redistribute connected

   redistribute rip

  !

 !

!

mpls ldp

 router-id 20.20.20.20

 interface GigabitEthernet0/4/0/0.620

 !

!

multicast-routing

 address-family ipv4

  mdt source Loopback0

  interface all enable

 !

 vrf VPN_A

  address-family ipv4

   mdt source Loopback0

   mdt data 232.0.1.0/24

   mdt default ipv4 232.0.0.1

   interface all enable

  !

 !

!

router eigrp 100

 address-family ipv4

  interface Loopback0

   passive-interface

  !

  interface GigabitEthernet0/4/0/0.620

  !

 !

!

router rip

 vrf VPN_A

  interface Loopback100

  !

  interface GigabitEthernet0/4/0/0.1020

  !

  redistribute bgp 65001

  default-metric 1

 !

 vrf VPN_B

  interface GigabitEthernet0/4/0/0.920

  !

  redistribute bgp 65001

  default-metric 1

 !

!

end




Comments

  • RP/0/3/CPU0:XR2#sh run 

    Fri Feb 18 08:31:31.398 UTC

    Building configuration...

    !! IOS XR Configuration 3.9.1

    !! Last configuration change at Fri Feb 18 07:10:44 2000 by xr2

    !

    hostname XR2

    banner login "Note: XR2 default login/password is xr2/cisco"

    domain lookup disable

    username xr2

     group root-lr

     password 7 0822455D0A16

    !

    cdp

    vrf VPN_A

     address-family ipv4 unicast

      import route-target

       65000:1

      !

      export route-target

       65001:1

      !

     !

    !

    vrf VPN_B

     address-family ipv4 unicast

      import route-target

       65000:2

      !

      export route-target

       65001:2

      !

     !

    !

    line console

     exec-timeout 0 0

    !

    interface Loopback0

     ipv4 address 20.20.20.20 255.255.255.255

    !

    interface MgmtEth0/3/CPU0/0

     shutdown

    !

    interface MgmtEth0/3/CPU0/1

     shutdown

    !

    interface MgmtEth0/3/CPU0/2

     shutdown

    !

    interface GigabitEthernet0/4/0/0

     cdp

    !

    interface GigabitEthernet0/4/0/0.620

     ipv4 address 20.6.20.20 255.255.255.0

     dot1q vlan 620

    !

    interface GigabitEthernet0/4/0/0.920

     vrf VPN_B

     ipv4 address 40.9.20.20 255.255.255.0

     dot1q vlan 920

    !

    interface GigabitEthernet0/4/0/0.1020

     vrf VPN_A

     ipv4 address 30.10.20.20 255.255.255.0

     dot1q vlan 1020

    !

    interface GigabitEthernet0/4/0/1

     shutdown

    !

    interface GigabitEthernet0/4/0/2

     shutdown

    !

    interface GigabitEthernet0/4/0/3

     shutdown

    !

    interface POS0/7/0/0

     shutdown

    !

    interface POS0/7/0/1

     shutdown

    !

    interface POS0/7/0/2

     shutdown

    !

    interface POS0/7/0/3

     shutdown

    !

    route-policy RIP

      if destination in (0.0.0.0/0) then

        set rip-metric 1

      else

        pass

      endif

    end-policy

    !

    router bgp 65001

     address-family ipv4 unicast

      network 20.6.20.0/24

      network 20.20.20.20/32

      allocate-label all

     !

     address-family vpnv4 unicast

     !

     address-family ipv4 mdt

     !

     neighbor 6.6.6.6

      remote-as 65001

      update-source Loopback0

      address-family ipv4 labeled-unicast

      !

      address-family vpnv4 unicast

      !

      address-family ipv4 mdt

      !

     !

     vrf VPN_A

      rd 65001:1

      address-family ipv4 unicast

       redistribute connected

       redistribute rip

      !

     !

     vrf VPN_B

      rd 65001:2

      address-family ipv4 unicast

       redistribute connected

       redistribute rip

      !

     !

    !

    mpls ldp

     router-id 20.20.20.20

     interface GigabitEthernet0/4/0/0.620

     !

    !

    multicast-routing

     address-family ipv4

      mdt source Loopback0

      interface all enable

     !

     vrf VPN_A

      address-family ipv4

       mdt source Loopback0

       mdt data 232.0.1.0/24

       mdt default ipv4 232.0.0.1

       interface all enable

      !

     !

    !

    router eigrp 100

     address-family ipv4

      interface Loopback0

       passive-interface

      !

      interface GigabitEthernet0/4/0/0.620

      !

     !

    !

    router rip

     vrf VPN_A

      interface Loopback100

      !

      interface GigabitEthernet0/4/0/0.1020

      !

      redistribute bgp 65001

      default-metric 1

     !

     vrf VPN_B

      interface GigabitEthernet0/4/0/0.920

      !

      redistribute bgp 65001

      default-metric 1

     !

    !

    end

  • R2#sh run 

    Building configuration...

     

    Current configuration : 3228 bytes

    !

    ! Last configuration change at 15:07:18 UTC Sun Sep 29 2013

    !

    version 12.2

    no service pad

    no service timestamps debug uptime

    no service timestamps log uptime

    !

    hostname R2

    !

    boot-start-marker

    warm-reboot

    boot-end-marker

    !

    vrf definition VPN_A

     rd 65000:1

     route-target export 65000:1

     route-target import 65001:1

     !

     address-family ipv4

     route-target export 65000:1

     route-target import 65001:1

     bgp next-hop Loopback0

     mdt default 232.0.0.1

     mdt data 232.0.1.0 0.0.0.255

     

     exit-address-family

    !

    vrf definition VPN_B

     rd 65000:2

     route-target export 65000:2

     route-target import 65001:2

     !

     address-family ipv4

     exit-address-family

    !

    security passwords min-length 1

    enable password cisco

    !

    no aaa new-model

    ip source-route

    !

    !

    !

    !         

    no ip domain lookup

    ip multicast-routing 

    ip multicast-routing vrf VPN_A 

    ip cef

    no ipv6 cef

    !

    !

    multilink bundle-name authenticated

    !

    !

    !

    !

    !

    !

    !

    !

    !

    interface Loopback0

     ip address 2.2.2.2 255.255.255.255

     ip pim sparse-mode

     ip igmp join-group 232.0.0.200 source 20.20.20.20

     ip igmp join-group 232.0.0.2 source 20.20.20.20

     ip ospf 1 area 0

    !

    interface FastEthernet0/0

     no ip address

     duplex full

    !

    interface FastEthernet0/0.25

     encapsulation dot1Q 25

     ip address 20.2.5.2 255.255.255.0

     ip pim sparse-mode

    !

    interface FastEthernet0/0.29

     vrf forwarding VPN_A

     encapsulation dot1Q 29

     ip address 30.2.9.2 255.255.255.0

     ip pim sparse-mode

    !

    interface FastEthernet0/0.210

     vrf forwarding VPN_B

     encapsulation dot1Q 210

     ip address 40.2.10.2 255.255.255.0

    !

    interface FastEthernet1/0

     no ip address

     shutdown

     duplex half

    !

    interface Serial2/0

     no ip address

     shutdown

     serial restart-delay 0

    !

    interface Serial2/1

     no ip address

     shutdown

     serial restart-delay 0

    !

    interface Serial2/2

     no ip address

     shutdown

     serial restart-delay 0

    !

    interface Serial2/3

     no ip address

     shutdown

     serial restart-delay 0

    !

    router ospf 1

     router-id 2.2.2.2

     log-adjacency-changes

     passive-interface Loopback0

     network 20.2.5.2 0.0.0.0 area 0

     mpls ldp autoconfig

    !

    router rip

     !

     address-family ipv4 vrf VPN_B

      redistribute bgp 65000 metric 1

      network 40.0.0.0

      no auto-summary

      version 2

     exit-address-family

     !

     address-family ipv4 vrf VPN_A

      redistribute bgp 65000 metric 1

      network 30.0.0.0

      no auto-summary

      version 2

     exit-address-family

    !

    router bgp 65000

     no bgp default ipv4-unicast

     bgp log-neighbor-changes

     neighbor 5.5.5.5 remote-as 65000

     neighbor 5.5.5.5 update-source Loopback0

     !

     address-family ipv4

      no synchronization

      no auto-summary

     exit-address-family

     !

     address-family vpnv4

      neighbor 5.5.5.5 activate

      neighbor 5.5.5.5 send-community extended

     exit-address-family

     !

     address-family ipv4 mdt

      neighbor 5.5.5.5 activate

      neighbor 5.5.5.5 send-community extended

     exit-address-family

     !

     address-family ipv4 vrf VPN_A

      no synchronization

      redistribute connected

      redistribute rip

     exit-address-family

     !

     address-family ipv4 vrf VPN_B

      no synchronization

      redistribute rip

     exit-address-family

    !

    !

    !

    no ip http server

    no ip http secure-server

    !

    !

    mpls ldp router-id Loopback0 force

    !

    !

    control-plane

    !

    !

    line con 0

     exec-timeout 0 0

     logging synchronous level 0 limit 20

     transport preferred none

     stopbits 1

    line aux 0

     stopbits 1

    line vty 0 4

     no login

    !

    end

  • never mind it was missing 'ip pim ssm default' on R2 , saw it on mroute on R2, since it had not the flag "s" for SSM.

Sign In or Register to comment.