ospf_Network Type on Ethernet link

Dear Friends,

while i m doing the Vol 2 Lab1 I did get this log message, Its the same wht mentioned in the INE solutions WB also.

KInldy advice how to solve these kind of issues ???

 


Rack3R5(config-if)#router os 1

Rack3R5(config-router)#nei

Rack3R5(config-router)#neighbor 183.3.45.4

Rack3R5(config-router)#

Sep 27 18:37:47.915: %OSPF-4-CFG_NBR_INVAL_NET_TYPE: Can not use configured neighbor: neighbor command is allowed only on NBMA and point-to-multipoint networks

Rack3R5(config-router)#interf fa0/1

Rack3R5(config-if)#ip os

Rack3R5(config-if)#ip ospf nei



Thanks

Riyas Rasheed

Comments

  • Hi,

    First of all check the OSPF network type using " show ip ospf interface" command. If it shows the interface as a "Non-Broadcast" or "point-to-multipoint" , you can assign the static neighbor command  for the neighbors connected to it.

    R1#sh ip ospf interface

    Serial1/0 is up, line protocol is up

      Internet Address 10.1.1.1/24, Area 0

      Process ID 1, Router ID 10.1.1.1, Network Type POINT_TO_POINT, Cost: 64

      Transmit Delay is 1 sec, State POINT_TO_POINT,

      Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5


    If you have such an interface type for OSPF, you would be given the same log as you got.


    *Mar  1 00:02:46.587: %OSPF-4-CFG_NBR_INVAL_NET_TYPE: Can not use configured neighbor: neighbor command is allowed only on NBMA and point-to-multipoint networks


    So, neighbor command is appropriate in the NBMA and Point-to-multipoint interface type only. Otherwise, it is not required by other link types.


    Good luck!
  • HI Hari,

    The interface type is Broadcast, Since its an ethernet link.
    and its provided in the INE solutions to use in such a way,



    !interface FastEthernet0/1 

    !ip ospf network non-broadcast

    router ospf 1



     neighbor 183.1.45.4




    But its not working as shown.






    THanks



    Riyas Rasheed






    On Sat, Sep 28, 2013 at 4:09 PM, Hari.sapkota <[email protected]> wrote:

    Hi,

    First of all check the OSPF network type using " show ip ospf interface" command. If it shows the interface as a "Non-Broadcast" or "point-to-multipoint" , you can assign the static neighbor command  for the neighbors connected to it.

    R1#sh ip ospf interface

    Serial1/0 is up, line protocol is up

      Internet Address 10.1.1.1/24, Area 0

      Process ID 1, Router ID 10.1.1.1, Network Type POINT_TO_POINT, Cost: 64

      Transmit Delay is 1 sec, State POINT_TO_POINT,

      Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5


    If you have such an interface type for OSPF, you would be given the same log as you got.


    *Mar  1 00:02:46.587: %OSPF-4-CFG_NBR_INVAL_NET_TYPE: Can not use configured neighbor: neighbor command is allowed only on NBMA and point-to-multipoint networks


    So, neighbor command is appropriate in the NBMA and Point-to-multipoint interface type only. Otherwise, it is not required by other link types.


    Good luck!



    INE - The Industry Leader in CCIE Preparation

    http://www.ine.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx


  • HI Hari,

    The interface type is Broadcast, Since its an ethernet link.

    and its provided in the INE solutions to use in such a way,



    !interface FastEthernet0/1 

    !ip ospf network non-broadcast

    router ospf 1


     neighbor 183.1.45.4

     


    But its not working as shown.




    THanks


    Riyas Rasheed

    Hi Riyas,

    I think you are missing something here, please refer to the following configuration & verification.

    R1(config-router)#do sh run inter e0/0

    Building configuration...

     

    Current configuration : 109 bytes

    !

    interface Ethernet0/0

     ip address 10.1.12.1 255.255.255.0

     ip ospf network non-broadcast

     half-duplex

    end

     

    R1(config-router)#do sh run | sec router ospf

    router ospf 1

     log-adjacency-changes

     network 10.1.12.1 0.0.0.0 area 0

     neighbor 10.1.12.2

    R1(config-router)#



    R1(config-router)#do sh ip ospf inter

    Ethernet0/0 is up, line protocol is up

      Internet Address 10.1.12.1/24, Area 0

      Process ID 1, Router ID 10.1.12.1, Network Type NON_BROADCAST, Cost: 10





    R1(config-router)#do sh ip ospf nei


    Neighbor ID     Pri   State           Dead Time   Address         Interface

    10.1.12.2         1   FULL/DR         00:01:33    10.1.12.2       Ethernet0/0




    Good luck!

  • The interface type is Broadcast, Since its an ethernet link.

    and its provided in the INE solutions to use in such a way,



    !interface FastEthernet0/1 

    !ip ospf network non-broadcast

    router ospf 1


     neighbor 183.1.45.4

     


    But its not working as shown.




    THanks


    Riyas Rasheed

    Sorry but what do you mean by it is not working as shown?

     

  • HI Hari,

    Thanks for your note,
    Yes, i tried to add neighbor statement in ospf before mentioning abt the network type.

    It will work.




    Thanks



    On Sun, Sep 29, 2013 at 12:34 AM, Hari.sapkota <[email protected]> wrote:

    image riyoks:


    HI Hari,

    The interface type is Broadcast, Since its an ethernet link.

    and its provided in the INE solutions to use in such a way,



    !interface FastEthernet0/1 

    !ip ospf network non-broadcast

    router ospf 1


     neighbor 183.1.45.4

     


    But its not working as shown.




    THanks


    Riyas Rasheed




    Hi Riyas,

    I think you are missing something here, please refer to the following configuration & verification.

    R1(config-router)#do sh run inter e0/0

    Building configuration...

     

    Current configuration : 109 bytes

    !

    interface Ethernet0/0

     ip address 10.1.12.1 255.255.255.0

     ip ospf network non-broadcast

     half-duplex

    end

     

    R1(config-router)#do sh run | sec router ospf

    router ospf 1

     log-adjacency-changes

     network 10.1.12.1 0.0.0.0 area 0

     neighbor 10.1.12.2

    R1(config-router)#



    R1(config-router)#do sh ip ospf inter

    Ethernet0/0 is up, line protocol is up

      Internet Address 10.1.12.1/24, Area 0

      Process ID 1, Router ID 10.1.12.1, Network Type NON_BROADCAST, Cost: 10





    R1(config-router)#do sh ip ospf nei


    Neighbor ID     Pri   State           Dead Time   Address         Interface

    10.1.12.2         1   FULL/DR         00:01:33    10.1.12.2       Ethernet0/0




    Good luck!



    INE - The Industry Leader in CCIE Preparation

    http://www.ine.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx

Sign In or Register to comment.