OUTBOUND DIAL-PEERS NOT WORKING

On my lab, from a CorpHQ phone, when I test dial-peers for outbound dialing, only 911 & 9911 work. When I go directly to the Gateway and type the CSIM START command, the 911 pattern works and the 912065015111 NATIONAL pattern works, however the 92065015111 LOCAL pattern geta an UNASSIGNED/UNALLOCATED NUMBER error even though Dial-peer 11 is being matched. Please see the configs and debug. 

Thanks,

Ron

___________________________________________________________________________________________________________________

dial-peer voice 10 pots

 destination-pattern 911

 no digit-strip

 port 0/0/0:23

!

dial-peer voice 11 pots

 destination-pattern 9[2-9]..[2-9]......$

 port 0/0/0:23

!         

dial-peer voice 12 pots

 destination-pattern 91[2-9]..[2-9]......$

 port 0/0/0:23

 forward-digits 11

_________________________________________________________________________________________________

CorpHQ#

//-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:

   Calling Number=, Called Number=92065015111, Peer Info Type=DIALPEER_INFO_SPEECH

//-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:

   Match Rule=DP_MATCH_DEST; Called Number=92065015111

//-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:

   Result=Success(0) after DP_MATCH_DEST

//-1/xxxxxxxxxxxx/DPM/dpMatchPeers:

   Result=SUCCESS(0) 

   List of Matched Outgoing Dial-peer(s): 

     1: Dial-peer Tag=11

ISDN Se0/0/0:23 Q931: pak_private_number: Invalid type/plan 0x0 0x0 may be overriden; sw-type 13

ISDN Se0/0/0:23 Q931: Sending SETUP  callref = 0x00A6 callID = 0x8027 switch = primary-ni interface = User 

CorpHQ#

ISDN Se0/0/0:23 Q931: TX -> SETUP pd = 8  callref = 0x00A6 

        Bearer Capability i = 0x8090A2 

                Standard = CCITT 

                Transfer Capability = Speech  

                Transfer Mode = Circuit 

                Transfer Rate = 64 kbit/s 

        Channel ID i = 0xA98383 

                Exclusive, Channel 3 

        Called Party Number i = 0xA1, '2065015111' 

                Plan:ISDN, Type:National

ISDN Se0/0/0:23 Q931: RX <- CALL_PROC pd = 8  callref = 0x80A6 

        Channel ID i = 0xA98383 

                Exclusive, Channel 3

ISDN Se0/0/0:23 Q931: RX <- DISCONNECT pd = 8  callref = 0x80A6 

        Cause i = 0x8281 - Unallocated/unassigned number

ISDN Se0/0/0:23 Q931: TX -> RELEASE pd = 8  callref = 0x00A6

ISDN Se0/0/0:23 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x80A6

Comments

  • You are receiving that error message from the PSTN.  Do you have a PSTN phone registered to that CME?

  • YES. Are you saying the PSTN phone may not be configured properly? 

    thanks,

    Ron

  • I meant to say PSTN router....

  • Please post your CorpHQ and PSTN CME config. Thanks.

  • Potentially yes, but I agree with rejohn would need to see the config to help you out more.

  • CORPHQ CONFIG

     

    CorpHQ#sh run

    Building configuration...

     

     

    Current configuration : 5785 bytes

    !

    ! Last configuration change at 12:37:24 PDT Wed Sep 25 2013

    ! NVRAM config last updated at 09:29:58 PDT Wed Sep 25 2013

    !

    version 12.4

    no service pad

    no service timestamps debug uptime

    no service timestamps log uptime

    no service password-encryption

    !

    hostname CorpHQ

    !

    boot-start-marker

    boot-end-marker

    !

    logging message-counter syslog

    !

    no aaa new-model

    clock timezone PST -8

    clock summer-time PDT recurring

    network-clock-participate wic 0 

    network-clock-select 1 T1 0/0/0

    !

    dot11 syslog

    ip source-route

    !

    !

    ip cef

    ip dhcp excluded-address 177.1.11.1 177.1.11.14

    ip dhcp excluded-address 177.1.11.21 177.1.11.254

    ip dhcp excluded-address 177.2.11.1 177.2.11.14

    ip dhcp excluded-address 177.2.11.21 177.2.11.254

    !

    ip dhcp pool CorpHQ-Phones

       network 177.1.11.0 255.255.255.0

       option 150 ip 177.1.10.10 177.1.10.20 

       default-router 177.1.11.1 

       dns-server 177.1.100.110 

    !

    ip dhcp pool Branch1-Phones

       network 177.2.11.0 255.255.255.0

       option 150 ip 177.1.10.10 177.1.10.20 

       default-router 177.2.11.1 

       dns-server 177.1.100.110 

    !         

    !

    no ip domain lookup

    ip multicast-routing 

    no ipv6 cef

    !

    multilink bundle-name authenticated

    !

    !

    !

    !

    isdn switch-type primary-ni

    !

    !

    !

    voice service voip 

     allow-connections h323 to h323

     fax protocol cisco 

     sip

      bind control source-interface Loopback0

      bind media source-interface Loopback0

    !

    !

    !         

    voice class codec 1

     codec preference 1 g711ulaw

     codec preference 2 g711alaw

     codec preference 3 g729r8

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    voice translation-rule 10

     rule 1 /^[2-9].........$/ /9&/

     rule 2 /^1[2-9].........$/ /9&/

     rule 3 /^011/ /9&/

    !         

    !

    voice translation-profile Prefix9_InFrom_CUCM

     translate called 10

    !

    !

    voice-card 0

     dsp services dspfarm

    !

    !

    !

    !

    !

    archive

     log config

      hidekeys

    !

    !

    !

    !

    controller T1 0/0/0

     pri-group timeslots 1-3,24

     description == Voice Circuit to PSTN

    !

    !

    !

    !

    !

    interface Loopback0

     ip address 177.1.254.1 255.255.255.255

     ip pim dense-mode

    !

    interface FastEthernet0/0

     description == To CorpHQ-Switch

     no ip address

     duplex auto

     speed auto

    !

    interface FastEthernet0/0.10

     description == Server VLAN

     encapsulation dot1Q 10

     ip address 177.1.10.1 255.255.255.0

     ip pim dense-mode

    !

    interface FastEthernet0/0.11

     description == Voice VLAN

     encapsulation dot1Q 11

     ip address 177.1.11.1 255.255.255.0

     ip helper-address 177.1.10.10

     ip nbar protocol-discovery

     ip pim dense-mode

    !

    interface FastEthernet0/0.12

     description == Data VLAN

     encapsulation dot1Q 12

     ip address 177.1.12.1 255.255.255.0

    !

    interface FastEthernet0/0.13

     description == PSTN PHONE VLAN

     encapsulation dot1Q 13

     ip address 177.1.13.1 255.255.255.0

    !

    interface FastEthernet0/1

     description === To PSTN

     ip address 177.1.19.254 255.255.255.0

     duplex auto

     speed auto

    !

    interface Serial0/0/0:23

     no ip address

     encapsulation hdlc

     isdn switch-type primary-ni

     isdn incoming-voice voice

     no cdp enable

    !

    interface Serial0/1/0

     description == Frame-Relay Circuit to WAN

     no ip address

     encapsulation frame-relay

     fair-queue 64 256 36

     cdp enable

     frame-relay lmi-type ansi

     ip rsvp bandwidth

    !

    interface Serial0/1/0.1 point-to-point

     description == FR To BR1

     bandwidth 384

     ip address 177.0.101.1 255.255.255.0

     ip pim dense-mode

     snmp trap link-status

     frame-relay interface-dlci 101   

     ip rsvp bandwidth 136

    !

    interface Serial0/1/0.2 point-to-point

     description == FR To BR2

     ip address 177.0.201.1 255.255.255.0

     snmp trap link-status

     frame-relay interface-dlci 102   

     ip rsvp bandwidth 136

    !

    router ospf 1

     log-adjacency-changes

     network 0.0.0.0 255.255.255.255 area 0

    !

    ip forward-protocol nd

    ip route 0.0.0.0 0.0.0.0 177.1.19.1

    ip route 0.0.0.0 0.0.0.0 FastEthernet0/0.10

    no ip http server

    no ip http secure-server

    !

    !

    !

    !

    !

    !         

    !

    !

    !

    control-plane

    !

    !

    !

    voice-port 0/0/0:23

    !

    voice-port 0/3/0

    !

    voice-port 0/3/1

    !

    ccm-manager music-on-hold

    !

    !

    sccp local Loopback0

    sccp ccm 177.1.10.10 identifier 1 priority 1 version 5.0.1 

    sccp ccm 177.1.10.20 identifier 2 priority 2 version 5.0.1 

    sccp ccm 177.1.254.3 identifier 3 priority 3 version 5.0.1 

    sccp

    !

    sccp ccm group 1

     bind interface Loopback0

     associate ccm 2 priority 1

     associate ccm 1 priority 2

     associate ccm 3 priority 3

     associate profile 1 register CorpHQ-729-MTP

     associate profile 2 register CorpHQ-711-MTP

     associate profile 3 register CorpHQ-HW-Xcode

    !

    dspfarm profile 3 transcode  

     codec g711ulaw

     codec g711alaw

     codec g729ar8

     codec g729abr8

     codec g729r8

     codec g729br8

     codec ilbc

     maximum sessions 2

     associate application SCCP

    !

    dspfarm profile 1 mtp  

     codec g729ar8

     codec g729r8

     rsvp     

     maximum sessions software 10

     associate application SCCP

    !

    dspfarm profile 2 mtp  

     codec g711ulaw

     rsvp

     maximum sessions software 10

     associate application SCCP

    !

    !

    dial-peer voice 1 pots

     incoming called-number .

     direct-inward-dial

    !

    dial-peer voice 10 pots

     destination-pattern 911

     no digit-strip

     port 0/0/0:23

    !

    dial-peer voice 11 pots

     translation-profile outgoing local

     destination-pattern 9[2-9]..[2-9]......$

     port 0/0/0:23

     forward-digits 10

    !

    dial-peer voice 12 pots

     destination-pattern 91[2-9]..[2-9]......$

     port 0/0/0:23

     forward-digits 11

    !

    dial-peer voice 100 voip

     description == Inbound/Outbound SIP PSTN GW From/To CUCM Pub

     translation-profile incoming Prefix9_InFrom_CUCM

     destination-pattern ^2065011...$

     voice-class codec 1

     session protocol sipv2

     session target ipv4:177.1.10.10

     incoming called-number .

     ip qos dscp cs3 signaling

    !

    !

    dial-peer hunt 1

    sip-ua 

    !

    !

    !         

    line con 0

     exec-timeout 0 0

     privilege level 15

     logging synchronous level 0 limit 20

    line aux 0

    line vty 0 4

     exec-timeout 0 0

     privilege level 15

     logging synchronous

     no login

    line vty 5 15

     exec-timeout 0 0

     privilege level 15

     logging synchronous

     no login

    !

    scheduler allocate 20000 1000

    ntp source Loopback0

    ntp master 2

    ntp server 177.1.254.254

    end

    __________________________________________________________________________________

    PSTN CONFIG

    PSTN#sh run

    Building configuration...

     

     

    Current configuration : 13974 bytes

    !

    ! No configuration change since last restart

    !

    version 12.4

    no service pad

    no service timestamps debug uptime

    no service timestamps log uptime

    no service password-encryption

    !

    hostname PSTN

    !

    boot-start-marker

    boot-end-marker

    !

    card type e1 0 0

    card type t1 0 1

    logging message-counter syslog

    !

    no aaa new-model

    clock timezone EST -5

    clock summer-time EST recurring

    network-clock-participate wic 0 

    network-clock-participate wic 1 

    no network-clock-participate aim 0 

    !

    dot11 syslog

    ip source-route

    !

    !

    ip cef

    !

    !

    no ip domain lookup

    ip domain name att.com

    ip name-server 177.1.100.110

    ip multicast-routing 

    no ipv6 cef

    !

    multilink bundle-name authenticated

    !

    !

    !

    !

    isdn switch-type primary-ni

    !         

    !

    !

    voice service voip 

     allow-connections h323 to h323

     allow-connections h323 to sip

     allow-connections sip to h323

     allow-connections sip to sip

     redirect ip2ip

     fax protocol cisco 

     sip

      bind control source-interface Loopback10

      bind media source-interface Loopback10

      header-passing

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !         

    !

    !

    !

    !

    !

    !

    voice translation-rule 101

     rule 1 /^+.*/ //

     rule 2 /^501.*/ //

     rule 3 /^1206.*/ //

     rule 4 /^00.*/ //

     rule 5 /^0011.*/ //

     rule 6 /^206/ /1&/

     rule 7 /^1512.*/ /&/

     rule 8 /^011(31.*)/ /1/

    !

    voice translation-rule 102

     rule 1 /^1(2065015111)$/ /1/ type any subscriber plan any isdn

     rule 2 /^1(2065015555)$/ /1/ type any subscriber plan any isdn

     rule 3 /^1(2065015151)$/ /1/ type any subscriber plan any isdn

     rule 4 /^1(5126026222)$/ /1/ type any national plan any isdn

     rule 5 /^31670357575$/ /&/ type any international plan any isdn

     rule 6 /^31207037333$/ /&/ type any international plan any isdn

     rule 7 /^31107047444$/ /&/ type any international plan any isdn

     rule 8 /^911$/ /&/ type any unknown plan any unknown

     rule 9 /^15126022.../ /&/ type any unknown plan any unknown

     rule 10 /^31207033.../ /&/ type any unknown plan any unknown

     rule 11 /^....$/ /&/ type any unknown plan any unknown

    !

    voice translation-rule 103

     rule 1 /^206.*/ /&/ type any subscriber plan any isdn

     rule 2 /^1/ // type any national plan any isdn

     rule 3 /^00/ // type any international plan any isdn

    !

    voice translation-rule 201

     rule 1 /^+.*/ //

     rule 2 /^602.*/ //

     rule 3 /^1512.*/ //

     rule 4 /^00.*/ //

     rule 5 /^0011.*/ //

     rule 6 /^512/ /1&/

     rule 7 /^1206.*/ /&/

     rule 8 /^011(31.*)/ /1/

    !

    voice translation-rule 202

     rule 1 /^1(5126026222)$/ /1/ type any subscriber plan any isdn

     rule 2 /^1(2065015555)$/ /1/ type any national plan any isdn

     rule 3 /^1(2065015151)$/ /1/ type any national plan any isdn

     rule 4 /^1(2065015111)$/ /1/ type any national plan any isdn

     rule 5 /^31670357575$/ /&/ type any international plan any isdn

     rule 6 /^31207037333$/ /&/ type any international plan any isdn

     rule 7 /^31107047444$/ /&/ type any international plan any isdn

     rule 8 /^911$/ /&/ type any unknown plan any unknown

     rule 9 /^12065011.../ /&/ type any unknown plan any unknown

     rule 10 /^31207033.../ /&/ type any unknown plan any unknown

     rule 11 /^....$/ /&/ type any unknown plan any unknown

    !

    voice translation-rule 203

     rule 1 /^512.*/ /&/ type any subscriber plan any isdn

     rule 2 /^1/ // type any national plan any isdn

     rule 3 /^00/ // type any international plan any isdn

    !

    voice translation-rule 301

     rule 1 /^+.*/ //

     rule 2 /^20.*/ //

     rule 3 /^0([1-8].*)/ /311/

     rule 4 /^011/ //

     rule 5 /^0031/ //

     rule 6 /^703..../ /3120&/

     rule 7 /^00(1.*)/ /1/

    !

    voice translation-rule 302

     rule 1 /^31207037333$/ /7037333/ type any subscriber plan any isdn

     rule 2 /^7033(...)$/ /02070331/

     rule 3 /^911$/ /112/ type any unknown plan any unknown

     rule 4 /^31(670357575)$/ /01/ type any national plan any isdn

     rule 5 /^31(107047444)$/ /01/ type any national plan any isdn

     rule 6 /^12065015555$/ /&/ type any international plan any isdn

     rule 7 /^12065015151$/ /&/ type any international plan any isdn

     rule 8 /^12065015111$/ /&/ type any international plan any isdn

     rule 9 /^15126026222$/ /&/ type any international plan any isdn

     rule 10 /^12065011...$/ /&/ type any unknown plan any unknown

     rule 11 /^15126022...$/ /&/ type any unknown plan any unknown

     rule 12 /^....$/ /&/ type any unknown plan any unknown

    !

    voice translation-rule 303

     rule 1 /^703.*/ /&/ type any subscriber plan any isdn

     rule 2 /^010/ // type any national plan any isdn

     rule 3 /^1/ // type any international plan any isdn

    !

    voice translation-rule 1000

     rule 1 /.*(1...$)/ /2065011/

     rule 2 /.*(2...$)/ /5126021/

     rule 3 /.*(45..$)/ /0207571/

    !

    voice translation-rule 1001

     rule 1 /^1206...5...$/ /+&/

     rule 2 /^1512...6...$/ /+&/

     rule 3 /^31.0...7...$/ /+&/

    !

    !

    voice translation-profile 1-HQ-Change_DNIS-Check_ANI

     translate called 101

    !

    voice translation-profile 1-HQ-Proper_Types

     translate calling 102

     translate called 103

    !

    voice translation-profile 2-BR1-Change_DNIS-Check_ANI

     translate called 201

    !

    voice translation-profile 2-BR1-Proper_Types

     translate calling 202

     translate called 203

    !         

    voice translation-profile 3-BR2-Change_DNIS-Check_ANI

     translate called 301

    !

    voice translation-profile 3-BR2-Proper_Types

     translate calling 302

     translate called 303

    !

    voice translation-profile SIP-NORMALIZE-DNIS-ANI

     translate calling 1001

     translate called 1000

    !

    !

    voice-card 0

     dspfarm

    !

    !

    !

    !

    !

    archive

     log config

      hidekeys

    !         

    !

    !

    !

    !

    controller E1 0/0/0

     clock source internal

     pri-group timeslots 1-3,16

     description == Voice Circuit to Branch2

    !

    controller T1 0/1/0

     clock source internal

     cablelength long 0db

     pri-group timeslots 1-3,24

     description == Voice Circuit to CorpHQ

    !

    controller T1 0/1/1

     clock source internal

     cablelength long 0db

     pri-group timeslots 1-3,24

     description == Voice Circuit to Branch1

    !

    !

    !         

    !

    !

    interface Loopback0

     ip address 177.1.254.254 255.255.255.255

    !

    interface Loopback10

     ip address 177.1.254.250 255.255.255.255

    !

    interface Loopback11

     ip address 177.1.254.251 255.255.255.255

    !

    interface FastEthernet0/0

     description ==TO INTERNET==

     ip address 192.168.1.150 255.255.255.0

     duplex auto

     speed auto

    !

    interface FastEthernet0/1

     description === To HQ

     ip address 177.1.19.1 255.255.255.0

     duplex auto

     speed auto

    !         

    interface Serial0/0/0:15

     description == PRI Circuit to R3-BR2

     no ip address

     encapsulation hdlc

     isdn switch-type primary-net5

     isdn protocol-emulate network

     isdn incoming-voice voice

     isdn negotiate-bchan resend-setup

     no isdn outgoing ie network-facility 

     isdn outgoing display-ie

     no cdp enable

    !

    interface Serial0/1/0:23

     description == PRI Circuit to R1-HQ

     no ip address

     encapsulation hdlc

     isdn switch-type primary-5ess

     isdn protocol-emulate network

     isdn incoming-voice voice

     isdn negotiate-bchan

     isdn outgoing display-ie

     no cdp enable

    !         

    interface Serial0/1/1:23

     description == PRI Circuit to R2-BR1

     no ip address

     encapsulation hdlc

     isdn switch-type primary-ni

     isdn protocol-emulate network

     isdn incoming-voice voice

     isdn supp-service name calling

     isdn negotiate-bchan resend-setup

     isdn outgoing ie network-facility 

     no cdp enable

    !

    router ospf 1

     log-adjacency-changes

     network 0.0.0.0 255.255.255.255 area 0

    !

    ip forward-protocol nd

    ip route 0.0.0.0 0.0.0.0 192.168.1.1

    ip http server

    ip http authentication local

    no ip http secure-server

    ip http path flash:

    !         

    !

    !

    !

    !

    !

    !

    !

    !

    control-plane

    !

    !

    !

    voice-port 0/0/0:15

     translation-profile incoming 3-BR2-Change_DNIS-Check_ANI

     description == Voice PRI to Branch2

    !

    voice-port 0/1/0:23

     translation-profile incoming 1-HQ-Change_DNIS-Check_ANI

     description == Voice PRI to CorpHQ

    !

    voice-port 0/1/1:23

     translation-profile incoming 2-BR1-Change_DNIS-Check_ANI

     description == Voice PRI to Branch1

    !

    !

    !

    !

    !

    dial-peer voice 1 pots

     description == All inbound calls from HQ BR1 BR2 into PSTN

     incoming called-number .

     direct-inward-dial

    !

    dial-peer voice 101 pots

     description == Subscriber Calls from PSTN into CorpHQ

     translation-profile outgoing 1-HQ-Proper_Types

     preference 1

     destination-pattern ^2065011...$

     direct-inward-dial

     port 0/1/0:23

     forward-digits 10

    !

    dial-peer voice 102 pots

     description == National Calls from PSTN into CorpHQ

     translation-profile outgoing 1-HQ-Proper_Types

     preference 1

     destination-pattern ^12065011...$

     direct-inward-dial

     port 0/1/0:23

     forward-digits 10

    !

    dial-peer voice 103 pots

     description == International Calls into CorpHQ from PSTN Coming from NL Ph

     translation-profile outgoing 1-HQ-Proper_Types

     preference 1

     destination-pattern ^0012065011...$

     direct-inward-dial

     port 0/1/0:23

     forward-digits 10

    !

    dial-peer voice 104 pots

     description == + Calls into CorpHQ from PSTN Coming from Mobiles

     translation-profile outgoing 1-HQ-Proper_Types

     preference 1

     destination-pattern +12065011...$

     direct-inward-dial

     port 0/1/0:23

     forward-digits 10

    !         

    dial-peer voice 201 pots

     description == Subscriber Calls from PSTN into Branch1

     translation-profile outgoing 2-BR1-Proper_Types

     preference 1

     destination-pattern ^5126022...$

     direct-inward-dial

     port 0/1/1:23

     forward-digits 10

    !

    dial-peer voice 202 pots

     description == National Calls from PSTN into Branch1

     translation-profile outgoing 2-BR1-Proper_Types

     preference 1

     destination-pattern ^15126022...$

     direct-inward-dial

     port 0/1/1:23

     forward-digits 10

    !

    dial-peer voice 203 pots

     description == International Calls into Branch1 from PSTN Coming from NL Ph

     translation-profile outgoing 2-BR1-Proper_Types

     preference 1

     destination-pattern ^0015126022...$

     direct-inward-dial

     port 0/1/1:23

     forward-digits 10

    !

    dial-peer voice 204 pots

     description == + Calls into Branch1 from PSTN Coming from Mobiles

     translation-profile outgoing 2-BR1-Proper_Types

     preference 1

     destination-pattern +15126022...$

     direct-inward-dial

     port 0/1/1:23

     forward-digits 10

    !

    dial-peer voice 301 pots

     description == Subscriber Calls from PSTN into Branch2

     translation-profile outgoing 3-BR2-Proper_Types

     destination-pattern ^7033...$

     direct-inward-dial

     port 0/0/0:15

     forward-digits 7

    !

    dial-peer voice 302 pots

     description == National Calls from PSTN into Branch2

     translation-profile outgoing 3-BR2-Proper_Types

     destination-pattern ^0207033...$

     direct-inward-dial

     port 0/0/0:15

     forward-digits 10

    !

    dial-peer voice 303 pots

     description == International Calls into Branch2 from PSTN Coming from US Ph

     translation-profile outgoing 3-BR2-Proper_Types

     destination-pattern ^01131207033...$

     direct-inward-dial

     port 0/0/0:15

     forward-digits 9

     prefix 0

    !

    dial-peer voice 304 pots

     description == International Calls into Branch2 from PSTN Coming from US Ph

     translation-profile outgoing 3-BR2-Proper_Types

     destination-pattern ^31207033...$

     direct-inward-dial

     port 0/0/0:15

     forward-digits 9

     prefix 0 

    !

    dial-peer voice 305 pots

     description == + Calls into Branch2 from PSTN Coming from Mobiles

     translation-profile outgoing 3-BR2-Proper_Types

     destination-pattern +31207033...$

     direct-inward-dial

     port 0/0/0:15

     forward-digits 9

     prefix 0

    !

    dial-peer voice 1000 voip

     description == Calls into AT&T SIP ITSP for VC Week1 Lab1

     rtp payload-type nse 99

     rtp payload-type nte 100

     voice-class sip localhost dns:sip1.att.com 

     session protocol sipv2

     incoming called-number .

     dtmf-relay rtp-nte

     codec g711ulaw

    !

    dial-peer voice 5000 voip

     service aa

     destination-pattern A5000

     session target ipv4:177.1.254.254

     incoming called-number A5000

     dtmf-relay h245-alphanumeric

     codec g711ulaw

     no vad

    !

    !

    num-exp 1888....... 911

    num-exp 1900....... 911

    num-exp 1976....... 911

    num-exp 1777....... 911

    num-exp 1444....... 911

    num-exp 0800....... 911

    num-exp 0900....... 911

    sip-ua 

    !

    !

    !

    telephony-service

     no auto-reg-ephone

     max-ephones 1

     max-dn 10

     ip source-address 177.1.254.254 port 2000

     caller-id block code *67

     system message You WILL PASS this Exam!

     voicemail A5000

     max-conferences 8 gain -6

     call-forward pattern .T

     dn-webedit 

     transfer-system full-consult

     transfer-pattern .T

     create cnf-files version-stamp 7960 Sep 01 2012 15:29:37

    !

    !

    ephone-dn  1  dual-line

     number 12065015111 secondary +12065015111

     label Seattle, US +1 206 501 5111

     description INE PSTN Phone

     name Seattle US Phone

    !

    !

    ephone-dn  2  dual-line

     number 15126026222 secondary +15126026222

     label Austin, US +1 512 602 6222

     name Austin TX Phone

    !         

    !

    ephone-dn  3  dual-line

     number 31207037333 secondary +31207037333

     label Amsterdam, NL +31 20 703 73 33

     name Amsterdam NL Phone

    !

    !

    ephone-dn  4  dual-line

     number 12065015555 secondary +12065015555

     label Hurley Mobile +1 206 501 5555

     name Hurley's Mobile

     call-forward busy A5000

     call-forward noan A5000 timeout 16

    !

    !

    ephone-dn  5  dual-line

     number 12065015151 secondary +12065015151

     label Hurley's Home +1 206 501 5151

     name Hurley's Home

     call-forward busy A5000

     call-forward noan A5000 timeout 12

    !

    !         

    ephone-dn  6  dual-line

     number 31670357575 secondary +31670357575

     label Sawyer's Mobile +31 6 70357575

     name Sawyer's Mobile

     call-forward busy A5000

     call-forward noan A5000 timeout 16

    !

    !

    ephone-dn  7  dual-line

     number 911 secondary 112

     label US/EU Emer/FreePhone/Prem

     name Emergency Services

    !

    !

    ephone-dn  8  dual-line

     number 15126026262 secondary +15126026262

     label BLinus Mobile +1 512 602 6262

     name Benjamin Linus Mobile

     call-forward busy A5000

     call-forward noan A5000 timeout 16

    !

    !

    ephone-dn  9  dual-line

     number 31207037373 secondary +31207037373

     label DHume Home +31 20 703 73 73

     name Desmond Hume Home

     call-forward busy A5000

     call-forward noan A5000 timeout 16

    !

    !

    ephone-dn  10  dual-line

     number 31107047444 secondary +31107047444

     label Rotterdam, NL +31 10 704 74 44

     name Rotterdam NL Phone

    !

    !

    ephone  1

     device-security-mode none

     mac-address A456.3040.0DAA

     type 7975

     button  1:1 2:2 3:3 4:10

     button  5:6 6o7,8,5,4

    !

    !

    !

    line con 0

     exec-timeout 0 0

     privilege level 15

     logging synchronous level 0 limit 20

    line aux 0

    line vty 0 4

     exec-timeout 0 0

     privilege level 15

     logging synchronous

     no login

    line vty 5 15

     exec-timeout 0 0

     privilege level 15

     logging synchronous

     no login

    !

    scheduler allocate 20000 1000

    ntp source Loopback0

    ntp master 10

    ntp server 64.90.182.55

    end

     

    PSTN#

  •  

    CORPHQ CONFIG

    CorpHQ#sh run

    Building configuration...

     

     

    Current configuration : 5785 bytes

    !

    ! Last configuration change at 12:37:24 PDT Wed Sep 25 2013

    ! NVRAM config last updated at 09:29:58 PDT Wed Sep 25 2013

    !

    version 12.4

    no service pad

    no service timestamps debug uptime

    no service timestamps log uptime

    no service password-encryption

    !

    hostname CorpHQ

    !

    boot-start-marker

    boot-end-marker

    !

    logging message-counter syslog

    !

    no aaa new-model

    clock timezone PST -8

    clock summer-time PDT recurring

    network-clock-participate wic 0 

    network-clock-select 1 T1 0/0/0

    !

    dot11 syslog

    ip source-route

    !

    !

    ip cef

    ip dhcp excluded-address 177.1.11.1 177.1.11.14

    ip dhcp excluded-address 177.1.11.21 177.1.11.254

    ip dhcp excluded-address 177.2.11.1 177.2.11.14

    ip dhcp excluded-address 177.2.11.21 177.2.11.254

    !

    ip dhcp pool CorpHQ-Phones

       network 177.1.11.0 255.255.255.0

       option 150 ip 177.1.10.10 177.1.10.20 

       default-router 177.1.11.1 

       dns-server 177.1.100.110 

    !

    ip dhcp pool Branch1-Phones

       network 177.2.11.0 255.255.255.0

       option 150 ip 177.1.10.10 177.1.10.20 

       default-router 177.2.11.1 

       dns-server 177.1.100.110 

    !         

    !

    no ip domain lookup

    ip multicast-routing 

    no ipv6 cef

    !

    multilink bundle-name authenticated

    !

    !

    !

    !

    isdn switch-type primary-ni

    !

    !

    !

    voice service voip 

     allow-connections h323 to h323

     fax protocol cisco 

     sip

      bind control source-interface Loopback0

      bind media source-interface Loopback0

    !

    !

    !         

    voice class codec 1

     codec preference 1 g711ulaw

     codec preference 2 g711alaw

     codec preference 3 g729r8

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    voice translation-rule 10

     rule 1 /^[2-9].........$/ /9&/

     rule 2 /^1[2-9].........$/ /9&/

     rule 3 /^011/ /9&/

    !         

    !

    voice translation-profile Prefix9_InFrom_CUCM

     translate called 10

    !

    !

    voice-card 0

     dsp services dspfarm

    !

    !

    !

    !

    !

    archive

     log config

      hidekeys

    !

    !

    !

    !

    controller T1 0/0/0

     pri-group timeslots 1-3,24

     description == Voice Circuit to PSTN

    !

    !

    !

    !

    !

    interface Loopback0

     ip address 177.1.254.1 255.255.255.255

     ip pim dense-mode

    !

    interface FastEthernet0/0

     description == To CorpHQ-Switch

     no ip address

     duplex auto

     speed auto

    !

    interface FastEthernet0/0.10

     description == Server VLAN

     encapsulation dot1Q 10

     ip address 177.1.10.1 255.255.255.0

     ip pim dense-mode

    !

    interface FastEthernet0/0.11

     description == Voice VLAN

     encapsulation dot1Q 11

     ip address 177.1.11.1 255.255.255.0

     ip helper-address 177.1.10.10

     ip nbar protocol-discovery

     ip pim dense-mode

    !

    interface FastEthernet0/0.12

     description == Data VLAN

     encapsulation dot1Q 12

     ip address 177.1.12.1 255.255.255.0

    !

    interface FastEthernet0/0.13

     description == PSTN PHONE VLAN

     encapsulation dot1Q 13

     ip address 177.1.13.1 255.255.255.0

    !

    interface FastEthernet0/1

     description === To PSTN

     ip address 177.1.19.254 255.255.255.0

     duplex auto

     speed auto

    !

    interface Serial0/0/0:23

     no ip address

     encapsulation hdlc

     isdn switch-type primary-ni

     isdn incoming-voice voice

     no cdp enable

    !

    interface Serial0/1/0

     description == Frame-Relay Circuit to WAN

     no ip address

     encapsulation frame-relay

     fair-queue 64 256 36

     cdp enable

     frame-relay lmi-type ansi

     ip rsvp bandwidth

    !

    interface Serial0/1/0.1 point-to-point

     description == FR To BR1

     bandwidth 384

     ip address 177.0.101.1 255.255.255.0

     ip pim dense-mode

     snmp trap link-status

     frame-relay interface-dlci 101   

     ip rsvp bandwidth 136

    !

    interface Serial0/1/0.2 point-to-point

     description == FR To BR2

     ip address 177.0.201.1 255.255.255.0

     snmp trap link-status

     frame-relay interface-dlci 102   

     ip rsvp bandwidth 136

    !

    router ospf 1

     log-adjacency-changes

     network 0.0.0.0 255.255.255.255 area 0

    !

    ip forward-protocol nd

    ip route 0.0.0.0 0.0.0.0 177.1.19.1

    ip route 0.0.0.0 0.0.0.0 FastEthernet0/0.10

    no ip http server

    no ip http secure-server

    !

    !

    !

    !

    !

    !         

    !

    !

    !

    control-plane

    !

    !

    !

    voice-port 0/0/0:23

    !

    voice-port 0/3/0

    !

    voice-port 0/3/1

    !

    ccm-manager music-on-hold

    !

    !

    sccp local Loopback0

    sccp ccm 177.1.10.10 identifier 1 priority 1 version 5.0.1 

    sccp ccm 177.1.10.20 identifier 2 priority 2 version 5.0.1 

    sccp ccm 177.1.254.3 identifier 3 priority 3 version 5.0.1 

    sccp

    !

    sccp ccm group 1

     bind interface Loopback0

     associate ccm 2 priority 1

     associate ccm 1 priority 2

     associate ccm 3 priority 3

     associate profile 1 register CorpHQ-729-MTP

     associate profile 2 register CorpHQ-711-MTP

     associate profile 3 register CorpHQ-HW-Xcode

    !

    dspfarm profile 3 transcode  

     codec g711ulaw

     codec g711alaw

     codec g729ar8

     codec g729abr8

     codec g729r8

     codec g729br8

     codec ilbc

     maximum sessions 2

     associate application SCCP

    !

    dspfarm profile 1 mtp  

     codec g729ar8

     codec g729r8

     rsvp     

     maximum sessions software 10

     associate application SCCP

    !

    dspfarm profile 2 mtp  

     codec g711ulaw

     rsvp

     maximum sessions software 10

     associate application SCCP

    !

    !

    dial-peer voice 1 pots

     incoming called-number .

     direct-inward-dial

    !

    dial-peer voice 10 pots

     destination-pattern 911

     no digit-strip

     port 0/0/0:23

    !

    dial-peer voice 11 pots

     translation-profile outgoing local

     destination-pattern 9[2-9]..[2-9]......$

     port 0/0/0:23

     forward-digits 10

    !

    dial-peer voice 12 pots

     destination-pattern 91[2-9]..[2-9]......$

     port 0/0/0:23

     forward-digits 11

    !

    dial-peer voice 100 voip

     description == Inbound/Outbound SIP PSTN GW From/To CUCM Pub

     translation-profile incoming Prefix9_InFrom_CUCM

     destination-pattern ^2065011...$

     voice-class codec 1

     session protocol sipv2

     session target ipv4:177.1.10.10

     incoming called-number .

     ip qos dscp cs3 signaling

    !

    !

    dial-peer hunt 1

    sip-ua 

    !

    !

    !         

    line con 0

     exec-timeout 0 0

     privilege level 15

     logging synchronous level 0 limit 20

    line aux 0

    line vty 0 4

     exec-timeout 0 0

     privilege level 15

     logging synchronous

     no login

    line vty 5 15

     exec-timeout 0 0

     privilege level 15

     logging synchronous

     no login

    !

    scheduler allocate 20000 1000

    ntp source Loopback0

    ntp master 2

    ntp server 177.1.254.254

    end

    IIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIII

    IIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIII

     

     

    PSTN CONFIG

    PSTN#sh run

    Building configuration...

     

     

    Current configuration : 13974 bytes

    !

    ! No configuration change since last restart

    !

    version 12.4

    no service pad

    no service timestamps debug uptime

    no service timestamps log uptime

    no service password-encryption

    !

    hostname PSTN

    !

    boot-start-marker

    boot-end-marker

    !

    card type e1 0 0

    card type t1 0 1

    logging message-counter syslog

    !

    no aaa new-model

    clock timezone EST -5

    clock summer-time EST recurring

    network-clock-participate wic 0 

    network-clock-participate wic 1 

    no network-clock-participate aim 0 

    !

    dot11 syslog

    ip source-route

    !

    !

    ip cef

    !

    !

    no ip domain lookup

    ip domain name att.com

    ip name-server 177.1.100.110

    ip multicast-routing 

    no ipv6 cef

    !

    multilink bundle-name authenticated

    !

    !

    !

    !

    isdn switch-type primary-ni

    !         

    !

    !

    voice service voip 

     allow-connections h323 to h323

     allow-connections h323 to sip

     allow-connections sip to h323

     allow-connections sip to sip

     redirect ip2ip

     fax protocol cisco 

     sip

      bind control source-interface Loopback10

      bind media source-interface Loopback10

      header-passing

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !         

    !

    !

    !

    !

    !

    !

    voice translation-rule 101

     rule 1 /^+.*/ //

     rule 2 /^501.*/ //

     rule 3 /^1206.*/ //

     rule 4 /^00.*/ //

     rule 5 /^0011.*/ //

     rule 6 /^206/ /1&/

     rule 7 /^1512.*/ /&/

     rule 8 /^011(31.*)/ /1/

    !

    voice translation-rule 102

     rule 1 /^1(2065015111)$/ /1/ type any subscriber plan any isdn

     rule 2 /^1(2065015555)$/ /1/ type any subscriber plan any isdn

     rule 3 /^1(2065015151)$/ /1/ type any subscriber plan any isdn

     rule 4 /^1(5126026222)$/ /1/ type any national plan any isdn

     rule 5 /^31670357575$/ /&/ type any international plan any isdn

     rule 6 /^31207037333$/ /&/ type any international plan any isdn

     rule 7 /^31107047444$/ /&/ type any international plan any isdn

     rule 8 /^911$/ /&/ type any unknown plan any unknown

     rule 9 /^15126022.../ /&/ type any unknown plan any unknown

     rule 10 /^31207033.../ /&/ type any unknown plan any unknown

     rule 11 /^....$/ /&/ type any unknown plan any unknown

    !

    voice translation-rule 103

     rule 1 /^206.*/ /&/ type any subscriber plan any isdn

     rule 2 /^1/ // type any national plan any isdn

     rule 3 /^00/ // type any international plan any isdn

    !

    voice translation-rule 201

     rule 1 /^+.*/ //

     rule 2 /^602.*/ //

     rule 3 /^1512.*/ //

     rule 4 /^00.*/ //

     rule 5 /^0011.*/ //

     rule 6 /^512/ /1&/

     rule 7 /^1206.*/ /&/

     rule 8 /^011(31.*)/ /1/

    !

    voice translation-rule 202

     rule 1 /^1(5126026222)$/ /1/ type any subscriber plan any isdn

     rule 2 /^1(2065015555)$/ /1/ type any national plan any isdn

     rule 3 /^1(2065015151)$/ /1/ type any national plan any isdn

     rule 4 /^1(2065015111)$/ /1/ type any national plan any isdn

     rule 5 /^31670357575$/ /&/ type any international plan any isdn

     rule 6 /^31207037333$/ /&/ type any international plan any isdn

     rule 7 /^31107047444$/ /&/ type any international plan any isdn

     rule 8 /^911$/ /&/ type any unknown plan any unknown

     rule 9 /^12065011.../ /&/ type any unknown plan any unknown

     rule 10 /^31207033.../ /&/ type any unknown plan any unknown

     rule 11 /^....$/ /&/ type any unknown plan any unknown

    !

    voice translation-rule 203

     rule 1 /^512.*/ /&/ type any subscriber plan any isdn

     rule 2 /^1/ // type any national plan any isdn

     rule 3 /^00/ // type any international plan any isdn

    !

    voice translation-rule 301

     rule 1 /^+.*/ //

     rule 2 /^20.*/ //

     rule 3 /^0([1-8].*)/ /311/

     rule 4 /^011/ //

     rule 5 /^0031/ //

     rule 6 /^703..../ /3120&/

     rule 7 /^00(1.*)/ /1/

    !

    voice translation-rule 302

     rule 1 /^31207037333$/ /7037333/ type any subscriber plan any isdn

     rule 2 /^7033(...)$/ /02070331/

     rule 3 /^911$/ /112/ type any unknown plan any unknown

     rule 4 /^31(670357575)$/ /01/ type any national plan any isdn

     rule 5 /^31(107047444)$/ /01/ type any national plan any isdn

     rule 6 /^12065015555$/ /&/ type any international plan any isdn

     rule 7 /^12065015151$/ /&/ type any international plan any isdn

     rule 8 /^12065015111$/ /&/ type any international plan any isdn

     rule 9 /^15126026222$/ /&/ type any international plan any isdn

     rule 10 /^12065011...$/ /&/ type any unknown plan any unknown

     rule 11 /^15126022...$/ /&/ type any unknown plan any unknown

     rule 12 /^....$/ /&/ type any unknown plan any unknown

    !

    voice translation-rule 303

     rule 1 /^703.*/ /&/ type any subscriber plan any isdn

     rule 2 /^010/ // type any national plan any isdn

     rule 3 /^1/ // type any international plan any isdn

    !

    voice translation-rule 1000

     rule 1 /.*(1...$)/ /2065011/

     rule 2 /.*(2...$)/ /5126021/

     rule 3 /.*(45..$)/ /0207571/

    !

    voice translation-rule 1001

     rule 1 /^1206...5...$/ /+&/

     rule 2 /^1512...6...$/ /+&/

     rule 3 /^31.0...7...$/ /+&/

    !

    !

    voice translation-profile 1-HQ-Change_DNIS-Check_ANI

     translate called 101

    !

    voice translation-profile 1-HQ-Proper_Types

     translate calling 102

     translate called 103

    !

    voice translation-profile 2-BR1-Change_DNIS-Check_ANI

     translate called 201

    !

    voice translation-profile 2-BR1-Proper_Types

     translate calling 202

     translate called 203

    !         

    voice translation-profile 3-BR2-Change_DNIS-Check_ANI

     translate called 301

    !

    voice translation-profile 3-BR2-Proper_Types

     translate calling 302

     translate called 303

    !

    voice translation-profile SIP-NORMALIZE-DNIS-ANI

     translate calling 1001

     translate called 1000

    !

    !

    voice-card 0

     dspfarm

    !

    !

    !

    !

    !

    archive

     log config

      hidekeys

    !         

    !

    !

    !

    !

    controller E1 0/0/0

     clock source internal

     pri-group timeslots 1-3,16

     description == Voice Circuit to Branch2

    !

    controller T1 0/1/0

     clock source internal

     cablelength long 0db

     pri-group timeslots 1-3,24

     description == Voice Circuit to CorpHQ

    !

    controller T1 0/1/1

     clock source internal

     cablelength long 0db

     pri-group timeslots 1-3,24

     description == Voice Circuit to Branch1

    !

    !

    !         

    !

    !

    interface Loopback0

     ip address 177.1.254.254 255.255.255.255

    !

    interface Loopback10

     ip address 177.1.254.250 255.255.255.255

    !

    interface Loopback11

     ip address 177.1.254.251 255.255.255.255

    !

    interface FastEthernet0/0

     description ==TO INTERNET==

     ip address 192.168.1.150 255.255.255.0

     duplex auto

     speed auto

    !

    interface FastEthernet0/1

     description === To HQ

     ip address 177.1.19.1 255.255.255.0

     duplex auto

     speed auto

    !         

    interface Serial0/0/0:15

     description == PRI Circuit to R3-BR2

     no ip address

     encapsulation hdlc

     isdn switch-type primary-net5

     isdn protocol-emulate network

     isdn incoming-voice voice

     isdn negotiate-bchan resend-setup

     no isdn outgoing ie network-facility 

     isdn outgoing display-ie

     no cdp enable

    !

    interface Serial0/1/0:23

     description == PRI Circuit to R1-HQ

     no ip address

     encapsulation hdlc

     isdn switch-type primary-5ess

     isdn protocol-emulate network

     isdn incoming-voice voice

     isdn negotiate-bchan

     isdn outgoing display-ie

     no cdp enable

    !         

    interface Serial0/1/1:23

     description == PRI Circuit to R2-BR1

     no ip address

     encapsulation hdlc

     isdn switch-type primary-ni

     isdn protocol-emulate network

     isdn incoming-voice voice

     isdn supp-service name calling

     isdn negotiate-bchan resend-setup

     isdn outgoing ie network-facility 

     no cdp enable

    !

    router ospf 1

     log-adjacency-changes

     network 0.0.0.0 255.255.255.255 area 0

    !

    ip forward-protocol nd

    ip route 0.0.0.0 0.0.0.0 192.168.1.1

    ip http server

    ip http authentication local

    no ip http secure-server

    ip http path flash:

    !         

    !

    !

    !

    !

    !

    !

    !

    !

    control-plane

    !

    !

    !

    voice-port 0/0/0:15

     translation-profile incoming 3-BR2-Change_DNIS-Check_ANI

     description == Voice PRI to Branch2

    !

    voice-port 0/1/0:23

     translation-profile incoming 1-HQ-Change_DNIS-Check_ANI

     description == Voice PRI to CorpHQ

    !

    voice-port 0/1/1:23

     translation-profile incoming 2-BR1-Change_DNIS-Check_ANI

     description == Voice PRI to Branch1

    !

    !

    !

    !

    !

    dial-peer voice 1 pots

     description == All inbound calls from HQ BR1 BR2 into PSTN

     incoming called-number .

     direct-inward-dial

    !

    dial-peer voice 101 pots

     description == Subscriber Calls from PSTN into CorpHQ

     translation-profile outgoing 1-HQ-Proper_Types

     preference 1

     destination-pattern ^2065011...$

     direct-inward-dial

     port 0/1/0:23

     forward-digits 10

    !

    dial-peer voice 102 pots

     description == National Calls from PSTN into CorpHQ

     translation-profile outgoing 1-HQ-Proper_Types

     preference 1

     destination-pattern ^12065011...$

     direct-inward-dial

     port 0/1/0:23

     forward-digits 10

    !

    dial-peer voice 103 pots

     description == International Calls into CorpHQ from PSTN Coming from NL Ph

     translation-profile outgoing 1-HQ-Proper_Types

     preference 1

     destination-pattern ^0012065011...$

     direct-inward-dial

     port 0/1/0:23

     forward-digits 10

    !

    dial-peer voice 104 pots

     description == + Calls into CorpHQ from PSTN Coming from Mobiles

     translation-profile outgoing 1-HQ-Proper_Types

     preference 1

     destination-pattern +12065011...$

     direct-inward-dial

     port 0/1/0:23

     forward-digits 10

    !         

    dial-peer voice 201 pots

     description == Subscriber Calls from PSTN into Branch1

     translation-profile outgoing 2-BR1-Proper_Types

     preference 1

     destination-pattern ^5126022...$

     direct-inward-dial

     port 0/1/1:23

     forward-digits 10

    !

    dial-peer voice 202 pots

     description == National Calls from PSTN into Branch1

     translation-profile outgoing 2-BR1-Proper_Types

     preference 1

     destination-pattern ^15126022...$

     direct-inward-dial

     port 0/1/1:23

     forward-digits 10

    !

    dial-peer voice 203 pots

     description == International Calls into Branch1 from PSTN Coming from NL Ph

     translation-profile outgoing 2-BR1-Proper_Types

     preference 1

     destination-pattern ^0015126022...$

     direct-inward-dial

     port 0/1/1:23

     forward-digits 10

    !

    dial-peer voice 204 pots

     description == + Calls into Branch1 from PSTN Coming from Mobiles

     translation-profile outgoing 2-BR1-Proper_Types

     preference 1

     destination-pattern +15126022...$

     direct-inward-dial

     port 0/1/1:23

     forward-digits 10

    !

    dial-peer voice 301 pots

     description == Subscriber Calls from PSTN into Branch2

     translation-profile outgoing 3-BR2-Proper_Types

     destination-pattern ^7033...$

     direct-inward-dial

     port 0/0/0:15

     forward-digits 7

    !

    dial-peer voice 302 pots

     description == National Calls from PSTN into Branch2

     translation-profile outgoing 3-BR2-Proper_Types

     destination-pattern ^0207033...$

     direct-inward-dial

     port 0/0/0:15

     forward-digits 10

    !

    dial-peer voice 303 pots

     description == International Calls into Branch2 from PSTN Coming from US Ph

     translation-profile outgoing 3-BR2-Proper_Types

     destination-pattern ^01131207033...$

     direct-inward-dial

     port 0/0/0:15

     forward-digits 9

     prefix 0

    !

    dial-peer voice 304 pots

     description == International Calls into Branch2 from PSTN Coming from US Ph

     translation-profile outgoing 3-BR2-Proper_Types

     destination-pattern ^31207033...$

     direct-inward-dial

     port 0/0/0:15

     forward-digits 9

     prefix 0 

    !

    dial-peer voice 305 pots

     description == + Calls into Branch2 from PSTN Coming from Mobiles

     translation-profile outgoing 3-BR2-Proper_Types

     destination-pattern +31207033...$

     direct-inward-dial

     port 0/0/0:15

     forward-digits 9

     prefix 0

    !

    dial-peer voice 1000 voip

     description == Calls into AT&T SIP ITSP for VC Week1 Lab1

     rtp payload-type nse 99

     rtp payload-type nte 100

     voice-class sip localhost dns:sip1.att.com 

     session protocol sipv2

     incoming called-number .

     dtmf-relay rtp-nte

     codec g711ulaw

    !

    dial-peer voice 5000 voip

     service aa

     destination-pattern A5000

     session target ipv4:177.1.254.254

     incoming called-number A5000

     dtmf-relay h245-alphanumeric

     codec g711ulaw

     no vad

    !

    !

    num-exp 1888....... 911

    num-exp 1900....... 911

    num-exp 1976....... 911

    num-exp 1777....... 911

    num-exp 1444....... 911

    num-exp 0800....... 911

    num-exp 0900....... 911

    sip-ua 

    !

    !

    !

    telephony-service

     no auto-reg-ephone

     max-ephones 1

     max-dn 10

     ip source-address 177.1.254.254 port 2000

     caller-id block code *67

     system message You WILL PASS this Exam!

     voicemail A5000

     max-conferences 8 gain -6

     call-forward pattern .T

     dn-webedit 

     transfer-system full-consult

     transfer-pattern .T

     create cnf-files version-stamp 7960 Sep 01 2012 15:29:37

    !

    !

    ephone-dn  1  dual-line

     number 12065015111 secondary +12065015111

     label Seattle, US +1 206 501 5111

     description INE PSTN Phone

     name Seattle US Phone

    !

    !

    ephone-dn  2  dual-line

     number 15126026222 secondary +15126026222

     label Austin, US +1 512 602 6222

     name Austin TX Phone

    !         

    !

    ephone-dn  3  dual-line

     number 31207037333 secondary +31207037333

     label Amsterdam, NL +31 20 703 73 33

     name Amsterdam NL Phone

    !

    !

    ephone-dn  4  dual-line

     number 12065015555 secondary +12065015555

     label Hurley Mobile +1 206 501 5555

     name Hurley's Mobile

     call-forward busy A5000

     call-forward noan A5000 timeout 16

    !

    !

    ephone-dn  5  dual-line

     number 12065015151 secondary +12065015151

     label Hurley's Home +1 206 501 5151

     name Hurley's Home

     call-forward busy A5000

     call-forward noan A5000 timeout 12

    !

    !         

    ephone-dn  6  dual-line

     number 31670357575 secondary +31670357575

     label Sawyer's Mobile +31 6 70357575

     name Sawyer's Mobile

     call-forward busy A5000

     call-forward noan A5000 timeout 16

    !

    !

    ephone-dn  7  dual-line

     number 911 secondary 112

     label US/EU Emer/FreePhone/Prem

     name Emergency Services

    !

    !

    ephone-dn  8  dual-line

     number 15126026262 secondary +15126026262

     label BLinus Mobile +1 512 602 6262

     name Benjamin Linus Mobile

     call-forward busy A5000

     call-forward noan A5000 timeout 16

    !

    !

    ephone-dn  9  dual-line

     number 31207037373 secondary +31207037373

     label DHume Home +31 20 703 73 73

     name Desmond Hume Home

     call-forward busy A5000

     call-forward noan A5000 timeout 16

    !

    !

    ephone-dn  10  dual-line

     number 31107047444 secondary +31107047444

     label Rotterdam, NL +31 10 704 74 44

     name Rotterdam NL Phone

    !

    !

    ephone  1

     device-security-mode none

     mac-address A456.3040.0DAA

     type 7975

     button  1:1 2:2 3:3 4:10

     button  5:6 6o7,8,5,4

    !

    !

    !

    line con 0

     exec-timeout 0 0

     privilege level 15

     logging synchronous level 0 limit 20

    line aux 0

    line vty 0 4

     exec-timeout 0 0

     privilege level 15

     logging synchronous

     no login

    line vty 5 15

     exec-timeout 0 0

     privilege level 15

     logging synchronous

     no login

    !

    scheduler allocate 20000 1000

    ntp source Loopback0

    ntp master 10

    ntp server 64.90.182.55

    end

     

    PSTN#

  • Hi,

    Can you remove rule 1 under translation-rule 10 and make a test call.

    voice translation-rule 101
     rule 1 /^+.*/ //


    if still fails, enable debugs on the PSTN VG and send the output.

    debug voice dialpeer inout
    debug isdn q931
    debug voice translation

  • Hi:


    After I removed Rule 1, it didn't work, so I ran debugs on the PSTN (one with the Rule IN and one with the rule OUT). I'm getting an UNALLOCATED/UNASSIGNED NUMBER on both ends... 


    Also, someone suggested the call isn't working because I'm sending the CALLED PARTY NUMBER as NATIONAL and it should be LOCAL since a LOCAL number is being dialed.




    Called Party Number i = 0xA1, '2065015111'

                    Plan:ISDN, Type:National


    Thanks,


    Ron

    _____________________________________________________________________________


    PSTN#show debug



    The following ISDN debugs are enabled on all DSLs:

    debug isdn error is             ON.

    debug isdn q931 is              ON.   (filter is OFF)
    DIALPEER:
      debug voip dialpeer inout is ON (filter is OFF)

    voip translation-rule
      voip translation debugging is on (Filter is OFF)
    ______________________________________________________________________________


    DEBUG WITH RULE 1 REMOVED


    IS-1/71F1FB94800A/DPM/dpMatchPeersMoreArg:

       Result=NO_MATCH(-1)
    ISDN Se0/1/1:23 Q931: TX -> CALL_PROC pd = 8  callref = 0x8088 
            Channel ID i = 0xA98383 
                    Exclusive, Channel 3

    ISDN Se0/1/1:23 Q931: TX -> DISCONNECT pd = 8  callref = 0x8088 
            Cause i = 0x8281 - Unallocated/unassigned number
    ISDN Se0/1/1:23 Q931: RX <- RELEASE pd = 8  callref = 0x0088

    ISDN Se0/1/1:23 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x8088
    //-1/71F1FB94800A/RXRULE/regxrule_stack_pop_RegXruleNumInfo: stack=0x4AE53AFC; count=1

    //-1/71F1FB94800A/RXRULE/regxrule_stack_pop_callinfo_internal: numinfo=0x4AF158AC
    //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
       Calling Number=, Called Number=, Voice-Interface=0x0,

       Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,
       Peer Info Type=DIALPEER_INFO_SPEECH
    //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

       Result=NO_MATCH(-1) After All Match Rules Attempt
    ______________________________________________________________________________


    DEBUG WITH RULE 1 ADDED BACK IN

    IDIALPEER_INFO_SPEECH

    //-1/5D5B1A9D8009/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=2065015111

    //-1/5D5B1A9D8009/DPM/dpMatchPeersCore:
       No Outgoing Dial-peer Is Matched; Result=NO_MATCH(-1)

    //-1/5D5B1A9D8009/DPM/dpMatchPeersMoreArg:
       Result=NO_MATCH(-1)

    //-1/5D5B1A9D8009/DPM/dpMatchPeersCore:
       Calling Number=, Called Number=2065015111, Peer Info Type=DIALPEER_INFO_SPEECH

    //-1/5D5B1A9D8009/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=2065015111

    //-1/5D5B1A9D8009/DPM/dpMatchPeersCore:
       No Outgoing Dial-peer Is Matched; Result=NO_MATCH(-1)

    //-1/5D5B1A9D8009/DPM/dpMatchPeersMoreArg:
       Result=NO_MATCH(-1)

    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       Calling Number=2065015111, Called Number=2065015111, Peer Info Type=DIALPEER_INFO_SPEECH

    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=2065015111

    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       No Outgoing Dial-peer Is Matched; Result=NO_MATCH(-1)

    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersMoreArg:
       Result=NO_MATCH(-1)

    //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
       Calling Number=2065015111, Called Number=, Voice-Interface=0x0,

       Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,
       Peer Info Type=DIALPEER_INFO_SPEECH

    //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
       Result=NO_MATCH(-1) After All Match Rules Attempt

    //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
       Calling Number=2065015111, Called Number=, Voice-Interface=0x0,

       Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,
       Peer Info Type=DIALPEER_INFO_SPEECH

    //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
       Result=NO_MATCH(-1) After All Match Rules Attempt

    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       Calling Number=, Called Number=2065015111, Peer Info Type=DIALPEER_INFO_SPEECH

    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=2065015111

    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       No Outgoing Dial-peer Is Matched; Result=NO_MATCH(-1)

    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersMoreArg:
       Result=NO_MATCH(-1)

    //-1/5D5B1A9D8009/DPM/dpMatchPeersCore:
       Calling Number=, Called Number=2065015111, Peer Info Type=DIALPEER_INFO_SPEECH

    //-1/5D5B1A9D8009/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=2065015111

    //-1/5D5B1A9D8009/DPM/dpMatchPeersCore:
       No Outgoing Dial-peer Is Matched; Result=NO_MATCH(-1)

    //-1/5D5B1A9D8009/DPM/dpMatchPeersMoreArg:
       Result=NO_MATCH(-1)

    ISDN Se0/1/1:23 Q931: TX -> CALL_PROC pd = 8  callref = 0x8087 
            Channel ID i = 0xA98383 

                    Exclusive, Channel 3
    ISDN Se0/1/1:23 Q931: TX -> DISCONNECT pd = 8  callref = 0x8087 

            Cause i = 0x8281 - Unallocated/unassigned number
    ISDN Se0/1/1:23 Q931: RX <- RELEASE pd = 8  callref = 0x0087

    ISDN Se0/1/1:23 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x8087
    //-1/5D5B1A9D8009/RXRULE/regxrule_stack_pop_RegXruleNumInfo: stack=0x4AE53A4C; count=1

    //-1/5D5B1A9D8009/RXRULE/regxrule_stack_pop_callinfo_internal: numinfo=0x4AF15940
    //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

       Calling Number=, Called Number=, Voice-Interface=0x0,
       Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,

       Peer Info Type=DIALPEER_INFO_SPEECH
    //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

       Result=NO_MATCH(-1) After All Match Rules Attempt











    On Wed, Sep 25, 2013 at 9:19 PM, rejohn <[email protected]> wrote:

    Hi,

    Can you remove rule 1 under translation-rule 10 and make a test call.

    voice translation-rule 101
     rule 1 /^+.*/ //


    if still fails, enable debugs on the PSTN VG and send the output.

    debug voice dialpeer inout
    debug isdn q931
    debug voice translation




    INE - The Industry Leader in CCIE Preparation

    http://www.INE.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx

  • Do a step by step walk through as you call out.

    Do 2 debugs, debug voice translation and deb VoIP dial peer input. 

    When I call from the HQ router into the pstn router...what helps decide matching to a dial peer??  Destination pattern, maybe an incoming called number...what else??



    Sent from my iPhone

    On Sep 25, 2013, at 11:09 PM, rjferriolo <[email protected]> wrote:

    Hi:


    After I removed Rule 1, it didn't work, so I ran debugs on the PSTN (one with the Rule IN and one with the rule OUT). I'm getting an UNALLOCATED/UNASSIGNED NUMBER on both ends... 


    Also, someone suggested the call isn't working because I'm sending the CALLED PARTY NUMBER as NATIONAL and it should be LOCAL since a LOCAL number is being dialed.




    Called Party Number i = 0xA1, '2065015111'

                    Plan:ISDN, Type:National


    Thanks,


    Ron

    _____________________________________________________________________________


    PSTN#show debug



    The following ISDN debugs are enabled on all DSLs:

    debug isdn error is             ON.

    debug isdn q931 is              ON.   (filter is OFF)
    DIALPEER:
      debug voip dialpeer inout is ON (filter is OFF)

    voip translation-rule
      voip translation debugging is on (Filter is OFF)
    ______________________________________________________________________________


    DEBUG WITH RULE 1 REMOVED


    IS-1/71F1FB94800A/DPM/dpMatchPeersMoreArg:

       Result=NO_MATCH(-1)
    ISDN Se0/1/1:23 Q931: TX -> CALL_PROC pd = 8  callref = 0x8088 
            Channel ID i = 0xA98383 
                    Exclusive, Channel 3

    ISDN Se0/1/1:23 Q931: TX -> DISCONNECT pd = 8  callref = 0x8088 
            Cause i = 0x8281 - Unallocated/unassigned number
    ISDN Se0/1/1:23 Q931: RX <- RELEASE pd = 8  callref = 0x0088

    ISDN Se0/1/1:23 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x8088
    //-1/71F1FB94800A/RXRULE/regxrule_stack_pop_RegXruleNumInfo: stack=0x4AE53AFC; count=1

    //-1/71F1FB94800A/RXRULE/regxrule_stack_pop_callinfo_internal: numinfo=0x4AF158AC
    //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
       Calling Number=, Called Number=, Voice-Interface=0x0,

       Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,
       Peer Info Type=DIALPEER_INFO_SPEECH
    //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

       Result=NO_MATCH(-1) After All Match Rules Attempt
    ______________________________________________________________________________


    DEBUG WITH RULE 1 ADDED BACK IN

    IDIALPEER_INFO_SPEECH

    //-1/5D5B1A9D8009/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=2065015111

    //-1/5D5B1A9D8009/DPM/dpMatchPeersCore:
       No Outgoing Dial-peer Is Matched; Result=NO_MATCH(-1)

    //-1/5D5B1A9D8009/DPM/dpMatchPeersMoreArg:
       Result=NO_MATCH(-1)

    //-1/5D5B1A9D8009/DPM/dpMatchPeersCore:
       Calling Number=, Called Number=2065015111, Peer Info Type=DIALPEER_INFO_SPEECH

    //-1/5D5B1A9D8009/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=2065015111

    //-1/5D5B1A9D8009/DPM/dpMatchPeersCore:
       No Outgoing Dial-peer Is Matched; Result=NO_MATCH(-1)

    //-1/5D5B1A9D8009/DPM/dpMatchPeersMoreArg:
       Result=NO_MATCH(-1)

    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       Calling Number=2065015111, Called Number=2065015111, Peer Info Type=DIALPEER_INFO_SPEECH

    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=2065015111

    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       No Outgoing Dial-peer Is Matched; Result=NO_MATCH(-1)

    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersMoreArg:
       Result=NO_MATCH(-1)

    //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
       Calling Number=2065015111, Called Number=, Voice-Interface=0x0,

       Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,
       Peer Info Type=DIALPEER_INFO_SPEECH

    //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
       Result=NO_MATCH(-1) After All Match Rules Attempt

    //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
       Calling Number=2065015111, Called Number=, Voice-Interface=0x0,

       Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,
       Peer Info Type=DIALPEER_INFO_SPEECH

    //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
       Result=NO_MATCH(-1) After All Match Rules Attempt

    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       Calling Number=, Called Number=2065015111, Peer Info Type=DIALPEER_INFO_SPEECH

    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=2065015111

    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       No Outgoing Dial-peer Is Matched; Result=NO_MATCH(-1)

    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersMoreArg:
       Result=NO_MATCH(-1)

    //-1/5D5B1A9D8009/DPM/dpMatchPeersCore:
       Calling Number=, Called Number=2065015111, Peer Info Type=DIALPEER_INFO_SPEECH

    //-1/5D5B1A9D8009/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=2065015111

    //-1/5D5B1A9D8009/DPM/dpMatchPeersCore:
       No Outgoing Dial-peer Is Matched; Result=NO_MATCH(-1)

    //-1/5D5B1A9D8009/DPM/dpMatchPeersMoreArg:
       Result=NO_MATCH(-1)

    ISDN Se0/1/1:23 Q931: TX -> CALL_PROC pd = 8  callref = 0x8087 
            Channel ID i = 0xA98383 

                    Exclusive, Channel 3
    ISDN Se0/1/1:23 Q931: TX -> DISCONNECT pd = 8  callref = 0x8087 

            Cause i = 0x8281 - Unallocated/unassigned number
    ISDN Se0/1/1:23 Q931: RX <- RELEASE pd = 8  callref = 0x0087

    ISDN Se0/1/1:23 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x8087
    //-1/5D5B1A9D8009/RXRULE/regxrule_stack_pop_RegXruleNumInfo: stack=0x4AE53A4C; count=1

    //-1/5D5B1A9D8009/RXRULE/regxrule_stack_pop_callinfo_internal: numinfo=0x4AF15940
    //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

       Calling Number=, Called Number=, Voice-Interface=0x0,
       Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,

       Peer Info Type=DIALPEER_INFO_SPEECH
    //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

       Result=NO_MATCH(-1) After All Match Rules Attempt











    On Wed, Sep 25, 2013 at 9:19 PM, rejohn <[email protected]> wrote:

    Hi,

    Can you remove rule 1 under translation-rule 10 and make a test call.

    voice translation-rule 101
     rule 1 /^+.*/ //


    if still fails, enable debugs on the PSTN VG and send the output.

    debug voice dialpeer inout
    debug isdn q931
    debug voice translation




    INE - The Industry Leader in CCIE Preparation

    http://www.INE.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx




    INE - The Industry Leader in CCIE Preparation

    http://www.INE.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx
  • INCOMING CALLED NUMBER

    ANSWER ADDRESS
    DESTINATION-PATTERN

    PORT


    On Thu, Sep 26, 2013 at 12:34 AM, michael.thompson <[email protected]> wrote:
    Do a step by step walk through as you call out.

    Do 2 debugs, debug voice translation and deb VoIP dial peer input. 


    When I call from the HQ router into the pstn router...what helps decide matching to a dial peer??  Destination pattern, maybe an incoming called number...what else??



    Sent from my iPhone


    On Sep 25, 2013, at 11:09 PM, rjferriolo <[email protected]> wrote:


    Hi:


    After I removed Rule 1, it didn't work, so I ran debugs on the PSTN (one with the Rule IN and one with the rule OUT). I'm getting an UNALLOCATED/UNASSIGNED NUMBER on both ends... 



    Also, someone suggested the call isn't working because I'm sending the CALLED PARTY NUMBER as NATIONAL and it should be LOCAL since a LOCAL number is being dialed.






    Called Party Number i = 0xA1, '2065015111'

                    Plan:ISDN, Type:National


    Thanks,



    Ron


    _____________________________________________________________________________



    PSTN#show debug




    The following ISDN debugs are enabled on all DSLs:

    debug isdn error is             ON.


    debug isdn q931 is              ON.   (filter is OFF)
    DIALPEER:
      debug voip dialpeer inout is ON (filter is OFF)


    voip translation-rule
      voip translation debugging is on (Filter is OFF)
    ______________________________________________________________________________



    DEBUG WITH RULE 1 REMOVED



    IS-1/71F1FB94800A/DPM/dpMatchPeersMoreArg:


       Result=NO_MATCH(-1)
    ISDN Se0/1/1:23 Q931: TX -> CALL_PROC pd = 8  callref = 0x8088 
            Channel ID i = 0xA98383 
                    Exclusive, Channel 3


    ISDN Se0/1/1:23 Q931: TX -> DISCONNECT pd = 8  callref = 0x8088 
            Cause i = 0x8281 - Unallocated/unassigned number
    ISDN Se0/1/1:23 Q931: RX <- RELEASE pd = 8  callref = 0x0088


    ISDN Se0/1/1:23 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x8088
    //-1/71F1FB94800A/RXRULE/regxrule_stack_pop_RegXruleNumInfo: stack=0x4AE53AFC; count=1


    //-1/71F1FB94800A/RXRULE/regxrule_stack_pop_callinfo_internal: numinfo=0x4AF158AC
    //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
       Calling Number=, Called Number=, Voice-Interface=0x0,


       Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,
       Peer Info Type=DIALPEER_INFO_SPEECH
    //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:


       Result=NO_MATCH(-1) After All Match Rules Attempt
    ______________________________________________________________________________



    DEBUG WITH RULE 1 ADDED BACK IN

    IDIALPEER_INFO_SPEECH


    //-1/5D5B1A9D8009/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=2065015111


    //-1/5D5B1A9D8009/DPM/dpMatchPeersCore:
       No Outgoing Dial-peer Is Matched; Result=NO_MATCH(-1)


    //-1/5D5B1A9D8009/DPM/dpMatchPeersMoreArg:
       Result=NO_MATCH(-1)


    //-1/5D5B1A9D8009/DPM/dpMatchPeersCore:
       Calling Number=, Called Number=2065015111, Peer Info Type=DIALPEER_INFO_SPEECH


    //-1/5D5B1A9D8009/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=2065015111


    //-1/5D5B1A9D8009/DPM/dpMatchPeersCore:
       No Outgoing Dial-peer Is Matched; Result=NO_MATCH(-1)


    //-1/5D5B1A9D8009/DPM/dpMatchPeersMoreArg:
       Result=NO_MATCH(-1)


    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       Calling Number=2065015111, Called Number=2065015111, Peer Info Type=DIALPEER_INFO_SPEECH


    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=2065015111


    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       No Outgoing Dial-peer Is Matched; Result=NO_MATCH(-1)


    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersMoreArg:
       Result=NO_MATCH(-1)


    //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
       Calling Number=2065015111, Called Number=, Voice-Interface=0x0,


       Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,
       Peer Info Type=DIALPEER_INFO_SPEECH


    //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
       Result=NO_MATCH(-1) After All Match Rules Attempt


    //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
       Calling Number=2065015111, Called Number=, Voice-Interface=0x0,


       Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,
       Peer Info Type=DIALPEER_INFO_SPEECH


    //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
       Result=NO_MATCH(-1) After All Match Rules Attempt


    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       Calling Number=, Called Number=2065015111, Peer Info Type=DIALPEER_INFO_SPEECH


    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=2065015111


    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       No Outgoing Dial-peer Is Matched; Result=NO_MATCH(-1)


    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersMoreArg:
       Result=NO_MATCH(-1)


    //-1/5D5B1A9D8009/DPM/dpMatchPeersCore:
       Calling Number=, Called Number=2065015111, Peer Info Type=DIALPEER_INFO_SPEECH


    //-1/5D5B1A9D8009/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=2065015111


    //-1/5D5B1A9D8009/DPM/dpMatchPeersCore:
       No Outgoing Dial-peer Is Matched; Result=NO_MATCH(-1)


    //-1/5D5B1A9D8009/DPM/dpMatchPeersMoreArg:
       Result=NO_MATCH(-1)


    ISDN Se0/1/1:23 Q931: TX -> CALL_PROC pd = 8  callref = 0x8087 
            Channel ID i = 0xA98383 


                    Exclusive, Channel 3
    ISDN Se0/1/1:23 Q931: TX -> DISCONNECT pd = 8  callref = 0x8087 


            Cause i = 0x8281 - Unallocated/unassigned number
    ISDN Se0/1/1:23 Q931: RX <- RELEASE pd = 8  callref = 0x0087


    ISDN Se0/1/1:23 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x8087
    //-1/5D5B1A9D8009/RXRULE/regxrule_stack_pop_RegXruleNumInfo: stack=0x4AE53A4C; count=1


    //-1/5D5B1A9D8009/RXRULE/regxrule_stack_pop_callinfo_internal: numinfo=0x4AF15940
    //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:


       Calling Number=, Called Number=, Voice-Interface=0x0,
       Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,


       Peer Info Type=DIALPEER_INFO_SPEECH
    //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:


       Result=NO_MATCH(-1) After All Match Rules Attempt














    On Wed, Sep 25, 2013 at 9:19 PM, rejohn <[email protected]> wrote:

    Hi,

    Can you remove rule 1 under translation-rule 10 and make a test call.

    voice translation-rule 101
     rule 1 /^+.*/ //


    if still fails, enable debugs on the PSTN VG and send the output.

    debug voice dialpeer inout
    debug isdn q931
    debug voice translation




    INE - The Industry Leader in CCIE Preparation


    http://www.INE.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx




    INE - The Industry Leader in CCIE Preparation


    http://www.INE.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx



    INE - The Industry Leader in CCIE Preparation

    http://www.INE.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx

  • If you dial this number 92065015111 from CorpHQ, the PSTN receives it as 2065015111 and hits translation-profile 1-HQ-Change_DNIS-Check_ANI which applied on  voice-port 0/1/0:23. THen PSTN GW will check the rules configured under voice translation-rule 101. As per the latest debug you sent, this number 2065015111 is not changed to 12065015111 hence your getting unallocated number error. 12065015111is the number you assigned on PSTN phone button 1.

    Can you send the unfiltered debug including  voice translations.

  • Not sure what you mean by unfiltered debug and do you mean on the PSTN side or the CorpHQ side? 


    THX


    On Thu, Sep 26, 2013 at 1:19 AM, rejohn <[email protected]> wrote:

    If you dial this number 92065015111 from CorpHQ, the PSTN receives it as 2065015111 and hits translation-profile 1-HQ-Change_DNIS-Check_ANI which applied on  voice-port 0/1/0:23. THen PSTN GW will check the rules configured under voice translation-rule 101. As per the latest debug you sent, this number 2065015111 is not changed to 12065015111 hence your getting unallocated number error. 12065015111is the number you assigned on PSTN phone button 1.

    Can you send the unfiltered debug including  voice translations.




    INE - The Industry Leader in CCIE Preparation

    http://www.INE.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx

  • I mean the complete debug output. Do it on both. Thanks.

  • CORPHQ DEBUG


    CorpHQ#
    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:

       Calling Number=, Called Number=92065015111, Peer Info Type=DIALPEER_INFO_SPEECH
    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:

       Match Rule=DP_MATCH_DEST; Called Number=92065015111
    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:

       Result=Success(0) after DP_MATCH_DEST
    //-1/xxxxxxxxxxxx/DPM/dpMatchPeers:

       Result=SUCCESS(0) 
       List of Matched Outgoing Dial-peer(s): 

         1: Dial-peer Tag=11
    //-1/xxxxxxxxxxxx/RXRULE/regxrule_vp_translate: No profile found in voice port or trunk group for outgoing direction

    //-1/xxxxxxxxxxxx/RXRULE/regxrule_vp_translate: calling_number= calling_octet=0x0
            called_number=92065015111 called_octet=0x0

            redirect_number= redirect_type=4294967295 redirect_plan=4294967295
    ISDN Se0/0/0:23 Q931: pak_private_number: Invalid type/plan 0x0 0x0 may be overriden; sw-type 13

    ISDN Se0/0/0:23 Q931: Sending SETUP  callref = 0x0080 callID = 0x8001 switch = primary-ni interface = User 

    ISDN Se0/0/0:23 Q931: TX -> SETUP pd = 8  callref = 0x0080 
            Bearer Capability i = 0x8090A2 

                    Standard = CCITT 
                    Transfer Capability = Speech  

                    Transfer Mode = Circuit 
                    Transfer Rate = 64 kbit/s 

            Channel ID i = 0xA98383 
                    Exclusive, Channel 3 

            Called Party Number i = 0xA1, '2065015111' 
                    Plan:ISDN, Type:National

    ISDN Se0/0/0:23 Q931: RX <- CALL_PROC pd = 8  callref = 0x8080 
            Channel ID i = 0xA98383 

                    Exclusive, Channel 3
    ISDN Se0/0/0:23 Q931: RX <- DISCONNECT pd = 8  callref = 0x8080 

            Cause i = 0x8281 - Unallocated/unassigned number
    ISDN Se0/0/0:23 Q931: TX -> RELEASE pd = 8  callref = 0x0080

    ISDN Se0/0/0:23 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x8080
    //-1/D84225F78002/RXRULE/regxrule_stack_pop_callinfo_internal: numinfo=0x0

    _________________________________________________________________________________


    PSTN DEBUG


    ISeersMoreArg:

       Result=NO_MATCH(-1)
    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       Calling Number=2065015111, Called Number=2065015111, Peer Info Type=DIALPEER_INFO_SPEECH

    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=2065015111
    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:

       No Outgoing Dial-peer Is Matched; Result=NO_MATCH(-1)
    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersMoreArg:
       Result=NO_MATCH(-1)

    //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
       Calling Number=2065015111, Called Number=, Voice-Interface=0x0,
       Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,

       Peer Info Type=DIALPEER_INFO_SPEECH
    //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
       Result=NO_MATCH(-1) After All Match Rules Attempt

    //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
       Calling Number=2065015111, Called Number=, Voice-Interface=0x0,
    PSTN#

       Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,
       Peer Info Type=DIALPEER_INFO_SPEECH
    //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

       Result=NO_MATCH(-1) After All Match Rules Attempt
    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       Calling Number=, Called Number=2065015111, Peer Info Type=DIALPEER_INFO_SPEECH

    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=2065015111
    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:

       No Outgoing Dial-peer Is Matched; Result=NO_MATCH(-1)
    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersMoreArg:
       Result=NO_MATCH(-1)

    //-1/15F4EF978003/DPM/dpMatchPeersCore:
       Calling Number=, Called Number=2065015111, Peer Info Type=DIALPEER_INFO_SPEECH
    //-1/15F4EF978003/DPM/dpMatchPeersCore:

       Match Rule=DP_MATCH_DEST; Called Number=2065015111
    //-1/15F4EF978003/DPM/dpMatchPeersCore:
       No Outgoing Dial-peer Is Matched; Result=NO_MATCH(-1)

    //-1/15F4EF978003/DPM/dpMatchPeersMoreArg:
       Result=NO_MATCH(-1)
    ISDN Se0/1/1:23 Q931: TX -> CALL_PROC pd = 8  callref = 0x8081 

            Channel ID i = 0xA98383 
                    Exclusive, Channel 3
    ISDN Se0/1/1:23 Q931: TX -> DISCONNECT pd = 8  callref = 0x8081 

            Cause i = 0x8281 - Unallocated/unassigned number
    ISDN Se0/1/1:23 Q931: RX <- RELEASE pd = 8  callref = 0x0081
    ISDN Se0/1/1:23 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x8081

    //-1/15F4EF978003/RXRULE/regxrule_stack_pop_RegXruleNumInfo: stack=0x4B2893EC; count=1
    //-1/15F4EF978003/RXRULE/regxrule_stack_pop_callinfo_internal: numinfo=0x4B3732F0

    //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
       Calling Number=, Called Number=, Voice-Interface=0x0,
       Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,

       Peer Info Type=DIALPEER_INFO_SPEECH
    //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
       Result=NO_MATCH(-1) After All Match Rules Attempt

    ISDN Se0/1/0:23 Q931: Ux_DLRelInd: DL_REL_IND received from L2
    ISDN Se0/1/0:23 Q931: Ux_DLRelInd: DL_REL_IND received from L2



    On Thu, Sep 26, 2013 at 2:19 AM, rejohn <[email protected]> wrote:

    I mean the complete debug output. Do it on both. Thanks.




    INE - The Industry Leader in CCIE Preparation

    http://www.INE.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx

  • CorpHQ#sh debug


    DIALPEER:
      debug voip dialpeer inout is ON (filter is OFF)
    voip translation-rule

      voip translation debugging is on (Filter is OFF)
    _________________________________________________________________________________


    CorpHQ#

    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       Calling Number=, Called Number=92065015111, Peer Info Type=DIALPEER_INFO_SPEECH

    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=92065015111
    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:

       Result=Success(0) after DP_MATCH_DEST
    //-1/xxxxxxxxxxxx/DPM/dpMatchPeers:
       Result=SUCCESS(0) 

       List of Matched Outgoing Dial-peer(s): 
         1: Dial-peer Tag=11
    //-1/xxxxxxxxxxxx/RXRULE/regxrule_vp_translate: No profile found in voice port or trunk group for outgoing direction

    //-1/xxxxxxxxxxxx/RXRULE/regxrule_vp_translate: calling_number= calling_octet=0x0
            called_number=92065015111 called_octet=0x0

            redirect_number= redirect_type=4294967295 redirect_plan=4294967295
    //-1/C4887AE4800E/RXRULE/regxrule_stack_pop_callinfo_internal: numinfo=0x0
    _________________________________________________________________________________


    PSTN#show debug

    DIALPEER:
      debug voip dialpeer inout is ON (filter is OFF)

    voip translation-rule
      voip translation debugging is on (Filter is OFF)
    _________________________________________________________________________________


    PSTN#


    //eer Info Type=DIALPEER_INFO_SPEECH

    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=2065015111

    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       No Outgoing Dial-peer Is Matched; Result=NO_MATCH(-1)

    //-1/xxxxxxxxxxxx/DPM/dpMatchPeers:
       Result=NO_MATCH(-1)

    //-1/xxxxxxxxxxxx/RXRULE/regxrule_get_profile_from_voiceport_internal: Found profile 2-BR1-Change_DNIS-Check_ANI defined on voice-port

    //-1/xxxxxxxxxxxx/RXRULE/regxrule_get_RegXrule: Invalid translation ruleset tag=0
    //-1/xxxxxxxxxxxx/RXRULE/regxrule_profile_subst_internal: Error: ruleset for calling number not found

    PSTN#
    //-1/xxxxxxxxxxxx/RXRULE/regxrule_match: No match; number=2065015111 rule precedence=1

    //-1/xxxxxxxxxxxx/RXRULE/regxrule_match: No match; number=2065015111 rule precedence=2
    //-1/xxxxxxxxxxxx/RXRULE/regxrule_match: No match; number=2065015111 rule precedence=3

    //-1/xxxxxxxxxxxx/RXRULE/regxrule_match: No match; number=2065015111 rule precedence=4
    //-1/xxxxxxxxxxxx/RXRULE/regxrule_match: No match; number=2065015111 rule precedence=5

    //-1/xxxxxxxxxxxx/RXRULE/regxrule_match: No match; number=2065015111 rule precedence=6
    //-1/xxxxxxxxxxxx/RXRULE/regxrule_match: No match; number=2065015111 rule precedence=7

    //-1/xxxxxxxxxxxx/RXRULE/regxrule_match: No match; number=2065015111 rule precedence=8
    //-1/xxxxxxxxxxxx/RXRULE/regxrule_profile_match_internal: No match found

    //-1/xxxxxxxxxxxx/RXRULE/regxrule_profile_subst_internal: Number parameters do not match ruleset in profile 2-BR1-Change_DNIS-Check_ANI

    //-1/xxxxxxxxxxxx/RXRULE/regxrule_get_RegXrule: Invalid translation ruleset tag=0
    //-1/xxxxxxxxxxxx/RXRULE/regxrule_profile_subst_internal: Error: ruleset for redirect-called number not found

    //-1/2CEFFF9F8005/RXRULE/regxrule_stack_pop_RegXruleNumInfo: stack=0x4B289444; count=1
    //-1/2CEFFF9F8005/RXRULE/regxrule_stack_pop_callinfo_internal: numinfo=0x4B3732F0

    //-1/2CEFFF9F8005/RXRULE/regxrule_stack_push_RegXruleNumInfo_internal: stack=0x4B289444; count=1

    //-1/2CEFFF9F8005/DPM/dpMatchPeersCore:
       Calling Number=, Called Number=2065015111, Peer Info Type=DIALPEER_INFO_SPEECH

    //-1/2CEFFF9F8005/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=2065015111

    //-1/2CEFFF9F8005/DPM/dpMatchPeersCore:
       No Outgoing Dial-peer Is Matched; Result=NO_MATCH(-1)

    //-1/2CEFFF9F8005/DPM/dpMatchPeersMoreArg:
       Result=NO_MATCH(-1)

    //-1/2CEFFF9F8005/DPM/dpMatchPeersCore:
       Calling Number=, Called Number=2065015111, Peer Info Type=DIALPEER_INFO_SPEECH

    //-1/2CEFFF9F8005/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=2065015111

    //-1/2CEFFF9F8005/DPM/dpMatchPeersCore:
       No Outgoing Dial-peer Is Matched; Result=NO_MATCH(-1)

    //-1/2CEFFF9F8005/DPM/dpMatchPeersMoreArg:
       Result=NO_MATCH(-1)

    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       Calling Number=2065015111, Called Number=2065015111, Peer Info Type=DIALPEER_INFO_SPEECH

    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=2065015111

    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       No Outgoing Dial-peer Is Matched; Result=NO_MATCH(-1)

    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersMoreArg:
       Result=NO_MATCH(-1)

    //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
       Calling Number=2065015111, Called Number=, Voice-Interface=0x0,

       Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,
       Peer Info Type=DIALPEER_INFO_SPEECH

    //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
       Result=NO_MATCH(-1) After All Match Rules Attempt

    //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
       Calling Number=2065015111, Called Number=, Voice-Interface=0x0,

       Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,
       Peer Info Type=DIALPEER_INFO_SPEECH

    //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
       Result=NO_MATCH(-1) After All Match Rules Attempt

    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       Calling Number=, Called Number=2065015111, Peer Info Type=DIALPEER_INFO_SPEECH

    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=2065015111

    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       No Outgoing Dial-peer Is Matched; Result=NO_MATCH(-1)

    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersMoreArg:
       Result=NO_MATCH(-1)

    //-1/2CEFFF9F8005/DPM/dpMatchPeersCore:
       Calling Number=, Called Number=2065015111, Peer Info Type=DIALPEER_INFO_SPEECH

    //-1/2CEFFF9F8005/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=2065015111

    //-1/2CEFFF9F8005/DPM/dpMatchPeersCore:
       No Outgoing Dial-peer Is Matched; Result=NO_MATCH(-1)

    //-1/2CEFFF9F8005/DPM/dpMatchPeersMoreArg:
       Result=NO_MATCH(-1)

    //-1/2CEFFF9F8005/RXRULE/regxrule_stack_pop_RegXruleNumInfo: stack=0x4B289444; count=1
    //-1/2CEFFF9F8005/RXRULE/regxrule_stack_pop_callinfo_internal: numinfo=0x4B3732F0

    //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
       Calling Number=, Called Number=, Voice-Interface=0x0,

       Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,
       Peer Info Type=DIALPEER_INFO_SPEECH

    //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
       Result=NO_MATCH(-1) After All Match Rules Attempt



    On Thu, Sep 26, 2013 at 12:34 AM, michael.thompson <[email protected]> wrote:
    Do a step by step walk through as you call out.

    Do 2 debugs, debug voice translation and deb VoIP dial peer input. 


    When I call from the HQ router into the pstn router...what helps decide matching to a dial peer??  Destination pattern, maybe an incoming called number...what else??



    Sent from my iPhone


    On Sep 25, 2013, at 11:09 PM, rjferriolo <[email protected]> wrote:


    Hi:


    After I removed Rule 1, it didn't work, so I ran debugs on the PSTN (one with the Rule IN and one with the rule OUT). I'm getting an UNALLOCATED/UNASSIGNED NUMBER on both ends... 



    Also, someone suggested the call isn't working because I'm sending the CALLED PARTY NUMBER as NATIONAL and it should be LOCAL since a LOCAL number is being dialed.






    Called Party Number i = 0xA1, '2065015111'

                    Plan:ISDN, Type:National


    Thanks,



    Ron


    _____________________________________________________________________________



    PSTN#show debug




    The following ISDN debugs are enabled on all DSLs:

    debug isdn error is             ON.


    debug isdn q931 is              ON.   (filter is OFF)
    DIALPEER:
      debug voip dialpeer inout is ON (filter is OFF)


    voip translation-rule
      voip translation debugging is on (Filter is OFF)
    ______________________________________________________________________________



    DEBUG WITH RULE 1 REMOVED



    IS-1/71F1FB94800A/DPM/dpMatchPeersMoreArg:


       Result=NO_MATCH(-1)
    ISDN Se0/1/1:23 Q931: TX -> CALL_PROC pd = 8  callref = 0x8088 
            Channel ID i = 0xA98383 
                    Exclusive, Channel 3


    ISDN Se0/1/1:23 Q931: TX -> DISCONNECT pd = 8  callref = 0x8088 
            Cause i = 0x8281 - Unallocated/unassigned number
    ISDN Se0/1/1:23 Q931: RX <- RELEASE pd = 8  callref = 0x0088


    ISDN Se0/1/1:23 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x8088
    //-1/71F1FB94800A/RXRULE/regxrule_stack_pop_RegXruleNumInfo: stack=0x4AE53AFC; count=1


    //-1/71F1FB94800A/RXRULE/regxrule_stack_pop_callinfo_internal: numinfo=0x4AF158AC
    //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
       Calling Number=, Called Number=, Voice-Interface=0x0,


       Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,
       Peer Info Type=DIALPEER_INFO_SPEECH
    //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:


       Result=NO_MATCH(-1) After All Match Rules Attempt
    ______________________________________________________________________________



    DEBUG WITH RULE 1 ADDED BACK IN

    IDIALPEER_INFO_SPEECH


    //-1/5D5B1A9D8009/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=2065015111


    //-1/5D5B1A9D8009/DPM/dpMatchPeersCore:
       No Outgoing Dial-peer Is Matched; Result=NO_MATCH(-1)


    //-1/5D5B1A9D8009/DPM/dpMatchPeersMoreArg:
       Result=NO_MATCH(-1)


    //-1/5D5B1A9D8009/DPM/dpMatchPeersCore:
       Calling Number=, Called Number=2065015111, Peer Info Type=DIALPEER_INFO_SPEECH


    //-1/5D5B1A9D8009/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=2065015111


    //-1/5D5B1A9D8009/DPM/dpMatchPeersCore:
       No Outgoing Dial-peer Is Matched; Result=NO_MATCH(-1)


    //-1/5D5B1A9D8009/DPM/dpMatchPeersMoreArg:
       Result=NO_MATCH(-1)


    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       Calling Number=2065015111, Called Number=2065015111, Peer Info Type=DIALPEER_INFO_SPEECH


    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=2065015111


    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       No Outgoing Dial-peer Is Matched; Result=NO_MATCH(-1)


    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersMoreArg:
       Result=NO_MATCH(-1)


    //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
       Calling Number=2065015111, Called Number=, Voice-Interface=0x0,


       Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,
       Peer Info Type=DIALPEER_INFO_SPEECH


    //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
       Result=NO_MATCH(-1) After All Match Rules Attempt


    //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
       Calling Number=2065015111, Called Number=, Voice-Interface=0x0,


       Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,
       Peer Info Type=DIALPEER_INFO_SPEECH


    //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
       Result=NO_MATCH(-1) After All Match Rules Attempt


    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       Calling Number=, Called Number=2065015111, Peer Info Type=DIALPEER_INFO_SPEECH


    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=2065015111


    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       No Outgoing Dial-peer Is Matched; Result=NO_MATCH(-1)


    //-1/xxxxxxxxxxxx/DPM/dpMatchPeersMoreArg:
       Result=NO_MATCH(-1)


    //-1/5D5B1A9D8009/DPM/dpMatchPeersCore:
       Calling Number=, Called Number=2065015111, Peer Info Type=DIALPEER_INFO_SPEECH


    //-1/5D5B1A9D8009/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=2065015111


    //-1/5D5B1A9D8009/DPM/dpMatchPeersCore:
       No Outgoing Dial-peer Is Matched; Result=NO_MATCH(-1)


    //-1/5D5B1A9D8009/DPM/dpMatchPeersMoreArg:
       Result=NO_MATCH(-1)


    ISDN Se0/1/1:23 Q931: TX -> CALL_PROC pd = 8  callref = 0x8087 
            Channel ID i = 0xA98383 


                    Exclusive, Channel 3
    ISDN Se0/1/1:23 Q931: TX -> DISCONNECT pd = 8  callref = 0x8087 


            Cause i = 0x8281 - Unallocated/unassigned number
    ISDN Se0/1/1:23 Q931: RX <- RELEASE pd = 8  callref = 0x0087


    ISDN Se0/1/1:23 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x8087
    //-1/5D5B1A9D8009/RXRULE/regxrule_stack_pop_RegXruleNumInfo: stack=0x4AE53A4C; count=1


    //-1/5D5B1A9D8009/RXRULE/regxrule_stack_pop_callinfo_internal: numinfo=0x4AF15940
    //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:


       Calling Number=, Called Number=, Voice-Interface=0x0,
       Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,


       Peer Info Type=DIALPEER_INFO_SPEECH
    //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:


       Result=NO_MATCH(-1) After All Match Rules Attempt














    On Wed, Sep 25, 2013 at 9:19 PM, rejohn <[email protected]> wrote:

    Hi,

    Can you remove rule 1 under translation-rule 10 and make a test call.

    voice translation-rule 101
     rule 1 /^+.*/ //


    if still fails, enable debugs on the PSTN VG and send the output.

    debug voice dialpeer inout
    debug isdn q931
    debug voice translation




    INE - The Industry Leader in CCIE Preparation


    http://www.INE.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx




    INE - The Industry Leader in CCIE Preparation


    http://www.INE.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx



    INE - The Industry Leader in CCIE Preparation

    http://www.INE.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx

  • Try running DNA(Dialed Number Analyzer). From there you can check the matching of the destination more easily and then troubleshoot.

  • Sorry to hear you are having hard time to fix the issue. The solution is you must need to dial 912065015111 so that the CorpHQ GW sends 12065015111 to PSTN router as incoming called number. It shouldn't be translated by any TR (as of rule 3 under TR 101) and get matched with line#1 extension for PSTN phone.

  • Hi Mijanur:


    Everything is working now because I had to prefix a '1' on the local dial-peer at CorpHQ, however this is kind of a jerry rigged fix because the fix should be on the PSTN. Not only did I have to prefix a '1' for a local number but I had to also prefix a '1' at Branch1 on the Called Party Transformation Pattern for that same area code. If I wasn't a novice with voice translation-rules, I would fix the PSTN myself however, I'm not going to continue to bother anyone with this issue and move on with my lab.


    Thanks again for your help,


    Ron



    On Mon, Sep 30, 2013 at 1:46 AM, MijanurRahman <[email protected]> wrote:

    Sorry to hear you are having hard time to fix the issue. The solution is you must need to dial 912065015111 so that the CorpHQ GW sends 12065015111 to PSTN router as incoming called number. It shouldn't be translated by any TR (as of rule 3 under TR 101) and get matched with line#1 extension for PSTN phone.




    INE - The Industry Leader in CCIE Preparation


    http://www.INE.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx

Sign In or Register to comment.