Help accessing devices via Terminal server 2511

Hello,

I was hoping to get help setting up my 2511 term server. I have configured it following suggestions from different posts here, but still not able to get it working. After spending quite some time looking at config and trying to modify, still not able to get it working. Any help or advice would be appreciated. I have a 2511 with aui transceiver and two octal cables, but only using 13 lines. When I try reverse telnet to remote devices, I am able to see them booting all the way to the "press enter to get started" but connection does not respond to key strokes. If I clear line and try to access again, I get stuck in "Trying 10.1.1.2, 2001 ... Open"

I have tried: changing telnet speed settings, stopbits, flowcontrol hardware... here is my config:

Cisco Internetwork Operating System Software
IOS (tm) 2500 Software (C2500-C-L), Version 12.3(22), RELEASE SOFTWARE (fc2)

hostname TermServer
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
ip subnet-zero
no ip domain lookup
ip host SW1 2001 10.1.1.2
ip host SW2 2002 10.1.1.2
ip host SW3 2003 10.1.1.2
ip host SW4 2004 10.1.1.2
ip host BB3 2005 10.1.1.2
ip host BB2 2006 10.1.1.2
ip host BB1 2007 10.1.1.2
ip host R3 2008 10.1.1.2
ip host R2 2009 10.1.1.2
ip host R1 2010 10.1.1.2
ip host R6 2013 10.1.1.2
ip host R5 2014 10.1.1.2
ip host R4 2015 10.1.1.2
!
!
interface Ethernet0
 ip address 10.1.1.2 255.255.255.0
 no ip route-cache
 no ip mroute-cache
!        
interface Serial0
 no ip address
 no ip route-cache
 no ip mroute-cache
 shutdown
!
interface Serial1
 no ip address
 no ip route-cache
 no ip mroute-cache
 shutdown
!
no ip http server
ip classless
!
alias exec sw1 telnet sw1 2001
alias exec sw2 telnet sw2 2002
alias exec sw3 telnet sw3 2003
alias exec sw4 telnet sw4 2004
alias exec bb3 telnet bb3 2005
alias exec bb2 telnet bb2 2006
alias exec bb1 telnet bb1 2007
alias exec r3 telnet r3 2008
alias exec r2 telnet r2 2009
alias exec r1 telnet r1 2010
alias exec r6 telnet r6 2013
alias exec r5 telnet r5 2014
alias exec r4 telnet r4 2015
!
line con 0
 exec-timeout 0 0
 logging synchronous
 telnet speed 9600 9600
line 1 16
 exec-timeout 0 0
 no exec
 transport input telnet
 telnet speed 9600 9600
 autohangup
 stopbits 1
line aux 0
line vty 0 4
 password cisco
 login
line vty 5 15
 password cisco
 login

---------------

TermServer#sh line
   Tty Typ     Tx/Rx    A Modem  Roty AccO AccI   Uses   Noise  Overruns   Int
*    0 CTY              -    -      -    -    -      0       0     0/0       -
     1 TTY   9600/9600  -    -      -    -    -      0       2     0/0       -
     2 TTY   9600/9600  -    -      -    -    -      0      42     0/0       -
     3 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
     4 TTY   9600/9600  -    -      -    -    -      0      15     0/0       -
     5 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
     6 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
     7 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
     8 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
     9 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
    10 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
    11 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
    12 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
    13 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
    14 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
    15 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
    16 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
    17 AUX   9600/9600  -    -      -    -    -      0       0     0/0       -

-----

TermServer#telnet 10.1.1.2 2001
Trying 10.1.1.2, 2001 ... Open

Please advise.

Comments

  • I would remove the aliases - by default when you type "r1", the router will do a lookup on the name "r1" and open a telnet session to the ip address if found. Your "ip host" lines will ensure that R1 is found and the appropriate ip address/port is used.

    The default port speed is 9600, so there is no need for the "telnet speed" lines. May not hurt anything, but I am reading the working config files from my 2509 and 2511 that are currently offline.

    My config also does not have "autohangup", but it has "transport input all" and "transport output none" under line 1 8 (2509) or line 1 16 (2511):

    line con 0
    logging synchronous
    line 1 8
     transport input all
     transport output none <-- edited 
    line aux 0
    line vty 0 4 
     password ******
     logging synchronous
     login
    !
    !
    end

    Other configurations may work, but this config worked for me...

  • Hi Darrell,

    Thanks for the quick response. I removed all the aliases and modified config to match the suggestion exactly as you provided, but still not able to connect. It just stays at "Trying 10.1.1.2, 2015 ... Open". If I reboot the remote device while in this state, I can see it rebooting but not able to type anything inside. Also, just in case, all my remote devices are at factory setting configs as I erased startup and reloaded. Does this matter? I figured it wouldn't since I thought they should be at blank configs and ready for me to copy the different inital configs from workbooks. Any other suggestions? Please let me know.

     

  • TermServer#telnet 10.1.1.2 2001
    Trying 10.1.1.2, 2001 ... Open

    Nothing looks wrong here - the "Open" means you are connected to your device - press the enter key a few times to what happens.

    The config I have on my lines is -

    line 1 16
     no exec
     exec-timeout 0 0
     transport input telnet

     

  •  "Trying 10.1.1.2, 2015 ... Open". 

     

    It indicates that your Access server configuration for the line number 2015 is fine but it doesn't necessarily mean that your host is connected with the console and running. If you have configured and mapped "ip host <hostname> <IP> <port> successfully which is also called "reverse telnet" mechanism, you will be able to see its status "open" even if your host is disconnected.

     

    Good luck!

  • TermServer#telnet 10.1.1.2 2001
    Trying 10.1.1.2, 2001 ... Open

    Hello, welshydragon and Hari.sapkota. Thanks for the response. pressing "enter" or any key does not work. If I physically powercycle device in line 2001, in my case SW1, while in this "open" prompt, I will see the switch booting all the way to the "press ENTER to get started" prompt. However, any keys that I press do not work. This is the same issue for all my lines. Any idea why this would happen?

  • This could be due to your Octol Cable issue or might be issue with Async port. Sometimes in Cisco2500 series Access server, i have exprienced such an issue and later I came to know that one of two Async ports was damaged. So, better if you check it from hardware level rather than configuration of reverse telnet.

    Good luck!

  • Hari - You were right. The problem is solved! [:D]. I contacted ebay seller and got replacement 2511. Placed same config on and it works!!!  Thanks to all for the help and advice.

    Thanks!!

  • Hari - You were right. The problem is solved! Big Smile. I contacted ebay seller and got replacement 2511. Placed same config on and it works!!!  Thanks to all for the help and advice.

    Thanks!!

    It was obvious that your configuration didn't have any notable issue. Actually it happens on older hardware like 2500 and 2600 series routers. So, my recommendation would be to dedicate an ISR router with an Async port installed on it.. that would make more reliable access server which i'm also doing for my rack. 

    And most importantly, you have go to through hardware issue first to achieve quicker troubleshooting. [:)]

     

    Good luck!

  • How to solve it if I get connection refused message? And I am also getting " Unknown command or computer name" when giving "R10" in cli.

     

  • Hi,

    I think you are getting same message as shown below: If I'm not wrong, please take a look into the steps:

    Access_server#R3

    Trying R3 (172.16.20.1, 2003)...

    % Connection refused by remote host

     

    Access_server#cle

    Access_server#clear line

    Access_server#clear line 3

    [confirm]

     [OK]

    Access_server#R3

    Trying R3 (172.16.20.1, 2003)... Open

     

    Since you are asking about your "R10" is not found it's because of you don't have any mapping on your reverse telnet configuration with "ip host" command.

     

    Hope this helps!

  • Thanks, its working. silly mistake I have done! 

Sign In or Register to comment.