MPLS L3 VPN with EIGRP (ATC)


Hello....

I'm going through the ATC videos and trying out those very implementations
using GNS3 (XR just kept the name but it’s all normal ios), for some reason my routes
are getting into the CEs, I see them in the PEs. I have mutual redistribution
and consistent RTs and Eigrp Ass, and eigrp neighbor-ship for the Vrf is up:-

Please see my Config from one of the PEs: Thx in advance

 R2#show run
Building configuration...

Current configuration : 2032 bytes
!
upgrade fpd auto
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
vrf definition VPNA
 description TEST_VPNA
 rd 888:10
 route-target export 888:10
 route-target import 888:10
 !
 address-family ipv4
 exit-address-family
!
vrf definition VPNB
 rd 888:40
 route-target export 888:40
 route-target import 888:40
 !
 address-family ipv4
 exit-address-family
!
!
no aaa new-model
!
!
!
ip source-route
ip cef
!
!
!
!
no ipv6 cef
!
multilink bundle-name authenticated
mpls label range 2000 2999
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
redundancy
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
 !
!
interface FastEthernet0/0
 vrf forwarding VPNA
 ip address 10.1.2.2 255.255.255.0
 duplex auto
 speed auto
 !
!
interface FastEthernet0/1
 ip address 20.2.3.2 255.255.255.0
 ip router isis
 duplex auto
 speed auto
 mpls ip
 !
!
interface FastEthernet1/0
 vrf forwarding VPNB
 ip address 40.2.7.2 255.255.255.0
 duplex full
 !
!
!
router eigrp 10
 !
 address-family ipv4 vrf VPNA autonomous-system 30
  redistribute bgp 888
  network 10.1.2.0 0.0.0.255
 exit-address-family
!
router isis
 net 49.0001.0000.0000.0002.00
 is-type level-2-only
 passive-interface Loopback0
!
router bgp 888
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 3.3.3.3 remote-as 888
 neighbor 3.3.3.3 update-source Loopback0
 !
 address-family ipv4
  no synchronization
  no auto-summary
 exit-address-family
 !
 address-family vpnv4
  neighbor 3.3.3.3 activate
  neighbor 3.3.3.3 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf VPNA
  no synchronization
  redistribute eigrp 30
 exit-address-family
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
!
control-plane
 !
!
!
mgcp fax t38 ecm
mgcp behavior g729-variants static-pt
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 login
!
end

Comments

  • for some reason my routes are getting into the CEs

    I hope you are not getting routes in CEs right? Your configurations looks good, only be aware about EIGRP auto-summarization, which is truns on by default. I have also seen when we have EIGRP PE-CE protocol with metric propogation through VPN redistribution process of VRF hangs.

     clear the vrf routing table using clear ip route vrf VPNA it should work.

    Good Luck with your studies!

  • Narayan,

    I tried the clear ip route vrf VPNA and it didnt work but when i the eirgp isntance and pasted back the same eigrp config it worked!

    Many thaks for your help

  • In my opinion it is best to set the metric, because you can be graded after a reload/crash so with the set metric it works well.

  • unless i set to the same values in the VPNV4 routes on the PE, because i wanted to take advantage of the extended community attribute that carries the eigrp metric all through the core...may be i just didnt get what you meant[:)]

     

  • Yes in fact we dont have to set the metric because there is the extendend community but on this platform it seems to be buggy!

  • Yes in fact we dont have to set the metric because there is the extendend community but on this platform it seems to be buggy!


     

    Yes this should be a kind of bug because I tried on different IOS version got same result but I couldn't find this issue on IOS XR.

    Good Luck with your studies!

Sign In or Register to comment.