Switch replacement procedure 3560G to 3750X

Hello  Cisco experts,

 

 

My company will replace two 3560G (HSRP active Standby) with 2 3750X ( will
be stacked)  switches in the near future.

 

I need to make a switch replacement procedure ( starting from removing the
3560s  until the 3750x are put online, but i think i need your advice.

I have  google it, searched cisco website documents, various forums but i
couldnt find something to suit my needs.

 

My approach will be to

1. backup the standby  3560 config (traffi will flow through the active 3560)
.

2. remove the plug of 3560and put in one 3750x. Configure 3750x to accept
traffic and to be the  stack master.

3. backup the config on the remaining 3560 and remove it.

4. Plug in the second 3750x

5. Configure it as stack member.

 

 

Can you please advise me , point me to any document that shows a step by step
procedure when replacing a cisco ( moving fr one mode to another)

I am attaching show run








  •  

    I am pasting the two 3560G sh run :

     

    Location : Data center aggregation

    Vlan 10 --- WAN, Vlan 20 FW; NET , Vlan 40 DMZ  , VLAN 50 Vmware,

     

    Is there a written procedure when transition between switches ?

     

    HSRP Active

     

    version 12.2

     

    !

    interface GigabitEthernet0/1

    switchport access vlan 10

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/2

    switchport access vlan 10

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/3

    switchport access vlan 20

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/4

    switchport access vlan 20

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/5

    switchport access vlan 30

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/6

    switchport access vlan 30

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/7

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/8

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/9

    switchport access vlan 50

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/10

    switchport access vlan 50

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/11

    switchport access vlan 60

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/12

    switchport access vlan 60

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/13

    switchport access vlan 70

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/14

    switchport access vlan 70

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/15

    switchport access vlan 80

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/16

    switchport access vlan 80

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/17

    switchport access vlan 90

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/18

    switchport access vlan 90

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/19

    switchport access vlan 100

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/20

    switchport access vlan 100

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/21

    speed 100

    duplex full

    !

    interface GigabitEthernet0/22

    switchport access vlan 50

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/23

    switchport access vlan 50

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/24

    switchport trunk encapsulation dot1q

    switchport trunk allowed vlan 10,20,30,50,60,70,80,90,100

    switchport mode trunk

    !

    interface GigabitEthernet0/25

    !

    interface GigabitEthernet0/26

    !

    interface GigabitEthernet0/27

    !

    interface GigabitEthernet0/28

    !

    interface Vlan1

    ip address 192.168.1.201 255.255.255.0

    no ip redirects

    standby 0 ip 192.168.1.20

    standby 0 priority 105

    standby 0 preempt

    !

    interface Vlan10

    ip address 172.20.10.2 255.255.255.0

    no ip redirects

    standby 1 ip 172.20.10.1

    standby 1 priority 105

    standby 1 preempt

    !

    interface Vlan20

    ip address 172.20.20.2 255.255.255.0

    no ip redirects

    standby 2 ip 172.20.20.1

    standby 2 priority 105

    standby 2 preempt

    !

    interface Vlan30

    ip address 172.20.30.2 255.255.255.0

    no ip redirects

    standby 3 ip 172.20.30.1

    standby 3 priority 105

    standby 3 preempt

    !

    interface Vlan40

    ip address 172.20.40.2 255.255.255.0

    no ip redirects

    standby 4 ip 172.20.40.1

    standby 4 priority 105

    standby 4 preempt

    !

    interface Vlan50

    ip address 172.20.50.2 255.255.255.0

    no ip redirects

    standby 5 ip 172.20.50.1

    standby 5 priority 105

    standby 5 preempt

    !

    interface Vlan60

    ip address 172.20.60.2 255.255.255.0

    no ip redirects

    standby 6 ip 172.20.60.1

    standby 6 priority 105

    standby 6 preempt

    !

    interface Vlan70

    ip address 172.20.70.2 255.255.255.0

    no ip redirects

    standby 7 ip 172.20.70.1

    standby 7 priority 105

    standby 7 preempt

    !

    interface Vlan80

    ip address 172.20.80.2 255.255.255.0

    no ip redirects

    standby 8 ip 172.20.80.1

    standby 8 priority 105

    standby 8 preempt

    !

    interface Vlan90

    ip address 172.20.90.2 255.255.255.0

    no ip redirects

    standby 9 ip 172.20.90.1

    standby 9 priority 105

    standby 9 preempt

    !

    interface Vlan100

    ip address 172.20.100.2 255.255.255.0

    no ip redirects

    standby 10 ip 172.20.100.1

    standby 10 priority 105

    standby 10 preempt

     

     

    HSRP Standby 

     

     

    version 12.2

     

    interface GigabitEthernet0/1

    switchport access vlan 10

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/2

    switchport access vlan 10

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/3

    switchport access vlan 20

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/4

    switchport access vlan 20

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/5

    switchport access vlan 30

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/6

    switchport access vlan 30

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/7

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/8

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/9

    switchport access vlan 50

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/10

    switchport access vlan 50

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/11

    switchport access vlan 60

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/12

    switchport access vlan 60

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/13

    switchport access vlan 70

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/14

    switchport access vlan 70

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/15

    switchport access vlan 80

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/16

    switchport access vlan 80

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/17

    switchport access vlan 90

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/18

    switchport access vlan 90

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/19

    switchport access vlan 100

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/20

    switchport access vlan 100

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/21

    !

    interface GigabitEthernet0/22

    switchport access vlan 50

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/23

    switchport access vlan 50

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/24

    switchport trunk encapsulation dot1q

    switchport trunk allowed vlan 10,20,30,50,60,70,80,90,100

    switchport mode trunk

    !

    interface GigabitEthernet0/25

    !

    interface GigabitEthernet0/26

    !

    interface GigabitEthernet0/27

    !

    interface GigabitEthernet0/28

    !

    interface Vlan1

    ip address 192.168.1.202 255.255.255.0

    no ip redirects

    standby ip 192.168.1.20

    standby preempt

    !

    interface Vlan10

    ip address 172.20.10.3 255.255.255.0

    no ip redirects

    standby 1 ip 172.20.10.1

    standby 1 preempt

    !

    interface Vlan20

    ip address 172.20.20.3 255.255.255.0

    no ip redirects

    standby 2 ip 172.20.20.1

    standby 2 preempt

    !

    interface Vlan30

    ip address 172.20.30.3 255.255.255.0

    no ip redirects

    standby 3 ip 172.20.30.1

    standby 3 preempt

    !

    interface Vlan40

    ip address 172.20.40.3 255.255.255.0

    no ip redirects

    standby 4 ip 172.20.40.1

    standby 4 preempt

    !

    interface Vlan50

    ip address 172.20.50.3 255.255.255.0

    no ip redirects

    standby 5 ip 172.20.50.1

    standby 5 preempt

    !

    interface Vlan60

    ip address 172.20.60.3 255.255.255.0

    standby 6 ip 172.20.60.1

    standby 6 preempt

    !

    interface Vlan70

    ip address 172.20.70.3 255.255.255.0

    no ip redirects

    standby 7 ip 172.20.70.1

    standby 7 preempt

    !

    interface Vlan80

    ip address 172.20.80.3 255.255.255.0

    no ip redirects

    standby 8 ip 172.20.80.1

    standby 8 preempt

    !

    interface Vlan90

    ip address 172.20.90.3 255.255.255.0

    no ip redirects

    standby 9 ip 172.20.90.1

    standby 9 preempt

    !

    interface Vlan100

    ip address 172.20.100.3 255.255.255.0

    no ip redirects

    standby 10 ip 172.20.100.1

    standby 10 preempt 








 

 

 

Thank you in advance for your help.

 

PS :Excuse my English. I am japanese. :d 

Comments

  • My approach will be to

    1. backup the standby  3560 config (traffi will flow through the active 3560)
    .

    2. remove the plug of 3560and put in one 3750x. Configure 3750x to accept
    traffic and to be the  stack master.

    3. backup the config on the remaining 3560 and remove it.

    4. Plug in the second 3750x

    5. Configure it as stack member.

     

     

    Can you please advise me , point me to any document that shows a step by step
    procedure when replacing a cisco ( moving fr one mode to another)

    Hi Tsubasa,

    I don't believe there is such doc that tell you the process to migrate from Cat 3560G to Cat 3750X stackwise. 

    Catalyst 3560G does not support Cisco stackwise, while Cat 3750X supports stackwise+.

    Your Cat 3560G runs HSRP, but when you migrate to Cat3750X with stackwise, you don't need it because Cat3750X runs single control plane on the stack. 

    What you need to do is:

    1. map the port from 3560G to 3750X and configure 3750X port accordingly

    2. configure the SVI without HSRP

    3. configure the rest

    My migration plan would be pre-configure 3750X stack, power it on in the same rack and then move the links. 

  • Alexander is exactly correct.  I would add two points.  If you're looking for near zero downtime and have the rack space:
    1) rack up the 3750 stack.  
    2) config hsrp priority 200 (or whatever u need to assure its first) and preempt 
    3) connect it to the network. 
    4) migrate user connections
    5) take out 3560s
    6) remove hsrp config (script this and be consoled because u will be changing IP and don't want to lose connectivity). 





    Sent from my iPhone

    On Jun 27, 2013, at 2:24 AM, Alexander.Halim <[email protected]> wrote:

    imageTsubasa:

    My approach will be to

    1. backup the standby  3560 config (traffi will flow through the active 3560)
    .

    2. remove the plug of 3560and put in one 3750x. Configure 3750x to accept
    traffic and to be the  stack master.

    3. backup the config on the remaining 3560 and remove it.

    4. Plug in the second 3750x

    5. Configure it as stack member.

     

     

    Can you please advise me , point me to any document that shows a step by step
    procedure when replacing a cisco ( moving fr one mode to another)

    Hi Tsubasa,

    I don't believe there is such doc that tell you the process to migrate from Cat 3560G to Cat 3750X stackwise. 

    Catalyst 3560G does not support Cisco stackwise, while Cat 3750X supports stackwise+.

    Your Cat 3560G runs HSRP, but when you migrate to Cat3750X with stackwise, you don't need it because Cat3750X runs single control plane on the stack. 

    What you need to do is:

    1. map the port from 3560G to 3750X and configure 3750X port accordingly

    2. configure the SVI without HSRP

    3. configure the rest

    My migration plan would be pre-configure 3750X stack, power it on in the same rack and then move the links. 




    INE - The Industry Leader in CCIE Preparation


    http://www.INE.com



  • Why even go with stacking the 3750s? You dont really limit your failure risk any less than you currently have you just introduce new failure scenarios (split-brain, stack failure, master failure, etc..). The only positive I see is only having a single device to configure one stacked.

     

    If it were me I would bring down the secondary 3560 and replace with a single 3750. Shift primary over to 3750. Then bring down the primary 3560 and replace it with a 3750. Shift primary back.

     

    Configs should need little to no modifications and should transition from 3560 to 3750 pretty easy.

     

    Just my opinion.

  • peetypeety ✭✭✭

    You need to read the Cisco doc on how to stack switches together before you do anything else, and when you get the switches you need to practice it.  Honestly, if it were me, make room in the rack for the 3750Xes, mount them, stack them, cable them to the existing switches temporarily, move everything over, and decomm the 3560s.

  • Why even go with stacking the 3750s? You dont really limit your failure risk any less than you currently have you just introduce new failure scenarios (split-brain, stack failure, master failure, etc..). The only positive I see is only having a single device to configure one stacked..

    Hi Ryan, I agree with you from design perspective. Replacing two 3560G with one 3750X stack is introducing one failure domain which may not be preferred in high available network.

  • peetypeety ✭✭✭

    Hi Ryan, I agree with you from design perspective. Replacing two 3560G with one 3750X stack is introducing one failure domain which may not be preferred in high available network.

    Correct, but there are great operational gains to be had from a stacked switch instead of two independent switches - etherchannel to downstream/upstream devices means the OP can double their operational bandwidth without running a single new cable.  This converts from an active/standby scenario to an active/active scenario.

  • Correct, but there are great operational gains to be had from a stacked switch instead of two independent switches - etherchannel to downstream/upstream devices means the OP can double their operational bandwidth without running a single new cable.  This converts from an active/standby scenario to an active/active scenario.

    Yes, agree with you as well. In design, you always need to give and take. You cannot have the beauty of both worlds.

    How about replacing the switches with N5K + vPC? But still, you have orphan ports scenario that you need to take care of.

    Thanks for sharing

  • peetypeety ✭✭✭

    How about replacing the switches with N5K + vPC? But still, you have orphan ports scenario that you need to take care of.

    N5K means tradeoffs too:

    Older-style N5010/5020 are very limited boxes. They're 60% XE and only 40% switchable GE/XE, so probably not the right port speeds to drop into the space where the 3560Gs sit currently.  They're also port-limited; to get to 48 ports it'd take a 5020 plus an expansion card, which means twice the rack space consumption.  These might be available on the used market for what 3750Xes run.

    Newer-style N5548 are very expensive, though more flexible with speed than the 5010/5020.  They offer XE and GE, but no FE; legacy connections would need an intermediate speed converter to connect in.  These will also be quite a bit more expensive than a pair of 3750X switches.

    Nexus 3048 could be a suitable alternative, but they have lots of limitations, and I have no idea what the price point is.

  • Thank you guys. 

     

    I got the point now. The company has already bought the 3750x. 

     

    Thank you all for your great support. 

     

     

     

Sign In or Register to comment.