14.3 no pop label for 150.1.4.4/32 on R5 and R6 after applying the filter

Hi

After applying the access-list on R4 , R5 , R6 .. I can not see  pop label for 150.1.4.4/32 on R5 and R6.

Please advice

 

Rack1R4#sh run | sec mpls
mpls label protocol ldp
mpls ldp neighbor 150.1.6.6 password CISCO
mpls ldp neighbor 150.1.5.5 password CISCO
no mpls ldp advertise-labels
mpls ldp advertise-labels for 10
 mpls ldp discovery transport-address interface
 mpls ip
 mpls ldp autoconfig
mpls ldp router-id Loopback0 force

Rack1R4#sh ip access-lists 10
Standard IP access list 10
    10 permit 150.1.4.0, wildcard bits 0.0.0.255 (8 matches)
    20 permit 150.1.5.0, wildcard bits 0.0.0.255 (8 matches)
    30 permit 150.1.6.0, wildcard bits 0.0.0.255 (6 matches)

Rack1R4#sh mpls forwarding-table | i 150.1.(5|6).
35     Pop tag     150.1.6.0/24      0          Et0/1      155.1.146.6
36     Pop tag     150.1.5.0/24      0          Se1/1      point2point
       Pop tag     150.1.5.0/24      0          Se1/0      155.1.0.5
45     Untagged    150.1.5.5/32      0          Se1/1      point2point
46     Untagged    150.1.6.6/32      0          Et0/1      155.1.146.6

Rack1R5#sh run | sec mpls
mpls label protocol ldp
mpls ldp neighbor 150.1.4.4 password CISCO
no mpls ldp advertise-labels
mpls ldp advertise-labels for 10
 mpls ip
 mpls ip
mpls ldp router-id Loopback0 force

Rack1R5#sh ip access-lists 10
Standard IP access list 10
    10 permit 150.1.4.0, wildcard bits 0.0.0.255 (7 matches)
    20 permit 150.1.5.0, wildcard bits 0.0.0.255 (5 matches)
    30 permit 150.1.6.0, wildcard bits 0.0.0.255 (3 matches)

Rack1R5#sh mpls forwarding-table | i 150.1.(4|6).
38     Untagged    150.1.4.4/32      0          Se1/1      point2point
40     46          150.1.6.6/32      0          Se1/1      point2point

 

Rack1R6#sh run | sec mpls
mpls label protocol ldp
mpls ldp neighbor 150.1.4.4 password CISCO
no mpls ldp advertise-labels
mpls ldp advertise-labels for 10
 mpls ldp discovery transport-address interface
 mpls ip
mpls ldp router-id Loopback0 force

Rack1R6#sh ip access-lists 10
Standard IP access list 10
    10 permit 150.1.4.0, wildcard bits 0.0.0.255 (7 matches)
    20 permit 150.1.5.0, wildcard bits 0.0.0.255 (5 matches)
    30 permit 150.1.6.0, wildcard bits 0.0.0.255 (3 matches)
Rack1R6#
Rack1R6#sh mpls forw
Rack1R6#sh mpls forwarding-table | i 150.1.(4|5).
35     Untagged    150.1.4.4/32      0          Et0/0.146  155.1.146.4
36     45          150.1.5.5/32      0          Et0/0.146  155.1.146.4
Rack1R6#

 

 

Comments


  • You are doing for a /24, it needs to be /32. Try the following:

    access-list 10 permit host 150.1.4.4

    access-list 10 permit host 150.1.5.5

    access-list 10 permit host 150.1.6.6

    It should work

    HTH

    Good luck!

  • Hi ,

    Thanks for the info..

    the issue still exists even after changing the access-list

    Rack1R4#sh mpls forwarding-table | i 150.1.(5|6).
    35     Untagged    150.1.6.0/24      0          Et0/1      155.1.146.6
    36     Untagged    150.1.5.0/24      0          Se1/1      point2point
           Untagged    150.1.5.0/24      0          Se1/0      155.1.0.5
    45     Untagged    150.1.5.5/32      0          Se1/1      point2point
    46     Untagged    150.1.6.6/32      0          Et0/1      155.1.146.6

    Rack1R4#sh run |  i access-list
    access-list 10 permit 150.1.4.4
    access-list 10 permit 150.1.5.5
    access-list 10 permit 150.1.6.6
    Rack1R4#

    Rack1R5(config)#access-list 10 permit 150.1.4.4
    Rack1R5(config)#access-list 10 permit 150.1.5.5
    Rack1R5(config)#access-list 10 permit 150.1.6.6
    Rack1R5(config)#exit
    Rack1R5#
    *Mar  1 03:15:04.463: %SYS-5-CONFIG_I: Configured from console by console
    Rack1R5#sh mpls for
    Rack1R5#sh mpls forwarding-table | i 150.1.(4|6).
    38     Untagged    150.1.4.4/32      0          Se1/1      point2point
    40     46          150.1.6.6/32      0          Se1/1      point2point

    Rack1R6(config)#access-list 10 permit 150.1.4.4
    Rack1R6(config)#access-list 10 permit 150.1.5.5
    Rack1R6(config)#access-list 10 permit 150.1.6.6
    Rack1R6(config)#
    Rack1R6(config)#exit

    Rack1R6#sh mpls forwarding-table | i 150.1.(4|5).
    35     Untagged    150.1.4.4/32      0          Et0/0.146  155.1.146.4
    36     45          150.1.5.5/32      0          Et0/0.146  155.1.146.4
    Rack1R6#

     

  • Hi,

    Looks like your routers are not advertising the labels to one another. Please check the following:

    - Do you have MPLS IP enabled on your IGP enabled interfaces? Are all the routers agreeing on LDP vs TDP? I would recommend configuring mpls ldp autoconfig under OSPF or ISIS as it makes your config less prone to errors.

    - Do you have CEF enabled on your routers?

    - How are your loopbacks advertised into IGP? Have you just enabled OSPF on the Loopbacks or have you configured your Loopbacks to be point-to-point network type?

    If you could post your config, I can take a look into it.

    HTH

    Good luck!

  • After applying the access-list on R4 , R5 , R6 .. I can not see  pop label for 150.1.4.4/32 on R5 and R6.

    Please advice

     

    Hi,

    As far I see in your config, you have configured mpls ldp autoconfig for all OSPF area on R4.

    Can you check and come with debug mpls ldp binding output from R5/R6?

    1. Check the routing, if you are correctly getting the route on R5/R6.

    2. Check the CEF is enabled or not

    4. Check LDP neighborship, using show mpls ldp neighbor/show mpls ldp discovery

    3. Turn on the debug mpls ldp binding  and clear the ldp neigghbor using clear mpls ldp neighbor *

    Good Luck


  • Hi qqabdal / Narayan,

    Thanks for your quick response..

     I tried enabling mpls ldp autoconfig feature on R4, R5, R6 but no luck. MPLS is enabled on the interfaces included in IGP.
     when I configured the loopback intf as OSPF point-to-point , I could not see outgoing label for loopback intf of R4, R5, R6.

    I am running this lab on GNS3..

    Rack1R4#sh mpls forwarding-table | i 150.1
    16     Untagged    150.1.5.0/24      0          Se1/1      point2point
    19     Untagged    150.1.2.0/24      0          Se1/1      point2point
           Untagged    150.1.2.0/24      0          Se1/0      155.1.0.2
    22     Untagged    150.1.1.0/24      0          Se1/1      point2point
           Untagged    150.1.1.0/24      0          Se1/0      155.1.0.1
    23     Untagged    150.1.3.0/24      0          Se1/1      point2point
           Untagged    150.1.3.0/24      0          Se1/0      155.1.0.3
    27     Untagged    150.1.7.0/24      0          Se1/1      point2point
           Untagged    150.1.7.0/24      0          Se1/0      155.1.0.3
    28     Untagged    150.1.6.0/24      0          Et0/1      155.1.146.6

    Rack1R5#sh mpls forwarding-table | i 150.1
    16     Untagged    150.1.0.0/16      0          Se1/1      point2point
           Untagged    150.1.0.0/16      0          Se1/0      155.1.0.4
    19     Untagged    150.1.2.0/24      0          Se1/0      155.1.0.2
    22     Untagged    150.1.1.0/24      0          Se1/0      155.1.0.1
    24     Untagged    150.1.3.0/24      0          Se1/0      155.1.0.3
    27     Untagged    150.1.7.0/24      0          Se1/0      155.1.0.3
    28     Untagged    150.1.4.0/24      0          Se1/1      point2point
    41     Untagged    150.1.6.0/24      0          Se1/1      point2point

    Rack1R6#sh mpls forwarding-table | i 150.1.
    20     Untagged    150.1.0.0/16      0          Et0/0.146  155.1.146.4
    37     Untagged    150.1.4.0/24      0          Et0/0.146  155.1.146.4
    38     Untagged    150.1.5.0/24      0          Et0/0.146  155.1.146.4

    *****After removing the point-to-point network type from lo 0 on R4 , R5 , R6

    Rack1R4#sh mpls forwarding-table | i 150.1.(5|6).
    16     Untagged    150.1.5.0/24      0          Se1/1      point2point
           Untagged    150.1.5.0/24      0          Se1/0      155.1.0.5
    26     Untagged    150.1.5.5/32      0          Se1/1      point2point
    28     Untagged    150.1.6.0/24      0          Et0/1      155.1.146.6
    30     Untagged    150.1.6.6/32      0          Et0/1      155.1.146.6

    Rack1R5#sh mpls forwarding-table | i 150.1.(4|6).
    26     Untagged    150.1.4.4/32      0          Se1/1      point2point
    31     30          150.1.6.6/32      0          Se1/1      point2point

    Rack1R6#sh mpls forwarding-table | i 150.1.
    20     Untagged    150.1.0.0/16      0          Et0/0.146  155.1.146.4
    24     Untagged    150.1.4.4/32      0          Et0/0.146  155.1.146.4
    25     26          150.1.5.5/32      0          Et0/0.146  155.1.146.4

    *******Debug  output

    Rack1R5#debug mpls ldp bindings
    LDP Label Information Base (LIB) changes debugging is on
    Rack1R5#clear mpls ldp neigh *
    Rack1R5#
    *Mar  1 01:52:41.967: %LDP-5-CLEAR_NBRS: Clear LDP neighbors (*) by console
    *Mar  1 01:52:41.983: %LDP-5-NBRCHG: LDP Neighbor 150.1.4.4:0 (1) is DOWN (User cleared session manually)
    Rack1R5#
    *Mar  1 01:52:48.043: tagcon: (Default-IP-Routing-Table) Assign peer id; 150.1.4.4:0: id 1
    *Mar  1 01:52:48.047: %LDP-5-NBRCHG: LDP Neighbor 150.1.4.4:0 (2) is UP
    *Mar  1 01:52:48.191: tagcon: 150.1.4.4:0: 150.1.4.4 added to addr<->ldp ident map
    *Mar  1 01:52:48.195: tagcon: 150.1.4.4:0: 204.12.1.4 added to addr<->ldp ident map
    *Mar  1 01:52:48.199: tagcon: 150.1.4.4:0: 155.1.146.4 added to addr<->ldp ident map
    *Mar  1 01:52:48.203: tagcon: 150.1.4.4:0: 155.1.45.4 added to addr<->ldp ident map
    *Mar  1 01:52:48.207: tagcon: 150.1.4.4:0: 155.1.0.4 added to addr<->ldp ident map
    *Mar  1 01:52:48.211: tagcon: tibent(150.1.5.5/32): label 26 from 150.1.4.4:0 added
    *Mar  1 01:52:48.215: tagcon: tibent(150.1.6.6/32): label 30 from 150.1.4.4:0 added
    Rack1R5#
    *Mar  1 01:52:48.219: tagcon: announce labels for: 150.1.6.6/32; nh 155.1.45.4, Se1/1, inlabel 31, outlabel 30 (from 150.1.4.4:0), add rem binding
    Rack1R5#

    Rack1R6#
    *Mar  1 01:54:14.195: %LDP-5-CLEAR_NBRS: Clear LDP neighbors (*) by console
    *Mar  1 01:54:14.211: %LDP-5-NBRCHG: LDP Neighbor 150.1.4.4:0 (1) is DOWN (User cleared session manually)
    Rack1R6#
    *Mar  1 01:54:19.607: tagcon: (Default-IP-Routing-Table) Assign peer id; 150.1.4.4:0: id 1
    *Mar  1 01:54:19.611: %LDP-5-NBRCHG: LDP Neighbor 150.1.4.4:0 (2) is UP
    *Mar  1 01:54:19.739: tagcon: 150.1.4.4:0: 150.1.4.4 added to addr<->ldp ident map
    *Mar  1 01:54:19.743: tagcon: 150.1.4.4:0: 204.12.1.4 added to addr<->ldp ident map
    *Mar  1 01:54:19.747: tagcon: 150.1.4.4:0: 155.1.146.4 added to addr<->ldp ident map
    *Mar  1 01:54:19.751: tagcon: 150.1.4.4:0: 155.1.45.4 added to addr<->ldp ident map
    *Mar  1 01:54:19.755: tagcon: 150.1.4.4:0: 155.1.0.4 added to addr<->ldp ident map
    *Mar  1 01:54:19.759: tagcon: tibent(150.1.5.5/32): label 26 from 150.1.4.4:0 added
    *Mar  1 01:54:19.763: tagcon: announce labels for: 150.1.5.5/32; nh 155.1.146.4, Et0/0.146, inlabel 25, outlabel 26 (from 150.1.4.4:0), add rem binding
    Rack1R6#
    *Mar  1 01:54:19.771: tagcon: tibent(150.1.6.6/32): label 30 from 150.1.4.4:0 added
    Rack1R6#
    *Mar  1 01:54:21.503: tagcon: (Default-IP-Routing-Table) Deassign peer id; 150.1.4.4:0: id 0
    Rack1R6#

    **************** FOR R4,R5,R6
    Cisco IOS Software, 3600 Software (C3640-JK9O3S-M), Version 12.4(12), RELEASE SOFTWARE (fc1)


    Rack1R4#sh run
    Building configuration...

    Current configuration : 2192 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Rack1R4
    !
    boot-start-marker
    boot-end-marker
    !
    enable password cisco
    !
    no aaa new-model
    memory-size iomem 5
    !
    !
    ip cef
    no ip domain lookup
    !
    !
    !
    mpls label protocol ldp
    mpls ldp neighbor 150.1.6.6 password CISCO
    mpls ldp neighbor 150.1.5.5 password CISCO
    no mpls ldp advertise-labels
    mpls ldp advertise-labels for 10
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface Loopback0
     ip address 150.1.4.4 255.255.255.0
    !
    interface Ethernet0/0
     ip address 204.12.1.4 255.255.255.0
     full-duplex
     mpls ip
    !
    interface Ethernet0/1
     ip address 155.1.146.4 255.255.255.0
     full-duplex
     mpls ldp discovery transport-address interface
     mpls ip
    !
    interface Ethernet0/2
     no ip address
     shutdown
     half-duplex
    !
    interface Ethernet0/3
     no ip address
     shutdown
     half-duplex
    !
    interface Serial1/0
     ip address 155.1.0.4 255.255.255.0
     encapsulation frame-relay
     mpls ip
     serial restart-delay 0
     frame-relay map ip 155.1.0.5 405 broadcast
     no frame-relay inverse-arp
    !
    interface Serial1/1
     ip address 155.1.45.4 255.255.255.0
     mpls ip
     serial restart-delay 0
    !
    interface Serial1/2
     no ip address
     shutdown
     serial restart-delay 0
    !
    interface Serial1/3
     no ip address
     shutdown
     serial restart-delay 0
    !
    router ospf 1
     log-adjacency-changes
     network 0.0.0.0 255.255.255.255 area 0
    !
    router rip
     version 2
     network 150.1.0.0
     network 155.1.0.0
     network 204.12.1.0
    !
    ip http server
    no ip http secure-server
    !
    !
    !
    access-list 10 permit 150.1.4.4
    access-list 10 permit 150.1.5.5
    access-list 10 permit 150.1.6.6
    !
    !
    mpls ldp router-id Loopback0 force
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    alias exec s sh ip int b
    alias exec su sh run
    alias exec c config t
    alias exec sr sh ip route
    alias exec o sh ip route ospf
    alias exec e sh ip route eigrp
    alias exec r sh ip route rip
    alias exec b sh ip route bgp
    alias exec ne sh ip eigrp nei
    alias exec no sh ip ospf nei
    alias exec nb sh ip bgp summary
    alias exec m sh ip mroute
    alias exec nm sh ip multicast nei
    alias exec sv6 sh ipv6 route
    !
    line con 0
     exec-timeout 0 0
     privilege level 15
     logging synchronous
    line aux 0
    line vty 0 4
     login
    !
    !
    end

    Rack1R4#

    Rack1R5#sh run
    Building configuration...

    Current configuration : 2228 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Rack1R5
    !
    boot-start-marker
    boot-end-marker
    !
    enable password cisco
    !
    no aaa new-model
    memory-size iomem 5
    !
    !
    ip cef
    no ip domain lookup
    !
    !
    !
    mpls label protocol ldp
    mpls ldp neighbor 150.1.4.4 password CISCO
    no mpls ldp advertise-labels
    mpls ldp advertise-labels for 10
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface Loopback0
     ip address 150.1.5.5 255.255.255.0
    !
    interface Ethernet0/0
     ip address 155.1.58.5 255.255.255.0
     full-duplex
     mpls ip
    !
    interface Ethernet0/1
     ip address 155.1.5.5 255.255.255.0
     full-duplex
     mpls ip
    !
    interface Ethernet0/2
     no ip address
     shutdown
     half-duplex
    !
    interface Ethernet0/3
     no ip address
     shutdown
     half-duplex
    !
    interface Serial1/0
     ip address 155.1.0.5 255.255.255.0
     encapsulation frame-relay
     mpls ip
     serial restart-delay 0
     frame-relay map ip 155.1.0.1 501 broadcast
     frame-relay map ip 155.1.0.2 502 broadcast
     frame-relay map ip 155.1.0.3 503 broadcast
     frame-relay map ip 155.1.0.4 504 broadcast
     no frame-relay inverse-arp
    !
    interface Serial1/1
     ip address 155.1.45.5 255.255.255.0
     mpls ip
     serial restart-delay 0
    !
    interface Serial1/2
     no ip address
     shutdown
     serial restart-delay 0
    !
    interface Serial1/3
     no ip address
     shutdown
     serial restart-delay 0
    !
    router ospf 1
     log-adjacency-changes
     network 0.0.0.0 255.255.255.255 area 0
    !
    router rip
     version 2
     network 150.1.0.0
     network 155.1.0.0
     no auto-summary
    !
    ip http server
    no ip http secure-server
    !
    !
    !
    access-list 10 permit 150.1.4.4
    access-list 10 permit 150.1.5.5
    access-list 10 permit 150.1.6.6
    !
    !
    mpls ldp router-id Loopback0 force
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    alias exec s sh ip int b
    alias exec su sh run
    alias exec c config t
    alias exec sr sh ip route
    alias exec o sh ip route ospf
    alias exec e sh ip route eigrp
    alias exec r sh ip route rip
    alias exec b sh ip route bgp
    alias exec ne sh ip eigrp nei
    alias exec no sh ip ospf nei
    alias exec nb sh ip bgp summary
    alias exec m sh ip mroute
    alias exec nm sh ip multicast nei
    alias exec sv6 sh ipv6 route
    !
    line con 0
     exec-timeout 0 0
     privilege level 15
     logging synchronous
    line aux 0
    line vty 0 4
     login
    !
    !
    end

    Rack1R5#

    Rack1R6#sh run
    Building configuration...

    Current configuration : 2287 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Rack1R6
    !
    boot-start-marker
    boot-end-marker
    !
    enable password cisco
    !
    no aaa new-model
    memory-size iomem 5
    !
    !
    ip cef
    no ip domain lookup
    !
    !
    !
    mpls label protocol ldp
    mpls ldp neighbor 150.1.4.4 password CISCO
    no mpls ldp advertise-labels
    mpls ldp advertise-labels for 10
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface Loopback0
     ip address 150.1.6.6 255.255.255.0
    !
    interface Ethernet0/0
     no ip address
     full-duplex
    !
    interface Ethernet0/0.67
     encapsulation dot1Q 67
     ip address 155.1.67.6 255.255.255.0
     mpls ip
    !
    interface Ethernet0/0.146
     encapsulation dot1Q 146
     ip address 155.1.146.6 255.255.255.0
     mpls ldp discovery transport-address interface
     mpls ip
    !
    interface Ethernet0/1
     no ip address
     shutdown
     full-duplex
    !
    interface Ethernet0/2
     no ip address
     shutdown
     half-duplex
    !
    interface Ethernet0/3
     no ip address
     shutdown
     half-duplex
    !
    interface Serial1/0
     ip address 54.1.1.6 255.255.255.0
     encapsulation frame-relay
     mpls ip
     serial restart-delay 0
     frame-relay map ip 54.1.1.254 101 broadcast
     no frame-relay inverse-arp
    !
    interface Serial1/1
     no ip address
     shutdown
     serial restart-delay 0
    !
    interface Serial1/2
     no ip address
     shutdown
     serial restart-delay 0
    !
    interface Serial1/3
     no ip address
     shutdown
     serial restart-delay 0
    !
    router ospf 1
     log-adjacency-changes
     network 0.0.0.0 255.255.255.255 area 0
    !
    router rip
     version 2
     network 54.0.0.0
     network 150.1.0.0
     network 155.1.0.0
     no auto-summary
    !
    ip http server
    no ip http secure-server
    !
    !
    !
    access-list 10 permit 150.1.4.4
    access-list 10 permit 150.1.5.5
    access-list 10 permit 150.1.6.6
    !
    !
    mpls ldp router-id Loopback0 force
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    alias exec s sh ip int b
    alias exec su sh run
    alias exec c config t
    alias exec sr sh ip route
    alias exec o sh ip route ospf
    alias exec e sh ip route eigrp
    alias exec r sh ip route rip
    alias exec b sh ip route bgp
    alias exec ne sh ip eigrp nei
    alias exec no sh ip ospf nei
    alias exec nb sh ip bgp summary
    alias exec m sh ip mroute
    alias exec nm sh ip multicast nei
    alias exec sv6 sh ipv6 route
    !
    line con 0
     exec-timeout 0 0
     privilege level 15
     logging synchronous
    line aux 0
    line vty 0 4
     login
    !
    !
    end

    Rack1R6#


  • Can somebody in this forum help me fixing the issue..

  • Can somebody in this forum help me fixing the issue..

     

     

    Hi Ameen,

    After looking into your config, you have /24 bits IP address on loopback, which is the main issue here. Can you correct this with /32.

    Look at here:

    R1(config-if)#do show run int lo0
    Building configuration...

    Current configuration : 93 bytes
    !
    interface Loopback0
     ip address 1.1.1.1 255.255.255.0
     ip ospf network point-to-point
    end

    On R1 I am configuring /24 address, let's check the MPLS forwarding table on R3

    R3(config-if)#do show mpls for
    Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop
    Label      Label      or Tunnel Id     Switched      interface
    16         No Label   2.2.2.2/32       0             drop
    17         No Label   1.1.1.1/32       0             drop
    18         No Label   12.12.12.0/24    0             Fa1/0      23.23.23.2
    19         Pop Label  4.4.4.4/32       0             Fa1/1      34.34.34.4
    20         No Label   2.2.2.0/24       0             Fa1/0      23.23.23.2
    21         No Label   1.1.1.0/24       0             Fa1/0      23.23.23.2
    22         No Label   4.4.4.0/24       0             drop

    I have similar filter on LDP :

    R3(config-if)#do show run | in mpls
    no mpls ldp advertise-labels
    mpls ldp advertise-labels for 10
     mpls ldp autoconfig area 0

    R3(config-if)#do show access-list 10
    Standard IP access list 10
        10 permit 1.1.1.1 (9 matches)
        20 permit 2.2.2.2 (9 matches)
        30 permit 3.3.3.3 (6 matches)
        40 permit 4.4.4.4 (9 matches)

    Let's change the address on /32.

    R1(config-if)#interface Loopback0
    R1(config-if)#ip address 1.1.1.1 255.255.255.255
    R1(config-if)#
    *May 27 18:41:04.611: %TDP-5-INFO: default: TDP ID removed
    *May 27 18:41:04.639: %LDP-5-NBRCHG: LDP Neighbor 2.2.2.2:0 (1) is DOWN (LDP Router ID changed)
    R1(config-if)#
    *May 27 18:41:06.555: %LDP-5-NBRCHG: LDP Neighbor 2.2.2.2:0 (2) is UP

    Let's check the label on R3:

    R3(config-if)#do show mpls for
    Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop
    Label      Label      or Tunnel Id     Switched      interface
    18         No Label   12.12.12.0/24    0             Fa1/0      23.23.23.2
    19         Pop Label  4.4.4.4/32       0             Fa1/1      34.34.34.4
    20         No Label   2.2.2.0/24       0             Fa1/0      23.23.23.2
    21         No Label   1.1.1.0/24       0             drop
    22         21         1.1.1.1/32       0             Fa1/0      23.23.23.2

    Can you check chaing address to /32 bits? Let me know if it works for you.

    Good Luck

  • Hi Narayan,

    Thanks for the help..

    After configuring the loop intf to /32 on R4, R5,R6 it is working fine.. Can you please let me know, how it is working correctly after chaning the mask to /32 on loop intfs. As this is not mentioned in the INE workbook..

     

    Regards,

    Ameen

     

     

     

     

  • Hi Narayan,

    Thanks for the help..

    After configuring the loop intf to /32 on R4, R5,R6 it is working fine.. Can you please let me know, how it is working correctly after chaning the mask to /32 on loop intfs. As this is not mentioned in the INE workbook..

    Hi Ameen,

    First I am happy that your problem is resovled now. Now let's discuss why it was not working with you: I have simple topology R1-R2-R3-R4.

    First understand how OSPF treats the Loopback interface by default and after changing into point to point network type:

    By default OSPF treats as a STUB HOST:

    R4#show ip ospf inter lo0
    Loopback0 is up, line protocol is up
      Internet Address 4.4.4.4/24, Area 0, Attached via Network Statement
      Process ID 1, Router ID 4.4.4.4, Network Type LOOPBACK, Cost: 1
      Topology-MTID    Cost    Disabled    Shutdown      Topology Name
            0           1         no          no            Base
      Loopback interface is treated as a stub Host

    Now let's check the MPLS forwarding table on R2:

    R2#show mpls forwarding-table
    Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop
    Label      Label      or Tunnel Id     Switched      interface
    16         Pop Label  1.1.1.1/32       0             Fa1/0      12.12.12.1
    17         Pop Label  3.3.3.3/32       0             Fa1/1      23.23.23.3
    18         Pop Label  34.34.34.0/24    0             Fa1/1      23.23.23.3
    19         19         4.4.4.4/32       0             Fa1/1      23.23.23.3 >>> I have /32 bits address

    Now Let's change the OSPF network type to point-to-point on R4:

    R4(config)#int lo0
    R4(config-if)#ip ospf network point-to-point

    R4#show ip ospf int lo0
    Loopback0 is up, line protocol is up
      Internet Address 4.4.4.4/24, Area 0, Attached via Network Statement
      Process ID 1, Router ID 4.4.4.4, Network Type POINT_TO_POINT, Cost: 1
      Topology-MTID    Cost    Disabled    Shutdown      Topology Name
            0           1         no          no            Base
      Transmit Delay is 1 sec, State POINT_TO_POINT
      Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

    Let's check again on R2:

    R2#show mpls forwarding-table
    Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop
    Label      Label      or Tunnel Id     Switched      interface
    16         Pop Label  1.1.1.1/32       0             Fa1/0      12.12.12.1
    17         Pop Label  3.3.3.3/32       0             Fa1/1      23.23.23.3
    18         Pop Label  34.34.34.0/24    0             Fa1/1      23.23.23.3
    20         20         4.4.4.0/24       0             Fa1/1      23.23.23.3 >>>Here we have label for 4.4.4.0/24 network 
     

    When you change the OSPF Network type point to point, it advertise the network with mask.

    Now you configured the LDP filtering, which allowing only /32 bits loopback address, means denying to all other networks.

    I hope it is clear now:)

    Good Luck with your studies!

     

  • Hi Narayan,

    yes, I got it now.

    Thanks for the help..

    Regards,

    Ameen

  • Hi Narayan,

    yes, I got it now.

    Thanks for the help..

    Good to know!

    Good Luck with your studies!

Sign In or Register to comment.