Site-2-Site VPN can only ping one way

 

image

 

Hello Everyone,

I'm having a problem with site-to-site vpn using PIX & FORTINET 60B, If I ping from network behind PIX say "ping 172.21.1.102", it is SUCCESFUL but when I ping from network behind FORTINET it is "Request Timed Out".  

FORTINET VPN CONFIGS:

config vpn ipsec phase1
    edit "HOTEL_FW"
        set interface "wan1"
        set nattraversal disable
        set dhgrp 2
        set keylife 86400
        set proposal 3des-sha1
        set dpd disable
        set remote-gw 222.127.244.54
        set psksecret ENC xxxxxxxxxxxxxxxx
    next
end

config vpn ipsec phase2
    edit "HOTEL_FW_2"
        set keepalive enable
        set pfs disable
        set phase1name "HOTEL_FW"
        set proposal 3des-sha1
        set replay disable
        set dst-subnet 10.100.10.0 255.255.255.0
        set keylifeseconds 86400
        set src-subnet 172.21.1.0 255.255.255.0
    next
end

 

PIX501 config.

access-list NONAT permit ip 10.100.10.0 255.255.255.0 172.21.1.0 255.255.255.0
ip address outside 222.127.244.54 255.255.255.252
ip address inside 10.100.10.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list NONAT
nat (inside) 1 10.100.10.0 255.255.255.0 0 0
route outside 0.0.0.0 0.0.0.0 222.127.244.53 1
http server enable
http 10.100.10.2 255.255.255.255 inside
sysopt connection permit-ipsec
crypto ipsec transform-set MYSET esp-3des esp-sha-hmac
crypto map MYMAP 10 ipsec-isakmp
crypto map MYMAP 10 match address NONAT
crypto map MYMAP 10 set peer 121.97.122.253
crypto map MYMAP 10 set transform-set MYSET
crypto map MYMAP 10 set security-association lifetime seconds 86400 kilobytes 4608000
crypto map MYMAP interface outside
isakmp enable outside
isakmp key ******* address 121.97.122.253 netmask 255.255.255.255
isakmp identity address
isakmp policy 1 authentication pre-share
isakmp policy 1 encryption 3des
isakmp policy 1 hash sha
isakmp policy 1 group 2
isakmp policy 1 lifetime 86400

I also tried this command on PIX:

PIX# debug packet outside src 172.21.1.102 netmask 255.255.255.255 dst 10.100.10.2 netmask 255.255.255.255 proto icmp

but nothings happen. I'm am new to site-site vpn, hope you can help me.. Thanks in advance..

Comments

  • by the way a while ago, i tried to ping from the Fortinet device itself to the PIX LAN ping is successful but if i ping LAN behind fortinet to PIX LAN unsuccessful still

  • Do you happen to have NONAT on the Fortinet side?

  • yes the traffic, 172.21.1.0 /24 --> 10.100.10.0 /24 have no NAT applied. What i'm also confuse qqabdal is that when I log-in on the fortinet and make my ping there, it will work I can ping the LAN of the PIX, but when I ping from the LAN network of a FORTINET, i get a "Requiest timed out message". What should I do here? please help, hope that there's somebody here that is also an expert in Fortinet.

    tnx qqabdal..

  • I never touched a Fortinet before, being honest here. But if you can ping the PIX LAN Interface but not the end host, I would have you check the end-host default-gateway. The issue is that you are able to establish the tunnel from the end host, so the default-gateway may be correct. It is worth checking though.

    The ASA/PIX let's you configure some special stuff like only allowing the PIX/ASA to start the tunnel, so if you could provide your full configuration on the PIX, we can take a look into that. By default it is bidirectional, but it may be configured to initiate only.

    Maybe someone with Fortinet experience can chime in.

  • Do you have access rules on the fortigate to allow the traffic? 

    Not sure if the 60b can do the full debug commands, 

     

    try this on cli

     


    Diagnose sniffer packet any ‘host x.x.x.x and port x.x.x.x’ 

    For the debugging vpn connections on the fortigate 

     

    diag debug enable

    diag vpn ike log-filter dst-addr4 xxxxx   
    (IP address of the peer vpn gateway)

    diag debug app ike -1

     

    This gives excellent info on the vpn connection. Have the tunnel torn down, then use these commands, then try initiate the tunnel from fortigate side with pings. 

     

    further debugging to check full flows and policy matches


    For example – tracing flow coming from
    192.168.10.1 on HTTP

     diagnose debug reset

     diagnose debug enable

    diagnose debug flow filter clear

    diagnose debug flow filter saddr 192.168.0.1

    diagnose debug flow show con enable

    diagnose debug flow show fun enable

    diagnose debug flow trace start 100

     

    to stop:

    diagnose debug reset

    diagnose debug disable

  • I never touched a Fortinet before, being honest here. But if you can ping the PIX LAN Interface but not the end host, I would have you check the end-host default-gateway. The issue is that you are able to establish the tunnel from the end host, so the default-gateway may be correct. It is worth checking though.

    The ASA/PIX let's you configure some special stuff like only allowing the PIX/ASA to start the tunnel, so if you could provide your full configuration on the PIX, we can take a look into that. By default it is bidirectional, but it may be configured to initiate only.

    Maybe someone with Fortinet experience can chime in.

     

    I dont think its routing if i understand him correctly. He can ping a host on fortinet side from a host on asa side. 

    This indicates routing is correct. 

     

    I think its more likely an access rule  that could be messing with him

     

  • Hello qqqbdal,

     

    Here's my pix config:

    PIX1# sh run
    : Saved
    :
    PIX Version 6.3(4)
    interface ethernet0 auto
    interface ethernet1 100full
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    enable password hfxgbgqscYsuZB5k encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    hostname PIX1
    fixup protocol dns maximum-length 512
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol tftp 69
    names
    access-list NONAT permit ip 10.100.10.0 255.255.255.0 172.21.1.0 255.255.255.0
    pager lines 24
    mtu outside 1500
    mtu inside 1500
    ip address outside 222.127.244.54 255.255.255.252
    ip address inside 10.100.10.1 255.255.255.0
    ip audit info action alarm
    ip audit attack action alarm
    pdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list NONAT
    nat (inside) 1 10.100.10.0 255.255.255.0 0 0
    route outside 0.0.0.0 0.0.0.0 222.127.244.53 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server TACACS+ max-failed-attempts 3
    aaa-server TACACS+ deadtime 10
    aaa-server RADIUS protocol radius
    aaa-server RADIUS max-failed-attempts 3
    aaa-server RADIUS deadtime 10
    aaa-server LOCAL protocol local
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    no snmp-server enable traps
    floodguard enable
    sysopt connection permit-ipsec
    crypto ipsec transform-set MYSET esp-3des esp-sha-hmac
    crypto map MYMAP 10 ipsec-isakmp
    crypto map MYMAP 10 match address NONAT
    crypto map MYMAP 10 set peer 121.97.122.253
    crypto map MYMAP 10 set transform-set MYSET
    crypto map MYMAP 10 set security-association lifetime seconds 86400 kilobytes 4608000
    crypto map MYMAP interface outside
    isakmp enable outside
    isakmp key ******** address 121.97.122.253 netmask 255.255.255.255
    isakmp identity address
    isakmp policy 1 authentication pre-share
    isakmp policy 1 encryption 3des
    isakmp policy 1 hash sha
    isakmp policy 1 group 2
    isakmp policy 1 lifetime 86400
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    username fortuna password OB.5DhIZ5nZLaqad encrypted privilege 15
    terminal width 80
    Cryptochecksum:cc00bb04cref430e357827cb8fd732c23
    : end

  • @taulz

    Lets consider network behind PIX is LAN A and the other end(Behind Fortinet) is LAN B:

    ------ Ping LAN A to LAN B -------
    ping 172.21.1.102 (SUCCESSFUL)


    FWF60B3908618567 # diag sniffer packet any 'icmp and src host 10.100.10.2'
    interfaces=[any]
    filters=[icmp and src host 10.100.10.2]
    3.350265 10.100.10.2 -> 172.21.1.102: icmp: echo request
    3.350357 10.100.10.2 -> 172.21.1.102: icmp: echo request
    3.350370 10.100.10.2 -> 172.21.1.102: icmp: echo request
    4.351473 10.100.10.2 -> 172.21.1.102: icmp: echo request

    --------------- Ping LAN B to LAN A -------
    ping 10.100.10.2 (Request Timed out)

     
    FWF60B3908618567 # diagnose sniffer packet any 'icmp and src host 172.21.1.102'
    interfaces=[any]
    filters=[icmp and src host 172.21.1.102]
    4.416299 172.21.1.102 -> 10.100.10.2: icmp: echo request
    9.393065 172.21.1.102 -> 10.100.10.2: icmp: echo request
    14.390071 172.21.1.102 -> 10.100.10.2: icmp: echo request
    19.390018 172.21.1.102 -> 10.100.10.2: icmp: echo request
    24.398988 172.21.1.102 -> 10.100.10.2: icmp: echo request

    ---------------------------

    After following the diag. commands:

    id=36871 trace_id=101 func=resolve_ip_tuple_fast line=3772 msg="vd-root received a packet(proto=1, 121.97.122.253:61699->121.97.122.1:8) from local."
    id=36871 trace_id=101 func=resolve_ip_tuple_fast line=3812 msg="Find an existing session, id-00956fde, original direction"
    id=36871 trace_id=102 func=resolve_ip_tuple_fast line=3772 msg="vd-root received a packet(proto=1, 121.97.122.253:61699->121.97.122.1:8) from local."
    id=36871 trace_id=102 func=resolve_ip_tuple_fast line=3812 msg="Find an existing session, id-00956fde, original direction"

  • I think my problem gets worse, can't ping on both sides, i have this error during debug:

    ISAKMP (0): beginning Main Mode exchange
    ISAKMP (0): retransmitting phase 1 (0)...
    ISAKMP (0): retransmitting phase 1 (1)...
    ISAKMP (0): deleting SA: src 222.127.244.54, dst 121.97.122.253
    ISADB: reaper checking SA 0xa17e5c, conn_id = 0
    ISADB: reaper checking SA 0xa189fc, conn_id = 0  DELETE IT!

    VPN Peer:ISAKMP: Peer Info for 121.97.122.253/500 not found - peers:0

    ISADB: reaper checking SA 0xa17e5c, conn_id = 0
    ISAKMP (0): beginning Main Mode exchange
    ISAKMP (0): retransmitting phase 1 (0)...
    ISAKMP (0): retransmitting phase 1 (1)...

     

  • It looks to be the fortinet?

    That pix config seems fine. Those debugs arent great. ~Delete it~ is an interested response. 

  • Did you get this solved? I checked your PIX config and it looks fine.

Sign In or Register to comment.