7971GE will not boot at all

Hello guys,

I've just started my Voice lab, but while upgrading the firmware on my 7971GE phone, I apparently messed up something.

Now the phone shows a dark blue screen with nothing on it and I can see that he downloads all the file it needes from the TFTP server, the only problem is that after few seconds it reboots and the procedure starts all over again. The phone never shows any Cisco logo and not a single word on the entire process.

My feeling is that something went wrong and corrupted the old firmware in the upgrade procedure maybe also because I've tryied to upgrade from a very old version (2005).

Not sure if matters but I can see with wireshark that every single packet that the phone sends out says "ethernet frame check sequence incorrect" and for example "0x00000000 should be 0x93F8234A". Maybe it's due to CRC offload I don't really know...

The factory default procedure (123456789*0#) hardly seems to matter cause the phone starts looking for the firware anyways.

Thanks for any advice!

Andrea

Comments

  • Hi,

    I can remember I faced kind of same issue - the phone showed a circle sign at corner on sudden while upgrading firmware and got rebooted but the same procedure again. Changing the switchport helped me to get rid of that, I changed the firmware to bit older version than the latest one. You can have a try with SIP firmware as well.

  • Hi, thank you for your reply; I've already tryed different cme's, also via ATM so I doubt that changing switchport might help.

    Also, the phone does not show the round thing on the bottom left corner, it does not show anything at all!

    I also tryed to attach my PC to the AUX port but the debug didn't help me very much, maybe I should post the logs here.

    Andrea

  • What are you using to perform the upgrade? I ran into this issue with my 7970. I ended up having to downgrade my firmware using tftpd32 on my desktop and it worked perfectly after that. I had to create an xml file that pointed to the firmware that I wanted to use. The file name was XMLDefault.cnf.xml. While I can't find the one that I used, I used a template that I found on the internet.

  • Hi Jahudson, I also used tftpd32 while trying to upload lower versions of the firmware but when it's done downloading the files it reboots immediately, then it ALWAYS keep trying to download the firmware another time and it goes on forever. According to what I see on the sniffed packets it never looks for XMLDefault.cnf.xml so I don't think that this is my case.

  • I remember running into that same issue. I used this site as a guide:

     

    http://www.adrianandgenese.com/blogger/2011/02/16/how-to-upgrade-or-convert-a-cisco-ip-79xx-7940-7960-794x-796x-797x-phone-to-sip-or-sccp/

     

    After using the correct tftpd, everything worked correctly.

  • Problem solved!

    It took a while for me to realize that the (3491672850*#) procedure was not meant to be used in case was not possible to type the standard (123456789*0#) sequence; apparently the first one is something very different, maybe it initializes the whole flash and when i tryied it all the line keys went from orange to red, blinking like they were posessed. After a while the phone downloaded the FW as usual but this time when it rebooted it was fine :)

    Thanks to all that replyed to this; I hope this solution will be useful to somebody.

    Andrea

Sign In or Register to comment.