WB Full LAB4 task 4.1

I was doing this task when I configured XR1 for IPv4 Labeled-unicast with R3, XR1 stopped sending routes just it's own Loopback although it recieves all iBGP routes normally !! I spent like 30 minutes trying to reset the configuration and the box itself but no way.

RP/0/0/CPU0:XR1#show bg labels
Sun Feb 24 13:16:17.559 UTC
BGP router identifier 10.0.0.19, local AS number 1000
BGP generic scan interval 60 secs
BGP table state: Active
Table ID: 0xe0000000
BGP main routing table version 75
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
              i - internal, r RIB-failure, S stale
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network            Next Hop        Rcvd Label      Local Label
*  10.0.0.1/32        10.0.193.3      16              nolabel        
*> 10.0.0.3/32        10.0.193.3      3               16008          
*> 10.0.0.4/32        10.0.193.3      17              16009          
*> 10.0.0.19/32       0.0.0.0         nolabel         3              

Processed 4 prefixes, 4 paths
RP/0/0/CPU0:XR1#show bgp
Sun Feb 24 13:16:22.412 UTC
BGP router identifier 10.0.0.19, local AS number 1000
BGP generic scan interval 60 secs
BGP table state: Active
Table ID: 0xe0000000
BGP main routing table version 75
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
              i - internal, r RIB-failure, S stale
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network            Next Hop            Metric LocPrf Weight Path
*>i10.0.0.1/32        10.0.0.5                 0    110      0 2000 i
*                     10.0.193.3                             0 2000 i
*>i10.0.0.2/32        10.0.0.2                 0    100      0 i
*> 10.0.0.3/32        10.0.193.3               0             0 2000 i
*> 10.0.0.4/32        10.0.193.3                    120      0 2000 i
*>i10.0.0.5/32        10.0.0.5                 0    100      0 i
*> 10.0.0.19/32       0.0.0.0                  0         32768 i
*>i10.0.0.20/32       10.0.0.20                0    100      0 i

Processed 7 prefixes, 8 paths

 

Configuration:
router bgp 1000
 address-family ipv4 unicast
  network 10.0.0.19/32
  allocate-label all
 !
 neighbor 10.0.193.3
  remote-as 2000
  address-family ipv4 labeled-unicast
   send-community-ebgp
   route-policy EBGP in
   route-policy PASS out
  !
 !

Comments

  • If you can Post your R3 config and Output ..

    Most probably send-label in R3 is Missing ..

  • nope that is not true, as shown in the previous output R3 is sending labeles for R1, R4 and his LP:

    *> 10.0.0.3/32        10.0.193.3      3               16008

    I assume that there is something wrong with the XR itself because it stopped advertising R2, R5 , XR1 Loopbacks after configuring "allocate-label all and address-family ipv4 labeled-unicast"

  • have you configured Static entry  stating Host route /32 route under router static IN XR..

     

    this could be the reason 

  • Mate, the static route configured, you can see labels from the peer normally and you also is labeling your loopback !! 

  • also what is the use of this static /32 route? is to rightly label the next hop in-case of E-BGP peering if it is not on the LP and it will only affect the forwarding plan not the control one, and here we're talking about the control plan that it is not working as supposed XR1 is receiving the local AS loopbacks through iBGP and not advertising them to the E-BGP peering nor label them !!

  • I am completely aggree with your Point..one more strange thing in your sh bgp Label is * entry for 10.0.0.1/32 strange and XR1 is unable to generate the Local Label for rest Of AS .. Is there any sort of RPL you are using which is causing susch behaviour....

     

    I have tried this LAB although its very lengthy fortunately able to finish till half Multicast working  .. i  faced the same issue  but unable to recall what i did for solution  i ll give one more try and look if can produce the same output...

     

    thanks 

  • hmmm the only IN RPL is PASS, I've just noticed the 10.0.0.1/32 and it is wiered too.

  • Hello All,

    According to the work book, a 'part' of the solution to this question
    is to enable XR1 (in AS 1000) to 'send-labels' with BGP routes that it
    exchanges with R3 (in AS2000). Thus this configuration deletes the
    'address-family ipv4 unicast' and enables the 'address-family ipv4
    labeled-unicast' as seen below. This would be the equivalent of enabling
    'send-label' on regular IOS

    !
    neighbor 10.0.193.3
    no address-family ipv4 unicast
    address-family ipv4 labeled-unicast
    send-community-ebgp
    route-policy RFC_1998 in
    route-policy PASS out
    !

    Unfortunately, after configurating the above, it didn't solve the
    problem as the loopbacks of AS1000 were no longer advertised to AS2000.
    What I did to fix this issue was to configure:

    !
     neighbor 10.0.193.3
      remote-as 2000
      address-family ipv4 unicast
       send-community-ebgp
       route-policy RFC1918 in
       route-policy PASS out
      !
      address-family ipv4 labeled-unicast
       send-community-ebgp
       route-policy RFC1918 in
       route-policy PASS out
      !

    Please, has anyone had this same or similar experience with this particular lab??

    Thanks!!!

    Crownade

  • Hello again,

    I just realised my earlier config did not completely solve the issue. Now if I shut down the connection between R3 and XR1, so that I only use the connection between R3 and R5 as my inter-AS link, then everything works fine. Which leads me to think that the issue above is something to do with the XR.

    Back to my earlier config, I'm able to ping between the loopbacks of the PE routes in both AS'es. However, I can't ping between interfaces in the VRF.

    If I remove the 'address-family ipv4 unicast' from XR1 as per the work book, then I can't ping between the loopbacks of the PE's.

    This is what my bgp output looks like when I remove address family configuration from XR1:

    RP/0/0/CPU0:XR1#
    RP/0/0/CPU0:XR1#show bgp ipv4 unicast
    Wed Mar 13 01:08:07.843 UTC
    BGP router identifier 10.0.0.19, local AS number 1000
    BGP generic scan interval 60 secs
    BGP table state: Active
    Table ID: 0xe0000000
    BGP main routing table version 17
    BGP scan interval 60 secs

    Status codes: s suppressed, d damped, h history, * valid, > best
                  i - internal, r RIB-failure, S stale
    Origin codes: i - IGP, e - EGP, ? - incomplete
       Network            Next Hop            Metric LocPrf Weight Path
    *> 10.0.0.1/32        10.0.193.3                             0 2000 i
    *>i10.0.0.2/32        10.0.0.2                 0    100      0 i
    *> 10.0.0.3/32        10.0.193.3               0             0 2000 i
    *> 10.0.0.4/32        10.0.193.3                    120      0 2000 i
    *>i10.0.0.5/32        10.0.0.5                 0    100      0 i
    *> 10.0.0.19/32       0.0.0.0                  0         32768 i
    *>i10.0.0.20/32       10.0.0.20                0    100      0 i

    Processed 7 prefixes, 7 paths
    RP/0/0/CPU0:XR1#
    RP/0/0/CPU0:XR1#
    RP/0/0/CPU0:XR1#
    RP/0/0/CPU0:XR1#show bgp ipv4 labeled-unicast
    Wed Mar 13 01:08:15.705 UTC
    BGP router identifier 10.0.0.19, local AS number 1000
    BGP generic scan interval 60 secs
    BGP table state: Active
    Table ID: 0xe0000000
    BGP main routing table version 17
    BGP scan interval 60 secs

    Status codes: s suppressed, d damped, h history, * valid, > best
                  i - internal, r RIB-failure, S stale
    Origin codes: i - IGP, e - EGP, ? - incomplete
       Network            Next Hop            Metric LocPrf Weight Path
    *> 10.0.0.1/32        10.0.193.3                             0 2000 i
    *> 10.0.0.3/32        10.0.193.3               0             0 2000 i
    *> 10.0.0.4/32        10.0.193.3                    120      0 2000 i
    *> 10.0.0.19/32       0.0.0.0                  0         32768 i

    Processed 4 prefixes, 4 paths
    RP/0/0/CPU0:XR1#
    RP/0/0/CPU0:XR1#

    And on R3:

    R3#
    R3#show bgp ipv4 unicast
    BGP table version is 13, local router ID is 10.0.0.3
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
                  r RIB-failure, S Stale, m multipath, b backup-path, x best-external
    Origin codes: i - IGP, e - EGP, ? - incomplete

       Network          Next Hop            Metric LocPrf Weight Path
    r>i10.0.0.1/32      10.0.0.1                 0    100      0 i
    *> 10.0.0.3/32      0.0.0.0                  0         32768 i
    r>i10.0.0.4/32      10.0.0.4                 0    100      0 i
    *> 10.0.0.19/32     10.0.193.19              0             0 1000 i
    R3#
    R3#

     

    Crownade

     

     

     

     

     

     

     

  • Forgive me if this is a stupid question - in IOS-XR, how do you move routes from the ipv4 unicast table to the ipv4 labeled-unicast table??

     

    Reason I ask is that I can see the following routes in the ipv4 unicast table:

    RP/0/0/CPU0:XR1#show bgp ipv4 unicast        
    Wed Mar 13 01:17:36.509 UTC
    BGP router identifier 10.0.0.19, local AS number 1000
    BGP generic scan interval 60 secs
    BGP table state: Active
    Table ID: 0xe0000000
    BGP main routing table version 17
    BGP scan interval 60 secs

    Status codes: s suppressed, d damped, h history, * valid, > best
                  i - internal, r RIB-failure, S stale
    Origin codes: i - IGP, e - EGP, ? - incomplete
       Network            Next Hop            Metric LocPrf Weight Path
    *> 10.0.0.1/32        10.0.193.3                             0 2000 i
    *>i10.0.0.2/32        10.0.0.2                 0    100      0 i
    *> 10.0.0.3/32        10.0.193.3               0             0 2000 i
    *> 10.0.0.4/32        10.0.193.3                    120      0 2000 i
    *>i10.0.0.5/32        10.0.0.5                 0    100      0 i
    *> 10.0.0.19/32       0.0.0.0                  0         32768 i
    *>i10.0.0.20/32       10.0.0.20                0    100      0 i

    Processed 7 prefixes, 7 paths
    RP/0/0/CPU0:XR1#

     

    But the IOS XR only has its own loopback and those receievd from the neibouring AS in the ipv4 label unicast table:

    RP/0/0/CPU0:XR1#show bgp ipv4 labeled-unicast
    Wed Mar 13 01:16:25.449 UTC
    BGP router identifier 10.0.0.19, local AS number 1000
    BGP generic scan interval 60 secs
    BGP table state: Active
    Table ID: 0xe0000000
    BGP main routing table version 17
    BGP scan interval 60 secs

    Status codes: s suppressed, d damped, h history, * valid, > best
                  i - internal, r RIB-failure, S stale
    Origin codes: i - IGP, e - EGP, ? - incomplete
       Network            Next Hop            Metric LocPrf Weight Path
    *> 10.0.0.1/32        10.0.193.3                             0 2000 i
    *> 10.0.0.3/32        10.0.193.3               0             0 2000 i
    *> 10.0.0.4/32        10.0.193.3                    120      0 2000 i
    *> 10.0.0.19/32       0.0.0.0                  0         32768 i

    Processed 4 prefixes, 4 paths
    RP/0/0/CPU0:XR1#

     

    The XR device does not have the loopbacks of the routers in the same AS (AS 1000 in this scenario - highlighted in bold above in the ipv4 unicast table) in the labeled-unicast table and as such is neither sending the routes nor any labels for them.

     

    Crownade

     

  • Perform the following on XR1, and you will see why XR1 no longer learns any of the loopbacks of AS 2000's routers.  R3 is incorrectly sending "ipv4u" updates (without labels) to XR1.  XR1 is expecting "ipv4lu" (with labels)....so this mismatch is causing XR1 to not accepted anything advertised from R3.

     

    RP/0/0/CPU0:XR1#debug bgp update 10.0.193.3 in all all 

    Sat Sep 21 01:24:49.989 UTC

    RP/0/0/CPU0:XR1#

    RP/0/0/CPU0:XR1#RP/0/0/CPU0:Sep 21 01:24:54.837 : bgp[139]: [rtr]: aspath loop detect failed due to finding our own AS 1000

    RP/0/0/CPU0:Sep 21 01:24:54.838 : bgp[139]: [rtr]: UPDATE from 10.0.193.3 contains nh 10.0.193.3/32, gw_afi 0, flags 0x0, nlri_afi 0

    RP/0/0/CPU0:Sep 21 01:24:54.839 : bgp[139]: [rtr] (ip4u): Address family from 10.0.193.3 is unrecognized or not configured

    RP/0/0/CPU0:Sep 21 01:24:54.840 : bgp[139]: [rtr]: aspath loop detect failed due to finding our own AS 1000

    RP/0/0/CPU0:Sep 21 01:24:54.841 : bgp[139]: [rtr]: UPDATE from 10.0.193.3 contains nh 10.0.193.3/32, gw_afi 0, flags 0x0, nlri_afi 0

    RP/0/0/CPU0:Sep 21 01:24:54.842 : bgp[139]: [rtr] (ip4u): Address family from 10.0.193.3 is unrecognized or not configured

    RP/0/0/CPU0:Sep 21 01:24:54.843 : bgp[139]: [rtr]: UPDATE from 10.0.193.3 contains nh 10.0.193.3/32, gw_afi 0, flags 0x0, nlri_afi 0

    RP/0/0/CPU0:Sep 21 01:24:54.844 : bgp[139]: [rtr] (ip4u): Address family from 10.0.193.3 is unrecognized or not configured

    RP/0/0/CPU0:Sep 21 01:24:54.845 : bgp[139]: [rtr]: UPDATE from 10.0.193.3 contains nh 10.0.193.3/32, gw_afi 0, flags 0x0, nlri_afi 0

    RP/0/0/CPU0:Sep 21 01:24:54.845 : bgp[139]: [rtr] (ip4u): Address family from 10.0.193.3 is unrecognized or not configured


    Notice that XR1 states (ip4u) even though I have "send-label" on R3 -> XR1 and "add ipv4 labeled-unicast" from XR1 -> R3.


    (XR1)


    neighbor 10.0.193.3

      remote-as 2000

      address-family ipv4 labeled-unicast

       send-community-ebgp

       route-policy PASS in

       route-policy PASS out




    route-policy PASS

      pass

    end-policy



    (R3)

    router bgp 2000

    neighbor 10.0.193.19 remote-as 1000

    address-family ipv4


    neighbor 10.0.193.19 activate

      neighbor 10.0.193.19 send-community

      neighbor 10.0.193.19 route-map RFC_1998 in

      neighbor 10.0.193.19 route-map PASS out

      neighbor 10.0.193.19 send-label




    route-map PASS, permit, sequence 10

      Match clauses:

      Set clauses:

      Policy routing matches: 0 packets, 0 bytes



    However, after I remove the empty outbound route-map PASS from 10.0.193.19, XR1 was able to learn about routes and labels for loopbacks in AS 2000. 

    Notice that debug on XR1 now correctly states that it is receiving "ipv4lu" updates from R3.




    RP/0/0/CPU0:XR1#

    RP/0/0/CPU0:XR1#RP/0/0/CPU0:Sep 21 01:32:06.567 : bgp[139]: [rtr]: aspath loop detect failed due to finding our own AS 1000

    RP/0/0/CPU0:Sep 21 01:32:06.568 : bgp[139]: [rtr]: UPDATE from 10.0.193.3 contains nh 10.0.193.3/32, gw_afi 0, flags 0x8, nlri_afi 2

    RP/0/0/CPU0:Sep 21 01:32:06.570 : bgp[139]: [rtr] (ip4lu): Received unreachables from 10.0.193.3

    RP/0/0/CPU0:Sep 21 01:32:06.571 : bgp[139]: [rtr] (ip4lu): UPDATE from 10.0.193.3 with attributes:

    RP/0/0/CPU0:Sep 21 01:32:06.572 : bgp[139]: [rtr] (ip4lu): nexthop 10.0.193.3/32, origin i, originator 0.0.0.0, path 2000 1000

    RP/0/0/CPU0:Sep 21 01:32:06.572 : bgp[139]: [rtr] (ip4lu): UPDATE from 10.0.193.3, prefix 10.0.0.5/32 DENIED due to:

    RP/0/0/CPU0:Sep 21 01:32:06.573 : bgp[139]: [rtr] (ip4lu):  as-path contains our own AS, or 0;

    RP/0/0/CPU0:Sep 21 01:32:06.574 : bgp[139]: [rtr]: aspath loop detect failed due to finding our own AS 1000

    RP/0/0/CPU0:Sep 21 01:32:06.575 : bgp[139]: [rtr]: UPDATE from 10.0.193.3 contains nh 10.0.193.3/32, gw_afi 0, flags 0x8, nlri_afi 2

    RP/0/0/CPU0:Sep 21 01:32:06.575 : bgp[139]: [rtr] (ip4lu): Received unreachables from 10.0.193.3

    RP/0/0/CPU0:Sep 21 01:32:06.576 : bgp[139]: [rtr] (ip4lu): UPDATE from 10.0.193.3 with attributes:

    RP/0/0/CPU0:Sep 21 01:32:06.577 : bgp[139]: [rtr] (ip4lu): nexthop 10.0.193.3/32, origin i, originator 0.0.0.0, path 2000 1000

    RP/0/0/CPU0:Sep 21 01:32:06.577 : bgp[139]: [rtr] (ip4lu): UPDATE from 10.0.193.3, prefix 10.0.0.2/32 DENIED due to:

    RP/0/0/CPU0:Sep 21 01:32:06.578 : bgp[139]: [rtr] (ip4lu):  as-path contains our own AS, or 0;

    RP/0/0/CPU0:Sep 21 01:32:06.579 : bgp[139]: [rtr] (ip4lu): UPDATE from 10.0.193.3, prefix 10.0.0.19/32 DENIED due to:

    RP/0/0/CPU0:Sep 21 01:32:06.579 : bgp[139]: [rtr] (ip4lu):  as-path contains our own AS, or 0;

    RP/0/0/CPU0:Sep 21 01:32:06.580 : bgp[139]: [rtr] (ip4lu): UPDATE from 10.0.193.3, prefix 10.0.0.20/32 DENIED due to:

    RP/0/0/CPU0:Sep 21 01:32:06.581 : bgp[139]: [rtr] (ip4lu):  as-path contains our own AS, or 0;

    RP/0/0/CPU0:Sep 21 01:32:06.581 : bgp[139]: [rtr]: UPDATE from 10.0.193.3 contains nh 10.0.193.3/32, gw_afi 0, flags 0x8, nlri_afi 2

    RP/0/0/CPU0:Sep 21 01:32:06.582 : bgp[139]: [rtr] (ip4lu): Received UPDATE from 10.0.193.3 with attributes: 

    RP/0/0/CPU0:Sep 21 01:32:06.583 : bgp[139]: [rtr] (ip4lu): nexthop 10.0.193.3/32, origin i, metric 2, path 2000

    RP/0/0/CPU0:Sep 21 01:32:06.583 : bgp[139]: [rtr] (ip4lu): Received prefix 10.0.0.1/32 with MPLS label 18 from neighbor 10.0.193.3

    RP/0/0/CPU0:Sep 21 01:32:06.584 : bgp[139]: [rtr] (ip4lu): Received prefix 10.0.0.4/32 with MPLS label 16 from neighbor 10.0.193.3

    RP/0/0/CPU0:Sep 21 01:32:06.584 : bgp[139]: [rtr]: UPDATE from 10.0.193.3 contains nh 10.0.193.3/32, gw_afi 0, flags 0x8, nlri_afi 2

    RP/0/0/CPU0:Sep 21 01:32:06.586 : bgp[139]: [rtr] (ip4lu): Received UPDATE from 10.0.193.3 with attributes: 

    RP/0/0/CPU0:Sep 21 01:32:06.586 : bgp[139]: [rtr] (ip4lu): nexthop 10.0.193.3/32, origin i, metric 0, path 2000

    RP/0/0/CPU0:Sep 21 01:32:06.587 : bgp[139]: [rtr] (ip4lu): Received prefix 10.0.0.3/32 with MPLS label 3 from neighbor 10.0.193.3




    RP/0/0/CPU0:XR1#show bgp ipv4 labeled-unicast summary 

    Sat Sep 21 01:32:30.678 UTC

    BGP router identifier 10.0.0.19, local AS number 1000

    BGP generic scan interval 60 secs

    BGP table state: Active

    Table ID: 0xe0000000

    BGP main routing table version 34

    BGP scan interval 60 secs


    BGP is operating in STANDALONE mode.



    Process       RcvTblVer   bRIB/RIB   LabelVer  ImportVer  SendTblVer  StandbyVer

    Speaker              34         34         34         34          34          34


    Neighbor        Spk    AS MsgRcvd MsgSent   TblVer  InQ OutQ  Up/Down  St/PfxRcd

    10.0.0.2          0  1000      63      54       34    0    0 00:38:24          5

    10.0.193.3        0  2000     144      75       34    0    0 00:14:10          3


    RP/0/0/CPU0:XR1#

    RP/0/0/CPU0:XR1#

    RP/0/0/CPU0:XR1#show bgp ipv4 labeled-unicast labels  

    Sat Sep 21 01:32:36.063 UTC

    BGP router identifier 10.0.0.19, local AS number 1000

    BGP generic scan interval 60 secs

    BGP table state: Active

    Table ID: 0xe0000000

    BGP main routing table version 34

    BGP scan interval 60 secs


    Status codes: s suppressed, d damped, h history, * valid, > best

                  i - internal, r RIB-failure, S stale

    Origin codes: i - IGP, e - EGP, ? - incomplete

       Network            Next Hop        Rcvd Label      Local Label

    *>i10.0.0.1/32        10.0.0.5        26              16007           

    *                     10.0.193.3      18              16007           

    *>i10.0.0.2/32        10.0.0.2        3               16005           

    *> 10.0.0.3/32        10.0.193.3      3               16008           

    * i10.0.0.4/32        10.0.0.5        28              16009           

    *>                    10.0.193.3      16              16009           

    *>i10.0.0.5/32        10.0.0.5        3               16003           

    *> 10.0.0.19/32       0.0.0.0         nolabel         3               

    *>i10.0.0.20/32       10.0.0.20       3               16000           


    Processed 7 prefixes, 9 paths

    RP/0/0/CPU0:XR1#


  • Perform the following on XR1, and you will see why XR1 no longer learns any of the loopbacks of AS 2000's routers.  R3 is incorrectly sending "ipv4u" updates (without labels) to XR1.  XR1 is expecting "ipv4lu" (with labels)....so this mismatch is causing XR1 to not accepted anything advertised from R3.

     

    RP/0/0/CPU0:XR1#debug bgp update 10.0.193.3 in all all 

    Sat Sep 21 01:24:49.989 UTC

    RP/0/0/CPU0:XR1#

    RP/0/0/CPU0:XR1#RP/0/0/CPU0:Sep 21 01:24:54.837 : bgp[139]: [rtr]: aspath loop detect failed due to finding our own AS 1000

    RP/0/0/CPU0:Sep 21 01:24:54.838 : bgp[139]: [rtr]: UPDATE from 10.0.193.3 contains nh 10.0.193.3/32, gw_afi 0, flags 0x0, nlri_afi 0

    RP/0/0/CPU0:Sep 21 01:24:54.839 : bgp[139]: [rtr] (ip4u): Address family from 10.0.193.3 is unrecognized or not configured

    RP/0/0/CPU0:Sep 21 01:24:54.840 : bgp[139]: [rtr]: aspath loop detect failed due to finding our own AS 1000

    RP/0/0/CPU0:Sep 21 01:24:54.841 : bgp[139]: [rtr]: UPDATE from 10.0.193.3 contains nh 10.0.193.3/32, gw_afi 0, flags 0x0, nlri_afi 0

    RP/0/0/CPU0:Sep 21 01:24:54.842 : bgp[139]: [rtr] (ip4u): Address family from 10.0.193.3 is unrecognized or not configured

    RP/0/0/CPU0:Sep 21 01:24:54.843 : bgp[139]: [rtr]: UPDATE from 10.0.193.3 contains nh 10.0.193.3/32, gw_afi 0, flags 0x0, nlri_afi 0

    RP/0/0/CPU0:Sep 21 01:24:54.844 : bgp[139]: [rtr] (ip4u): Address family from 10.0.193.3 is unrecognized or not configured

    RP/0/0/CPU0:Sep 21 01:24:54.845 : bgp[139]: [rtr]: UPDATE from 10.0.193.3 contains nh 10.0.193.3/32, gw_afi 0, flags 0x0, nlri_afi 0

    RP/0/0/CPU0:Sep 21 01:24:54.845 : bgp[139]: [rtr] (ip4u): Address family from 10.0.193.3 is unrecognized or not configured


    Notice that XR1 states (ip4u) even though I have "send-label" on R3 -> XR1 and "add ipv4 labeled-unicast" from XR1 -> R3.


    (XR1)


    neighbor 10.0.193.3

      remote-as 2000

      address-family ipv4 labeled-unicast

       send-community-ebgp

       route-policy PASS in

       route-policy PASS out




    route-policy PASS

      pass

    end-policy



    (R3)

    router bgp 2000

    neighbor 10.0.193.19 remote-as 1000

    address-family ipv4


    neighbor 10.0.193.19 activate

      neighbor 10.0.193.19 send-community

      neighbor 10.0.193.19 route-map RFC_1998 in

      neighbor 10.0.193.19 route-map PASS out

      neighbor 10.0.193.19 send-label




    route-map PASS, permit, sequence 10

      Match clauses:

      Set clauses:

      Policy routing matches: 0 packets, 0 bytes



    However, after I remove the empty outbound route-map PASS from 10.0.193.19, XR1 was able to learn about routes and labels for loopbacks in AS 2000. 

    Notice that debug on XR1 now correctly states that it is receiving "ipv4lu" updates from R3.




    RP/0/0/CPU0:XR1#

    RP/0/0/CPU0:XR1#RP/0/0/CPU0:Sep 21 01:32:06.567 : bgp[139]: [rtr]: aspath loop detect failed due to finding our own AS 1000

    RP/0/0/CPU0:Sep 21 01:32:06.568 : bgp[139]: [rtr]: UPDATE from 10.0.193.3 contains nh 10.0.193.3/32, gw_afi 0, flags 0x8, nlri_afi 2

    RP/0/0/CPU0:Sep 21 01:32:06.570 : bgp[139]: [rtr] (ip4lu): Received unreachables from 10.0.193.3

    RP/0/0/CPU0:Sep 21 01:32:06.571 : bgp[139]: [rtr] (ip4lu): UPDATE from 10.0.193.3 with attributes:

    RP/0/0/CPU0:Sep 21 01:32:06.572 : bgp[139]: [rtr] (ip4lu): nexthop 10.0.193.3/32, origin i, originator 0.0.0.0, path 2000 1000

    RP/0/0/CPU0:Sep 21 01:32:06.572 : bgp[139]: [rtr] (ip4lu): UPDATE from 10.0.193.3, prefix 10.0.0.5/32 DENIED due to:

    RP/0/0/CPU0:Sep 21 01:32:06.573 : bgp[139]: [rtr] (ip4lu):  as-path contains our own AS, or 0;

    RP/0/0/CPU0:Sep 21 01:32:06.574 : bgp[139]: [rtr]: aspath loop detect failed due to finding our own AS 1000

    RP/0/0/CPU0:Sep 21 01:32:06.575 : bgp[139]: [rtr]: UPDATE from 10.0.193.3 contains nh 10.0.193.3/32, gw_afi 0, flags 0x8, nlri_afi 2

    RP/0/0/CPU0:Sep 21 01:32:06.575 : bgp[139]: [rtr] (ip4lu): Received unreachables from 10.0.193.3

    RP/0/0/CPU0:Sep 21 01:32:06.576 : bgp[139]: [rtr] (ip4lu): UPDATE from 10.0.193.3 with attributes:

    RP/0/0/CPU0:Sep 21 01:32:06.577 : bgp[139]: [rtr] (ip4lu): nexthop 10.0.193.3/32, origin i, originator 0.0.0.0, path 2000 1000

    RP/0/0/CPU0:Sep 21 01:32:06.577 : bgp[139]: [rtr] (ip4lu): UPDATE from 10.0.193.3, prefix 10.0.0.2/32 DENIED due to:

    RP/0/0/CPU0:Sep 21 01:32:06.578 : bgp[139]: [rtr] (ip4lu):  as-path contains our own AS, or 0;

    RP/0/0/CPU0:Sep 21 01:32:06.579 : bgp[139]: [rtr] (ip4lu): UPDATE from 10.0.193.3, prefix 10.0.0.19/32 DENIED due to:

    RP/0/0/CPU0:Sep 21 01:32:06.579 : bgp[139]: [rtr] (ip4lu):  as-path contains our own AS, or 0;

    RP/0/0/CPU0:Sep 21 01:32:06.580 : bgp[139]: [rtr] (ip4lu): UPDATE from 10.0.193.3, prefix 10.0.0.20/32 DENIED due to:

    RP/0/0/CPU0:Sep 21 01:32:06.581 : bgp[139]: [rtr] (ip4lu):  as-path contains our own AS, or 0;

    RP/0/0/CPU0:Sep 21 01:32:06.581 : bgp[139]: [rtr]: UPDATE from 10.0.193.3 contains nh 10.0.193.3/32, gw_afi 0, flags 0x8, nlri_afi 2

    RP/0/0/CPU0:Sep 21 01:32:06.582 : bgp[139]: [rtr] (ip4lu): Received UPDATE from 10.0.193.3 with attributes: 

    RP/0/0/CPU0:Sep 21 01:32:06.583 : bgp[139]: [rtr] (ip4lu): nexthop 10.0.193.3/32, origin i, metric 2, path 2000

    RP/0/0/CPU0:Sep 21 01:32:06.583 : bgp[139]: [rtr] (ip4lu): Received prefix 10.0.0.1/32 with MPLS label 18 from neighbor 10.0.193.3

    RP/0/0/CPU0:Sep 21 01:32:06.584 : bgp[139]: [rtr] (ip4lu): Received prefix 10.0.0.4/32 with MPLS label 16 from neighbor 10.0.193.3

    RP/0/0/CPU0:Sep 21 01:32:06.584 : bgp[139]: [rtr]: UPDATE from 10.0.193.3 contains nh 10.0.193.3/32, gw_afi 0, flags 0x8, nlri_afi 2

    RP/0/0/CPU0:Sep 21 01:32:06.586 : bgp[139]: [rtr] (ip4lu): Received UPDATE from 10.0.193.3 with attributes: 

    RP/0/0/CPU0:Sep 21 01:32:06.586 : bgp[139]: [rtr] (ip4lu): nexthop 10.0.193.3/32, origin i, metric 0, path 2000

    RP/0/0/CPU0:Sep 21 01:32:06.587 : bgp[139]: [rtr] (ip4lu): Received prefix 10.0.0.3/32 with MPLS label 3 from neighbor 10.0.193.3




    RP/0/0/CPU0:XR1#show bgp ipv4 labeled-unicast summary 

    Sat Sep 21 01:32:30.678 UTC

    BGP router identifier 10.0.0.19, local AS number 1000

    BGP generic scan interval 60 secs

    BGP table state: Active

    Table ID: 0xe0000000

    BGP main routing table version 34

    BGP scan interval 60 secs


    BGP is operating in STANDALONE mode.



    Process       RcvTblVer   bRIB/RIB   LabelVer  ImportVer  SendTblVer  StandbyVer

    Speaker              34         34         34         34          34          34


    Neighbor        Spk    AS MsgRcvd MsgSent   TblVer  InQ OutQ  Up/Down  St/PfxRcd

    10.0.0.2          0  1000      63      54       34    0    0 00:38:24          5

    10.0.193.3        0  2000     144      75       34    0    0 00:14:10          3


    RP/0/0/CPU0:XR1#

    RP/0/0/CPU0:XR1#

    RP/0/0/CPU0:XR1#show bgp ipv4 labeled-unicast labels  

    Sat Sep 21 01:32:36.063 UTC

    BGP router identifier 10.0.0.19, local AS number 1000

    BGP generic scan interval 60 secs

    BGP table state: Active

    Table ID: 0xe0000000

    BGP main routing table version 34

    BGP scan interval 60 secs


    Status codes: s suppressed, d damped, h history, * valid, > best

                  i - internal, r RIB-failure, S stale

    Origin codes: i - IGP, e - EGP, ? - incomplete

       Network            Next Hop        Rcvd Label      Local Label

    *>i10.0.0.1/32        10.0.0.5        26              16007           

    *                     10.0.193.3      18              16007           

    *>i10.0.0.2/32        10.0.0.2        3               16005           

    *> 10.0.0.3/32        10.0.193.3      3               16008           

    * i10.0.0.4/32        10.0.0.5        28              16009           

    *>                    10.0.193.3      16              16009           

    *>i10.0.0.5/32        10.0.0.5        3               16003           

    *> 10.0.0.19/32       0.0.0.0         nolabel         3               

    *>i10.0.0.20/32       10.0.0.20       3               16000           


    Processed 7 prefixes, 9 paths

    RP/0/0/CPU0:XR1#


  • When you use an outbound route-map in IOS and labeled unicast you have to use "set mpls-label" in the route-map even if its otherwise empty, otherwise IOS won't send labels for matched prefixes.

  • Even with the SG I still have issues. Do you enable the address-family ipv4 unicast on XR1 for R3 or you disable it like in the SG?

     

    If I enable the ipv4 unicast family I got the loopback of AS1000 in AS2000 but the LSP is broken, I cannot ping from R6 to AS1000 VRF FOO.

Sign In or Register to comment.