BGP - Aggregate-address as-set summary-only

Hi There,

I was doing some BGP labs tonight and I noticed some unexpected behaviour in the Aggregate-address command.

When I configure an aggregate-address in BGP I send out the summary route as well as all the individual routes that were summarised. (all good)

When I configure an aggregate-address with the summary-only keyword I send the summary-address and DO NOT include the individual routes. (all good)

When I configure an aggregate-address with the AS-set keyword AND the summary-only keyword I send the summary-address only (no individual routes) but I include the AS numbers of all of the individual routes. (all good)

When I configure an aggregate-address and a suppress-map I send the summary-address and all the individual routes except for the routes that are specified in the suppress-map route-map. (all good)

However,

When I configure an aggregate-address with the AS-set keyword and the suppress-map keyword I do NOT send the summary-address??? (Weird) but the suppress-map works as I also do not send the prefix specified in the suppress-map route-map. I expected to see the summary route as well??? When I remove as-set from the command it advertises the summary except for the suppress-map routes and also shows the as-set info.

It seems as-set is breaking this command for me?

Is this a bug or is this normal behaviour. 

I am using GNS3 and IOS version "3600 Software (C3640-JK9S-M), Version 12.4(16), RELEASE SOFTWARE (fc1)"

Comments

  • Have you tried resetting the BGP neighbors? I labbed it up in GNS3 and everything is working like a charm.

    3700 Software (C3725-ADVENTERPRISEK9-M), Version 12.4(15)T10

     

  • Thanks for trying that HS268. I did deset the neighbours but it didn't fix the situation. The example I used was actually quite complex and for the sake of simplicity I left out a few details. I didn't think these would make any difference but maybe they do. I will paste some config when I get home tonight. Basically, it involves some local-as and allow-as-in config as well as the config you have tried. I'll be back in touch after some labbing when I get home. (currently at work)

  • Thanks for trying that HS268. I did deset the neighbours but it didn't fix the situation. The example I used was actually quite complex and for the sake of simplicity I left out a few details. I didn't think these would make any difference but maybe they do. I will paste some config when I get home tonight. Basically, it involves some local-as and allow-as-in config as well as the config you have tried. I'll be back in touch after some labbing when I get home. (currently at work)


    I also left one detail out. I did not use both summary-only and suppress-map in the same command in my previous test. While both are allowed invidually, these two options are by their own definition incompatible with each other I believe.

    As a test I did use both summary-only and suppress-map. The end result? Both the summry route and all the member routes are advertised. It seems the two options cancelled each other! I think the behavior might be undefined and paltform dependent.

  • Well I got home and tried to replicate the issue and post the results. The stupid router did exactly what I asked it to  :-)

     I cannot replicate the issue so I guess I was misconfiguring it when it occurred. Thanks for checking it out. I was combining exist/advertise maps with local-as/allow-as-in and aggregate addresses with all of the options turned on. I guess I messed up. Anyway, its good practice and thats the name of the game. Mistakes = learning.

  • LOL. Sometimes you just hate it when it works! Have been there (a lot). I'd have to say that 99% of times the problem is ours - like some nitty-gritty details we overlooked. When I started out as a C programmer in the system/platform area, I used to suspect UNIX kernel bugs a lot. I don't recall any of those suspicion turned out to be true :)

Sign In or Register to comment.