-BGP-

Hi,

I have 4 routers in AS1(R1,R8,R9,R10) and 6 routers in AS2 (R2,R3,R4,R5,R6,R7)

There is iBGP within AS1 and iBGP within AS2 and ofcourse eBGP within the AS1 and AS2.

R!-R2 and R7-R8 are the eBGP running..

When i do show ip bgp and show ip route bgp in all routers;

I can see AS2 routes installed in AS1 but i cannot see my own AS1 routes installed.

Same way I can see AS1 routes installed in AS2 but i do not see AS2 routes installed.

To summerize, AS1 routes are visible in AS2 and AS2 routes are visible in AS1 but not their own AS routes are visible..

 

For Example:-

I am in AS1. I can see AS2 routes but not my own AS1 routes.

sh rou bg
Fri Feb 15 05:23:55.388 UTC

B    9.9.0.2/32 [200/0] via 9.9.0.8, 00:00:17
B    9.9.0.3/32 [200/0] via 9.9.0.8, 00:00:17
B    9.9.0.4/32 [200/0] via 9.9.0.8, 00:00:17
B    9.9.0.5/32 [200/0] via 9.9.0.8, 00:00:17
B    9.9.0.6/32 [200/0] via 9.9.0.8, 00:00:17
B    9.9.0.7/32 [200/0] via 9.9.0.8, 00:00:17

 

RP/0/0/CPU0:XR1(config)#do sh bgp ipv4 uni

Status codes: s suppressed, d damped, h history, * valid, > best
              i - internal, r RIB-failure, S stale
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network            Next Hop            Metric LocPrf Weight Path
*> 9.9.0.1/32         0.0.0.0                  0         32768 i
*>i9.9.0.2/32         9.9.0.8                  0    300      0 9 i
*                     9.9.12.2                 0             0 9 i
*>i9.9.0.3/32         9.9.0.8                  0    300      0 9 i
*                     9.9.12.2                               0 9 i
*>i9.9.0.4/32         9.9.0.8                  0    300      0 9 i
*                     9.9.12.2                               0 9 i
*>i9.9.0.5/32         9.9.0.8                  0    300      0 9 i
*                     9.9.12.2                               0 9 i
*>i9.9.0.6/32         9.9.0.8                  0    300      0 9 i
*                     9.9.12.2                               0 9 i
*>i9.9.0.7/32         9.9.0.8                  0    300      0 9 i
*                     9.9.12.2                               0 9 i

*>i9.9.0.8/32         9.9.0.8                  0    100      0 i
* i9.9.0.9/32         9.9.0.9                  0    100      0 i
*>i                   9.9.0.9                  0    100      0 i
* i9.9.0.10/32        9.9.0.10                 0    100      0 i
*>i                   9.9.0.10                 0    100      0 i

Processed 10 prefixes, 18 paths

 

looks like its getting installed but not using as valid path..

*>i9.9.0.8/32         9.9.0.8                  0    100      0 i
* i9.9.0.9/32         9.9.0.9                  0    100      0 i
*>i                   9.9.0.9                  0    100      0 i
* i9.9.0.10/32        9.9.0.10                 0    100      0 i
*>i                   9.9.0.10                 0    100      0 i

 

I am in AS2

 


      9.0.0.0/8 is variably subnetted, 19 subnets, 2 masks
B        9.9.0.1/32 [200/0] via 9.9.0.7, 00:21:21
B        9.9.0.8/32 [200/0] via 9.9.0.7, 00:21:21
B        9.9.0.9/32 [200/0] via 9.9.0.7, 00:21:21
B        9.9.0.10/32 [200/0] via 9.9.0.7, 00:21:21
R5(config)# do sh ip bgp
BGP table version is 118, local router ID is 172.9.0.5
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, x best-external
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i9.9.0.1/32       9.9.0.7                  0    300      0 1009 i
* i                 9.9.0.7                  0    300      0 1009 i
r i9.9.0.2/32       9.9.0.2                  0    100      0 i
r>i                 9.9.0.2                  0    100      0 i
r i9.9.0.3/32       9.9.0.3                  0    100      0 i
r>i                 9.9.0.3                  0    100      0 i
r i9.9.0.4/32       9.9.0.4                  0    100      0 i
r>i                 9.9.0.4                  0    100      0 i
*> 9.9.0.5/32       0.0.0.0                  0         32768 i
r i9.9.0.6/32       9.9.0.6                  0    100      0 i
r>i                 9.9.0.6                  0    100      0 i
r i9.9.0.7/32       9.9.0.7                  0    100      0 i
r>i                 9.9.0.7                  0    100      0 i
* i9.9.0.8/32       9.9.0.7                  0    300      0 1009 i
*>i                 9.9.0.7                  0    300      0 1009 i
   Network          Next Hop            Metric LocPrf Weight Path
*>i9.9.0.9/32       9.9.0.7                  0    300      0 1009 i
* i                 9.9.0.7                  0    300      0 1009 i
*>i9.9.0.10/32      9.9.0.7                  0    300      0 1009 i
* i                 9.9.0.7                  0    300      0 1009 i
R5(config)#

 

9.9.0.1,9.9.0.8, 9.9.0.9, 9.9.0.10 are all in AS 1

9.9.0.2,9.9.0.3,9.9.0.4,9.9.0.5,9.9.0.6,9.9.0.7 are all in AS2

 

In AS1 I do not see my own installed routes which is 9.9.0.1,9.9.0.8,9.9.0.9,9.9.0.10 but i can see all routes of AS2.

In AS2 i do not see my own AS2 routes but i can see AS1 routes installed. 

 

The IGP running in AS1 is ISIS and IGP running in AS2 is OSPF

By seeing these, it looks like rib-failure...the goal is to ping both sides with source loopback address...so how to overcome rib-failure...

Can anyone help on this please...

 

Thanks

GP

Comments

  • Could your IGP routes be keeping your internal BGP routes out of the routing table?

  • All IGP protocols (EIGRP, OSPF, ISIS and RIP) and preferred over internal BGP routes, having administrative distance of 200 (see http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a0080094823.shtml) . Since you are peering with iBGP within your AS, all of the routes end up in the BGP-table with r, representing rib-failure, as you stated yourself.

    You should still have a reachability between your ASs just fine with the current configuration / setup. AS2 will simply use eBGP routes to reach your AS, and starting from your ASBR the traffic will follow your IGP routes.

  • Hi,

    IGP will be taken into consideration when we are within AS..but i should be able to reach from either way with source as loopback which i can't..is there any thing comands to overcome the rib-failure..pls let me know..config is straight forward..there is no redistribution in both AS sites...all are kept seperatly..its been hours troubleshooting still nothing i can do..

  • You are either redistributing ASBR-ASBR link into your IGP on both sides or doing next-hop-self on ASBR towards the other iBGP peers, aren't you?

  • A rib failure with BGP for prefixes within your AS isn't unexpected.  Routes learnt via iBGP will have a default AD of 200 which is beaten by the AD of all IGP protocols.  BGP will still advertise these prefixes to other peers regardless of this failure.  You can change this behavior for BGP with bgp suppress-inactive.  It wouldn't necessarily be wise to reduce the AD for iBGP routes although this wouldn't actually impact ISIS or OSPF as they don't rely on the routing table to distribute routes - unlike RIP and EIGRP.

    So the question is do you have an actual problem?  Is there full reachability?

     

  • Hi,

    I am not redistributing anything,just using next-hop-self and RR..

    Thanks

    GP

  • Hi,

    well, even if we use that command still the behaviour is the same it will show any rib-failure anymore....

    the question is in between the bgp i should have connectivity because i am advertising the loopback interfaces on both IGP and EGP

    so by this i shoudl be able to communcate within bgp and also with ebgp..

  • the question is in between the bgp i should have connectivity because i am advertising the loopback interfaces on both IGP and EGP

    So you describe your actual problem it's not clear e.g. can't ping this address when sourced from this address?  Have you tried any other verifications?

    Also a network diagram would help.

    As I stated previously a RIB failure in it's self isn't causing you a problem.  For example if do show ip route you will see the internal AS routes learnt via you IGP.

    The point I was trying to make about the command was that even if a BGP route has a RIB failure it is still advertised by default.

    Sorry to be a pain!

  • Hi,

    Thanks for the reply..

    its basic setup...

    there are 10 routers....R1,R8,R9,R10 are in AS1  and   R2,R3,R4,R5,R6,R7 are in AS2

    R1-R2 are EBGP   and    R7-R8 are EBGP

    R1,R8 are the RR for the AS1     and      R2,R7 are the RR for the AS2

    in AS1 ISIS is the IGP    and  in AS2 OSPF is the IGP

    i am not redistributing anything....all i am doing is using next-hop-self commands in R1,R2,R7,R8

    i am advertising the loopbacks in both IGP and EGP

    the goal here to ping from loopback to loopback from both direction AS1 to AS2 and AS2 to AS1 with all the 10 loopbacks inside both AS sites. that means all the routers should learn about all the 10 loopbacks of both AS sites..

    for example...9.9.0.x are the loopbacks of each router   and  9.9.0.5 source 9.9.0.1 should be reachable..

    R9---R1---R2---R3---R5

    |        |      |      |       |

    R10--R8---R7---R4---R6

    --AS1--     -----AS2------

    Thanks

    GP

     

  • its basic setup...

    So can you explain what is not working - from a reachability perspective?

  • Hi,

    i cannot reach from loopback of R1 to loopback of R5 (this is just an example)

    i cannot reach from the source of AS1 to destination loopback of AS2 or vice versa...

    lets say you are in R1 and you want to reach R5

    so ping 9.9.0.5 sou 9.9.0.1 is not working...like wise for all routers between AS1 to AS2 and vice versa..

    here is the full config...i have also given the show ip rou bgp...

     


    XR1

    route-policy PASS

      pass

    end-policy

    !

    router static

     address-family ipv4
    unicast

      9.9.12.2/32
    POS0/2/0/0

     !

    !

    router isis abc

     is-type level-2-only

     net
    0101.0000.0000.0001.00

     address-family ipv4
    unicast

      metric-style wide

     !

     address-family ipv6
    unicast

      metric-style wide

      single-topology

     !

     interface Loopback0

      address-family ipv4
    unicast

      !

      address-family ipv6
    unicast

      !

     !

     interface
    GigabitEthernet0/1/0/1.18

      address-family ipv4
    unicast

      !

      address-family ipv6
    unicast

      !

     !

     interface
    GigabitEthernet0/1/0/1.19

      address-family ipv4
    unicast

      !

      address-family ipv6
    unicast

      !

     !

    !

    router bgp 1

     address-family ipv4
    unicast

      network 9.9.0.1/32

      allocate-label all

     !

     address-family ipv6
    unicast

      network
    2002:9:9::1/128

     !

     neighbor 9.9.0.8

      remote-as 1

      update-source
    Loopback0

      address-family ipv4
    unicast

       route-policy PASS
    in

       route-reflector-client

       route-policy PASS
    out

       next-hop-self

      !

     !

     neighbor 9.9.0.9

      remote-as 1

      update-source
    Loopback0

      address-family ipv4
    unicast

       route-policy PASS
    in

      
    route-reflector-client

       route-policy PASS
    out

       next-hop-self

      !

     !

     neighbor 9.9.0.10

      remote-as 1

      update-source
    Loopback0

      address-family ipv4
    unicast

       route-policy PASS
    in

      
    route-reflector-client

       route-policy PASS
    out

       next-hop-self

      !

     !

     neighbor 9.9.12.2

      remote-as 2

      ebgp-multihop 255

      address-family ipv4
    unicast

       route-policy PASS
    in

       route-policy PASS
    out

      
    send-extended-community-ebgp

      !

     !

    !

    End

     

     

    XR2

    !

    interface POS0/5/0/0

     ipv4 address 9.9.12.2
    255.255.255.0

     ipv6 address
    2002:9:9:12::2/64

    !

    route-policy PASS

      pass

    end-policy

    !

    router static

     address-family ipv4
    unicast

      9.9.12.1/32
    POS0/5/0/0

     !

    !

    router ospf 9

     router-id 9.9.0.2

     address-family ipv4
    unicast

     area 0

      interface Loopback0

      !

      interface
    GigabitEthernet0/4/0/1.23

      !

      interface
    GigabitEthernet0/4/0/1.27

      !

     !

    !

    router ospfv3 9

     router-id 9.9.0.2

     address-family ipv6
    unicast

     area 0

      interface Loopback0

      !

      interface
    GigabitEthernet0/4/0/1.23

      !

      interface
    GigabitEthernet0/4/0/1.27

      !

     !

    !

    router bgp 9

     address-family ipv4
    unicast

      network 9.9.0.2/32

      allocate-label all

     !

     address-family ipv6
    unicast

      network
    2002:9:9::2/128

     !

     neighbor 9.9.0.3

      remote-as 2

      update-source
    Loopback0

      address-family ipv4
    unicast

       route-policy PASS
    in

      
    route-reflector-client

       route-policy PASS
    out

       next-hop-self

      !

     !

     neighbor 9.9.0.4

      remote-as 2

      update-source
    Loopback0

      address-family ipv4
    unicast

       route-policy PASS
    in

       route-policy PASS
    out

       next-hop-self

      !

     !

     neighbor 9.9.0.5

      remote-as 2

      update-source
    Loopback0

      address-family ipv4
    unicast

       route-policy PASS
    in

      
    route-reflector-client

       route-policy PASS
    out

       next-hop-self

      !

     !

     neighbor 9.9.0.6

      remote-as 2

      update-source
    Loopback0

      address-family ipv4
    unicast

       route-policy PASS
    in

       route-reflector-client

       route-policy PASS
    out

       next-hop-self

      !

     !

     neighbor 9.9.0.7

      remote-as 2

      update-source
    Loopback0

      address-family ipv4
    unicast

       route-policy PASS
    in

      
    route-reflector-client

       route-policy PASS
    out

       next-hop-self

      !

     !

     neighbor 9.9.12.1

      remote-as 1

      ebgp-multihop 255

      address-family ipv4
    unicast

       route-policy PASS
    in

       route-policy PASS
    out

      
    send-extended-community-ebgp

      !

     !

    !

    End

     

    XR3

     

    !

    interface Loopback0

     ipv4 address 9.9.0.3
    255.255.255.255

     ipv6 address
    2002:9:9::3/128

    !

    route-policy PASS

      pass

    end-policy

    !

    router ospf 9

     router-id 9.9.0.3

     address-family ipv4
    unicast

     area 0

      interface Loopback0

      !

      interface
    GigabitEthernet0/7/0/0.23

       cost 50

      !

      interface
    GigabitEthernet0/7/0/0.34

      !

      interface
    GigabitEthernet0/7/0/0.35

      !

     !

    !

    router ospfv3 9

     router-id 9.9.0.3

     address-family ipv6
    unicast

     area 0

      interface Loopback0

      !

      interface
    GigabitEthernet0/7/0/0.23

      !

     !

     area 1

      interface
    GigabitEthernet0/7/0/0.34

      !

      interface
    GigabitEthernet0/7/0/0.35

      !

     !

    !

    router bgp 9

     address-family ipv4
    unicast

      network 9.9.0.3/32

      allocate-label all

     !

     address-family ipv6
    unicast

      network
    2002:9:9::3/128

     !

     neighbor 9.9.0.2

      remote-as 2

      update-source
    Loopback0

      address-family ipv4
    unicast

       route-policy PASS
    in

       route-policy PASS
    out

      !

     !

     neighbor 9.9.0.7

      remote-as 2

      update-source
    Loopback0

      address-family ipv4
    unicast

       route-policy PASS
    in

       route-policy PASS
    out

      !

     

    End

     

     

    XR4

     

    !

    interface Loopback0

     ipv4 address 9.9.0.4
    255.255.255.255

     ipv6 address
    2002:9:9::4/128

    !

    route-policy PASS

      pass

    end-policy

    !

    router ospf 9

     router-id 9.9.0.4

     address-family ipv4
    unicast

     area 0

      interface Loopback0

      !

      interface
    GigabitEthernet0/9/0/0.34

      !

      interface
    GigabitEthernet0/9/0/0.46

      !

      interface
    GigabitEthernet0/9/0/0.47

      !

     !

    !

    router ospfv3 9

     address-family ipv6
    unicast

     area 0

      interface Loopback0

      !

      interface
    GigabitEthernet0/9/0/0.47

      !

     !

     area 1

      interface
    GigabitEthernet0/9/0/0.34

      !

      interface
    GigabitEthernet0/9/0/0.46

      !

     !

    !

    router bgp 9

     address-family ipv4
    unicast

      network 9.9.0.4/32

      allocate-label all

     !

     address-family ipv6
    unicast

      network
    2002:9:9::4/128

     !

     neighbor 9.9.0.2

      remote-as 2

      update-source
    Loopback0

      address-family ipv4
    unicast

       route-policy PASS
    in

       route-policy PASS
    out

      !

     !

     neighbor 9.9.0.7

      remote-as 2

      update-source
    Loopback0

      address-family ipv4
    unicast

       route-policy PASS
    in

       route-policy PASS
    out

      !

     

    End

     

     

    R5

     

     

    !

    !

    !

    !

    interface Loopback0

     ip address 9.9.0.5
    255.255.255.255

     ipv6 address
    2002:9:9::5/128

     ipv6 ospf 9 area 1

    router ospf 9

     router-id 9.9.0.5

     log-adjacency-changes

     network 9.9.0.5
    0.0.0.0 area 0

     network 9.9.35.5
    0.0.0.0 area 0

     network 9.9.56.5 0.0.0.0
    area 0

    !

    router bgp 9

     no bgp default
    ipv4-unicast

     no bgp default
    route-target filter

     bgp
    log-neighbor-changes

     neighbor 9.9.0.2
    remote-as 2

     neighbor 9.9.0.2
    update-source Loopback0

     neighbor 9.9.0.7
    remote-as 2

     neighbor 9.9.0.7
    update-source Loopback0

     

     address-family ipv4

      no synchronization

      network 9.9.0.5 mask
    255.255.255.255

      neighbor 9.9.0.2
    activate

      neighbor 9.9.0.2
    send-community both

      neighbor 9.9.0.2
    send-label

      neighbor 9.9.0.7
    activate

      neighbor 9.9.0.7
    send-community both

      neighbor 9.9.0.7
    send-label

      no auto-summary

     exit-address-family

     !

    no ip http server

    no ip http secure-server

    !

    ip bgp-community new-format

    end

     

    R5#

     

     

    R6

     

     

    !

    !

    interface Loopback0

     ip address 9.9.0.6
    255.255.255.255

    router ospf 9

     router-id 9.9.0.6

     log-adjacency-changes

     network 9.9.0.6
    0.0.0.0 area 0

     network 9.9.46.6
    0.0.0.0 area 0

     network 9.9.56.6
    0.0.0.0 area 0

    !

    router bgp 9

     no bgp default
    ipv4-unicast

     no bgp default
    route-target filter

     bgp
    log-neighbor-changes

     neighbor 9.9.0.2
    remote-as 2

     neighbor 9.9.0.2 update-source
    Loopback0

     neighbor 9.9.0.7
    remote-as 2

     neighbor 9.9.0.7
    update-source Loopback0

     

    address-family ipv4

      no synchronization

      network 9.9.0.6 mask
    255.255.255.255

      neighbor 9.9.0.2
    activate

      neighbor 9.9.0.2
    send-community both

      neighbor 9.9.0.2
    send-label

      neighbor 9.9.0.7
    activate

      neighbor 9.9.0.7
    send-community both

      neighbor 9.9.0.7
    send-label

      no auto-summary

     exit-address-family

    end

     

    R6#

     

     

    R7

     

     

    !

    !

    !

    interface Loopback0

     ip address 9.9.0.7
    255.255.255.255

    interface Serial2/0

     ip address 9.9.78.7
    255.255.255.0

     encapsulation ppp

     serial restart-delay
    0

    router ospf 9

     router-id 9.9.0.7

     log-adjacency-changes

     network 9.9.0.7
    0.0.0.0 area 0

     network 9.9.27.7
    0.0.0.0 area 0

     network 9.9.47.7
    0.0.0.0 area 0

    !

    router bgp 9

     no bgp default
    ipv4-unicast

     no bgp default
    route-target filter

     bgp
    log-neighbor-changes

     neighbor 9.9.0.2
    remote-as 2

     neighbor 9.9.0.2
    update-source Loopback0

     neighbor 9.9.0.3
    remote-as 2

     neighbor 9.9.0.3
    update-source Loopback0

     neighbor 9.9.0.4
    remote-as 2

     neighbor 9.9.0.4
    update-source Loopback0

     neighbor 9.9.0.5
    remote-as 2

     neighbor 9.9.0.5
    update-source Loopback0

     neighbor 9.9.0.6
    remote-as 2

     neighbor 9.9.0.6
    update-source Loopback0

     neighbor 9.9.78.8
    remote-as 1

     neighbor 9.9.78.8
    ebgp-multihop 255

    !

     address-family ipv4

      no synchronization

      network 9.9.0.7 mask
    255.255.255.255

      neighbor 9.9.0.2
    activate

      neighbor 9.9.0.2
    send-community both

      neighbor 9.9.0.2
    route-reflector-client

      neighbor 9.9.0.2
    next-hop-self

      neighbor 9.9.0.2
    send-label

      neighbor 9.9.0.3
    activate

      neighbor 9.9.0.3
    send-community both

      neighbor 9.9.0.3
    route-reflector-client

      neighbor 9.9.0.3
    next-hop-self

      neighbor 9.9.0.3
    send-label

      neighbor 9.9.0.4
    activate

      neighbor 9.9.0.4
    send-community both

      neighbor 9.9.0.4
    route-reflector-client

      neighbor 9.9.0.4
    next-hop-self

      neighbor 9.9.0.4
    send-label

      neighbor 9.9.0.5
    activate

      neighbor 9.9.0.5
    send-community both

      neighbor 9.9.0.5
    route-reflector-client

      neighbor 9.9.0.5
    next-hop-self

      neighbor 9.9.0.5
    send-label

      neighbor 9.9.0.6
    activate

      neighbor 9.9.0.6
    send-community both

      neighbor 9.9.0.6
    route-reflector-client

      neighbor 9.9.0.6
    next-hop-self

      neighbor 9.9.0.6
    send-label

      neighbor 9.9.78.8 activate

      neighbor 9.9.78.8
    send-community both

      neighbor 9.9.78.8
    route-map LP in

      neighbor 9.9.78.8
    send-label

      no auto-summary

     exit-address-family

     !

    !

    route-map LP permit 10

     set local-preference
    300

    !

    end

     

    R7(config)#

     

     

    R8

     

     

    !

    !

    !

    interface Loopback0

     ip address 9.9.0.8
    255.255.255.255

     ip router isis

     

    interface Serial2/0

     ip address 9.9.78.8
    255.255.255.0

     encapsulation ppp

    router isis

     net
    47.0108.0000.0000.0008.00

     metric-style wide

    !

    router bgp 1009

     no bgp default
    ipv4-unicast

     no bgp default
    route-target filter

     bgp
    log-neighbor-changes

     neighbor 9.9.0.1
    remote-as 1

     neighbor 9.9.0.1
    update-source Loopback0

     neighbor 9.9.0.9
    remote-as 1

     neighbor 9.9.0.9
    update-source Loopback0

     neighbor 9.9.0.10
    remote-as 1

     neighbor 9.9.0.10
    update-source Loopback0

     neighbor 9.9.78.7
    remote-as 2

     neighbor 9.9.78.7 ebgp-multihop
    255

     neighbor 2002:9:9::1
    remote-as 1

     neighbor 2002:9:9::1
    update-source Loopback0

     neighbor
    2002:9:9:78::7 remote-as 2

     !       

     address-family ipv4

      no synchronization

      network 9.9.0.8 mask
    255.255.255.255

      neighbor 9.9.0.1
    activate

      neighbor 9.9.0.1
    send-community both

      neighbor 9.9.0.1
    route-reflector-client

      neighbor 9.9.0.1
    next-hop-self

      neighbor 9.9.0.1
    send-label

      neighbor 9.9.0.9
    activate

      neighbor 9.9.0.9
    send-community both

      neighbor 9.9.0.9
    route-reflector-client

      neighbor 9.9.0.9
    next-hop-self

      neighbor 9.9.0.9
    send-label

      neighbor 9.9.0.10
    activate

      neighbor 9.9.0.10
    send-community both

      neighbor 9.9.0.10
    route-reflector-client

      neighbor 9.9.0.10
    next-hop-self

      neighbor 9.9.0.10
    send-label

      neighbor 9.9.78.7
    activate

      neighbor 9.9.78.7
    send-community both

    <span style="mso-

  • hi,

    loopback to loopback cannot be reached from either AS as source/destination..

    for example...from R1 loopback to R5 loopback cannot be reached...

    R1 loopback 9.9.0.1  R5 loopback 9.9.0.5

     

    so from R1 ping 9.9.0.5 source 9.9.0.1 cannot be reached....

    like wise any loopbacks in either AS are not working...

    Thanks

    GP

  • hi,

    can we use the route-map to redistribute the loopback in real lab exam due to rib-failure???

    i think if we use the route-map redistributed loopback might solve  the issue

    pls let me know..

    Thanks

    GP


  • Can you ping from R7 to R8 loopback to loopback. 

  • Can you ping from R7 to R8 loopback to loopback. 

    I couldn't agree more - I know we asked for more information - but you have to follow a structured approach by breaking the problem down.

    1. have you got full reachability within each AS
    2. Can you ping the IP addresses of the EIGRP neighbors
    3. Are all BGP peerings operational - eBGP and iBGP.
    4. Can the border routers ping each other loopbacks
    5. Can every router with one AS ping the border router's loopback in the other.

    And so on!  This is analogy of throwing a stone in a pond - start small and work outwards!

    Also I'm no expert on XR so I guess some else could comment on the attached configuration?

    By border router in this context - I mean a router running eBGP to the other AS.

    HTH

  • hi,

    thanks for the reply..no i cannot ping..

    all loopbacks in AS1 cannot ping all AS2 loopbacks and same vice versa..

    for example all R7 to R8

    ping 9.9.0.8 sou 9.9.0.7 not reachable..

    Thanks

    GP

  • hi,

    sorry about that...

    yes i can ping from R1-R2 and R7-R8 loopback to loopback..

    thanks

    GP

  • hi,

    its working fine now..changed the image..

    Thanks

    GP

     

Sign In or Register to comment.