Transformation patterns will not fire

I can't get any of my called party transformation patterns to fire in CUCM on any of my gateways. The TPs are in a partition that is assigned to a CSS that is assigned to each MGCP and H323 gateway. The TPs are not assigned to the device pools. The calls are going to the gateways because I can see the calls in the q931 debug output on each of the routers.

For example, I make a call to 912065015111. The translation pattern strips the 9 and globalizes to +12065015111. A route pattern +.! sends the call to the gateway. There is no digit strip or prefix so the number stays +12065015111.

My understanding is that the called party transformation pattern should kick in and localize the called party number. The called party TP is +.! with predot digit strip and no prefix. The called party number should be 12065015111 but the Q931 debug output on the router gateway shows +12065015111.  

Would appreciate some assistance to get the TP to work. What am I missing?

Comments

  • Double check that you applied to the called party transformation drop down. The way the interface is laid out it can be easy to apply to the Calling Party Transformation drop down.

  • Thanks for the response. I did check and the called party transformation pattern CSSs are being applied correctly to all 3 of the gateways with the problem.  Also, the "use device pool" setting on the gateway configuration is unchecked.

  • Did you reset MGCP gateway on the CM and no mgcp/mgcp in the ios gateway to apply the change?

     

  • Thanks. I am working on the INE voice racks. Each day a different rack but same configuration. Today I was on Vorack9. I loaded a tar file with a full set of translation patterns, route patterns, transformation patterns etc.. Everything loaded fine. The translation patterns work fine. The route patterns work fine. However, the transformation patterns for the MGCP and H323 gateways don't fire. I think it is a bug. I will give it another try tomorrow.

  • Hi,

    Please check with Dialed Number Analyzer (DNA) and find out if it's going through the CdPTP of not. Double check your CSS/Partition setting - dont reuse any CSS/Partition for the time being.

    Remember to reset the gateways from UCM to effect the changes.

  • Thanks. I have a voice lab rack rental at 12 PST today and will run the DNA and report back the results.

  • Thanks. I did use the DNA. However, the DNA by design does not list any called or calling party transformation patterns. I then checked the CSS and partiton settings. The called party transformation CSS were missing the partition assignment. Hmmmm....what could be the problem. I know I created and set the CSS and partitions. I checked my previous saved export configurations and found that ALL partition assignmemts to ALL CSS disappeared 4 sessions earlier. I either had a bad export or a bad import. Thanks. I learned something new.

  • Nice to hear that you found the root cause. I was also curious on your issue and I thought CSS/Partition settings are fine as this is the 'most' basic part to check.

  • I had a really similar issue on Vorack2 today.  Had it booked all day, but no matter what could not get Transformation patterns to fire via the MGCP gateway.

    CSSs were all OK, and contained the correct partitions.  Patterns matched as they should have.  CSS was applied to the port in MGCP config, and the tick box wasn't checked.

     

    Tried reloading the router, removing it and adding it again, nothing.

     

    Is there either some bug in 7.0, or a bug in Vorack2?

     

    EDIT:

    This one just got weirder.  It really bugged me so I booked some more rack time, now on vrack1.

     

    So call flow is like this B2Ph1 (3001, mask is set to +31207030XX -> RP (112, Use EPNM set to ON) -> RL (not SLRG) -> RG (Br2MGCPGw) -> CgPtXForm -> E1

     

    So without and xform, we get calling party at PSTN as +3120703001.

    With a xform of pattern: +3120.7030! digit strip predot, we get +3120703001

    If I add an xform of pattern: 3001 prefix digits 70, we get calling party at PSTN as 703001 (which is what I was trying to achieve.

     

    Calling Party Transform is set on the MGCP gateway, with correct CSS, and DP checkbox unticked.

     

    I'm guessing then on 7.0.1 the order of operations is REALLY weird with MGCP gateways?? 


  • While calling out you cannot DM the calling party number using ‘Calling Party Transformation Pattern’, on the same while calling in you cannot DM the called party number using ‘Called Party Transformation Pattern’.

    This is not a bug, just a limitation of release UCM 7.0 - this is fixed on later UCM releases. Please use other mechanisms to menipulate the calling #.

  • I am only able to get the calling party transformation patterns to match using the internal DNs, like 3XXX. I was never able to get the calling party transformation pattern to match on the calling party mask. I think that may be the design but have never seen documentation to that effect.

    In your case, if the Calling party TP is not used then the mask kicks in and gives you the correct calling party of +3120703001.

    If the calling party TP of +3120.7030! digit strip predot is used, there would be no TP match and the mask would kick in giving the correct +3120703001.

    So, I believe the calling party TP has to match to the internal DN...not the mask...in order for the TP to fire.

    I have found each Vorack session to be an adventure.

    regards,

     

  • I am on Vorack1 today. The calling party TPs are firing when I configure the following;

    The calling party TP of 2XXX will match and fire if I do not apply a calling party mask to the DN.

    The calling party TP of 512602XXXX will match and fire if the calling party mask of 512602XXXX is applied to the DN.

    The above worked for MGCP and H323 gateways.

    Any change to the TP requires a reset of the phone. It doesn't say to reset but must have a reset.

    regards,

  • Hi gyus,

     

    I have more or less the same situation.

    The MGCP doest not process the + . Im working with few rack,, i delete and put again the prefix configuration under incoming calling party settings , no mgcp,mgcp but nothing ..calls come to gw without + and missed calls under the phone .

    Also if i call from branch2 phones to the pstn "austin or seattle ofr example ,,calls progress". But if i call to CorpHQ ph1 calls doesnt progress and hit the following translation : +! instead of 00.! . I force with a more specific TP but again the same.

    Also i create a more specific called transformation and the same...

    :/

    Regads

     

Sign In or Register to comment.