ISDN interfaces are not up

Hi,

 

I am trying to set up a lab in for emulating a PSTN connection. I could not bring up the interfaces. I am using the cross over cable to connect the T1 interfaces of PSTN router directly to the HQ Router T1 interface.

 

PSTNRouter#show isdn status
Global ISDN Switchtype = primary-ni
ISDN Serial0/3/0:23 interface
        ******* Network side configuration *******
        dsl 1, interface ISDN Switchtype = primary-ni
    Layer 1 Status:
        DEACTIVATED
    Layer 2 Status:
        TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED
    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Active dsl 1 CCBs = 0
    The Free Channel Mask:  0x00000000
    Number of L2 Discards = 0, L2 Session ID = 0

Here is my PSTN and HQ config for emulating the PSTN connection.

PSTN Configuration:

card type t1 0 3
!
!
network-clock-participate wic 3
!
isdn switch-type primary-ni
!
Controller T1 0/3/0
 clock source internal
 cablelength long 0db
 pri-group timeslots 1-3,24
 !
controller T1 0/3/1
 clock source internal
 cablelength long 0db
 pri-group timeslots 1-3,24
!
interface Serial0/3/0:23
 description ** T1 PRI D-CHANNEL TO HQ **
 no ip address
 encapsulation hdlc
 isdn switch-type primary-ni
 isdn protocol-emulate network
 isdn incoming-voice voice
 isdn outgoing display-ie
 no cdp enable
!
voice-port 0/3/0:23
!

HQ Configuration

card type t1 0 0
!
!
network-clock-participate wic 0
!
isdn switch-type primary-ni
!
Controller T1 0/0/0
 clock source internal
 cablelength long 0db
 pri-group timeslots 1-3,24
 !
interface Serial0/0/0:23
 no ip address
 encapsulation hdlc
 isdn switch-type primary-ni
 isdn incoming-voice voice
 isdn outgoing display-ie
 no cdp enable
!
voice-port 0/0/0:23

Thanks,

Viki

 

 

 

 

 

 

 

 

 

 

 

 

 

Comments

  • Can you verify the pinnouts on your T1 crossover cable?
    It should be pin 1 to 4 and 2 to 5. 
    An ethernet crossover cable will not work.



    On Jan 15, 2013, at 9:52 PM, sethuvignesh <[email protected]> wrote:

    Hi,

     

    I am trying to set up a lab in for emulating a PSTN connection. I could not bring up the interfaces. I am using the cross over cable to connect the T1 interfaces of PSTN router directly to the HQ Router T1 interface.

     

    PSTNRouter#show isdn status 
    Global ISDN Switchtype = primary-ni
    ISDN Serial0/3/0:23 interface
            ******* Network side configuration ******* 
            dsl 1, interface ISDN Switchtype = primary-ni
        Layer 1 Status:
            DEACTIVATED
        Layer 2 Status:
            TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED
        Layer 3 Status:
            0 Active Layer 3 Call(s)
        Active dsl 1 CCBs = 0
        The Free Channel Mask:  0x00000000
        Number of L2 Discards = 0, L2 Session ID = 0

    Here is my PSTN and HQ config for emulating the PSTN connection.

    PSTN Configuration:

    card type t1 0 3
    !
    !
    network-clock-participate wic 3
    !
    isdn switch-type primary-ni
    !
    Controller T1 0/3/0
     clock source internal
     cablelength long 0db
     pri-group timeslots 1-3,24
     !
    controller T1 0/3/1
     clock source internal
     cablelength long 0db
     pri-group timeslots 1-3,24
    !
    interface Serial0/3/0:23
     description ** T1 PRI D-CHANNEL TO HQ **
     no ip address
     encapsulation hdlc
     isdn switch-type primary-ni
     isdn protocol-emulate network
     isdn incoming-voice voice
     isdn outgoing display-ie
     no cdp enable
    !
    voice-port 0/3/0:23
    !

    HQ Configuration

    card type t1 0 0
    !
    !
    network-clock-participate wic 0
    !
    isdn switch-type primary-ni
    !
    Controller T1 0/0/0
     clock source internal
     cablelength long 0db
     pri-group timeslots 1-3,24
     !
    interface Serial0/0/0:23
     no ip address
     encapsulation hdlc
     isdn switch-type primary-ni
     isdn incoming-voice voice
     isdn outgoing display-ie
     no cdp enable
    !
    voice-port 0/0/0:23

    Thanks,

    Viki

     
     
     
     
     
     
     
     
     
     
     
     
     



    INE - The Industry Leader in CCIE Preparation
    http://www.INE.com

    Subscription information may be found at:
    http://www.ieoc.com/forums/ForumSubscriptions.aspx

  • Also, one side of your link on your controller should be set to 'clock source line'. Doesn't matter which side (though the User side would be more common). 


    On Jan 15, 2013, at 9:52 PM, sethuvignesh <[email protected]> wrote:

    Hi,

     

    I am trying to set up a lab in for emulating a PSTN connection. I could not bring up the interfaces. I am using the cross over cable to connect the T1 interfaces of PSTN router directly to the HQ Router T1 interface.

     

    PSTNRouter#show isdn status 
    Global ISDN Switchtype = primary-ni
    ISDN Serial0/3/0:23 interface
            ******* Network side configuration ******* 
            dsl 1, interface ISDN Switchtype = primary-ni
        Layer 1 Status:
            DEACTIVATED
        Layer 2 Status:
            TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED
        Layer 3 Status:
            0 Active Layer 3 Call(s)
        Active dsl 1 CCBs = 0
        The Free Channel Mask:  0x00000000
        Number of L2 Discards = 0, L2 Session ID = 0

    Here is my PSTN and HQ config for emulating the PSTN connection.

    PSTN Configuration:

    card type t1 0 3
    !
    !
    network-clock-participate wic 3
    !
    isdn switch-type primary-ni
    !
    Controller T1 0/3/0
     clock source internal
     cablelength long 0db
     pri-group timeslots 1-3,24
     !
    controller T1 0/3/1
     clock source internal
     cablelength long 0db
     pri-group timeslots 1-3,24
    !
    interface Serial0/3/0:23
     description ** T1 PRI D-CHANNEL TO HQ **
     no ip address
     encapsulation hdlc
     isdn switch-type primary-ni
     isdn protocol-emulate network
     isdn incoming-voice voice
     isdn outgoing display-ie
     no cdp enable
    !
    voice-port 0/3/0:23
    !

    HQ Configuration

    card type t1 0 0
    !
    !
    network-clock-participate wic 0
    !
    isdn switch-type primary-ni
    !
    Controller T1 0/0/0
     clock source internal
     cablelength long 0db
     pri-group timeslots 1-3,24
     !
    interface Serial0/0/0:23
     no ip address
     encapsulation hdlc
     isdn switch-type primary-ni
     isdn incoming-voice voice
     isdn outgoing display-ie
     no cdp enable
    !
    voice-port 0/0/0:23

    Thanks,

    Viki

     
     
     
     
     
     
     
     
     
     
     
     
     



    INE - The Industry Leader in CCIE Preparation
    http://www.INE.com

    Subscription information may be found at:
    http://www.ieoc.com/forums/ForumSubscriptions.aspx

  • Hi Mark,

    I was using Ethernet crossover cables. If I need that to work then I need to crimp cables as per pin details you said me? Any other option?

    Thanks,
    Viki








    From:


    Mark Snow <[email protected]>;


    To:

    <[email protected]>;


    Subject:

    Re: [CCIE Voice] ISDN interfaces are not up


    Sent:

    Tue, Jan 15, 2013 11:15:16 PM


    Can you verify the pinnouts on your T1 crossover cable?
    It should be pin 1 to 4 and 2 to 5. 
    An ethernet crossover cable will not work.



    On Jan 15, 2013, at 9:52 PM, sethuvignesh <[email protected]> wrote:

    Hi,

     

    I am trying to set up a lab in for emulating a PSTN connection. I could not bring up the interfaces. I am using the cross over cable to connect the T1 interfaces of PSTN router directly to the HQ Router T1 interface.

     

    PSTNRouter#show isdn status 
    Global ISDN Switchtype = primary-ni
    ISDN Serial0/3/0:23 interface
            ******* Network side configuration ******* 
            dsl 1, interface ISDN Switchtype = primary-ni
        Layer 1 Status:
            DEACTIVATED
        Layer 2 Status:
            TEI = 0, Ces =
    1, SAPI = 0, State = TEI_ASSIGNED
        Layer 3 Status:
            0 Active Layer 3 Call(s)
        Active dsl 1 CCBs = 0
        The Free Channel Mask:  0x00000000
        Number of L2 Discards = 0, L2 Session ID = 0

    Here is my PSTN and HQ config for emulating the PSTN connection.

    PSTN Configuration:

    card type t1 0 3
    !
    !
    network-clock-participate wic 3
    !
    isdn switch-type primary-ni
    !
    Controller T1 0/3/0
     clock source internal
     cablelength long 0db
     pri-group timeslots 1-3,24
     !
    controller T1 0/3/1
     clock source internal
     cablelength long 0db
     pri-group timeslots 1-3,24
    !
    interface Serial0/3/0:23
     description ** T1 PRI D-CHANNEL TO HQ **
     no ip address
     encapsulation hdlc
     isdn switch-type primary-ni
     isdn protocol-emulate network
     isdn incoming-voice voice
     isdn outgoing display-ie
     no cdp enable
    !
    voice-port 0/3/0:23
    !

    HQ Configuration

    card type t1 0 0
    !
    !
    network-clock-participate wic 0
    !
    isdn switch-type primary-ni
    !
    Controller T1 0/0/0
     clock source internal
     cablelength long 0db
     pri-group timeslots 1-3,24
     !
    interface Serial0/0/0:23
     no ip address
     encapsulation hdlc
     isdn switch-type primary-ni
     isdn incoming-voice voice
     isdn outgoing display-ie
     no cdp enable
    !
    voice-port 0/0/0:23

    Thanks,

    Viki

     
     
     
     
     
     
     
     
     
     
     
     
     



    INE - The Industry Leader in CCIE Preparation
    http://www.INE.com

    Subscription information may be found at:
    http://www.ieoc.com/forums/ForumSubscriptions.aspx




    INE - The Industry Leader in CCIE Preparation

    http://www.INE.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx


  • Hi Viki,

    You don't have any other choice but crimpt the crossover PRI cable as Mark said. Also careful network/user side configurations on the controllers.

  • It is a bit confusing since RJ45 can be used for both, but T1 is not Ethernet - the pinouts Mark gave you is the only way.


    Hi Mark,

    I was using Ethernet crossover cables. If I need that to work then I need to crimp cables as per pin details you said me? Any other option?

    Thanks,
    Viki

  • Thanks Rahman, I will try to make alternative.

    Regards,
    Viki








    From:


    MijanurRahman <[email protected]>;


    To:

    <[email protected]>;


    Subject:

    Re: [CCIE Voice] ISDN interfaces are not up


    Sent:

    Wed, Jan 16, 2013 6:18:30 PM


    Hi Viki,

    You don't have any other choice but crimpt the crossover PRI cable as Mark said. Also careful network/user side configurations on the controllers.




    INE - The Industry Leader in CCIE Preparation

    http://www.INE.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx


Sign In or Register to comment.